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Glossary

alpha channel

The image's channel carrying the transparency information. An
image already has three channels: red, green and blue (RGB). The
alpha channel is the fourth channel (RGBA). The matte, or the
transparency information, is stored in this fourth channel. An image
without an alpha channel is always opaque.

animatic

A movie with sound that is developed from the storyboard. The
storyboard panel is exposed for the duration of the scene and at
times, the characters are placed on a trajectory to indicate motion.
The camera moves are also animated. The animatic is used to
determine the rhythm of a project and provides a good overview of
the project before beginning production.

animation
A simulation of movement created by displaying a series of pictures
or frames.

anime
An animation style known for its sinister and dark feel; popular in
Japan.

arc

Action rarely occurs in a straight-forward manner; rather it typically
unfolds in what storytellers refer to as an arc. The purpose of a
story arc is to move a character or a situation from one state or
scenario to the next.

aspect ratio
The relationship between the width and height dimensions for any
scene, frame or film format. Television ratio is 4:3 and widescreen
ratio is 16:9.

auto-feed

An automated method of feeding drawings into a scanner in which
multiple drawings are stacked into a sheet feeder. When the
scanner is activated, the drawings are scanned consecutively,
without further user intervention.

automatic lip-sync detection
Automatically mapping drawings in an element to the mouth chart
generated for a sound. This can save time when lip-syncing a voice
track.

axis

An imaginary line around which an object rotates.

For 2D graphics, there are two axes:

• X: Horizontal

• Y: Vertical

For 3D graphics, there are three axes:

• X: Horizontal

• Y: Vertical

• Z: Depth

background
The part of a scene that is farthest to the rear. The background is
the artwork, or decor, against which the animation takes place.

Bézier A method of defining curved lines invented by French
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mathematician Pierre Bézier. A Bézier curve is a mathematical or
parametric curve. Bézier curves use at least three points to define a
curve.

In Toon Boom, a function can be hooked to a Bézier curve and vary
along with the curve value information. Bézier curves are also very
useful in vector graphics. They are used to model smooth curves
and can be scaled indefinitely.

bitmap
An image composed of pixels with a single resolution (size). If it is
enlarged too much, it will lose definition and pixels will begin to
appear. This is known as pixelation.

breakdown

In cut-out animation, breakdown is the action of breaking a
character into pieces to create a puppet with articulations. To
break down a character, the artist cuts part, such as hands and
arms, from the character's model and pastes them in separate
layers. Next, the joints are fixed and the pivots set.

In traditional animation, a breakdown is an animation pose
generally found between two key poses. The key poses are the
main poses in an animation and the breakdowns are secondary
poses, ones that help to describe the motion and the rotation
curve.

camera shake
Camera shake occurs in a scene when the camera moves slightly
and quickly in several directions. This gives the impression of an
impact, vibration or, for example, bumps on the road.

caption
In a storyboard, a caption is a text field containing dialogue,
effects, sound, or slugging information.

cel

In traditional animation, a cel, also known as a celluloid, is a
transparent sheet on which the animation is inked and painted
before being sent to the camera.The picture's outline is drawn on
the front of the cel and then coloured along the back.

In Toon Boom, a cel is an individual space encountered in an
Xsheet's column, from which you can expose a drawing or a
function`s coordinate.

character design
Each character in an animated film is drawn from multiple angles in
poster-style format, called amodel sheet, which serves as a
reference for the animators.

clean up

After rough drawings have been tested and approved, all the noise
in the image (excess lines, notes, etc) is removed to create final
drawings which can be inked, painted and shot. The cleanup
process refers to either tracing a clean line over a rough drawing to
achieve the final version, or removing dirt and extra lines left by the
scanning process.

CMYK
Cyan, Magenta, Yellow, Black. Refers to the process used by
printers to define colour on the printed page.

colour card
A Colour Card is a solid colour card that is the same size as the
camera. The Colour Card can be used to fill the background with a
solid colour when there is no background image included.
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colour model

In animation, a colour model is the official colour design that must
be used to paint the animation. A model is the definitive character,
prop, or location design that each artist must follow for the
production.

colour wheel A display of the colour spectrum in the form of a circle.

compositing

Compositing is the action of incorporating all of a scene's elements
to create the final result prior to rendering. For example, the
compositing artist will import all the animation sequences,
background, overlays and underlays in the scene and position them
correctly. The artist will then set the camera frame and animate it, if
needed. Finally, the animator will create all the computer-
generated effects for the project.

cross dissolve An effect used to fade two scenes, one into the other.

cut
A direct transition between two scenes. When a cut is used, there
are no transition effects inserted to pass from one scene to the
next. The first scene ends and the second one starts immediately.

cut-out animation
The action of animating characters made of several pieces by
moving them around frame by frame. Cut-out animation can either
be computer generated or done traditionally using paper.

cycle
A group of images that together make up an action, such as
walking. A cycle is an action repeated as a loop over a period of
time. It can be a series of animated drawings or keyframes.

dialogue The text spoken by a character in a movie or animation.

dope sheet

Used by animators, directors and other members of a crew to
track the sequence and timing of images, dialogue, sound effects,
sound tracks and camera moves. Also known as an exposure sheet
or Xsheet.

doping To assig a particular drawing to a range of frames.

DPI

Dots Per Inch is the standard measure of resolution for
computerized printers. It is sometimes applied to screens, in which
case it should more accurately be referred to as pixels per inch.
Either way, the dot is the smallest discrete element making up the
image.

ease/velocity

In animation, the ease, also known as velocity, is the acceleration
and deceleration of a motion. It can be a motion created by a
function curve, or a series of animated drawings. Other common
terms for ease-in and ease-out are slow-in and slow-out.

ease-in
Gradual acceleration in the action. Another common term for ease-
in is slow-in.

ease-out
Gradual deceleration in the action. Another common term for ease-
out is slow-out.

establishing shot
A scene in which the viewer can see the whole area in which a
sequence is happening. For example, if a child is playing on the
ground in front of his house, the establishing shot would be a scene
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where the viewer can see the house, the ground, a part of the
street and the buildings around the central point of action. This
helps the viewer understand the story location and scene
orientation.

exposure
In animation, an exposure is the number of cels on which a drawing
appears in the scene. For a drawing to appear longer, the
exposure must be extended over a greater number of cels.

exposure sheet (Xsheet)

The exposure sheet or Xsheet, is a sheet with several vertical
columns and horizontal frames used to indicate a scene's timing.

Each column represents a scene's layer. In each column, the
drawing's numbers are indicated and repeated over the particular
amount of frames they need to appear.

The exposure sheet is used by animators, directors and other
members of a crew to track the sequence and timing of images,
dialogue, sound effects, sound tracks and camera moves. Also
known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a
sequence. A fade in occurs when the first scene appears
progressively, from complete transparency to its complete opacity.
A fade out occurs when the last scene progressively disappears,
going from complete opacity to complete transparency.

fast-in Dramatic acceleration at the start of the action.

fast-out Dramatic acceleration at the end of the action.

field
In animation, a field is a measurement unit used to calculate
motion, registration and camera positioning. A standard animation
scene will vary between 6 to 12 fields.

field chart
A guide containing all the field units that animation and layout artists use to
determine a scene size or camera motion.

film-1.33
Use this resolution setting for the widescreen film format that
conforms to the standard 4:3 pixel aspect ratio.

film-1.66
Use this resolution setting for the widescreen film format that
conforms to the 16:9 pixel aspect ratio. (The pixels are wider than
they are high).

flipping

In traditional animation, flipping is the action of going through the
drawings of an animation sequence very quickly in order to see the
animation in motion. Flipping can also be the action of creating a
mirror transformation of an object.

follow-through

The follow-through is the secondary motion caused by the main
action. For example, a character wearing a cloak is running. The
main action is the body running. This will cause the cloak to follow
the motion, although it will not move at the same time, but react a
few frames later and follow the main motion curve.

forward kinematics
Forward kinematics is a feature used to animate principally 3D
characters and cut-out puppets with hierarchy. It is used to animate
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a puppet from one of parent parts, such as a shoulder, and make
the rest of the arm move with it as a single piece.

frame

A frame is a single photographic image in a movie. In traditional
animation, the North American standard generally contains 24
frames per second, while in Europe the standard is 25 frames per
second.

frame rate

This is the measurement of the frequency (rate) at which an imaging
device produces unique consecutive images, called frames. The
term applies equally to computer graphics, video cameras, film
cameras, and motion capture systems.

Frame rate is most often expressed in frames per second (FPS) and
in progressive-scan monitors as hertz (Hz).

The frame rate is the speed at which the frames are played. They
are generally calculated by frame per second. For example, a scene
could be played back at 12, 24, 25, 30 or 60 frames per second or
any other number

functions

A function is a computer generated motion, trajectory or path that
elements, other trajectories and effects parameters can be
attached to. The function can be controlled by adding keyframes
and control points on the function curve.

gamut The range of colours that a particular device can represent.

HDTV

High Definition Television delivers a higher quality image than
standard television does because it has a greater number of lines
of resolution. To take advantage of the superior quality and make
full use of your resolution setting, your output device must be
compatible with HDTV technology.

hold
This is a frame in the animation in which the character maintains its
position without moving. A hold can be created between any two
keyframes.

HSV
Hue, Saturation, Value. A method of defining colours in terms of
hue (tint), saturation (shade) and value (tone or luminance).

in-between
The drawings that exist between the key poses. These are drawn
to create fluid transitions between poses.

ink and paint
The ink and paint process is the action of painting the empty zones
and colouring the lines on the final animation drawings, while
following a colour model.

interpolation
In animation, the interpolation is the computer generated motion
created between two keyframes. You have the choice to create
interpolation, or not, between your keyframes.

jump cut

A jump cut is a jerky cut between two scenes. Typically, a jump cut
is not visually pleasing. It is generally caused by one scene ending,
and a second one starting, with similar a image. The lack of
difference causes the eye to see a little jump between the two
scenes.
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key pose

Important positions in the action defining the starting and ending
points of any smooth transition. Keys, or key poses, are the main
drawings in an animation sequence describing the motion. For
example, if an arm is waving, the keys will be of the arm at one
extremity of the wave motion and the other extremity. By flipping
those drawings, the animator can see the skeleton of the motion
without having all of the drawings.

keyboard shortcuts

One or more keyboard keys which, when used, cause an operation
to be performed. Keyboard shortcuts are used throughout the
Toon Boom software and form an integral part of the workflow. It
is, in most cases, possible to customize the shortcuts in the
Preferences dialog of the software.

The shortcuts are written as follows in the Toon Boom user
documentation: Each key in a sequence is shown inside square
brackets as in: [Ctrl]+[A]. The brackets "[ ]"  separate the key from
the plus  sign (+). Neither the brackets, nor the plus sign are part of
the sequence. To use a shortcut, press the key and the character
simultaneously.

keyframe
Important positions in the action defining the starting and ending
points of any action. A keyframe is a computer generated position
at a specific moment (frame) on a given trajectory.

layer
In animation, a layer is an individual column, level or character. A
scene's layers are superposed to form the final image.

layout

The layout process is the communication step between the
storyboard and the animation. The layout and posing process is
the action of putting the storyboard on model, that is drawing the
character following the design in the model pack, so that the
animator can start his work. The layout artist will draw the
background, create the camera and field guide matching the scene
and the camera motion. Lastly, he will draw on model the main
action poses.

layout and posing
The action of putting on model, that is, at the right scale, the
storyboard for the animator to start his work.

library
A library is a storage area containing templates and assets that can
be reused in any project or scenes.

light table
The Light Table feature allows you to see the other layers in
transparency while you are working on a particular one in the
Drawing view.

line of action
Direction that the action will follow. Also known as the Path of
Action

lip-sync
The lip-sync is the character`s mouth synchronization with the
dialogue sound track. Frame by frame, the mouth will be adjusted
to fit the sound to give the illusion of the character is speaking.

low resolution
This format is ideal for videos destined for the web, where size and
fast download of a video file might take precedence over quality. A
low-resolution image is one that lacks fine detail.
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manual lip-sync detection

The manual swapping of mouth position drawings to match a voice
track. For this process, both sound scrubbing (listening to a sound
wave broken up frame-by-frame) and drawing substitutions from
the Library view are used.

master palette

A master palette is a group of colours attributed to a character or
a prop. The palette is used throughout the entire production to
maintain consistency in the look and to ensure that the same
colours are used throughout the production. Also known as
palette.

model/colour model

In animation, a model is the definitive character, prop or location
design that each artist must follow for the production. A colour
model is the official colour design that must be used to paint the
animation.

motion keyframe
In Toon Boom, the motion keyframe is a keyframe with computer-
generated interpolation.

mouth chart

Adding a lip-sync to a project can really enhance its quality and
storytelling. However, it can be difficult to shape a character's
mouth so that it matches the sound at the precise frame. To solve
this problem, Toon Boom provides a lip-sync feature which
analyses the contents of a sound element and generates a mouth
chart based on the eight animation phonemes (A, B, C, D, E, F, G,
and X, which is used to represent silence).

multiplane

The effect of passing through multiple levels of drawings to create
a sense of depth in a shot. A multiplane is a scene in which the
layers are placed at different distances from the camera so that
when the camera moves, a depth illusion occurs. With a multiplane,
all the perspective and scale is calculated automatically.

NTSC

The standard analogue television broadcasting system used in
North America. NTSC conforms to North American standards on
how rectangular pixels are displayed for computer and television
screens.

nudge
A small push (left, right, up, down, forward or backward) done
with the keyboard arrow keys on a selected element. Nudging is
used to move a selection very slightly and precisely.

onion skin
A feature that lets you see the previous and next drawings of a
sequence.

overlay
A part of the scene environment, such as a chair or a bush, that is
placed in front of the main animation.

PAL
A resolution that works best with the European format for
television and computer screens, as the rectangular pixels are
displayed at a different orientation.

palette/master palette

A palette or master palette is a group of colours attributed to a
character or a prop. The palette is used throughout the entire
project to maintain a consistency in the look and avoid the colour
changing during the animation. Also referred to as a master
palette.
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palette style

A palette style is a second version of an existing palette with a
slight change in the tint and value. A palette style can be used to
create the night version of a palette. It may also be called a clone
palette.

pan To move the camera across the scene in any direction.

panel
In a storyboard, a panel is a frame in a shot. A shot can be
composed of one or several panels.

paperless animation/tradigital
The paperless animation process is the action of animating
digitally. The main paperless animation process is to draw, frame
by frame, the animation directly in the software.

passing position
When drawing a walk sequence for a character, the passing
position is the point at which one leg passes the other.

path of action
Direction that the action will follow. Also known as the Line of
Action.

peg

In traditional animation, a tool used to ensure accurate registration
of action as cel layers move. In digital animation, in which you are
doing a more advanced puppet rigging, you can use peg layers.
Peg layers are trajectory layers that do not contain drawings. They
are motion paths that you can use to add path articulations. For
the latter, you can also use the Inverse Kinematics tool.

phoneme Unit of sound in a language.

pivot A pivot is the point around which a peg or a drawing rotates.

pixel

Smallest element of an image displayed on a monitor or TV screen.

Pixel, short for Picture Element, is a single point in a graphic image.
It is a small sample of an image, a dot, a square, or a very small
section made out of smooth filtering. If you zoom in close enough
on a digital image, you will see the pixels, which look like small
squares of different colours and intensity.

pose-to-pose animation

The pose-to-pose animation process is the action of creating all the
main action poses, called key poses, and then placing the
secondary poses between the keys. The secondary poses are
called breakdown. Finally, the animator fills the gaps with the in-
between drawings to achieve a smooth animation.

rendering

The final step when animating by computer. During rendering, the
computer takes each pixel that appears on screen and processes
all of the components as well as adding motion blur before it
produces a final image. In animation, the rendering process is the
action of calculating the final images after the compositing
process.

resolution

The resolution is the size of a scene, generally calculated in pixel.
For example, the NTSC resolution is 720 x 480. Resolution type
should match your final output: HDTV, film-1.33, film-1.66, NTSC,
PAL, low.

RGB Red, Green, Blue: method of defining colour by specifying amounts
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of these three colour components.

rigging
The rigging process is the action of attaching the cut-out puppet
parts one to the other.

rotary table
The Rotary Table is equivalent to the animation disk/table and
allows one to rotate the workspace to be more comfortable while
drawing.

rotoscoping

Is an animation technique in which animators trace over live-action
film movement, frame by frame, for use in animated films. The act
of sketching over live-action footage to create an animated
sequence.

roughs
The roughs are the skeleton sketch of an animation or a design.
Roughs mainly consist of sketch lines and shapes, though they can
also contain design details.

safey area

In animation and movie parlance, the safey area is the zone at the
centre of the scene's frame, one safe from being cropped by the TV
frame. As a TV frame cuts a margin off the original frame size,
maintaining a safey area ensures that the scene's main action will
remain clearly visible once the film is screened on television.

scene
A scene is a shot in a movie or show. A sequence is composed of
several scenes. A scene changes to another scene by a simple cut,
or a transition.

script

The script is the original text containing all the movie or show
information. In animation, the script contains all of the location
descriptions, dialogues, time and more. A project starts with a
script.

sequence
In animation, a sequence is a series of scenes or shots forming a
distinct part of the story or movie, usually connected by unity of
location or time.

shot
A shot is a scene in a movie or show. A sequence is composed of
several shots. A shot changes to another shot by a simple cut, or a
transition.

slow-in
Gradual acceleration in the action. Another common term for slow-
in is ease-in.

slow-out
Gradual deceleration in the action. Another common term for slow-
out is ease-out.

slugging
In Storyboard Pro, slugging refers to indicating the start and stop
times of dialogue and relevant actions.

sound scrubbing
A process that lets you hear sound in real time while you move the
playhead forward or backward. This is very useful for finely-tuned
lip-syncing.

stop-motion keyframe
A stop-motion keyframe is a keyframe with no computer generated
interpolation.

storyboard
A visual plan of all the scenes and shots in an animation. The
storyboard indicates what will happen, when it will happen and

21



Glossary Contents

how the objects in a scene are laid out.

straight-ahead

A technique in which an entire sequence is drawn from the first
position to the last, in order. There is very little planning in this
methodology, and where the character ends up and how it gets
there can be a surprise for both the audience and the animator.
While this approach is a lot more spontaneous and creative, it can
create inaccurate results.

strokes
Strokes are invisible vector lines forming the drawing zones. They
can be adjusted with Bézier handles.

tablet/pen
Device used in conjunction with, or instead of, a mouse to move a
mouse pointer (sometimes referred to as the cursor) around the
computer screen.

template

In Toon Boom, a template is an asset stored in the library, one that
can be reused in any project. A template can be a drawing, a series
of keyframes, a sound file, a panel, a cut-out character, an effect, a
trajectory, an animation, or anything else used in the software.

thumbnails A thumbnail is a very small image used as a reference or indicator.

timecode
Timecode is timing information printed on a movie clip to indicate
what scene, hour, minute and second is currently displayed on the
screen.

timeline
The timeline is a horizontal representation of the scene`s elements,
timing and keyframes.

trace and paint

After the rough animations have gone through cleanup and a final
line or pencil test, each drawing is traced and painted for the final
animation. In today's digital world, this may be done in a variety
ways other than via the traditional celluloid or acetate methods.

track breakdown
The soundtrack for animated film is broken down into individual
sounds documenting the precise frame-by-frame position of each
sound.

traditional animation
The traditional animation process is the action of drawing on paper
all of the animation sequences, before either scanning them or
inking them on cels.

trajectory
A computer generated path or trajectory that elements can follow.
The trajectory can be controlled by control points, keyframes and
velocity.

transition
A transition is an effect placed between two scenes as they pass
from one to the other. Common transition effects are cross-
dissolve and wipe.

underlay
In animation, an underlay is a specific part of the decor placed
behind the main animation.

aspect ratio
The aspect ratio describes the shape of the grid unit. A square grid
unit would have the ratio 1:1, whereas a grid unit of aspect ratio
4:3 is a unit with one side 1.33 times as big as the other side.
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vector

A vector-based image is composed of points and Bézier curves.
The computer reads the points and traces the segments, linking
them to reproduce the image shape. There is no fixed size or
resolution in a vector image. The graphic can be enlarged and
distorted as much as desired and the system will simply recalculate
the segments and rebuild the shapes. Vector images are translated
and displayed in pixels once the calculation is done.

velocity/ease

In animation, the velocity, also known as ease, is the acceleration or
deceleration of a motion. This can be achieved by a function curve,
or via a series of animated drawings. Other common terms for
ease-in and ease-out are slow-in and slow-out.

walk cycle

To avoid making innumerable drawings, animators routinely make
a walk cycle for their character. This comprises a series of drawings
``on the spot``  that describe the walk for that character. The illusion
of movement is created via the use of background pans.

workspace
In Toon Boom, the workspace is made up of the views, toolbars,
and menus.

Xsheet (exposure sheet)

The Xsheet or exposure sheet, is a sheet with several vertical
columns and horizontal frames used to indicate a scene's timing.

Each column represents a scene's layer. In each column, the
drawing numbers are indicated and spread over the specific
amount of frames they need to appear.

The exposure sheet is used by animators, directors and other
members of a crew to track the sequence and timing of images,
dialogue, sound effects, sound tracks and camera moves. Also
known as a Dope Sheet.

zone An area which can be painted with colour.
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Chapter 1: Introduction

The Sketch module is a component of the Stage module. It contains the essential tools to animate
frame-by-frame drawings and paint them. It allows you to add layers and animation, and paint and
adjust the timing. There are no effects, camera or other compositing tools included in this module.
The Sketch module allows you to focus on the paperless animation tasks at hand without being
distracted by other features that are not necessary to your work.

This guide is divided as follows:

• Toon Boom Harmony - About this Help System on page 1

• About Toon Boom Harmony on page 7

• Starting Toon Boom Harmony on page 13

• Interface on page 47

• Timing on page 97

• Character, Prop and Location Design on page 163

• Colour Styling and Colour Models on page 283

• Painting the Background on page 325

• Ink and Paint on page 339

• Paperless Animation on page 381

• Import on page 443

• Sound on page 487

• Export on page 513
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Chapter 2: Toon Boom Harmony - About this Help System
Toon Boom Harmony is an animation and digital content creation tool that offers you a wide array of
features and options. Harmony is packaged in several different modules and allows you to create
animation using the technique of your choice—see About Toon Boom Harmony on page 7.

This help system is built to guide you through the different workflows possible and explains which tool
and module to use in a production context.

• Help Structure on the next page

• Tutorials and Other Help Tools on page 4

1
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Help Structure

The fundamental concepts of animation and Harmony are explained in this guide. It covers the
essentials of various animation workflows, basic animation principles, as well as Harmony's interface.
Depending on what you want to do, you can either start with this Fundamentals Guide to get
immersed into the world of Harmony and animation or go right to the Getting Started Guide, which
covers the main functions and tasks. All conceptual and reference topics are omitted to get you up and
running in a very short amount of time.

If your work revolves more around system administration or coordination tasks, you will probably
want to move over to the Installation Guide followed by the Control Center and Server Guide to learn
how to install and configure Harmony.

The core of this help system revolves around the main animation techniques you can use in Harmony to
create animation:

• Traditional Animation

• Paperless Animation

• Cut-out Animation

If you use one of the animation technique listed above to produce games, you can complete your
learning process using the Gaming Guide.

2
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All workflows join in the compositing step of the process. All the information on compositing in
Harmony can be found in the Compositing Guide. Finally, you can watch the rendered animations in
the Play module. To learn how to use the Play module, refer to the Play guide.

If you are focusing on a single part of the workflow such as ink and paint or digital Xsheet creation, you
can simply read the Fundamentals Guide and one of the corresponding module guides:

• Paint Guide

• Xsheet Guide

• Scan Guide

• Draw Guide

• Sketch Guide

Other satellite guides are also available to learn about additional information such as the preferences
and keyboard shortcuts.

• Keyboard Shortcuts Guide

• Preferences Guide

• Scripting Guide

• Utilities Guide

If you are already a Harmony user and want to know more about the new features that were added to
this latest version, refer to:

• Release Notes

3
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Tutorials and Other Help Tools

Aside from the main product documentation, you can find supplementary material to learn more
about Harmony. The Toon Boom website's online resources section offers a variety of videos and
samples that can further your knowledge of Harmony.

• Video Tutorials: toonboom.com/resources/video-tutorials/harmony-network

• Templates and Sample Scenes: toonboom.com/resources/templates/harmony-network

• Tips and Tricks: toonboom.com/resources/tips-and-tricks/harmony-network

• White Papers: toonboom.com/solutions/white-papers
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System Requirements

Here are the technical specifications for Toon Boom Harmony 11.1.0.

Harmony Network
Toon Boom Harmony Network is a server-client configuration. The server stores all the assets, and
holds the database. The client machines simply run the software and allow the members of your team
to work on Harmony and access the assets directly from the database.

Note that an Internet connection is required to activate the animation software.

Before installing Harmony, refer to theHarmony and Your IT Department white paper to learn about
the network prerequisites for a Toon Boom Harmony installation. This document should be taken as a
guide to help you understand the preliminary steps before performing a typical Harmony installation.

There are multiple ways of installing Harmony, as well as numerous types of hardware that can work
with Harmony. To perform a custom installation which fits the studio’s requirements, a proper analysis
of the studio is required, such as: the type of project, the productivity expected, and the delivery date,
etc. If you are not yet familiar with Harmony, you should get in touch with your sales contact at Toon
Boom to organize a needs analysis of your studio and production in order to make the best of
Harmony and optimize your production pipeline.

The person who performs the installation should have the knowledge and expertise required for
setting up and configuring networks, computers, and operating systems. If you do not have an IT
department or someone who knows the network technology thoroughly, contact your sales
representative at Toon Boom to organize an installation with our consulting department.

• White Paper: Harmony and Your IT Department

Harmony
Here are the specifications to install Harmony on client machines. Note that this does not encompass
the network and server specifications for Harmony Network.

Requirements Windows MacOS X

Operating System
Windows 7 64-bit
Windows 8 64-bit

Mac OS X 10.7.5
Mac OS X 10.8.5
Mac OS X 10.9.3 or later

Processor
Intel Core i7, 3.4 GHz
Intel Core i5, 3 GHz
Intel Core 2 Duo

Monitor
Optimized for 1920 x 1080 or higher
Minimum requirement is 1280 x 800

Memory
16 GB
8 GB
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4 GB

Video Card

Fast

‣ NVIDIA Geforce GTX 780

Medium

‣ NVIDIA Geforce GTX 560

‣ NVIDIA GeForce GTX 650

Slow

‣ Intel HD Graphics 4000,
5000

‣ Intel Iris GraphicsNVIDIA
GeForce GT 520, 620, 720

Fast

‣ NVIDIA GeForce GTX
775M

Medium

‣ AMD Radeon HD 6770

‣ NVIDIA GeForce 750M

Slow

‣ Intel HD Graphics 4000,
5000

‣ Intel Iris Graphics

‣ NVIDIA GeForce 320M

‣ Radeon HD 4670

Drawing Tablet

Best

‣ Wacom Intuos Pro

‣ Wacom Cintiq

Basic

‣ Wacom Bamboo

‣ Wacom Intuos

Media Player Apple QuickTime Player (free)

6
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Chapter 3: About Toon Boom Harmony
Toon Boom Harmony is the most advanced professional animation software on the market. Bringing
together an impressive 2D drawing toolset with the ability to work in a real 3D space, and import 3D
models,

Harmony Network combines the animation toolset of Harmony with an impressive database for
collaborative workflow. Share assets, batch vectorize and render, and increase production efficiency.

Top Features

• AdvancedDrawing Tools: Texture brushes, and thick and thin pencil lines

• Smart Colour Palettes: Colour you can adjust on the fly

• Character Rigging: Hierarchy, deform, and effects for creating sophisticated rigs

• Special Effects: An array of effects including highlights and shadows, glows, blurs, and a full
particle effects engine

• Real 3D Camera: A camera you can reposition in a full 3D space

• 3D Integration: Allowing you to import 3D models, position and animate them in 3D space

• Batch Vectorizing and Rendering: Quickly process images for import and export through a
single workstation or a render farm

• Database File Sharing: Share libraries, colour palettes, animation, and more across the whole
team

• Production Pipeline Integration: Seamlessly integrate content from pre-production via
Toon Boom Storyboard Pro

Toon Boom Pipeline
Toon Boom Harmony has been recognized for its excellence by winning many awards, including a
Primetime Emmy® Engineering Award and the prestigious Ub Iwerks Annie Award for the integrated
pipeline with Toon Boom Storyboard Pro.

Harmony works perfectly with Toon Boom Storyboard Pro for all pre-production phases. Therefore,
animatics created in Toon Boom Storyboard Pro can be imported seamlessly in Harmony for
animation and scene setup guidance.

Modules

Harmony Network is composed of the following modules:

7
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• Control Center below

• Stage on the facing page

• Draw on the facing page

• Sketch on page 10

• Scan on page 10

• Xsheet on page 11

• Paint on page 11

• Play on page 11

• Cloud on page 12

These modules are all accessible from:

• Windows: Start > Programs > Toon Boom Harmony 11.1.0

• Mac OS X: Applications > Toon Boom Harmony 11.1.0

• Linux: /usr/local/ToonBoomAnimation/harmony_11.1/lnx86_64/bin

• Controlcenter

• Stage

• Draw

• Sketch

• Scan

• Stage -xsheet

• Stage -paint

• Play

• ServerActivation

• ClientActivation

• LicenseWizard

Control Center

The Control Center module controls the database and organizes the production. The Control
Center module is used to create the environments, jobs and scenes, as well as importing and
exporting scene packages. The technical director or system administrator also uses the Control
Center to create the login information for users to access the database.

Control Center is also available in a cloud form where users can access scenes via the Internet.

To learn more about Control Center, refer to the following guides:

8
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• Fundamentals Guide

• Installation Guide

• Control Center and Server Guide

Stage

The Stage module is the core of Harmony. It comprises all the major drawing, animation and
compositing features. It is used to work in the scene: design, character breakdown, cut-out
animation, traditional animation, ink and paint, exposure sheet, timeline, effects, compositing,
camera moves, colour styling, and so on.

You cannot create scenes in Stage Harmony Network, you require Control Center. You create them
directly in Stage with Harmony Stand Alone.

To learn more about Stage, refer to the following guides:

• Fundamentals Guide

• Getting Started Guide

• Traditional Animation Guide

• Paperless Animation Guide

• Cut-out Animation Guide

• Gaming Guide

• Compositing Guide

• Play Guide

• Preferences Guide

• Keyboard Shortcuts Guide

• Scripting Guide

• Utilities Guide

Draw

9
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The Draw module is a component of the Stage module. It contains all the tools necessary to create a
paperless frame-by-frame animation project. There is no node system in this module, only the basic
essential effects. Contrary to the Stage module, instead of creating effects in the Network view, you
simply create them in the Timeline view. The Draw module also includes all the scene setup and
camera features for you to do the compositing for your project.

• Fundamentals Guide

• Draw Guide

• Preferences Guide

Sketch

The Sketch module is a component of the Stage module. It contains the essential tools to animate
frame-by-frame drawings and paint them. It allows you to add layers and animation, and paint and
adjust the timing. There are no effects, camera or other compositing tools included in this module.
The Sketch module allows you to focus on the paperless animation tasks at hand without being
distracted by other features that are not necessary to your work.

To learn more about the Sketch module, refer to the following guides:

• Fundamentals Guide

• Sketch Guide

• Preferences Guide

Scan

The Scan module is used to scan drawings in batch. It creates a drawing list from the timing and
exposure previously created in the exposure sheet (via Stage or Xsheet module).

It is possible to scan the drawings from a TWAIN device directly in the Stage module.

To learn more about the Scan module, refer to the following guides:

• Fundamentals Guide

• Scan Guide
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Xsheet

The Xsheet module is a component of the Stage module. It contains the tools used to create digital
exposure sheets, columns and timing. It is mainly used in large traditional animation studios to
maintain a structure and avoid users having to learn the full product application. This way, the Xsheet
team can concentrate on their task without having to deal with the compositing and drawing tools.

To learn more about the Xsheet module, refer to the following guides:

• Fundamentals Guide

• Xsheet Guide

• Preferences Guide

Paint

Paint module is a component of the Stage module. It contains the drawing, painting and colour
styling tools. It is mainly used in large traditional animation studios to maintain a structure and avoid
users having to learn the full product application. This way, the colour styling or ink and paint team
can concentrate on their task without having to deal with the compositing and timing tools.

To learn more about the Paint module, refer to the following guides:

• Fundamentals Guide

• Paint Guide

• Preferences Guide

Play

The Play module is used to play back the rendered image sequences enabling the user to view the
final scenes and compositing results.

To learn more about the Play module, refer to the following guides:

• Fundamentals Guide

• Play Guide
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Cloud

Access your Database via the Cloud. When you're running a studio, you will most likely have a
database set up. This enables all the artists working on your production to share the same scenes
and assets.

What the Toon Boom Cloud enables you to do is to host this database on the Internet. When you do
so, you can have freelancers log in from anywhere with an internet connection. Then they can
download a scene from the database, work on it, and upload it again.

No more need to spend time copying files to an FTP. No need to have an admin exporting and
importing files from the database. Do it all directly through the Cloud.

To learn more about the Cloud module, refer to the following guides:

• Installation Guide

• Control Center and Server Guide
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Chapter 4: Starting Toon Boom Harmony
Once Harmony is installed, you are ready to start the application and animate! In this chapter, you will
learn about starting the application, setting the resolution and opening the scenes.

• Network Connection and Centralized Database on the next page

• Starting Sketch on page 15

• Welcome Screen on page 20

• Saving a Scene on page 22

• Setting the Scene Length on page 30

• Adding a Drawing Layer on page 31

• Scene Settings on page 34

• Verifying the Project Integrity on page 42

• Basic Commands on page 44

• Preferences on page 46
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Network Connection and Centralized Database

The Harmony solution is a revolutionary team-based infrastructure for animation production and 2D
games. Its array of features increases productivity and encourages creativity. Developed in conjunction
with leading studios worldwide, Harmony is specifically designed for long-term episodic and feature
length projects, providing a true animation pipeline. Several animators can work simultaneously on the
same project while the asset library provides users with easy access to up-to-date media assets.
Harmony is truly scalable; more than 100 staging clients can share animation just as easily as a few can.

Note that Harmony can be used in Database mode via the Network connection or as a standalone
application.

What is the Network Connection?

Harmony Network is the link between the client machines and the server. It lets you work on the
different projects stored in the central Harmony database.

At the heart of the Harmony solution is the server, which centralizes all the production assets in a
repository. Loaded with production proven tools to manage administration tasks, the server is
completely flexible and will fit in your existing infrastructure, whether you are on Windows, Linux or
Mac OS X. To learn more, refer to the Control Center Guide.

Working with Harmony Stage Via Harmony Network

When you start Harmony Stage, you can opt to either work offline in the application as a standalone
software, or connect to the database to work on projects via Harmony Network.

When working with Harmony Network, the scenes and their data are stored directly on the server. No
data is saved or stored on the client machine. The client machines access the database and load the
scenes and drawings directly from the server. Each time the user saves his scene, the data is updated
directly on the server. There are no upload or download operations (check-in, check-out) done
between the server and the clients.

If you have a standalone license, you will not have access to the database. You will automatically start the
application in standalone mode.
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Starting Sketch

You can run the Harmony on the Linux, Mac OS X or Windows operating systems.

How to start Harmony Sketch

1. Do one of the following:

‣ Mac OS X: Double-click on the Harmony Sketch icon or select Applications > Toon Boom
Harmony 11.1 > Sketch.

‣ Windows: Double-click on the Harmony Sketch icon or select Start > Programs/All
Programs > Toon Boom Harmony 11.1 > Sketch

‣ Linux: Select Applications > Toon Boom Harmony 11.1 > Sketch

Toon Boom Harmony opens.

If you have a standalone license, Toon Boom Harmony will open directly with the Welcome screen.

2. In the User Name field, enter your username. It is generally provided by the supervisor, system
administrator or team lead.

3. Select theConnect to Database orWork Offline option.

‣ Connect to Database: (Your database must first be set up.) Lets you work on Harmony
connected to the database so you can access scenes stored in the central database of the
Toon Boom Server; certain options become available in the different menus. However, you
will not be able to create new scenes directly from Harmony Stage and the available scenes
will be the ones that were previously created using the Control Center.

‣ Work Offline: Enabled by default when you start Harmony for the first time. Using this
mode lets you create new scenes and work locally on your machine on independent projects
as you would with any local software. However, the following limitations apply:

• Options exclusive to Harmony Network will not be available in the different
menus.

• You will not have access to any projects stored in the central database of the
Toon Boom Server.

4. Click OK.

In Offline mode, the Welcome Screen opens—see Welcome Screen on page 20.

In Database mode, the Database Selector opens—see Connecting to the Database on the next
page.
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Connecting to the Database

Before you can work in Sketch via Harmony Network, you must be connected to the Harmony
Database. When you connect to the database, you cannot create new scenes directly from Harmony
Stage. The available scenes will be the ones that were previously created using the Control Center.

How to connect to the Harmony database

1. Start Sketch—see Starting Sketch on the previous page.

2. In the Toon Boom Stage window, select theConnect to Database option.

3. In the User Name field, type in your Harmony username which is provided by your project lead or
system administrator.

4. Click OK.

The Database Selector dialog box opens, displaying the environments available in Harmony
database.
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5. In the Environments column, select the scene's environment (project, movie).

6. In the Jobs column, select the scene's job (episode, sequence).

7. In the Scenes column, select the scene.

8. Get the permissions needed for this session by selecting one of the following options:

A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can be
locked. Locking means to get the rights to modify a scene or its assets. Other users cannot modify
locked items. They will be prompted with an error message saying that the scene has been locked by
another user. At that moment the scene will be displayed as read-only.

See the table below to understand the different lock possibilities.

Lock Description

Scene or Version Lock
Controls the Xsheet timing, layers, Network modules but not the draw-
ing, palettes, palette-lists or templates.

Drawing Lock Only one user can edit and save a locked drawing.

Palette Lock Only one user can edit and save a locked palette.

Palette-list Lock Only one user can edit and save a locked palette-list.

Library Folder lock Only one user can edit and save into that folder in the Library.

‣ Get rights to modify the scene: Allows the user to modify the selected version of the scene
and access the version manager during the opened session.

‣ Get rights to modify the scene version: Allows the user to modify the currently selected
scene version, but locks access to the version manager during the opened session.

‣ Get rights to modify the scene assets: Automatically gets all the edit rights to modify the
scene and its assets. the user locking the scene using this option is the only user that can
edit and save the scene version, all the drawings in that scene, all the palettes in the palette-
list, both palette-lists, but not the library folders..

9. Choose the version you want to open from the Version menu—see Saving a Scene on page 22.
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‣ The Saved By and Saved Date fields display the user who last saved the selected scene and
the date of the last save.

10. Click Open.

Global Lock
Harmony Network has a lock system, referred to as Global Lock, for the different scenes and scene
assets. As all the data on the server can be accessed directly and modified from any client machine by
default, the scenes are locked. Users must obtain the rights to modify scenes in order to save their
work on the server.

Only one user at a time can modify a scene. Once a scene is opened on a client machine, other users
can only open the scene in read-only mode; they will not be able to save any modifications.

If you work in standalone mode, you automatically have the rights to modify all drawings and palettes.

The Global Lock has three levels:

A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can be
locked. Locking means to get the rights to modify a scene or its assets. Other users cannot modify
locked items. They will be prompted with an error message saying that the scene has been locked by
another user. At that moment the scene will be displayed as read-only.

See the table below to understand the different lock possibilities.

Lock Description

Scene or Version Lock
Controls the Xsheet timing, layers, Network modules but not the draw-
ing, palettes, palette-lists or templates.

Drawing Lock Only one user can edit and save a locked drawing.

Palette Lock Only one user can edit and save a locked palette.

Palette-list Lock Only one user can edit and save a locked palette-list.

Library Folder lock Only one user can edit and save into that folder in the Library.

‣ Get rights to modify the scene: Allows the user to modify the selected version of the scene
and access the version manager during the opened session.

‣ Get rights to modify the scene version: Allows the user to modify the currently selected
scene version, but locks access to the version manager during the opened session.

‣ Get rights to modify the scene assets: Automatically gets all the edit rights to modify the
scene and its assets. the user locking the scene using this option is the only user that can edit
and save the scene version, all the drawings in that scene, all the palettes in the palette-list,
both palette-lists, but not the library folders..

These three levels of locking are available from the Database Selector when the user logs into
Harmony. From there you can select a scene and obtain the rights to modify it by selecting the desired
lock option.
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There are several different ways to obtain the rights to modify the scenes. It can be done when the
user loads a scene from Harmony, inside the application once the scene is loaded, or when an
environment, job or scene is created using the Control Center module.

Acquiring Rights to a Scene Once it is Loaded

If you opened a scene in read-only mode, but realize that you need to modify it, you can easily acquire
the necessary rights without closing and reloading the scene.

Note that it is not possible to acquire the rights to modify the scene assets once the scene is loaded.
This process is done during the initial loading of the scene. To learn more about enabling the rights to
modify while creating environments, jobs and scenes, refer to the Control Center guide.

How to set the scene's rights after the scene is loaded

‣ In the top menu, select File > Rights toModify Scene or Rights toModify Scene Version.
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Welcome Screen

When you start Toon Boom Harmony, the Welcome Screen appears. If a scene is already open, you
can display the Welcome screen by selectingHelp > Show Welcome Screen.

Note that Harmony Network does not display a Welcome Screen. It displays the Database Selector window.

The Welcome Screen allows you to:

1. Create scenes

2. Choose the scene resolution

3. Add or delete a custom scene resolution

4. Open recent scenes from a list

5. Open scenes by browsing

6. Open the Help documentation

7. Open Harmony directly without opening the Welcome screen first.
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To display the Welcome screen later on, go to the top menu and select Help > Show Welcome
Screen.

Accessing the Documentation

How to access the Harmony documentation

‣ In the Documentation section, click on the listed links to access the online documentation.

All the Harmony guides can also be opened directly in the software. From the top menu, select
Help > Help or press F1.
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Saving a Scene

It is important to regularly save your scene. As you make changes to a scene, an asterisk (*) appears in
the title bar beside the scene name to indicate that the scene contains unsaved changes.

It is quite frequent, when working on a scene, to try out different timings, effects, camera motions or
parameters to see which one will work best. Harmony allows you to save a new version of your scene.
It is really important to note that the drawings and palettes are the same between ALL the scene
versions. You can modify the timing, effects, parameters and camera motion, but if you modify the
drawings, they will be changed everywhere.

You can also automatically save your work. Refer to the Preferences guide to learn more about this
function.

When you use Harmony Network and work in a scene on the database, there are many choices and
options available when you save your work.

• Save the scene as the current version.

• Save different versions representing different stages of the production of your scene.

• Save different versions representing different scene setups.

• Choose specific assets that you want to save, such as drawings or palettes.

When you open the scene from the database and select the version you want to edit, you can save the
changes you made in the current version or create a new version. The simplest way to save your work
is to update the current version.

You can delete any unnecessary versions using the Version Manager.

When working with multiple versions, you may want to merge some of the changes from one version
into another. You may have created a version with some suggestions that you submitted to the
director while continuing to work on the official version. If the director has approved some of the
changes, you can go ahead and import them into the official version.

You might want to save some specific aspects of your scene or save a new version. The Advance Save
feature allows you to do this. Once you have chosen the components to save, you will conclude the
procedure by following the instructions in the section. All the specific components that are selected
throughout the different tabs of the Advanced Save dialog box will be saved.

How to save a scene

‣ From the top menu, select File > Save.

‣ Press Ctrl + S (Windows/Linux) or ⌘ + S (Mac OS X).

Auto-Save

How to open the Preferences dialog box

1. Do one of the following:

‣ Windows/Linux: From the top menu, select Edit > Preferences.

‣ Mac OS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. Select theGeneral tab.
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3. In the Save section, select theAuto-save option.

• Interval (minutes): This is the frequency at which the auto-save takes place.

• Inactivity Interval (seconds):When Auto-save is about to take place, it verifies if you are
drawing or doing anything in the application. If so, Auto-save waits this number of seconds
before attempting another save.

• Ask Before Saving: Before performing an auto-save, you are prompted with a message to
confirm if you want to save or not. You can choose to turn off this option.

• Enabled: This enables the Auto-save feature. If you do not want the system to automatically
save your work, deselect this option. The auto-save is off by default.

How to save the current version of a scene in Harmony Network:

1. Make sure that you have the necessary rights to save the current scene version. If you do not, you
can acquire the rights by selecting File > Rights toModify Scene Version or Rights toModify
Scene.

2. From the top menu, select File > Save or press Ctrl + S (Windows/Linux) or ⌘ + S (Mac OS X).

When saving the scene for the first time, the Save dialog box opens, prompting you to name the
version.

3. Edit the information in the current version:

‣ In the This Version field, enter a relevant name for the current version.

‣ In the Description field, enter a short description of the current version.
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4. Click Save.

How to delete versions

1. Make sure you have the necessary rights. If you do not, select File > Rights toModify Scene.

2. From the top menu, select File > Manage Versions.

The Versions dialog box opens.

3. In the Existing Versions list, select the scene version you want to delete. When a version is selected,
information about it appears in the Description list.

4. Click Delete.

The Confirm Delete Versions dialog box opens, warning you that the operation cannot be undone.

5. Click one of the following:

‣ Yes: ONLY if you are absolutely certain that the version can be deleted.

‣ No: To cancel the operation and keep the version.

About the Advanced Save dialog box

1. Make sure that you have the necessary rights to save the current scene version. If you do not, you

48



Toon Boom Harmony 11.1 Sketch Module Network User Guide

can acquire the rights by selecting File > Rights toModify Scene Version or Rights toModify
Scene.

2. From the top menu, select File > Advanced Save.

The Advanced Save dialog box opens.

File

In the File tab of the Save dialog box, you can do the following:
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• Save the scene as a new version

• Overwrite an existing version

• Set a new current version.

Parameter Description

Save

‣ Enable this option if you want to save the modifications
made to the current scene.

‣ Deselect the Save option if you only want to save specific
components of your scene listed in the Drawings, Palettes
or Palette Lists tabs. This will disable all option in the File
tab.

This Version (number)
Saves the current version of the scene. You can rename the current ver-
sion by typing a new name into the field.

New Version (number)
Saves the current scene as a new version. You can name this new version
by typing a name into the field.

Overwrite Existing Version
Lets you select an existing version of your scene from the list to over-
write it.

Description
Use this field to add or edit an existing description for the
scene version you want to save.

Mark as Current
Lets you set this scene version as the current one. This version will be
automatically selected as the default current version when the scene is
selected in theDatabase Selector dialog box

Drawings

The Drawings tab lists the modified drawings.
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Parameter Description

Drawing list
Lets you select the modified drawings to save, and deselect
the ones you do not want to save.

Select All Selects all modified drawings in list.

Deselect All Deselects all modified drawings in the list.

Palettes

The Palette tab lists the modified colour palettes.
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Parameter Description

Colour Palette list
Lets you select the colour palette to save, and deselect the
ones you do not want to save.

Show Recovered
Displays the recovered palettes in the list of modified
palettes.

Select All Selects all modified colour palettes in the palette list.

Deselect All Deselects all modified colour palettes in the palette list.

Palette Lists

The Palette Lists tab lists all the modified colour palette lists.

Parameter Description

Palette Lists
Lets you select the modified palette list to save, and deselect
the ones you do not want to save.

Show Recovered
Displays the recovered palettes in the list of modified
palettes.

Select All Selects all modified palette lists in the list.

Deselect All Deselects all modified palette lists in the list.

How to save with advanced settings

1. After selecting the components to save, click Save.
All the specific components that were selected throughout the different tabs of theAdvanced
Save dialog box are saved.
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How to enable and disable the Open in Read Only mode if plugin syntax errors are
detected preference

How to open the Preferences dialog box

1. Do one of the following:

‣ Windows/Linux: From the top menu, select Edit > Preferences.

‣ Mac OS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. Select theGeneral tab.

3. In the Save section, enable or disable theOpen in ReadOnly mode if plugin syntax errors are
detected option.
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Setting the Scene Length

Once you have opened your scene, you can set its length.

How to set the scene length

1. From the top menu, select Scene > Scene Length.

The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.

New Scene Startup Script
When you create a new scene, the TB_sceneCreated script automatically sets the scene length to 60
frames and adds one of each of the following modules: drawing element, composite, display and
write.

You can find the script in the Script Editor window.

You can customize this script to fit your current project needs. This way, you can set the default scene
length to any number of frames you want, or even decide which types of elements and modules you
want to be in your scene when you create it.

Refer to the Toon Boom Harmony Scripting Guide to learn more about using, creating and
customizing scripts.
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Adding a Drawing Layer

Now that your scene is set up, you can start adding drawing layers.

How to add a drawing layer from the Timeline view

1. In the Timeline view, click the Add Layers button.

2. In the Name field, name your new layer.

3. Set the Line Art option to Vector to get a vector layer or to Bitmap to have a bitmap layer.

4. Click OK.

A new drawing layer is added to the Timeline view.
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Locking Drawings

The drawings are stored on the server database providing access to them from every client machine.
They are locked to avoid different users from modifying the same drawings simultaneously. Only one
person at a time can get the rights to modify them. The drawing rights are independent from the
scene rights because in a production rush, two users may need to work on the same scene to finish
painting the drawings faster. One user will get the rights for one set of drawings, and the second user
the rights to another set of drawings. This prevents work from being duplicated.

When enabled, the Edit Drawings mode gives you the right to modify drawings, as well as create new
drawings by drawing directly on an empty cell. This mode is enabled by default when you open a scene
version with the rights enabled.

If you open the scene with full rights from the Welcome screen or Control Center, the Edit Drawing mode is
not available.

When you disable the Edit Drawing Mode, you can use the Get Rights to Modify Drawings option on a
selection of specific drawings. This is useful when, for example, many users are working on the same
scene during the ink and paint process and they want to split the drawings to paint between them.

Also, once you got the rights to modify drawings, you can release these rights if necessary.

If your system crashes and the drawings remain locked, you can force the release of the rights. You
must use this option carefully as data loss may occur if the scene is currently open and being edited by
another person. Verify that no one else is using the scene prior to forcing the release of the drawing
rights.

Since the drawings are stored on the server, you might at times need to refresh the drawings that are
displayed in your scene.

How to enable the Edit Drawing Mode

1. From the top menu, select Edit > Edit DrawingMode.

How to get the rights on a selection of drawings

1. Make sure that the Edit Drawing Mode is disabled.

2. In the Xsheet view, select the drawings you want to edit.
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3. From the top menu, select Edit > Get Rights toModify Drawings or press Alt + L.

How to release the rights on a selection of drawings

1. In the Xsheet view, select the drawings you want to release.

2. From the top menu, select Edit > Release Rights toModify Drawings or press Alt + Shift + L.

How to force the release of the rights of locked drawings

1. In the Xsheet view, select the drawings you want to release.

2. From the top menu, select Edit > Force Release Rights toModify Drawings.

A Warning dialog box opens.

3. Do one of the following:

‣ Click Yes to force the release.

‣ Click No to cancel the force release.

How to read changed drawings

‣ From the top menu, select File > Read ChangedDrawings.
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Scene Settings

When you created your new scene, you set up the resolution and the alignment. However, if you want
to change these initial settings later, you can do it using the Scene Settings dialog box. The different
Scene Settings options are separated into four tabs.

How to open the Scene Settings dialog box

1. From the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.
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Resolution Tab

Parameter Description

Resolution Presets

You can select your project’s resolution (camera frame size) from this
preset list.

‣ HDTV: High definition television delivers a higher quality image than
standard television (4:3) does, because it has a greater number of
lines of resolution. To take advantage of the superior quality your
output device must be compatible with HDTV technology to make
this resolution setting useful.

‣ HDTV_Vertical: The "vertical resolution" of HDTV_Vertical refers to
how the images will be aligned in relation to the actual scene frame
(default 4:3 grid). Note that the camera resolution and the scene
frame are not the same. When working with 12 or 16 field drawing
grids, the grid is a different aspect ratio from the camera frame.
When you fit vertically, you fit the images with the top and bottom of
the scene grid.

‣ film-1.33: Use this resolution setting for the academy film format
that conforms to the standard 4:3 aspect ratio.

‣ film-1.66: Use this resolution setting for the widescreen film format
that conforms to the 16:9 aspect ratio.

‣ film-1.66_Vertical: This is essentially the same as film-1.66. Refers to
how the drawing is fit into the scene frame. When working with 12 or
16 field drawing grids, the grid is a different aspect ratio from the
camera frame. When you fit vertically, you fit the images with the top
and bottom of the scene frame.
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‣ NTSC: This is the standard analogue television broadcasting system
used in North America and conforms to the North American
standards on how rectangular pixels are displayed for computer and
television screens.

‣ PAL: This resolution works best with the European format for
television and computer screens, as the rectangular pixels are
displayed at a different orientation.

‣ Low: This format is ideal for videos destined for the web, where size
and fast download of a video file might take precedence over
quality.

Selected Resolution
Preset

Displays the selected resolution preset.

Save Resolution Set-
ting

Click the Save Resolution button after you define your new resolution
to save it as a preset.

If you are working in Harmony Network, you will be prompter a dialog
box asking you to name the new resolution as well as the level at
which you want to save the resolution,conf file.

Pixel Dimensions

Displays the pixel dimensions for your project resolution.

If you decide to type in the pixel dimensions, or use the up and down
arrows to change the pixel increments, you will have to save your
custom selection in order to save it as a new preset. It will then appear
in the resolution selection list. It doesn't modify the current resolution
preset.

Aspect Ratio
Displays the ratio between the horizontal and vertical dimensions of the camera
framing. Each resolution setting has a preset aspect ratio that cannot be
changed.

Frame per second

Sets the frame rate for your project. The higher the frame rate, for
example 30 fps, the faster the animation will pla. The lower the frame
rate, for example 12 fps, the slower your animation will play. Avoid
going under 12 frames per second as your animation will have a
choppy playback. The human eye requires a minimum of 12 frames per
second to perceive a fluid animation.

Field of View
Use these options to define the FOV (field of view) of the camera
(angle of the camera cone) and how the drawing elements (and
drawing grid) align to the scene grid. The drawing grid is always

60



Toon Boom Harmony 11.1 Sketch Module Network User Guide

scaled proportionally to a 4:3 ratio (unless you change the scene
alignment), therefore changing the Field of View setting may not show
a visible difference if your project resolution is also 4:3, such as NTSC.

‣ Horizontal Fit: The camera resolution is set to fit the left and right
edges of the scene grid.

‣ Vertical Fit: The camera resolution is set to fit the top and bottom
edges of the scene grid.

‣ Custom Fov: After selecting this option, use the now-active field to
the right to enter in a value, in degrees, of the angle that you want
the camera cone to be. Increasing this value will make the camera
cone wider (the angle is more obtuse), widening the FOV and
making the grid and all elements appear farther away. Decreasing
the default value will create the opposite effect.

Projection

The Projection settings allows you to modify the type of camera your
scene is using. You can either use a perspective camera (regular
camera) or orthographic camera (no perspective).

‣ Perspective: The Perspective option is the default and most
common option. Objects placed closer to the camera will be
displayed bigger and objects placed further away will be displayed
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smaller.

‣ Orthographic: The Orthographic option is very specific to the
gaming pipeline. It changes the camera from Perspective to
Orthographic, meaning that there is no more perspective in the
Camera view. Objects, when moved in depth will not change size.
There is more information available about this option in the Gaming
user guide. In order to create scenes with the Orthographic camera
by default, you need to create a new custom scene resolution.

Alignment Tab

Parameter Description

Alignment

The Alignment presets give you two preset options:

‣ 4:3 12 Fields: Defines the units of your project to have a 4:3 ratio
and sets up 12 of these units to run both vertically and horizontally in
four cardinal quarters (NW, NE, SW, SE). This Alignment preset is
visible in the FOV and drawing grids.

‣ Square 12 Fields: Defines the units of your project to have a 1:1 or
square ratio and sets up 12 units to run both vertically and
horizontally in four cardinal quarters (NW, NE, SW, SE). This
Alignment preset is NOT visible in the FOV and drawing grids.

Units Aspect Ratio

In the Units Aspect Ratio fields, enter the aspect ratio of the grid you
will use. The aspect ratio describes the shape of the grid unit. A
square grid unit would have the ratio 1:1, whereas a grid unit of aspect
ratio 4:3 is a unit with one side 1.33 times as big as the other side.
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If the aspect ratio you want to use is 1:1, enter 1 in the Left/Right field
(X-axis) and 1 in the Up/Down field (Y-axis). The default Aspect Ratio is
set to 4:3 as it is the one used by traditional animators, who are
accustomed to working with the grid system described above.

Number of Units

In the Number of Units fields, enter the number of horizontal, vertical
and depth units for your scene’s grid.

Animators who prefer to work traditionally will understand the default
setting of 24 units horizontal by 24 units vertical as it, once again,
corresponds to the grid above. Twelve is a common setting for the
field depth.

Those who prefer to work in pixels should enter the pixel dimensions
(3) of their project. This way if you want to move something over 600
pixels you just need to type in 600 units.

Coordinat
es at
Centre

In the Coordinates at Centre, you can enter a new coordinate for the
centre of your scene.

By default, the (0,0) centre is set in the middle of the grid as shown in
the grid above. If you want to change the centre of your grid, for
example to the upper left corner, you would enter (-12, 12), -12 units
across and 12 units up. That is of course unless you changed the
number of units to match the pixel dimensions of your scene. Then you
would enter negative half the width and positive half the height.

Save
Saves your current Alignment settings and be able to select them later from the
list.
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If you change your scene‘s alignment from 4:3 12 Fields to Square 12 Fields part way though your project,
you may find that the animation grid becomes offset. To correct this, choose the following setting from the
Layer Properties panel‘s Advanced tab: Alignment > Alignment Rule > Centre First Page.

Bitmap Resolution Tab

The bitmap resolution settings at the scene level affects newly created bitmap art layers.

Parameter Description

Scene Resolution This is the scene resolution preset name and size in pixel.

Width

This is the width of the resolution for the bitmap that will be created.
This is not the actual size of the bitmap. TVG drawings (Toon Boom
drawing native format) have an infinite size. Bitmap TVGs are composed
of small tiles. Therefore it does not mean that because you have art-
work at the four corners of your camera frame or even quite far outside
of your drawing that your bitmap image will be very large and heavy. By
default, it is set to the same width as the scene resolution.

Height
This is the height of the resolution for the bitmap that will be created.
By default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene res-
olution. If you increase the percentage, the width and height fields will
increase accordingly. If you plan to animate the camera and zoom into
your background, you will need to set a higher resolution so that the
smaller area in which you will zoom will be 100% of the scene resolution.
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Advanced Tab

The Advanced tab contains an option for Toon Boom Digital Pro release 7.3 and Harmony release
7.3.

Since version 7.8, the method in which Z-Ordering is calculated has been optimized. Enable this
option if you want to use the version 7.3 system.

Toon Boom Digital Pro and Toon Boom Harmony 7.3 allowed smaller values on the Z-axis such as
0.0001. Since version 7.8, the Z-ordering calculation is now optimized and allows only larger values
such as 0.001.
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Verifying the Project Integrity

The Check Files command verifies the integrity of the drawing and palette files in your project.

How to open the Check Files dialog box

‣ From the top menu, select File > Check Files.

Check Files

Use the Check Files dialog box to verify that the data is consistent, correct, and accessible.

• Click Check Colours to open the Check Colours dialog box.

Check Colours

The Check Colours dialog box checks the palette integrity and displays the colour recovery data.

66



Toon Boom Harmony 11.1 Sketch Module Network User Guide

Related Tasks

Saving a Scene 22
Setting the Scene Length 30
Adding a Drawing Layer 31
Reference Materials

Scene Settings 34
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Basic Commands

This table lists the most common commands used in Harmony.

Command Action Access Methods

Open Displays the Open
Scene dialog box.
Browse your file system
for a scene file.

The Open command is
not disabled when a
scene is opened. You
can open a new scene
from the current one
and the previous scene
will be closed.

File > Open

Press Ctrl + O
(Windows/Linux) or ⌘
+ O (Mac OS X).

Close Closes the currently
opened scene, but does
not close the Harmony
application.

File > Close

Save Saves all changes made
to the opened scene,
drawings, palettes, and
palette lists.

File > Save

Press Ctrl + S
(Windows/Linux) or ⌘
+ S (Mac OS X).

Quit Closes
HarmonyHarmony
Stage.

Windows/Linux: File >
Quit

Mac OS X: Stage>
Quit

Cut Removes selected
objects. You can then
paste the object or its
properties to another
object.

Edit > Cut

Press Ctrl + X
(Windows/Linux) or ⌘
+ X (Mac OS X).

Copy Copies selected objects
and properties.

Edit > Copy

Press Ctrl + C
(Windows/Linux) or ⌘
+ C (Mac OS X).

Paste Places an object you cut
or copied into the
location you select in
the Camera, Drawing
and Timeline views.

Edit > Paste

Press Ctrl + V
(Windows/Linux) or ⌘
+ V (Mac OS X).
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Command Action Access Methods

Delete Removes selected
objects.

Edit > Delete

Delete

Select All Selects all drawing
objects in the current
drawing window in the
Drawing, Timeline and
Camera views. This
helps you manage
multiple objects as one
when moving them.

Edit > Select All

Press Ctrl + A
(Windows/Linux) or ⌘
+ A (Mac OS X).

Deselect All Deselects all selected
objects in the Drawing
and Camera views.

Edit > Deselect All

Esc

Undo Removes remove the
last change made to
your project. Harmony
supports multiple undo,
so you can undo
changes you made in
the order you made
them.

Edit > Undo

Press Ctrl + Z
(Windows/Linux) or ⌘
+ Z (Mac OS X).

Redo Redoes and operation
you have undone that
you later decide to
keep. This command is
active only after you use
the Undo command.

Edit > Redo

Press Ctrl + Shift + Z
(Windows/Linux) or ⌘
+ Shift + Z (Mac OS X).

Help Launches the Toon
Boom Harmony Online
Help system, complete
with instructions on
how to use the system.
This requires an
internet connection.

Help > Help

Toon Boom Harmony
on the Web

Launches the Toon
Boom Harmony
website, which features
a Support and
Community > Forum
section.

Help > Toon Boom
Harmony on the Web

About Use the About
command to access
general information
about the software.

Windows/Linux: Help
> About

Mac OS X: Stage >
About
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Preferences

An important feature of Toon Boom Harmony is the Preferences dialog box. From here you can
customize your interface, tool behaviour and shortcuts. Throughout this guide, you are often required
to go to the Preferences dialog box to set parameters and options.

To learn about the different preferences available, refer to the Preferences Guide.

How to open the Preferences dialog box

1. Do one of the following:

‣ Windows/Linux: From the top menu, select Edit > Preferences.

‣ Mac OS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).
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Chapter 5: Interface
Knowing how to manage the Toon Boom Harmony interface helps you to work efficiently and organize
your workspace conveniently. There are a series of views and toolbars you can use as you perform
different operations. Usually, each person has a specific way of working in the interface and prefer
particular views and toolbars. In this chapter, you will learn about the main elements of the interface
and how to manage them.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. Sketch is a subset of
Harmony Stage.

The Harmony interface is set to a dark theme by default. You have the option of switching to a light
theme.

How to change the interface theme

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS
X) .

The Preferences dialog box opens.

2. Select theGeneral tab.

3. In the Options section, deselect theUse Dark StyleSheet option to use the light theme.

4. Restart Harmony.
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This chapter is divided as follows:

• Menus on the facing page

• Managing the Views on page 51

• Managing the Toolbars on page 55

• Managing the Workspace on page 60

• View References on page 65

• Toolbar References on page 88

• Interface Navigation on page 91
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Menus

Harmony has a large number of functions and options that you can access from the following menus:

Top Menu

The top menu contains most of the commands. Depending on the view you are working in and the
element, some commands are available and others not. The top menu is always located at the very
top of the interface.

The top menu contains the following categories:

• File

• Edit

• View

• Layers

• Scene

• Drawing

• Windows

• Help

On Mac OS X, there is a Stage category containing the following commands:

• Preferences

• About

• Quit

View Menu

Some views have their own menu. These menus contain commands specifically related to that view.

How to access the view menu

1. In the view's top-left corner, click the Menu button.

A list of commands is displayed.

You can find a view menu in the following views:
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• Camera view

• Colour view

• Drawing view

• Function view

• Integrated Help view

• Library view

• Model view

• Module Library view

• Network view

• Perspective view

• Script Editor view

• Side view

• Timeline view

• Top view

• Xsheet view

Quick Access Menu

Each view has a quick access menu containing commands you will use most often. This menu is
accessed by right-clicking anywhere in the view.
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Managing the Views

The Harmony user interface is composed of different views, each one designed for a specific purpose.
You can modify the location and accessibility of the views by adding a new view as a tab or as a
window. You can also swap the view locations around.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. Sketch is a subset of
Harmony Stage.

It is important to know about the active view. When a view is active, a red rectangle appears around
the view. Keyboard shortcuts and top menu options are linked to the active view. If a menu option is
greyed out, it either means it does not apply to your layer, drawing or other type of selection or the
option does not apply to the active view.

Workspace modifications are automatically saved when you exit the application unless you deselected
the Automatically Save Workspace option in the Preferences dialog box.

How to add a view

1. Select the view you want to add fromWindows > the desired view.

‣ You can also use the Window drop-down menu button in each view. Click theAddView
button and select a view from the list.You can open several instances of the same view
except for the Timeline, Tool Properties, Colour and Drawing views.
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By default, the view appears tabbed.

How to dock a floating window in the workspace

1. Drag the window’s tab onto one of the workspace’s views. You can drop the view onto the other
existing tabs to tab the view with the other ones. You can also drop the view onto either side of an
existing view to insert the floating one beside it. When you get close to one of the edges, a black
rectangle will appear, indicating where the view will be inserted.

How to close a view

1. Click the Close View
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button.

‣ If there are several tabs in the same window, hold Shift down and click the Close View
button to close all tabs together.

How to swap views around

1. Select the view's tab and drag it onto one of the view’s separators, top area or onto another
view’s tab.

2. When a blue rectangle outline appears showing an available location for the view, release the
mouse button and drop the view tab into position. One of three things will happen:

• The view becomes a tabbed window.

• The view becomes a floating window.

• The view becomes a new docked window.

How to resize a view

1. Position your cursor on the edge of the view you want to resize.

2. When you see the Resizing cursor, click and drag the side of the window to the desired width
or height.
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You can also temporarily hide a view to get more working space.

How to temporarily hide a view

1. On the edge of the window you want to hide, click theCollapse/Expand button.

The view is compressed and only the Collapse/Expand button is visible.

2. Click theCollapse/Expand button again to redisplay the view.
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Managing the Toolbars

Harmony contains toolbars which, by default, are located at the top of the interface. Some of the
workspace’s views also have their own toolbars which you can move around. You can reposition the
toolbars to suit your work style or hide unused ones.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. Sketch is a subset of
Harmony Stage.

You can display or hide toolbars using the menus. The Toolbar menu only contains the View toolbars
of the views that are displayed in the workspace. As you show or hide views in your workspace, the
Toolbar menu updates.

The top toolbars can also be displayed directly in a view. Only one instance of each toolbar can be
displayed. If a toolbar is already displayed in the top area and you decide to display it in a view, the
selected toolbar will move from the top area to the view.

The View toolbars can be customized to contain your favourite tools and options. Using the Toolbar
Manager window, you can organize different toolbars to suit your working style.

If you prefer to have all your tools visible in the Tools toolbar, the Flat Tool Toolbar option allows you
to expand the toolbar so there are no nested toolsets in the toolbar. When you set this option, you
will need to close Harmony and restart it for the new interface to be displayed. A default set of tools
will appear in the toolbar. However, you can customize which tool icons appear in the toolbar to fit
your work pattern.

If the default toolbar does not contain the tools you require, you can customize the toolbar.

Once you are displaying the flat toolbars, you can customize the tools which appear in the toolbar.
This means that you can change the default set of tools and replace the tools you use less frequently
with ones use more often. This customizing is done through the Toolbar Manager.

How to show and hide a toolbar

1. From the top menu, selectWindows > Toolbars > the desired toolbar.
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‣ You can right-click anywhere in the toolbar area to access Harmony toolbars. View toolbars,
however, are not available by right-clicking the toolbar area. You can access the toolbar of
any open and active view by right-clicking in the view's top area or the Windows menu.

How to resize a toolbar

1. Hide a portion of a toolbar by dragging another open toolbar over its tail-end.

2. Click on the arrows appearing at the end of the collapsed toolbar to expand it.

80



Toon Boom Harmony 11.1 Sketch Module Network User Guide

How to move a toolbar

1. Select the toolbar you want to move by clicking its anchor point and dragging it into a view toolbar
area or another position in the top or side interface toolbar area.

2. When a highlighted zone appears showing an available location for the toolbar, release the mouse
button and drop the toolbar into position.

‣ 1. Dock to the top toolbar area.
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‣ 2. Move a toolbar down a row.

‣ 3. Dock to the left toolbar area.

How to customize a view toolbar

1. In the chosen view, right-click on any button in the toolbar where you want to add or subtract a
new button. You can also reorder the buttons. Make sure the button you right-click on is active.

2. From the menu, select Customize.

The Toolbar Manager window opens.

3. To add a new icon to your toolbar, select the tool or command from the Available Tools list and
click the Right Arrow button to switch it to the Toolbar list.

4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click the
Left Arrow button to switch to the Available Tools list.
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5. To reorder the icons in your toolbar, select the command to be moved from the Toolbar list and
click the Up or Down buttons to move it to the correct location.

6. Click OKwhen you are finished.

How to use enable the Flat Tool Toolbar preference

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS
X).

2. In the Preferences dialog box, select theGeneral tab.

3. Select the Flat Tool Toolbar option.

4. Click OK.

5. Save your work and close Harmony.

6. Restart Harmony.

The Tools toolbar no longer contains nested tools.
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Managing the Workspace

The Harmony interface is composed of several views. You can customize your workspace to suit your
working style, save it as a new workspace, and load it from the Workspace toolbar.

The first time you open Harmony, the default workspace is loaded. Other workspaces are available
such as the Hand-Drawn Animation and Compositing workspaces. These display different views and
toolbars. You can access these workspaces, and any others you create, from the Windows menu and
the Workspace toolbar.

By default, when you modify the look of a workspace, it is automatically saved. If you prefer to keep
your workspaces as they are and only save the modifications when you really want to, you must disable
the Automatically Save Workspace option.

The Workspace Manager allows you to modify, create, delete, rename and reorder you workspaces.
You can save your workspace as a new version to avoid over-writing the current one. If you do not
want to modify the current workspace, use the Workspace Manager to create another one and then
modify that one.

You can also restore modified workspaces to their original default layout if you do not like the current
modifications or inadvertently closed some windows.

How to load a workspace

1. Do one of the following:

‣ From the top menu, selectWindows >Workspace >Workspace.

‣ Select a workspace from the Workspace toolbar.

How to open the Workspace Manager
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1. Do one of the following:

‣ In the Workspace toolbar, click the button.

‣ From the top menu, selectWindows >Workspace >Workspace Manager.

How to create a new workspace

1. Open the Workspace Manager.

2. In the Available Workspaces list, select an existing workspace.

3. At the bottom of the Available Workspaces list, click the Add button to add a workspace.

4. Select the new workspace that was created. Click Rename and give it a new name.
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5. Select the new workspace and click the Right Arrow button to move it to the Workspace
toolbar.

6. Click OK.

How to rename a workspace

1. Open the Workspace Manager.

2. Choose the workspace to be renamed from the list.

3. Double-click on the workspace to be renamed or click the Rename button. This allows you to edit
the name.

4. Type in the new name of the workspace.

5. Press the Enter/Return key to validate the name.

6. Click OK.

How to disable the Automatically Save Workspace preference

1. From the top menu, select Edit > Preferences (Windows/Linux) orStage > Preferences (Mac OS
X) to open the Preferences dialog box.

2. Select theGeneral tab.

3. In the Options section, deselect theAutomatically Save Workspace option.

4. Click OK.
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The Save Workspace button appears in the Workspace toolbar.

How to save a workspace manually

1. Do one of the following:

‣ In the Workspace toolbar, click the Save Workspace button.

‣ You can also selectWindows >Workspace > Save Workspace.

How to save your workspace as a new version

1. From the top menu, selectWindows >Workspace > Save Workspace As.

The Save Workspace As dialog box opens.

2. Type in a workspace name and click OK.

How to delete a workspace

1. Open the Workspace Manager.

2. In the Workspace Manager, select the workspace to be deleted and click the Left Arrow
button to move it to the Available Workspaces list.

3. Select the workspace from the Available Workspaces list, then click the Delete button to
delete the workspace.

4. Click OK.

How to show a workspace

1. Open the Workspace Manager.

2. In the Available Workspaces list, select the workspace to be displayed and click the Right Arrow
button to move it to the Workspace toolbar.

3. Click OK.

How to hide a workspace

1. Open the Workspace Manager.

2. In the Workspace Manager, select the workspace to be hidden and click the Left Arrow button
to move it to the Available Workspaces list.

3. Click OK.
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How to reorder workspaces

1. Open the Workspace Manager.

2. In the Workspace toolbar, select the workspace to be reordered and on the Up or Down
buttons to move it up or down.

3. Click OK.

How to restore the default workspaces

‣ From the top menu selectWindows > Restore Default Workspace.
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View References

Harmony contains a series of views that are each focused on a specific set of tasks. Here are the views
available:

• Camera view

• Colour view

• Message Log view

• Model view

• Script Editor view

• Timeline view

• Tool Properties view

• Xsheet view

Camera View
The Camera view is the centre of operations in Harmony. In this view, you will draw, paint, animate,
create animation paths and see your results. You can also move through your symbol’s hierarchy.

The Camera view has a top and bottom toolbar that you can use to navigate in the view, change the
display mode, or go back up your symbols hierarchy.
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1. Light Table

When you have a drawing layer or drawing selected, the Light Table button button allows you to
fade the colours of the other layers so you can see the current artwork better as you edit with a
drawing tool. Note that the light table does not work when using a layer editing tool such as the
Transform tool.

2. Current Drawing On Top

When this button is enabled, the drawing that you are currently editing with a drawing tool is
temporarily displayed in front of all the other elements. The actual scene is not modified.

3. Camera Mask

The Camera Mask button shows or hides a black mask around the scene’s frame to avoid seeing
the unnecessary artwork. This option is handy when you are animating and setting up the scene. It
allows you to see your scene’s composition better.

You can also access this feature from the top menu by selecting View > Show > CameraMask.
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4. Safe Area

The Safe Area button shows or hides the TV safety zone and the centre of the camera frame. The
Safe Area will adapt to the scene resolution as well as the safety zone and frame’s centre.

You can also access this feature from the top menu by selecting View > Show > Safe Area.

6. Outline Locked Drawings

Drawings that are locked in the Timeline view (cannot be selected in the Camera view) will be
displayed as wireframes.

7. Reset View

The Reset View button will reset any panning, zooming or rotation done in the Camera view and
return the display to the initial settings. You can also press Shift + M.

8. Zoom Menu

The Zoom menu lets you enlarge or reduce the Camera or Drawing view display.

To make the camera frame size always match the size of your view, select the Fit to View option.
Click the drop-down arrow and select a zoom level or press 1 and 2.
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9. OpenGL View Mode

The OpenGL View Mode button switches the Camera view to fast display, letting you see your
animation play in real time. The OpenGL display requires less memory. The final look of your effects
is not shown in the OpenGL View Mode. You must switch to the Render View Mode to see your
effects.

9a. Render View Mode
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The Render View Mode button switches the Camera view to a fully rendered display showing the
final image of the current frame. If a modification is done to your current frame or if you move to a
different frame, click theUpdate Preview button to update the display if your preview does not
update automatically.

The Render View Mode display lets you see the final look of your frames including effects and
antialiasing. You cannot play back your scene in Render View Mode. To see your scene fully rendered
and to play it back, you must press the Render and Play button in the Playback toolbar.

9b. Matte View Mode

The Matte View Mode button switches the Camera view to a matte display showing the alpha
channel of the elements in your scene. The transparency level ranges from 0 to 100 percent. Zero
percent is completely transparent and represented by black and 100 percent is completely opaque
and represented by white. Everything in between these extremes has a transparency level
somewhere between 1 and 99 percent and is represented in various shades of grey.

‣ To access the Matte View mode, click on the Render View Mode button and select
Matte View from the drop-down menu.

10. Drawing Name

The Drawing Name field displays the name of the selected drawing, as well as the layer containing it.
If the cell does not contain any drawing, an Empty Cell text is shown in the field.

11. Tool Name

The Tool Name field displays the name of the selected tool. If you temporarily override a drawing
tool using a keyboard shortcut, the tool’s name will be highlighted in red. You can temporarily
override a tool by holding its keyboard shortcut without the [Alt] key. For example, the Select tool
shortcut is Alt + S. If you hold down [S], you will switch to the Select tool. As soon as you release the
key, you will return to the tool you were using.

12. Frame Number

The Frame Number field displays the number of the current frame.

13. Selected Colour

The colour swatch displays the currently selected colour in the Colour view.
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14. Camera View Toolbar

The Camera View toolbar contains all the tools and options you can use in the Camera view to draw,
animate or set up the scene. The toolbar can be displayed or hidden by right-clicking on it and
selecting or deselecting the Camera View toolbar.

15. View Menu

The View menu contains all the tools and options that you can use in the Camera view to draw,
animate or set up the scene.

16. Editing Stack Menu

The Editing Stack menu displays the names of the symbols and their hierarchy when you are editing a
symbol. You can click on the different names to go back up to the different parent symbols or the
top/current project.

Colour View
The Colour view is where you create colours and palettes and import existing palettes into your
project. The Colour view is also necessary for drawing, painting and creating colour styling.

The Colour view has two display modes:
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• List mode

• Swatch mode

How to switch between the display modes

1. From the Colour View menu, select Colours > Swatch Mode and do one of the following:

‣ Select the option to display the swatches.

‣ Deselect the option to display the colour list.

When you are painting on bitmap layers, the Colour view will look like the following. It contains a
subset of the tools available when working with vector layers.

1. Add Colour

The Add Colour button lets you add a new colour swatch to the bottom of your colour list.

2. Remove Colour

The Remove Colour button lets you delete the currently selected colour swatches. If the colour
swatch is used in your project, the Delete Colour dialog box will appear asking you to confirm the
operation.
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‣ Click OK to confirm the operation or Cancel to cancel it.

Zones painted with colour swatches which have been deleted will turn red, easily identifying them so
you can repaint them with another colour swatch.

3. Add Texture

The Add Texture button lets you add a bitmap colour swatch to your palette. You can load
photos and textures and paint your drawings with it. The bitmap image must be a TGA or PSD file
format.

4. Set Current Brush Colour

The Set Current Brush Colour button let you set the currently selected colour swatch as the
colour used by the Brush tool. If you select a new colour in the Colour view while using the Brush
tool, the Set Current Brush Colour swatch will be updated.

5. Set Current Pencil Colour

The Set Current Pencil Colour button lets you set the currently selected colour swatch as the
colour used by the Pencil , Polyline , Ellipse , Rectangle and Line tools. If you
select a new colour in the Colour view while using any of these tools, the Set Current Pencil Colour
swatch will be updated.

6. Set Current Paint Colour

The Set Current Paint Colour
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button lets you set the currently selected colour swatch as the colour used by the Brush
tool. If you select a new colour in the Colour view while using the Paint tool, the Set Current Paint
Colour swatch will be updated.

7. Link/Unlink Three Colours

The Link/Unlink Three Colours button lets you link the Set Current Brush Colour, Set Current
Pencil Colour and Set Current Paint Colour swatches to the currently selected colour swatches in the
Colour view.

8. Show/Hide Palette List View

The Show/Hide Palette List View button lets you display the Palette List view in the Colour view. This
option is for the advanced user who wants to create colour palettes for their props and characters.

9. Colour Swatch Name

Each colour swatch available in the Colour view can have its own name, making it easy to identify
which colour is used to paint what part of your character or background.

Two colours can have the same name.
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10. Colour Swatch

A colour swatch is a specific colour used to paint a certain zone of a character or background. Colour
palettes are composed of colour swatches. They can also be called colour pots. When you paint a
zone with a colour swatch, the zone is linked to the swatch. So if you update the swatch’s tint, the
zone will be updated along with it. This allows you to modify your animation colours even after it is
completely painted.

11. Colour View Menu

The Colour view menu lets you access commands related to the Colour view such as creating
new palettes, adding new colour swatches, and displaying the Tint panel.

12. Add Palette

The Add Palette button lets you add a new palette to the bottom of your palette list.

13. Remove Palette

The Remove Palette button lets you delete the currently selected palette. If the colour swatch is
used in your project, zones painted with colour swatches which have been deleted will turn red,
easily identifying them so you can repaint them with another colour swatch.

14. Link Palette

The Link Palette button lets you access other palettes created in the project and link them to your
scene.

15. Order Palette List

The Up and Down arrows let you reorder the selected palette. When using clone palettes (colour
styles), the highest palette is the list will override its clone located lower in the list.
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16. Edit Palette Mode

In Network mode, the Edit Palette Mode button lets you get the rights to modify the palette.
The palette files can be locked to avoid accidentally modifying the palette.

Message Log View
The Message log view displays information gathered during a render task, such as which frames and
at what time they were each rendered. The view also contains a list of the colour recovery operations.

Model View
Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view.
This drawing can be used and loaded in any of your Harmony scenes.

Once a drawing is loaded in the Model view, you can use the Dropper tool to select a colour from
the model and use it to paint in the Camera or Drawing view without having to pick the colour from
the colour palette.
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Script Editor View
Qt Script provides access to many of the functions supported in the interface. With Qt Script, you can
automate a number of Harmony functions to speed the completion of various repetitive tasks. The
Script Editor view allows you to edit existing scripts and create new ones. Refer to the Scripting guide
to learn more about scripting with Harmony.
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Script List

On the left side of the Script Editor view, all existing script files are listed and can be modified in this
view. The script format is JavaScript. Click on a file to display its content in the Script Content
window of the view.

Script Content

On the right side of the Script Editor view, the contents of the selected script are displayed and can
be edited.

Search Toolbar

The Search toolbar allows you to search a string within the selected script content. You can use the
Previous and Next buttons to navigate through the results.

Syntax Check

This function verifies the syntax of the currently displayed script and lists any error found.

Save Changes

Once you are satisfied with the modifications made to the script, click Save Changes to save the
modifications.

Timeline View
To set your animation timing, you will mostly work with the Timeline and Xsheet views. It is extremely
useful to become familiar with the Timeline view, how it works, and its interface.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. Sketch is a subset of
Harmony Stage.

The Timeline view is the main view used when adjusting the timing of drawings and ordering layers.
The Timeline view displays layers, scene length, layer names, drawings and frames.
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The Timeline view allows you to read your timing from left to right. It represents the scene’s elements
in their simplest form. You can also see the layers and their names, as well as the drawing’s exposure.
The drawing name is displayed when you place the cursor above the drawing’s exposure.

1. Enable/Disable All

The Enable/Disable All button is used to show or hide all layers simultaneously.

When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet
view. When a column is hidden in the Xsheet view, the corresponding layer is disabled in the Timeline
view.

To disable a particular layer, deselect the layer’s checkbox or press D.

To enable a particular layer, select the layer’s checkbox or press A.

2. Show Selection and Hide All Others
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The Show Selection and Hide All Others button is used to show only the currently selected layer
in the Timeline view and disable all the other layers.

3. Add Layers

The Add Layers button lets you add new layers to the Timeline view.

4. Delete Layers

The Delete Layers button lets you delete the currently selected layers in the Timeline view.

5. Current Drawing Displayed

The highlighted drawing represents the drawing currently displayed and is linked to play head
position.

6. Current Frame

The red play head represents the current frame displayed and marked in the Playback toolbar. If you
slide the play head to the left or right, it will scrub through your frames and update the Camera view.

7. Change Track Colour

The Change Track Colour button lets you change the colour of the exposed frames; this helps
you to quickly locate a layer in the Timeline view. Double-click on the colour swatch to open the
Select Colour window and choose a new colour. You can modify the layer for any type of layer, such
as group, peg, drawing, and effects.
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8. Lock/Unlock Layer

The Lock/Unlock Layer button lets you prevent the selection or editing of a layer in the
Camera view. To select some of the layers without selecting others, in the Timeline view, lock the
layers you do not want to select.

You can display the locked drawings as outlines in the Camera view to quickly find out which
drawings are locked.

How to display locked drawings as outline

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac
OS X).

2. In the Preferences dialog box, select theCamera tab.

3. In the Tools section, select the Show LockedDrawings As Outlines option.
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9. Onion Skin

The Onion Skin button enables the Onion Skin option on a particular layer. If you want to see the
previous and next frames of a specific layer, go to the Timeline view and click the Onion Skin button
for that particular layer. Blue arrows appear on both sides of the play head. Pull on the blue arrows
to add more frames to the onion skin display.

To activate the general Onion Skin preview, in the Tools toolbar, click the Onion Skin button.

10. Zoom

The Zoom tool is used to increase or reduce the width of the frames in the Timeline view. Drag the
cursor to the right to increase the width or to the left to reduce it. You can also press 1 and 2.

11. Drawing Exposure

In the Timeline view, when a drawing is exposed, it is represented as a grey block. If the drawing is
exposed for several frames, the block is extended. When a second drawing is exposed, a new grey
block is displayed.

• The exposure’s colour can be changed. To pick a new colour, double-click on the Change
Track Colour button in the corresponding layer.

Tool Properties View
The contextual Tool Properties view contains the most common options and operations related to the
currently selected tool. As soon as you select a tool from the Tools toolbar, the Tool Properties view
updates.

For example, if you choose the Select tool in the Tools toolbar, the Tool Properties view will display
the options and operations related to the Select tool, such as Snap to Contour, Apply to All Drawings,
Flip Horizontal, and Flatten.
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Options

Options are different modes you can apply to a selected tool to modify its behaviour to fit the
current task’s needs.

Operations

Operations are actions you can perform while using the selected tool.

Xsheet View
The Xsheet view lets you read the timing vertically, displays the drawing layers as columns, and shows
the drawing’s name. You can also see the functions and keyframes of the motion paths in the Xsheet’s
function columns. The value of each keyframe is shown in the Xsheet view; these are displayed as black
squares in the Timeline view. The Xsheet view contains more details than the Timeline view, and is
faster and easier to read.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. Sketch is a subset of
Harmony Stage.
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1. Xsheet Main Section

The Xsheet view has three sections. By default, only the main section is visible. It displays the drawing
layers, also known as drawing columns.
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2. Column List Section

The Column List section allows you to show and hide columns in the Xsheet view. When you hide a
layer in the Xsheet view, it is also disabled in the Timeline view.

You can use the Column List to hide individual columns or hide an entire column type (drawing or
function) from the Xsheet view. By default, the Functions section is hidden.

How to display the Column List section

1. In the Xsheet view, click the Expand button on the right side of the main section to show the
Functions section. Click on the same button to collapse it. You can also use the Show Column List

button in the Xsheet View toolbar.

‣ In Harmony, you can also go to the Xsheet view menu and select View > Show Column
List.

2. Click the Expand button on the right side of the Functions section to display the Column List
section.
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3. Xsheet View Toolbar

The Xsheet view has its own toolbar where you can find the most common features. This toolbar is
displayed by default. If you do not see it, selectWindows > Toolbars > Xsheet View.

The Xsheet view must be part of your workspace in order to display its toolbar.

4. Column Header

Each column available in the Xsheet view has a header displaying the column’s name. The column’s
name is the same as the corresponding timeline layer. If you rename one or the other, they will both
be renamed.

A quick access menu is available when you right-click. This menu contains the command affecting an
entire column such as renaming, changing the default colour, or deleting a column.

The tooltip that appears when you hover at the top of each Xsheet column shows the folder path to
the source drawings for that column.
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5. Current Drawing

A drawing selected in dark red indicates that the drawing is currently displayed in the Drawing and
Camera views. The current drawing selection is not linked to the drawing displayed in the Camera
view since drawings from each visible layer are displayed at once.

5a. Current Frame

The darker frame appearing in the Xsheet view represents the current frame.

6. Drawing Exposure

In the drawing columns, you can see the drawing names and their exposure. You can use any
alphanumeric symbol to name your drawing. When a drawing is exposed over more than one cell, a
vertical black line is displayed to indicate the continuity of the exposure. When there is no drawing in
a cell, the cell will be blank.

7. Frame Numbers
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On the left side of the Xsheet view, the frame numbers are shown indicating where you are. These
read vertically instead of being displayed horizontally as they are in the Timeline view.

• To go to a particular frame, click the frame number.

• To select an entire range of frames, click and drag a selection downwards.

8. Current Frame Display

At the bottom-right of the Xsheet view, you can see the current frame number, as well as the column
containing the drawing currently displayed in the Drawing view.

10. Increase/Decrease Exposure

You can quickly increase or decrease the exposure of the selected cell by clicking on the up and down
arrows in the Increase/Decrease Exposure field.

11Overwrite/Insert Modes

The Overwrite/Insert button allows you to decide the way the values are inserted into the Xsheet.
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Toolbar References

Harmony has several toolbars. The Top toolbars are available at the top of the interface and the View
toolbars are in individual windows. View toolbars are only shown if the particular view is displayed in
the workspace. This is a complete list of the toolbars available in Toon Boom Harmony.

Top Toolbars

Art Layer

A drawing is composed of two layers, a line layer and a colour layer. The colour layer is always placed
under the line layer. These layers are accessible in the Drawing or Camera view (using drawing tools).
When you view the final drawing, you will see the final composition of the lines and colours, not two
separate layers. You need to change your Preferences to allow the use of those advanced Art layers
in order to see them.

You can draw and paint in all layers. If you prefer to work in a single layer, everything can be done in
Line Art.

• Line Art

• Colour Art

Edit Toolbar

The Edit toolbar contains common operations such as Copy, Paste, Cut, Undo and Redo. These
options can also be found in the Edit menu.

File Toolbar

The File toolbar contains the common file operations such as New, Save and Open. These options
can also be found in the File menu.

Flip Toolbar

This toolbar lets you enable what type of drawing to include in your flipping selection. You can flip
through the key, breakdown or in-between drawings individually, or view a combination.

Mark Drawing Toolbar

The Mark Drawing toolbar lets you identify drawings such as Key, Breakdown and In-between. The
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drawing Identification feature can help the animator stay well organized and save time when
identifying key, breakdown or in-between drawings in the Xsheet and Timeline views.

Onion Skin Toolbar

When designing or animating, it is useful to be able to see your previous drawings. The Onion Skin
tool is used to preview the previous and subsequent drawings. By default, the previous drawings will
appear with a shade of red and the next drawings will be displayed with a shade of green, but you
can change the display options in the Preferences dialog box. In the Onion Skin toolbar, you can
select what type of drawing you want to display in your onion skin display.

Playback Toolbar

The Playback toolbar lets you play back your animation and sound. Use it to scrub the sound to
create your lip-sync, loop the playback, navigate through frames, and change the playback range
and speed.

Name Button Description

Play

Plays and stops the
animation.

You can also select Play >
Play Scene Forward or
Stop.

Render and Play
Creates a render of your scene to
play back the final result including the
effects.

Loop

Repeatedly plays back your
animation indefinitely.

You can also select Play >
Loop.

Sound

Enables sound in the
playback.

You can also select Play >
Enable Sound.

Sound Scrubbing

Enables sound scrubbing in
the playback.

You can also select Play >
Enable Sound Scrubbing.
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Jog Frames
Lets you scroll through the play-
back’s frames.

Lets you change the playback frame
range by entering new values in the
Start and Stop fields. You can also
click on the Start and Stop words to
set the start or end frame at the cur-
rent frame.

FPS
Lets you enter a new value to change
the speed of the playback.

Scripting Toolbar

The Scripting toolbar lets you import and access the scripts created to automate actions and
operations.

Tools Toolbar

The Tools toolbar contains all of the main tools you will use while working in Harmony. In the default
workspace, you will find this toolbar on the left-most side of the interface.

Workspace Toolbar

The first time you open Harmony, the default workspace is loaded. Other workspaces are available
such as the Hand-Drawn Animation and Compositing workspaces; these display different views and
toolbars. You can access these workspaces and any you create, from the Windows menu and the
Workspace toolbar.

View Toolbars
Here is a list of the view toolbars available in Harmony:

• Camera View Toolbar

• Model View Toolbar

• Script Editor View Toolbar

• Timeline View Toolbar

• Xsheet View Toolbar
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Interface Navigation

Toon Boom Harmony supports zoom in, zoom out, rotate, pan and reset view for easy interface
navigation for the views.

Command Action Access Methods

Zoom In Zooms into the view.

View > Zoom In

Press 2 or roll the mouse
wheel up.

In the Timeline view, press
Ctrl (Windows/Linux) or ⌘
(Mac OS X) and roll the
mouse wheel up.

Zoom Out Zooms out of the view.

View > Zoom Out

Press 1 or roll the mouse
wheel down.

In the Timeline view, press
Ctrl (Windows/Linux) or ⌘
(Mac OS X) and roll the
mouse wheel down.

Zoom In or Out Zooms in or out of the view.
Roll the middle mouse
button up or down.

Pan Moving parallel to the view.

Hold down the Spacebar and
drag the mouse in the direction
in which you want to pan the
view.

Recenter view
Recenters the view on your mouse
cursor.

Press N

Reset Pan
Resets the view’s pan to its default
position.

View > Reset Pan

Press Shift + N

Reset View
Resets the view to its default pos-
ition.

View > Reset View

Press Shift + M

Reset Rotation
Resets the view’s rotation to its
default position.

View > Reset
Rotation

Press Shift + X

Reset Zoom
Resets the view’s zoom to its default
position.

View > Reset Zoom

Toggle Full Screen
Enlarges the selected view to full
screen. The full screen process is
done in three stages.

View > Toggle Full
Screen

Press Ctrl + F
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First, the selected view
enlarges to the maximum
width or height, but keeps
the tool views such as
Colour or Tool Properties
view.

Second, the view enlarges
to full screen.

Third, the view returns to
its original size.

(Windows/Linux) or
⌘ + F (Mac OS X)

Rotate 90 CW
Rotates the Camera view 90 degrees
clockwise, like an animation table.

View > Rotate View CW

Rotate 90 CCW
Rotates the Camera view 90 degrees
counter-clockwise, like an animation
table.

View > Rotate View CCW

Toggle Quick Close-up

Use the Magnifier tool to
quickly center on the
mouse position and zoom
in to a pre-defined value
such as 4X. Then you can
zoom out again. Hold the
shift key and press Z to
zoom in and back out
again. Replacing the Reset
Zoom by pressing Shift +.

The area where you zoom
in or out is dependent on
the cursor location in the
Camera view. If you zoom
in and them move the
cursor to a different
location when you zoom
out the mouse will be
centered on that location.

Using the Play Menu to Navigate
From the top menu, you can select any of the following commands from the Play menu to navigate
around the interface.

Command Description

First Frame Jump to the first frame. You can also press <.

Next Frame
Jumps to the frame after the currently selected frame in the Timeline view.
You can also press the period (.) key.

Last Frame Jumps to the last frame. You can also press >.

Previous Frame
Jumps to the frame before the frame currently selected in the Timeline
view. You can also press the comma (,) key.
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Go to Frame

Opens the Go to Frame window in which you can enter the
number of the frame you want to display.

You can also use the Go button, which you can add to the
Timeline View toolbar through the Toolbar Manager. Open the
Go to Frame dialog box and enter the frame number to jump
to.

Enable Playback Plays back your animation from the Top, Side, or Perspective view.

Zoom Tool
From the Tools toolbar, use the Zoom tool to zoom in and zoom out in the Camera or Drawing
view.

• The keyboard shortcuts are 1 and 2.

• When the Zoom In mode is selected, hold Alt as you click to zoom out.

When you select the Zoom tool, its properties are displayed in the Tool Properties view.

Zoom ToolOptions Button Description

Zoom In Zooms in

Zoom Out Zooms out

Operations Button Description

Perform Zoom In
Zoom in the Camera or Drawing view.
The keyboard shortcut is 2.

Perform Zoom Out
Zoom out the Camera or Drawing view.
The keyboard shortcut is 1.

Reset Zoom Restores the current zoom level to 100%.

Reset View
Restores the original display by resetting
any pan, rotation or zoom actions.

Navigating between Frames and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the drawings, frames,
and layers using keyboard shortcuts that work in the Camera, Drawing, Timeline, and Xsheet views.

You can navigate through:
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• Drawings

• Frames

• Columns

How to navigate through drawings, frames and columns

1. In the Timeline or Xsheet view, select a cell.

2. Once the cell is selected, you can navigate between:

‣ Previous and next layers: From the top menu, select Drawing > Previous Layer andNext
Layer or press H and J.

‣ Previous and next drawings: From the top menu, select Drawing > Previous Drawing and
Next Drawing or press F and G.

‣ Previous and next frames: From the top menu, select Play > Previous Frame andNext
Frame or press comma (,) and period (.).
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Chapter 6: Timing

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. Sketch is a subset of
Harmony Stage.

When you create hand-drawn animation traditionally or in a paperless environment, it is important to
know how to set and modify the timing of your drawings.

In a traditional workflow, the person in charge of the digital exposure sheet reproduces the paper
exposure sheet created by the animator. In a paperless workflow, the animator creates and manages
his own exposure sheet directly in Harmony without the need for reproduction.

If you are more of a traditional animator, you are more likely to work with an exposure sheet. If you are
a digital animator, you may prefer to work with a timeline to visualize your timing. Harmony offers
both.

The Xsheet view displays the digital reproduction of a traditional paper exposure sheet used in hand-
drawn animation. You can set the animation sequence's exposure and name the drawings.

The Timeline view is also used to visualize timing, and represents elements and groups of elements as
layers.

You can adjust timing in both views; your choice depends on which technique you are used to working
with. Depending on your working style, some actions may seem preferable to do in one view instead
of another. Many of the actions you perform in the Xsheet can also be accomplished in the Timeline.
This chapter will often show both techniques. You will be able to choose which one you prefer.

In this topic, you will learn how to work on your drawing’s exposure and length. The exposure and
animation paths for symbols are covered in separate chapters.

The exposure sheet is not mandatory for Cut-out animation. It can be useful for creating characters and
parts, but is not really needed for animation and timing. If you plan to work with Cut-out animation, you can
still gain useful tips by reviewing the section on exposure sheets.
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The basic digital exposure sheet process is divided into the following steps:

• Preparation on the facing page

• Frames on page 101

• Filling Exposure on page 120

• Managing Drawings on page 142

• Modifying the Layer and Column Display on page 149
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Preparation

The digital exposure task is quite simple. There are very few things to prepare in order to get ready.

Opening the Scene

The scene is generally created during a previous step such as scanning (in a traditional animation
workflow), scene setup, digital layout, or production organization.

Using the Workspace

The person creating the exposure sheet will need only the Xsheet view to create the digital exposure
sheet, although the Timeline view may also be helpful. If you are doing paperless animation, use the
Camera view if you want to sketch at the same time.

If you work with this layout often, you can use the Workspace Manager to save it as a
workspace,and name it Xsheet, for example.

While drawing and animating paperless animation, you can use the Workspace Manager to save a
frequently used layout and name it Paperless Animation, for example.
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Preparing References

To start an exposure sheet, you need to prepare your references. For traditional animation, you will
need to reproduce the animator's paper exposure sheet. If you are working remotely, the studio can
scan the paper exposure sheet using third-party software and send the digital files to be opened and
viewed digitally.

In paperless animation, you will usually create an exposure sheet from the Xsheet view.The
information from your layout and posing or storyboard will help you approximate how many
elements are required in the scene.
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Frames

Once the references are ready, you need to set the scene length by adding the right number of frames
to your scene. You can set the global scene length from the top menu.

In the Xsheet and Timeline view, you can add and remove frames from a scene to edit its length.

How to set the scene length

1. From the top menu, select Scene > Scene Length.

The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.

How to extend a scene in the Timeline view

1. In the Timeline view, drag the scene length bracket to the right to add more frames to your scene.

How to add frames before or after a selection to the extend scene length in the
Xsheet view

You can add frames anywhere in the middle of the scene. If you select a frame row in the Xsheet view,
Harmony will add the new frames before or after the selection, depending on your choice.

1. In the Xsheet view, select a frame row.

2. Do one of the following:

‣ From the top menu, select Scene > Add Frames Before Selection or Add Frames After
Selection.

‣ In the Xsheet view, right-click and select Frames > Add Frames Before Selection or Add
Frames After Selection.

‣ In the Xsheet view toolbar, click the Add Frames button to add frame after your
selection.
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‣ Press Ctrl + G and Ctrl + H (Windows/Linux) or ⌘ + G and Ctrl + H (Mac OS X).

The Add Frames dialog box opens.

3. In the Number of Frames to Add field, enter the number of frames needed in the scene.

How to add frames at the start or end to extend the scene length from the top menu

1. From the top menu, select Scene > Add Frames At Start or Add Frames At End.

‣ In the Xsheet view toolbar, press the Add Frames button to add frame after your
selection.

The Add Frames dialog box opens.

2. In the Number of Frames to Add field, enter the number of frames needed in the scene.

How to reduce the scene length in the Timeline view

When you remove frames at the end of a scene to reduce the scene length in the Timeline view, the
exposed drawings and symbols are not deleted. They are still available if you extend the scene
afterwards.

1. In the Timeline view, drag the scene length bracket to the left to remove frames from the scene.

How to remove a frame or a range of frames to reduce the scene length in the
Xsheet view

In the Xsheet view, you can remove any selected frame range, such as the last frame.

1. In the Xsheet view, do one of the following:

‣ Select a frame in a given column.

‣ Select a frame range by clicking the first frame’s number and then dragging the selection
highlight down to the last frame to delete.
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2. To delete the selected frames, do one of the following:

‣ From the top menu, select Scene > Remove Selected Frames.

‣ Press Delete to delete the selection.

‣ Click Remove Frames button. To remove several frame selections, click the button
repeatedly.

If you selected a range of frames, the Warning dialog box may open.

3. To complete the operation:

‣ Click Yes to delete the selection.

‣ Click No to delete only the exposure in the cell and not the frames.

‣ Select theDon’t Show This Message Again option to prevent the warning message from
being displayed each time you delete a frame range.
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Creating Drawing Elements

Before filling any value or setting any timing or exposure, you need to add different drawing elements.

Each drawing element is represented as a vertical element column in the Xsheet view and a horizontal
element layer in the Timeline view.

In Harmony, whether you work in the Timeline or Xsheet view, any modification you do to one view will
be applied to both. You can also see your layers displayed in the Network view as modules.

To start an exposure sheet, you will use drawing elements. Drawing elements are drawing containers.
Any image file, either bitmap or vector, will use a drawing element.

When you add a drawing element to your scene, a folder is added to the scene directory. This folder is
named the same way as the drawing element. Its purpose is to contain all the drawings related to this
element. For example, in cut-out animation, a character can have many heads available. All of the head
drawings will be contained in this folder, even if they are not exposed in the Timeline or the Xsheet
view. There is always a drawing container connected to a drawing element (layer, column).

There are different element types available such as Sound and Expression. A sound element will contain
sound files. Expressions, Beziers, Eases, 3D Path, Quadmaps and Pegs are for motion purposes during the
compositing step. It is not necessary to create these types to create your exposure sheet.

You can add drawing elements from the Timeline view, Xsheet view, and the Scene menu.

This section is divided as follows:

• Layer and Column Concepts below

• Layer and Column Types on the facing page

• Adding New Drawing Elements on page 106

• Deleting Layers and Columns on page 108

• Layer and Column Properties on page 108

• Modifying Layers and Columns on page 109

• Duplicating Layers and Columns on page 111

• Cloning Layers and Columns on page 111

• Adding an Annotation Column on page 112

Layer and Column Concepts
A layer is linked to a directory, the location where all its drawings are saved. This directory has the
same name as the layer. When a name is typed in a cell,Harmony searches the layer's directory for the
corresponding drawing to display. If there is no corresponding drawing, a new one is created.

Drawings are exposed in cells, and linked to the drawings saved in the layer's directory. Removing a
drawing from a cell means it is not displayed. It will not be deleted from the directory.

A drawing that is exposed multiple times (for example, in a walk cycle) would be linked to the same
original drawing in the layer's directory. If you modify, repaint, or correct the drawing, all exposed
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drawings with the same name are updated simultaneously. You must duplicate or create a new
drawing to modify a single exposure and retain the others.

When you create a drawing cycle, all of the repeated drawings are linked to the original files. This means that
when you modify, repaint, or correct a drawing named “1,” all drawings named “1” are updated simultaneously.
In order to modify a drawing independently from its other exposures, you must duplicate the drawing.

Layer and Column Types
A column is also known as a layer. There are several types of layers that you can add in the Xsheet and
Timeline view. Each layer is tagged with an icon to help differentiate them. Some layers are
represented differently in the Xsheet view.

Drawing Layer

The most common layer type is the drawing layer. Any time you need to create a vector drawing or
import a symbol or image, you can use a drawing layer. You can also create bitmap artwork on a
drawing layer.

Bitmap images are contained in Bitmap layers.

Bitmap Layer
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If you import a picture or bitmap images in your project, they are inserted in a Bitmap layer. If you
choose to vectorize your image when you import, the bitmap object will be placed on a Drawing
layer. This way, you can have bitmap images mixed with vector drawings on a Drawing layer.

When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you
place a non-vectorized bitmap into a symbol, you will still not be able to mix vector drawings with it
on the same layer. If you place a vectorized bitmap in a symbol, you must enter the symbol to be able
to mix it with vector artwork.

Colour-Card Layer

The Colour-Card layer is used to add a plain colour background to a scene. By default, your scene
has no background colour and if you render it as a QuickTime movie or image sequence, it will have a
black background.

This layer is not visible in the Xsheet view.

Sound Layer

You can import sound files to add dialog and sound effects to your project. The sound layer will be
added to your Timeline and Xsheet view when you import a sound file in your scene.

In the Xsheet view, the Sound layer is a dark grey colour.

Adding New Drawing Elements
There are different ways to add a drawing layer to your project. By default, when you create a new
scene there is one Drawing column in the Xsheet view and one corresponding Drawing layer in the
Timeline view.

You can add an element for each drawing and it will appear as a column in the Xsheet view, a layer in
the Timeline view, and a module in the Network view.

How to add a drawing element from the Timeline view

1. Do one of the following:

‣ In the Timeline View menu, select Insert > Drawing.

‣ In the Timeline view toolbar, click the Add Layers button.

‣

‣ Press Ctrl + R (Windows/Linux) or ⌘ + R (Mac OS X).

The Add Drawing Layer dialog box opens.
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2. In the Name field, enter a relevant element name.

3. Do one of the following:

‣ Click OK to add the layer and close the dialog box.

‣ Click Apply to add the layer and keep the dialog box open to add another layer.

‣ Click Close to cancel the operation.

The new drawing element appears in the Timeline and Xsheet Views.

How to add a drawing element from the Xsheet view

1. Do one of the following:

‣ In the Xsheet view menu, select Columns > AddColumns.

‣ Click the Add Columns button.

‣ Press Shift + C.

The Add Column dialog box opens.

2. In the Name field, type a relevant element name.

3. In the Type field, select Drawing.

4. To complete the operation:

‣ Click OK to add your new layers and close the dialog box.

‣ Click Apply to add your new layers and keep the dialog box open to add column.

‣ Click Close to cancel the operation.

The new drawing element appears in the Timeline and Xsheet Views—see Layer and Column Types
on page 105.
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Deleting Layers and Columns
You can delete an element in the Timeline view or Xsheet view.

How to delete layers in the Timeline view

1. In the Timeline view, select the layers to be deleted.

2. Do one of the following:

‣ In the Timeline’s Layer toolbar, click the Delete Layers button.

How to delete columns in the Xsheet view

1. In the Xsheet view, select the columns to be deleted by clicking on their header.

2. Do one of the following

‣ Right-click on the selection and select Delete Columns.

‣ In the Xsheet View toolbar, click the Delete Columns button.

‣ Press Delete.

The Confirm Delete dialog box opens.

3. To complete the operation:

‣ Click OK to delete the selected layers.

‣ Click Cancel to cancel the operation.

Layer and Column Properties
Each element has its own set of properties that can be modified, including effect and peg layers.

If you want to modify some of the element’s properties, display the Layer Properties or Column
Properties editor. You can display the Layer Properties editor from the Timeline or Network view as a
dialog box or open the Layer Properties as a view of its own.
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The Layer Properties editor allows you to:

• Rename the layer

• Enable or disable the layer

• Lock the layer

• Change the track colour

The Column Properties editor allows you to:

• Rename the layer

• Enable or disable the layer

• Adjust parameters for bitmap format, scan type and field chart

How to display the Column Properties editor from the Xsheet view

1. Do one of the following:

‣ In the Xsheet view, double-click on a column’s header.

‣ In the Xsheet view, right-click on a column's header and select Column Editor.

‣ Press Shift + E.

Modifying Layers and Columns
Once you add layers and columns to your project, you can modify their properties, names, or
ordering.
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You can change the order of your elements in the Timeline view and Xsheet view. When you change the
order of your elements in one view, the other one is updated.

How to rename a layer in the Timeline view

1. In the Timeline view, double-click on the name of the layer to rename.

2. In the Name field, rename the layer and press Enter/Return.

How to rename a layer in the Layer Properties editor

1. In the Timeline view, double-click anywhere on the layer except the layer name to rename.

The Layer Properties editor opens.

2. In the Name field, rename the layer.

3. Click Close.

How to rename a column

1. In the Xsheet view, double-click on a column name. Do not click on the drawing folder name that
the column is linked to (this also appears in the column header just below the column name).

The Drawing dialog box opens.

2. In the Name field, rename the column.

3. Click OK.

How to reorder layers in the Timeline view

1. In the Timeline view, select the layers to move.

2. Drag the selection to the new location.

3. Do one of the following:

‣ Drop the selection on an existing layer to make it a child of another element layer.

‣ Drop it between the existing layers. Timeline layers that are located above the selection are
displayed in front it. Layers located under it in the Timeline View are displayed behind it.
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How to reorder columns in the Xsheet view

1. In the Xsheet view, click on the column’s header with the middle mouse button.

2. Drag the column to its new position.

Duplicating Layers and Columns
Duplicating an element provides you with a copy of the drawings and their exposure. You can modify
anything you want in the duplicated element without affecting the original one.

How to duplicate an element

1. In the Timeline or Xsheet view, click the layer you want to duplicate.

2. In the Xsheet View menu, select Drawings > Duplicate Drawings.

The new duplicated layer or column appears.

Cloning Layers and Columns
Cloning a layer or column provides you with a copy of the selected element that uses the same
drawings as the original. For example, if you modify a drawing in the cloned or original column, it is
updated in both columns.

You can choose whether or not to copy the column timing to the cloned columns.

• You can modify the column timing independently from each other, but the drawings remain
linked.

• You can copy the columns timing, so drawings and timings remain linked.

You can clone selected modules from the Network view in the same way.

This feature is useful when you want to reuse a hand-drawn animation but have different timings.
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How to clone an element

1. In the Timeline or Xsheet view, select the layer or column you want to clone.

2. Do one of the following:

‣ In the Xsheet View toolbar, click the Clone Selected Columns: Drawings Only button.

‣ From the top menu, select Edit > Clone to clone the columns' drawings only.

‣ In the Xsheet View or Timeline View toolbar, click the Clone Selected Layers/Columns:
Drawings Only button.

The new cloned layer or column appears.

Adding an Annotation Column
The Annotation columns are useful for marking actions, corrections or other information related to
your animation that you want to draw or write. This way, you can print your Xsheet, take it back to
your animation table and work with the annotations.

How to add an annotation column

1. Do one of the following:

‣ In the Xsheet View menu, select Columns > AddColumns.

‣ In the Xsheet View toolbar, click theAddColumns button.

‣ Press Shift + C.

The Add Column dialog box opens.

2. In the Name field, type in an appropriate name.

3. From the Type list, select Annotation and click OK.

The new column appears.

Drawing and Typing in the Annotation Column
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In the annotation column, you can type in your notes and relevant information, as well as draw
sketches and ideas that will be useful in producing your animation.

How to draw in the Annotation column

Pen tablet pressure sensitivity is not supported in the Annotation column.

1. To draw in an Annotation column, simply use your mouse or pen tablet.

How to type in an Annotation column

Typing in an Annotation column is independent from the Drawing mode. You can be in either mode
and the typing will work.

1. Do one of the following:

‣ In the selected cell, press Ctrl (Windows/Linux) or ⌘ (Mac OS X).

‣ In the selected cell, hold down Ctrl + Shift + click (Windows/Linux) or ⌘ + Shift + click (Mac
OS X)..

2. In the selected cell, type the desired text.
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To learn about typing values in the Xsheet view, refer to Typing Exposure on page 121.

How to erase part of a drawn annotation using Erasing mode

You can erase part or all of the Annotation column’s text and drawn annotations.

Annotations that you type in cannot be erased using this method.

1. In the Annotation column header, click to cycle through the icons until the Eraser icon is
displayed.

2. In the column, click and drag the cursor on top of the drawn annotation to erase parts of it.

When using a pen on a tablet, you MUST flip your pen to the eraser side for the eraser to work.

How to erase an Annotation column selection

1. In the Annotation column header, click to cycle through the icons until the Select icon is
displayed.

2. In the Xsheet view, select the cell range you want to clear of text or drawn annotations. A selection
is indicated by four pairs of dots on the left side of a cell. Do not select any cells if you plan to clear
everything.
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3. In the Xsheet view, right-click in the Annotation column.

4. Do one of the following:

‣ Select Annotation > Erase All to erase the entire content of the column.

‣ Select Annotation > Erase Selected Images to erase the images contained in the selected
cell range.

‣ Select Annotation > Erase Selected Texts to erase the text contained in the selected cell
range.

Changing the Drawing Settings
You can change the pen size and colour when you draw in the Annotation column.

How to change the pen width

1. Right click on a frame within an annotation column or in the Xsheet View menu, select Annotation
> Pen Width.

2. Do one of the following:

‣ Select a pen width preset.

‣ Select Change Current.

If you selected the Change Current option, the Pen Width dialog box opens.

3. In the Pen Width field, type the number of pixels you want the pen size to be.

4. Click OK.

How to change the pen colour

1. In the Xsheet View menu, select Annotation > Change Pen Colour.

The Select Colour dialog box opens.
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2. Choose the new colour.

3. Click OK.

Displaying Tick Marks
When working with the Annotation columns, it is useful to display tick marks on odd-numbered
frames.

To display the tick marks, you must run a short script.

How to display tick marks

1. From the top menu, selectWindows > Script Editor.

2. From the Script Editor menu, select File > New Script.

3. Type in a name for your script and click OK.

4. In the File list, select the script you created.

5. On the right side of the view, type the following script:

function display_tick_marks()

{
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preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", true);

MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER",
false));

}

6. Click Verify.

The script is verified.

7. From the File menu, select Play/Debug > Run.

A dialog box opens with your script selected in the Files column.

8. In the Functions column, select display_tick_marks and click OK.

Tick marks appear on odd frames in the Annotation column.

If you do not see tick marks, close and restart Harmony.

How to turn off the display of tick marks

1. Follow steps 1 to 5 ofHow to display tick marks and use the following script:

{

preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", false);

MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER",
false));

}

2. Follow steps 6 to 8.

All tick marks are removed from the Annotation column.

Importing an Annotation File
If you scanned your paper exposure sheet’s annotations or if you need to place some pictures or
drawings in the annotation columns, you can easily import them.

How to import annotation files

1. In the Xsheet view, select the first cell in the annotation column where you want the imported
image to start.

2. Right click on the frame or from the Xsheet view menu, select Annotation > Import File.

3. Browse for the bitmap image to import.
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4. Click Open.

The image appears in the annotation column.

Linking External Files with Timing Columns
Timing columns are unique in that they can reference a source folder outside of the project folder to
bring images into the project. For example, you may have background scenes created in a third party
software that you might need to update in the future; by using Timing columns, you can dynamically
link your backgrounds, expose different backgrounds at different times, and have live, automatic
updating capabilities.

If the project file is moved, or the folder that the column is linked to is moved, then dynamic linking is
broken and the images that were in that folder will disappear in Toon Boom Harmony.

How to use a Timing column

1. In the Xsheet view, click on the Add Columns button.

2. In the Add Column dialog box, type in the name of the new column, then from the Type menu,
select Timing.

3. Do one of the following:

‣ Click OK if you are finished.

‣ Click Apply if you want to continue adding more columns and column types.

A peach coloured column appears in the Xsheet with the name you typed in, and for the header,
<unused>.

4. In the Timing Column field, click theArrow button to create a new timing column, or select the
name of the column from the list. If you have an element directory selected in the Name field, the
Timing Column will indicate which files are called from that element directory. Remember that the
file displayed at each frame is based on the element name, cell label, and extension. If the element
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is toto, the timing column is labeled 1, 2, and 3, and the extension is TVG, Harmony will display
drawings totobody-1.tvg, totobody-2.tvg, and totobody-3.tvg at the selected frames.

In the Xsheet, the <unused> header changes to the name of the module in the Network view.

5. From the Extension list, select the file format of the files you want to display.

6. Click OK.

7. In the Xsheet view, in the Timing column, type the number that corresponds to the suffix of the
drawing file that you want to expose to make it appear in the Camera view.
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Filling Exposure

Harmony provides different tools to fill in exposures and values, create cycles, and set increments.

This section is divided as follows:

• Filling Exposure Mode below

• Typing Exposure on the facing page

• Holding Exposure on page 122

• Extending a Single Exposure on page 123

• Extending an Exposure Sequence on page 124

• Dragging Cells on page 125

• Increasing and Decreasing Exposure on page 128

• Inserting Blank Cells on page 131

• Deleting Exposure on page 130

• Setting the Exposure on page 132

• Filling a Selection with a Single Exposure on page 133

• Filling a Selection with a Sequence on page 134

• Filling a Selection Randomly on page 136

• Filling Empty Cells on page 137

• Creating Cycles on page 138

• Managing Drawings on page 142

• Renaming a Drawing on page 142

• Deleting a Drawing on page 143

• Duplicating a Drawing on page 144

• Copying and Pasting Drawings on page 144

• Merging Drawings on page 147

Filling Exposure Mode
In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These
modes control the filling behaviour. The Timeline view only uses the Overwrite mode.

How to toggle between Overwrite and Insert modes

1. Do one of the following:

‣ In the bottom-right corner of the Xsheet view, click theOverwrite/Insert button.

‣ Press I.
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Overwrite Mode

By default, the Xsheet view is set to Overwrite mode. Adding a new value or a new value sequence
overwrites existing ones. The existing timing sequence remains in the same place and is not pushed
down the column.

Insert Mode

The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value
sequence over existing ones, the new values are inserted between the old ones. The existing timing
sequence is pushed down the column.

Typing Exposure
To fill in your exposure, you can directly type the values in the Xsheet view and Timeline view.

How to type values in the Xsheet view

You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

1. In an Xsheet column, double-click on one cell.
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2. Type a value or drawing name in the cell.

3. Press Enter/Return to move to the next cell.

4. Press Esc to exit the typing mode and return to normal mode.

Holding Exposure
Drawings in an animation project are not always exposed on a single frame; they are often exposed
for more than one frame. The most common exposure of a drawing is two frames. In the industry, this
type of exposure is known as animation in double frames or animation on twos. A drawing can also be
exposed for three, four, five cells and so on. To prevent mistakes and save time, the Xsheet lets you
hold your cells automatically as you type.

The Set Exposure option allows you to choose how many frames you want to hold for your exposure.

• This option is only available in the Xsheet view.

• The selected Set Exposure settings will be kept from session to session. You will not
have to set them every time you use Toon Boom Harmony.
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How to hold exposure

1. In the Xsheet View menu, select Exposure > Hold Exposure > Hold 2 Cells.

2. In the Xsheet view, right-click and select Exposure > Set Exposure To > Set Exposure to 1, 2,3,
or Set Exposure.

3. Type a value or drawing name in the cell.

‣ Press Enter/Return to move on to the next cell.

‣ Press Esc to quit the typing mode.

‣ If you selected Set Exposure, the Set Exposure dialog box opens. You can hold as many
cells as needed.

Extending a Single Exposure
Extending the exposure lets you select an Xsheet cell that contains a value and pull it down to the
desired frame.

How to extend a cell exposure gesturally

1. In the Xsheet view, select the red arrow in the cell’s right side. Make sure you see the drag down
cursor.

2. Pull down the selected cell to the desired frame.

The red selection box must be visible when releasing the mouse button. If not, the action is considered
cancelled.
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Extending an Exposure Sequence
When working with a sequence that contains only numbers, you can extend an exposure sequence in a
similar manner to extending a single exposure.

How to extend an exposure to create a sequence

1. In the Xsheet view, select a cell containing a number.

2. In the selected cell, click the red arrow on the cell’s right side. Make sure to see the drag down
cursor.

3. Hold down the Shift key. Make sure a plus (+) sign appears.

4. Pull down the selection box to the desired frame.

The red selection box must be visible when releasing the mouse button. If not, the action is considered
cancelled.

5. First release the Shift key, then release the mouse button.
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Dragging Cells
To readjust your timing, you can drag one or several cells to a new location. You can drag a cell to any
other frame in the same column or into another column.

How to drag a cell to another location in the Timeline view

1. In the Timeline view, select one or several cells to move.

2. Click on the cells selection and drag it to the new location.

3. Drop the selection. Do one of the following:

‣ Drop by simply releasing the mouse or pen to overwrite the existing cells.

‣ Hold Ctrl (Windows/Linux) or ⌘ (Mac OS X) while dropping the selection to copy the cells.
The original cells will not be moved.

‣ Press Shift while dropping to insert the selection between the existing frames.
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How to drag a cell to another location in the Xsheet view

1. In the Xsheet view, select one or more cells.

2. In the Xsheet view, select the small dotted area on the left side of the selected cells.

3. Drag the selection to any other cell in the same column or in another column.

4. Do one of the following:

‣ Drop the selection to overwrite the existing cells.
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‣ Hold down Ctrl (Windows/Linux) or ⌘ (Mac OS X) while dropping the selection to copy the
cells. The original selection will not be moved.

‣ Press Shift while dropping the selection to insert it between the existing frames.

You can turn off the Gestural Drag Mode for the Xsheet view to prevent drawings from being
dragged from one location to another.

How to turn off the Gestural Drag mode

1. Do one of the following:

‣ In the Xsheet view, right-click and deselect theGestural DragMode option.

‣ Click the Toggle Gestural Drag Mode button (you may have to customize the toolbar to display
it).
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The dragging pad disappears when the Gestural Drag mode is off.

This feature does not apply to Annotation columns.

Increasing and Decreasing Exposure
Once a value is entered in the Timeline or Xsheet view, you can increase and decrease its exposure.

How to increase exposure

Increasing the exposure adds one more exposure to a selected cell; repeating this action adds an
extra cell each time. This is an efficient way of extending a drawing exposure and is always set in
Insert mode. Increasing an exposure pushes the existing exposure ahead.

1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following:

‣ Right-click on the selected cell and select Exposure > Increase Exposure.

‣ Press +.

‣ In the Xsheet or Timeline View toolbar, click the Increase Exposure button.

How to decrease exposure

1. In the Timeline or Xsheet view, select a cell.
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2. Do one of the following:

‣ Right-click on the selected cell and select Exposure > Decrease Exposure.

‣ In the Xsheet or Timeline View toolbar, click the Increase Exposure button.

‣ Press -.

How to increase and decrease exposure using the Increase/Decrease Exposure field

You can use this option in the Xsheet view to increase or decrease the exposure of a selected drawing.

1. In the Xsheet view, select the cell to modify.

2. Do one of the following:

‣ In the Xsheet's bottom right-corner, enter the number of cells over which the drawing will be
exposed.

‣ In the Xsheet’s bottom-right corner, increase or decrease the drawing’s exposure by
clicking the up or down arrows.

‣ Press + to increase exposure.

‣ Press - to decrease exposure.
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How to use the Clear Exposure and Pull feature

You can use this option to reduce a drawing’s exposure.

1. In the Timeline or Xsheet view, select or range of cells.

2. Do one of the following:

‣ Right-click on the selected cell and select Exposure > Clear Exposure and Pull.

‣ In the Xsheet or Timeline View toolbar, click the Clear Exposure and Pull button.

3. The exposure is reduced by the selected number of cells.

Deleting Exposure
You can delete a drawing’s exposure in several ways. When you delete a drawing’s exposure from the
Timeline or Xsheet view, you are not deleting the actual drawing file. You can always retrieve it by
typing its name again in a cell.

You can delete the exposure contained in a selected cell range or delete the entire exposure of a
drawing exposed over several cells . Note that you can also delete the exposure for drawings
contained inside a collapsed group.

How to delete selected exposures

1. In the Timeline or Xsheet view, select the exposure you want to delete.

2. Do one of the following:

‣ Right-click and select Delete.

‣ Press Delete.
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How to clear the entire exposure of a drawing

1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.

2. Do one of the following:

‣ In the Timeline view, right-click on the selection and select Exposure > Clear Exposure.

‣ In the Xsheet View toolbar, click the Clear Exposure button (you may have to customize
the toolbar to display it).

Inserting Blank Cells
You can place an empty cell between other cells. This is always done in Insert mode and pushes down
existing exposure, even if you are set to Overwrite mode.

How to insert blank cells

1. In the Xsheet or Timeline view, select the cell in which you want to insert a blank cell.

2. Do one of the following:

‣ Right-click on the selected cell and select Exposure > Insert Blank Cell.

‣ In the Xsheet or Timeline view toolbar, click the Insert Blank Cell button (you may have
to customize the toolbar to display it).

‣ Press Shift + J.

The blank cell is inserted.

How to clear a selected cell range without changing the exposure and timing

1. In the Xsheet view, select the frame range to clear.
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2. Right-click on the selected cells and select Clear.

Setting the Exposure
You can easily increase or decrease the exposure for a selected cell range by using the Set Exposure
options.

How to set the exposure

1. In the Timeline or Xsheet view, select the cell range on which you want to set the exposure.

2. Do one of the following:

‣ In the Xsheet view, right click and select Exposure > Set Exposure to > Set Exposure to 1,
2, or 3, or Set Exposure.
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‣ In the Timeline View toolbar, click one of the Set Exposure buttons (you may
have to customize the toolbar to display them).

3. In the Xsheet view, right-click and select Exposure > Set Exposure to > Set Exposure to 1, 2, or
3, or Set Exposure.

If you chose the Set Exposure option, the Set Exposure dialog box opens.

4. Type the number of frames you want the drawings to display and click OK.

The new timing is displayed in the Xsheet view.

Filling a Selection with a Single Exposure
The Fill Selection option lets you fill the same value over an entire selection. The selection can be over
one cell, a cell range in one column, a cell range over many columns, an entire column, or many
columns. You can use numbers, words, letters, or any alphanumeric value.

How to fill a selection with a single exposure

1. In the Xsheet or Timeline view, select a cell range.

2. Do one of the following:

‣ Click the Fill Selection button in the Xsheet or Timeline view toolbar (you may have to
customize the toolbar to display it).
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‣ Press Ctrl + T (Windows/Linux) or ⌘ + T (Mac OS X)).

The Fill Selection dialog box opens.

3. In the Value field, type the desired value.

4. To insert a keyframe in the frame following the last cell in the selection, select theAddKey
Exposure After option. Otherwise, leave it deselected.

5. Click OK.

Filling a Selection with a Sequence
You can create a numbered sequence over a selection. The sequence can be forward, backward,
single, double or higher increment, as a cycle, and so on. The sequence can be over one cell, a cell
range in one or more columns, or one or more columns.

How to fill a selection with a sequence

1. In the Xsheet or the Timeline view, select a cell range.

2. Do one of the following:

‣ In the Timeline view, right-click and select Exposure > Sequence Fill.

‣ In the Xsheet View toolbar, click the Sequence Fill button (you may have to customize
the toolbar to display it).

‣ Press Ctrl + M (Windows/Linux) or ⌘ + M (Mac OS X).

The Sequence Fill dialog box opens.

158



Toon Boom Harmony 11.1 Sketch Module Network User Guide

3. In the Starting Value field, type the first number in the sequence.

4. In the Increment field, type the number by which the drawing number will increase from frame to
frame. For example, an increment of 1 is used in this sequence:1-2-3-4; this sequence increments
by 2: 1-3-5-7; and this one, by -2: 8-6-4-2.

5. In the Hold field, select an exposure holding value.

6. Select theCycle option if you want a cycle; enter the number of cells for this cycle’s duration.

If you choose a two-cell hold, a cycle of three drawings will last for six cells.

7. If you selected a larger range than the amount of frames needed, select the End Frame option and
type the last frame needed.

8. If you want to have more than one digit in your numbers such as “001” instead of “1”, select the
Padding option and add as many pound signs (#) as digits needed. In the field, you can type a
letter or word to add before the drawing number.

9. To insert a keyframe in the frame following the last cell in the selection, select theAddKey
Exposure After option. Otherwise, leave it deselected.

10. Click OK.
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Filling a Selection Randomly
You can fill in random values over a selection. You can give a maximum and a minimum value and
create a range for the system to choose the random values from. The selection can be over one cell,
a cell range in one column or more, or an entire column or many entire columns.

How to fill cells randomly

1. In the Xsheet view, select a cell range.

2. Do one of the following:

‣ In the Xsheet view, click the Fill Cells Randomly button (you may have to customize the
toolbar to display it).

The Fill Cells Randomly dialog box opens.

3. In the Minimum Value field, enter the lowest acceptable value.

4. In the Maximum Value field, enter the highest acceptable value.

5. In theHold field, choose an exposure holding value.
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6. If you are applying this option to a drawing column, enable theWhole Numbers option to avoid
decimal points.

7. Click OK.

Filling Empty Cells
The Filling Empty Cells feature is used to extend the exposure of single frame drawings to fill the
range of empty cells after each one.

When creating drawings on cells that are not side-by-side, the exposure of the first drawing no longer
fills automatically. You need to select the frame range where you want your drawings to hold their
exposure up to the next drawing and use the Fill Empty Cells command.

How to fill empty cells

1. In the Xsheet view or Timeline view, select a cell range.

2. Do one of the following:

‣ In the Timeline View toolbar, click on the Fill Empty Cells button.
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Each drawing in the selection is exposed in the range of empty cells that follow it.

Creating Cycles
Once you have entered a series of drawings and exposures, you can create cycles out of them in
several ways.

You can loop your drawings using the following commands:

• Paste Cycle

• Paste Reverse

• Create Cycle

When you create a drawing cycle, all of the repeated drawings are linked to the same original files.
This means that when you modify, repaint, or correct a drawing named “1,” all drawings named “1”
are updated simultaneously. In order to modify a drawing independently from its other exposures,
you must duplicate the drawing.

How to create a cycle

1. In the Timeline view, select the cell range to loop.

2. In the Timeline View toolbar, click the Create Cycle button (you may have to customize the
toolbar to display it).

The Create Cycle dialog box opens.
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3. Enter the number of cycles you want, including the current selection.

How to paste a cycle

1. In the Xsheet or Timeline view, select the cell range to loop.

2. From the top menu, select Edit > Copy.

3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. Do one of the following:

‣ From the top menu, select Edit > Paste Cycle.

‣ Right-click and select Paste Cycle.

‣ Press Ctrl + / (Windows/Linux) or ⌘ + / (Mac OS X).

The Paste Cycle dialog box opens.

5. Do one of the following:

‣ In the Number of Cycles field, enter the number of cycles you want to paste.

‣ Increase or decrease the number of cycles you want to paste.

6. In the Cycle Type menu, select the type of cycle you want to paste.
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‣ Normal (forward): Pastes cycles as for all cycles, starting with the first cell of your selection
and ending with the last.

‣ Reverse: Pastes cycles in the reverse order of the original selection, starting with the last
cell of your selection and ending with the first one.

‣ Forward > Reverse: Pastes the first cycle in your selection as is, then the following one in
reverse order. This repeated until all cycles are pasted.

‣ Reverse > Forward: Pastes the first cycle in your selectionin reverse order, then the
following one as is. This repeated until all cycles are pasted.

7. Click OK.

You can perform the same operation using the Paste Special dialog box. To open the Paste Special dialog
box, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘ + B (Mac OS X).

How to paste a reversed cycle

1. In the Xsheet or Timeline view, select the cell range to paste in reverse order.

2. From the top menu, select Edit > Copy.

3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. Do one of the following:

‣ From the top menu, select Edit > Paste Reverse.

‣ Right-click and select Paste Reverse.

‣ Press Ctrl + . (Windows/Linux) or ⌘ + . (Mac OS X).
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Managing Drawings

Drawings that are created in Toon Boom Harmony are not stored in their cells. They are actual files
stored in the project’s folder. If you want to rename a drawing or delete a drawing from your project,
you need to edit the file and not the cells.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. Sketch is a subset of
Harmony Stage.

This section is divided as follows:

• Renaming a Drawing below

• Deleting a Drawing on the facing page

• Duplicating a Drawing on page 144

• Copying and Pasting Drawings on page 144

• Merging Drawings on page 147

Renaming a Drawing
To rename a drawing, you need to select the drawing cell and use the Rename Drawing command.

How to rename a drawing

1. In the Xsheet or Timeline view, select the drawing to rename.

2. Do one of the following:

In the Xsheet or Timeline View toolbar, click the Rename Drawing button (you may have to
customize the toolbar to display it).

‣ Press Ctrl + D (Windows/Linux) or ⌘ + D (Mac OS X).

The Rename Drawing dialog box opens.

3. In the New Name field, type in the new drawing name.

How to rename a drawing sequence with a prefix

You can rename a drawing sequence with a prefix, which can be quite useful for cut-out puppet
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breakdown and deformation animation.

1. In the Xsheet or Timeline view, select your drawing sequence. Note that you can only select a
drawing range in one column or layer at the time.

2. Right-click and select Drawings > Rename Drawingwith Prefix.

The Rename Drawing with Prefix dialog box opens.

3. In the Prefix to Add field, type the prefix to add before the drawing name.

How to rename drawings by their frame position

You can rename a series of drawings relative to their frame position. This is useful in hand-drawn
animation.

1. In the Xsheet or Timeline view, select the drawing sequence to be renamed.

2. From the top menu, select Drawing > Rename by Frame.

Deleting a Drawing
You can permanently delete a drawing file from a project's folder.

Deleting a drawing file is an operation that cannot be undone.
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How to delete a drawing

1. In the Xsheet or Timeline view, select the drawings to delete.

2. Do one of the following:

‣ From the top menu, select Drawing > Delete SelectedDrawings.

‣ Right-click and select Drawings > Delete SelectedDrawings.

Duplicating a Drawing
If you want to modify a drawing that already exists, but keep the original drawing intact, you can
duplicate the drawing and work on the copy. When duplicating a drawing, the selected cell is replaced
with the new drawing. The exposure of the original drawing that was on the current cell is removed.
The original drawing is not deleted from the project folder or other cells in which it is exposed.

With Toon Boom Harmony you can create a keyframe at the same time as you duplicate your drawing.
This way you can modify and reposition drawings without affecting the original drawing.

How to duplicate a drawing

1. In the Xsheet or Timeline view, select the drawing to duplicate.

2. Do one of the following:

‣ From the top menu, select Drawing > Duplicate Drawing.

‣ Right-click and select Drawings > Duplicate Drawings.

‣ In the Xsheet view toolbar, click the Drawing > Duplicate Drawing button.

‣ Press Alt + Shift + D.

Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting
the actual drawings, you are pasting the exposure.
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If you want to copy and paste the selected drawings into a different layer or paste the selection in the
same layer to duplicate the drawings, you must use the Paste Special feature.

There are three methods of pasting your selected drawings with the Paste Special dialog box:

• Never Create Drawing Files: Pastes all of your drawings as is. If there is a drawing in a cell, it is
overwritten by the pasted selection.

• Always Create Drawings: Pastes all of your drawings as is, unless a pasted drawing has the
same name as an existing one. In this case, the pasted drawing is duplicated and renamed.

• Only Create Drawings When They Do Not Exist: Pastes only the drawings that are named
differently from existing drawings. If a drawing has the same name as an existing one, it is
ignored and not pasted. This avoids the duplication of drawings in your layers.

This option is useful when you are pasting cut-out character templates containing drawings you
may already have in your scene and some new ones. Using this option, you only paste the new
drawings and are not duplicating all of the other parts you already have.

If you want to perform another Paste Special operation using the same settings you used previously,
you can use the Paste Special Again command instead. You can paste your selection using the same
settings as in the most recent Paste Special operation, without opening the Paste Special dialog box.

How to paste drawings with the Paste Special command

1. In the Xsheet or Timeline view, select the drawings to copy and press Ctrl + C (Windows/Linux) or
⌘ + C (Mac OS X).

2. In the Xsheet or Timeline view, select the cell where you want your pasted selection to start.

3. Do one of the following:

‣ Right-click and select Paste Special.

‣ From the top menu, select Edit > Paste Special.

‣ In the Xsheet or Timeline View toolbar, click the Paste Special button (you may need to
customize the toolbar to display it).

‣ Press Ctrl + B (Windows/Linux) or ⌘ + B (Mac OS X).
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The Paste Special dialog box opens.

4. Select theBasic tab.

5. In the Drawings section, select an option: Always Create Drawings orOnly Create Drawings
When They Do Not Exist.

How to paste new drawings with the previous Paste Special settings

1. Do one of the following:

‣ From the top menu, select Edit > Paste Special Again.

‣ Right-click and select Paste Special Again

‣ In the Xsheet or Timeline view toolbar, click the Paste Special Again button (you may
have to customize the toolbar to display it).

‣ Press Ctrl + Shift + B (Windows/Linux) or ⌘ + Shift + B (Mac OS X).
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Merging Drawings

There are two methods of merging drawings.

• You can merge selected drawings in adjacent elements. The columns and layers will be left
intact, and each new merged drawing will reside in the frames of the left-most column or lower
layer.

• You can merge elements. All drawings will be merged. Unused columns and layers will be
deleted, but the original drawing files are still accessible.

How to merge selected drawings

1. In the Xsheet view, select the drawings you want to merge.

2. Do one of the following:

‣ In the Xsheet View menu, select Columns> Merge SelectedDrawings.

‣ In the Timeline View menu, select Layers > Merge SelectedDrawings.
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3. Do one of the following:

‣ In the Xsheet View menu, select Columns > Merge Selected Columns.

‣ In the Timeline View menu, select Layers > Merge Selected Layers.

In the Xsheet view, the right-most column will contain the merged drawings and the remaining
columns will be left blank at the corresponding frames. In the Timeline view, the bottom timeline
layer will contain the merged drawings from all layers and the other layers will be left blank at the
corresponding frames. Drawings are not deleted and are still accessible.

How to merge drawings in entire layers or columns

1. Do one of the following:

‣ In the Timeline view,select the layers you want to merge.

‣ In the Xsheet view, Shift-click the headers of the columns you want to merge.

2. Do one of the following:

‣ In the Xsheet View menu, select Columns > Merge Selected Columns.

‣ In the Timeline View menu, select Layers > Merge Selected Layers.
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In the Xsheet view, the right-most column will contain the merged drawings and the other columns
will be deleted. In the Timeline view, the bottom timeline layer will contain the merged drawings
from all layers and the other layers will be deleted. Drawings are not deleted and are still accessible.

Modifying the Layer and Column Display
You can change the way a layer in the Timeline view or a column in the Xsheet view display. You can
stay organized without changing the content of elements or your animation output.

This section is divided as follows:

• Showing and Hiding Layers below

• Showing and Hiding Columns on the next page

• Modifying the Look of the Column on page 152

• Xsheet Thumbnails on page 156

• Changing the Colour of a Layer or Column on page 157

• Setting Scene Markers on page 158

• Setting Tempo Markers on page 162

Showing and Hiding Layers
As you work in the Camera view, some layers may be in the way or are used as references. You can
hide these layers to make your work area less cluttered and easier to navigate. You can show and hide
layers in the Timeline view in several different ways.

How to show or hide all layers

1. Do one of the following:

‣ In the Timeline view’s Layer toolbar, click the Enable/Disable All button to show or hide all
layers.

How to show or hide individual layers

1. Do one of the following:

‣ On the right side of the Timeline view, select or deselect the layer’s checkbox.
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When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet
view.

How to enable the selected layer and disable all others

1. Do one of the following:

‣ In the Timeline view’s Layer toolbar, click the Show Selection and Hide All Others button.

Showing and Hiding Columns
The Xsheet view has a Column List section that can display all the columns contained in the exposure
sheet. It can be used to hide individual columns.

If you need to see a column after it has been hidden, you can display it directly from the Xsheet view
without using the Column List section.

You can also hide an entire column type, such as Drawing or Sound.

When a column is hidden in the Xsheet view, the corresponding layer is disabled in the Timeline view.

How to show or hide columns in the Xsheet view

1. In the Xsheet View toolbar, click the Show Column List button.

2. On the right side of the Functions section, click the Expand button to display the Column List
section.

3. Do one of the following:

‣ In the Column List section, select the columns to display and deselect the columns to hide.

How to show a hidden column in the Xsheet view

1. In the Xsheet view menu, click on the thick grey line that represents a hidden column. You can also
right-click on the column header and select Show Hidden Columns.
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The Show Hidden Columns dialog box opens.

2. In the Show column, select the hidden columns you want to display in the Xsheet view.

‣ Click Check to select all the selected columns.

‣ Click Uncheck to deselcted all selected columns.

How to show or hide Xsheet columns using the Column List

3. On the right side of the Functions section, click the Expand button to display the Column List
section.

4. In the Column List section, select the columns to display and deselect the columns to hide.

How to show or hide an Xsheet column type using the Column List

1. In the Column List section, click the button corresponding to the type you want to show or hide.

Column Type but-
ton

Action
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Show/Hide All Columns

Show/Hide Drawing Columns

Show/Hide Sound Columns

Show/Hide Annotation Columns

Modifying the Look of the Column
In Harmony, you can modify the way the column displays drawings, empty cells and the column width.

You can modify the following elements:

• Empty cells

• Row units

• Held exposure

• Column width

How to modify the look of empty cell

1. From the Xsheet View menu, select View > Empty Cells > With an “X” or Blank.

How to modify row units

1. From the Xsheet View menu, select View > Row Units > Frames or Feet.
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How to modify the look of a held exposure

‣ In the Xsheet View menu, select View > Held Exposures > Line or Value.

How to modify column width

1. In the Xsheet view, select any column to modify the width.

2. From the Xsheet view menu, select View > Set Columns Width.

The Xsheet Column Width dialog box opens.

3. In the Column Width field, enter the desired width in pixels.

4. To end the operation:

‣ Click OK to validate and close the dialog box.

‣ Click Apply to validate the operation and keep the dialog box opened to adjust the next
column’s width.

‣ Click Set As Default to create all the new columns to this width.

‣ Click Close to cancel the operation.

5. To restore all columns to the default value, in the Xsheet View menu, select All Columns to
Default Width.

Drawing Identification
In the Xsheet view, you can identify drawings as Key, Breakdown or In-between. This helps to keep the
Xsheet well organized while animating.

When working with several animators, directors, or even other studios, the necessity for retakes will
often arise. Harmony also gives you the possibility to mark new drawings as either Retake Key, Retake
Breakdown, or Retake Inbetweens.

If your production requires you to mark drawings with a custom marker, you also have the option to
create your own.

Make custom marks for the Xsheet by creating your own icons, then cutting, pasting and changing a
bit of code. Not only is it possible to have your custom mark appear in the Xsheet and Mark Drawing
toolbars, but also in the Onion Skin and Flip toolbars.
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You can create custom shortcuts for the Drawing Identification options in the Preferences dialog box.

How to mark a drawing as Key, Breakdown or In-between

1. From the top menu, selectWindows > Toolbars > Mark Drawing.

The Mark Drawing toolbar displays.

2. In the Xsheet view, select the cell you want to identify. This option is not available in the Timeline
view.

3. In the Mark Drawing toolbar, click one of these buttons: Mark as Key Drawing , Mark as
Breakdown Drawing  or Mark as In-between Drawing . In the Xsheet View menu, you can
also select Drawing > Mark Drawing As > Key Drawing, Breakdown Drawing, In-between
Drawing, Retake Key, Retake BD and Retake IB.

‣ If you selected Mark as Key Drawing, a icon appears in the cell.

‣ If you selected Mark as Breakdown Drawing, a icon appears in the cell.

‣ If you selected Mark as In-Between Drawing, there is no icon displayed in the cell since it is
used to remove a Key or Breakdown marker.
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How to create custom markers

1. With a bitmap editing software, create the following icons in PNG format:

‣ Mark Drawing Toolbar icon (24 x 24 pixel)

‣ Onion Skin Toolbar icon (24 x 24 pixel)

‣ Flip Toolbar icon (24 x 24 pixel)

‣ Xsheet Column icon (16 x 16 pixel)

2. Close Harmony.

3. When your icons are ready, open the Toon Boom Harmony drawingTypes.d folder.

If the drawingTypes.d folder does not exist, you must create it. To do so, copy the
resources folder from the following location.

• Windows: C:/Program Files (x86)/Toon Boom Animation/Harmony
11.1/resources/drawingTypes.d

• Mac OS X: /Applications/Harmony 11.1/resources/drawingTypes.d

• Linux:
/usr/local/ToonBoomAnimation/ProductNameVersion/resources/drawingTypes.d

Stand-alone

‣ Windows: C:\Users\USERNAME\AppData\Roaming\Toon Boom Animation\Toon
Boom Harmony\full-1100-pref\drawingTypes.d

‣ Mac OS X: /Users/USERNAME/Library/Preferences/Toon Boom
Animation/Toon Boom Harmony/full-1100-pref/drawingTypes.d
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The Library folder is usually hidden in the Finder. To see all the hidden folders and files,
type the following in a terminal window:

defaults write com.apple.Finder AppleShowAllFiles YES

‣ Linux: /home/USERNAME/Toon Boom Animation/Toon Boom Harmony/full-
1100-pref/drawingTypes.d/

Network

In Harmony Network, the path is global for all users so you must create the folder and place in
/USA_DB.

‣ /USA_DB/drawingTypes.d

4. Paste your icons in the drawingTypes.d directory.

5. In the same directory, open the drawingTypes.xml file in a text editor.

6. For each custom icon you want to create, add the following line. Make sure to place it before this
closing tag: </DrawingTypes>.

‣ <DrawingType text="NewButtonName" pixmapFile="XsheetIcon.png"
commandIcon="MarkDrawingIcon.png" flipIcon="FlipIcon.png"
onionIcon="OnionIcon.png" />

7. In that line, replace the following information with your new icon information:

‣ NewButtonName: Write the name of your new marker. This name will appear in the button
tooltip.

‣ XsheetIcon.png: Write the name of the icon that you created to appear in the Xsheet
column. Include the file extension.

‣ MarkDrawingIcon.png: Write the name of the icon that you created to appear in the Mark
Drawing toolbar. Include the file extension.

‣ FlipIcon.png: Write the name of the icon that you created to appear in the Flip toolbar.
Include the file extension.

‣ OnionIcon.png: Write the name of the icon that you created to appear in the Onion Skin
toolbar. Include the file extension.

8. Save the file and close it.

9. Start Harmony.

Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it is not always easy to quickly
identify a particular column. Displaying the column thumbnails makes this easier. This option displays a
small thumbnail picture of the current frame below the column header.

How to display the thumbnails

1. In the Xsheet view, select View > Show Thumbnails.

The thumbnails appear.
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Changing the Colour of a Layer or Column
To easily identify elements in the Timeline or Xsheet view, you can change the colour of layers and
columns.

How to change the layer’s colour in the Timeline view

1. Do one of the following:

‣ In the Timeline view, click the colour swatch of the layer you want to modify.

2. In the Select Colour dialog box, select a new colour for your layer.

3. Click OK.

The layer’s background colour is updated. In a Drawing layer, exposed cells are the brighter,
selected colour for easy identification. The corresponding column colour is also updated.

How to reset a layer’s colour in the Timeline view

1. In the Timeline view, select the layers to reset.

How to change a column’s colour in the Xsheet view

1. In the Xsheet view, select one or more columns to modify.
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2. Right-click on the column’s header and select Colour > Change Columns Colour.

3. In the Select Colour dialog box, select a new colour for your columns.

4. Click OK.

The column’s colour is updated. The corresponding column colour is also updated.

How to reset the column’s colour in the Xsheet view

1. In the Xsheet view, select the columns to reset.

2. Right-click on the column’s header and select Colour > Default Columns Colour.

Setting Scene Markers
Scene markers are visual indicators displayed at the top of the timeline in the frame counter area. You
can use it to denote anything relevant to your work. You can indicate at the frames you want to clean
up, a change in action, an impact, or where you intend to apply an effect. You can also add a note to a
scene marker, which is displayed when you hover over the scene marker.

There are two ways to add a scene marker. You can make a frame range selection and mark that
whole section or simply mark the current frame.

How to mark the current frame

1. In the Timeline view, make sure the playhead is set on the frame you want to mark. Even if you
right-click on a different frame, the scene marker will be created on the current frame, which means
where the red playhead is.

2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.
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The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or
the colour of the last scene marker you created.

3. Double-click the Colour box to select a colour for your scene marker.

4. In the Note field, enter text to display a tooltip.

5. Click OK.

6. In the Timeline view, the scene marker is displayed at the current frame. Hover over the scene
marker to display its note as a tooltip.

How to create a scene marker on a frame range

1. In the Timeline view frame counter, select the frame range on which you want to mark your scene.

2. Right-click and select Scene Markers.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or
the colour of the last scene marker you created.
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3. Click the colour swatch and select a colour for the scene marker.

4. In the Note field, enter text to display as a tooltip.

5. Click OK.

6. In the Timeline view, the scene marker is displayed over the selected frame counters. Hover over
the scene marker to display its note as a tooltip.

How to edit a scene marker

If you select only a part of a scene marker, you will not open the scene marker for editing. You will only be
able to create a new scene marker to overwrite it.

1. In the Timeline view frame counter, select the entire scene marker.

2. Right-click the selection and select Edit Scene Marker.

The Timeline Scene Marker dialog box opens.

3. Make your changes.

4. Click OK.

How to delete a scene marker

1. In the Timeline view frame counter, at least one frame counter in the scene marker you want to
delete.
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2. Right-click the selection and select Delete Scene Marker.
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Setting Tempo Markers

Tempo markers are used to synchronize your animation with a musical score. This lets you reproduce
the FPB (Frames Per Beat) and use the tempo signature as tempo markers. The Xsheet view allows
you to pace your animation according to the tempo or beat of the soundtrack music or to any rhythmic
sound, such as the ticking of a clock or water leaking from a spout.

How to set the tempo markers

1. In the Xsheet View menu, select View > Set TempoMarker or in the sound column, right-click and
select View > Set TempoMarker.

The Tempo Marker dialog box opens.

2. Reproduce the tempo and beat value of your music or sound for the Xsheet view marker display.

‣ Starting Frame: Enter the number of the frame where you want the tempo markers to
begin.

‣ Frames/Beat: Set the frames per beat value. This will determine the frequency (in frames) in
which a beat marker will appear. Keep in mind that, by default, 24 frames represent 1
second.

‣ Beat/Bar: Set the tempo of your music or sound. This will determine the frequency (in beats)
in which a tempo marker will appear in the Xsheet view.

3. Click OK.
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Chapter 7: Character, Prop and Location Design

Another important step in the project creation is the character, prop and location design. This
determines the style and models to follow for the entire project.

The design can be created on paper and scanned in or it can be created digitally. You can draw and
even create the colours entirely on paper, while others like to design on paper and scan the drawings
to create the colour model in a software program. The most popular method is to design directly in
Harmony.

To save paper and time and avoid having to recreate colour palettes, Harmony gives you the ability to
design all elements directly in the application. This keeps all your work within the same software,
avoids using a lot of paper and losing time scanning in elements and importing them.

The character and prop design process is divided in three steps:

• Preparation on the next page

• Sketching the Model on page 166

• Cleaning and Inking the Model on page 179

Harmony has an extensive set of drawing tools that can be used to design your characters. You can
learn more about this in the following topic:

• Drawing Tasks on page 181

Each drawing tool has a series of options to customize its behaviour and drawing style. You can learn
more about them in the following section:

• Drawing Tool References on page 242
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Preparation

To prepare for the design task, you will need to go through a few steps:

• Getting References below

• Using the Workspace below

Getting References

Creating models requires two main reference sources, the script and the storyboard. Once you have
the script in hand, you can learn about the characters and their personalities, the props, the
ambiances, and so on. This will be your main reference, so it is very important to read it carefully.

The storyboard is the second reference source and it can be quite useful as well. Although it will not
yet be the final version of the storyboard, it will show you what the character is doing and what props
need to be designed.

Using the Workspace
Once your scene is created, you can open it and set your workspace.

To sketch the characters, props or locations directly in Harmony, you will mostly use the Camera
views along with the Colour, Timeline and Tool Properties views.

188



Toon Boom Harmony 11.1 Sketch Module Network User Guide

189



Chapter 7: Character, Prop and Location Design Sketching the Model

Sketching the Model

Now that your references and scene are created, you can start designing. To draw your characters,
props and key locations, you will need to learn the following:

• Drawing with the Brush or Pencil Tool below

• Override Tool on the facing page

• Relative Size on page 168

• Palettes and Colours on page 172

• Sketching the Character on page 176

Drawing with the Brush or Pencil Tool

The Brush and Pencil tools are used for drawing and sketching. Both tools support pressure
sensitivity, allowing you to create lines with variable thickness. The Brush tool produces contour vector
lines. The Pencil and shape tools produce central vector lines. This means that a pencil line’s control
points (used to deform its shape) are located along the length of the central spine, while the Brush
line’s control points are located along the contour.
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• If you draw with the Brush tool and want to modify the thickness, use the Contour Editor
tool.

• If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor
tool.

• You can also convert a brush zone into a pencil line with the Brush Stroke to Pencil Line option.

If you sketch a drawing using a semitransparent colour to get a paper-like feel, you should use the
Brush tool as it produces a more realistic and natural feel. The pencil line is very useful for tracing clean
or final drawings.

Also, it is recommended to use brush lines when designing cut-out puppet articulations which use
patches.

Override Tool
The Override tool lets you increase productivity by rapidly switching between tools used for short
tasks and your previous tool. Most drawing tool shortcuts are accessed using the Alt key followed by
another key, such as the Eraser tool which is accessed by pressing Alt + E.

If you are drawing with the Brush tool and need to briefly switch to the Eraser before continuing, hold
down the E key while you are erasing. Once you are done, release the E key to return to the previous
tool; in this case, the Brush tool. You can do the same for most drawing tools that have a shortcut
composed of Alt followed by another key.

191



Chapter 7: Character, Prop and Location Design Relative Size

Relative Size

The size relation between the props, characters and backgrounds is very important in maintaining
consistency and structure throughout the project.

A production can contain many characters and props. It is not unusual for these to be created by
different people. If there is no size control implemented, the characters and elements created by
different artists can vary greatly. When this occurs, the characters that are placed together in a scene
will be out of proportion. The animator or person doing the scene setup will then have to scale them
to the correct size.

When a character or prop is scaled down, the outline will become increasingly thinner. By the time the
element is scaled to its proper size, the outline may be so thin that a difference between one
character's outline and the one beside it will not look very good.

Here are a few tips you can use to create a suitable size relation.
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Line Up

A line up consists of copying and pasting all your character designs into the same drawing and then
scaling them to the correct proportion in relation to the other characters. This line up is very
important and should be handed to any animator, layout and posing artist or scene setup person
working on the project.

For the prop design, it is recommended that you paste one of the main character's hands or even the
full body beside the prop. This enables the animator to know what size to draw the prop.

In your character design scene, it is a good idea to create a column for the character line up.The line
up is usually done during the character design step. When the character builder imports the model
to the breakdown scene, the size relation should be correct.

Field Chart

Harmony includes a field chart in its Camera view. This tool is very useful in setting the characters'
and props' heights.

It is recommended that you keep the character design and breakdown inside the 12 field size. This
ensures that it fits the default camera size and the template thumbnails. If some parts were drawn
too big or too far apart, you can use the Reposition All Drawings tool and reposition, scale or rotate
multiple drawings from different layers all at once.
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Use the Show Grid option to display a grid in the Camera view.

Name Button Description Keyboard Shortcut

Show
Grid Displays the grid

From the top menu,
select View > Grid >
Show Grid

Press Ctrl + '
(Windows/Linux) or
⌘ + ' (Mac OS X).

Square Displays a standard square grid
From the top menu,
select View > Grid >
Square.

12 Field Grid Displays a 12-field size grid
From the top menu,
select View > Grid >
12 Field Grid.

16 Field Grid Displays a 16-field size grid
From the top menu,
select View > Grid >
16 Field Grid.

Underlay
Displays the grid under the drawing
elements

From the top menu, select
View > Grid > Underlay

Overlay
Displays the grid over the drawing
elements

From the top menu, select
View > Grid > Overlay

How to use the Reposition All Drawings

1. In the Tools toolbar from the Select drop-down menu, select the Reposition All Drawings
tool. This also automatically selects every stroke in your drawing in the Camera view.

2. To deform or reposition a selection:

‣ To reposition, click and drag your selection to a new area.

‣ To scale, pull or push on the top, side, bottom or corner control points. Hold down Shift
to lock the selection’s ratio.
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3. When you release your cursor, every drawing contained in the drawing layer you repositioned,
scaled, rotated or skewed will follow the same transformation.

Brush Size

Harmony provides a variety of pens and brushes and also allows you to create and save your own
through creating a tool preset.

It is a good idea to create and save pens with precise sizes and parameters to trace and design your
models and breakdowns.

How to create a tool preset

1. In the Tools toolbar, select a tool, for example the Brush tool.

2. Use the Tool Properties view to customize the tool.

3. To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the
tool. Note that when using this preset in another scene not using that colour palette, upon
selecting this new preset, a colour recovery dialog box will appear asking to add this colour to
your scene.

4. In the Tool Presets toolbar, click the New Tool Preset button.

5. In the New Tool Preset dialog box, in the Name field, type a name for your new preset.

6. From the icon list, select an icon to quickly identify your preset or upload your own by clicking the
File button.
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7. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset.

8. When you select any of the following options, they will take effect when you use the tool preset. If
an option is deselected, then using a tool preset will not override your current settings.

‣ Colour: Saves the current colour into the tool preset.

‣ Tool: Only the colour will be associated. You could, for example, set three different
colours with shortcuts. It would use the current tool with the chosen preset colour.

9. Click OK.

Palettes and Colours
Harmony has an integrated palette system. Each character, prop or background can have its own set
of colours and each colour in the palette can be associated to colour fill zones on a drawing. You can
create as many palettes and colours as you need.

Each scene created in Harmony includes a default colour palette which contains a standard set of
colours for sketching and painting.
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You can sketch and design using the default palette without any problem. However, it is not
recommended that you use the default palette for the colour models. A different colour palette should
be created for each colour model.

To sketch and design with a different colour swatch or create a palette for each character, prop or key
location, you will need to learn how to manage the Harmony palettes.

How to create a new palette (Basic Palette Lists mode)

1. From the Colour View menu, select Palettes >New or click the New Palette button.

‣ Make sure that you have the necessary rights to modify the palette list. If you do not, select
Edit > Edit Palette List Mode.

The Create Palette window opens.

2. Enter the palette name according to the model.

3. Click OK.

The palette appears in the drawing element’s palette list.

How to lock or unlock the palette list

‣ In the Colour view, click the Edit Palette Mode button.

A grey pencil icon appears in the top-right corner of the Palette list.

How to add or modify a solid colour swatch

1. In the Colour view, click the New Colour button.

2. From the Colour View menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens.
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3. To set your colour, do one of the following:

‣ In the colour wheel, select a colour.

‣ Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options
to change the look of the colour picking area.

‣ Click the Dropper button to select any colour on your screen. It can be from the Toon
Boom Harmony interface, your operating system or any other open application.

You can also clickMultiWheelMode to open the Multiwheel Colour dialog box. This displays all
the picking area styles together and also contains a picking undo list. To return to the regular
Colour Picker window, click Single WheelMode.
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4. Click on the Shade Scale swatches to modify the shade of the selected colour.

5. Adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha
field.

6. Click theAdd button to add the current selected colour to the Colour Storage Library, so you can
quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by
double-clicking on its name.
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Sketching the Character

You are now ready to sketch your models. There are two tasks to perform in order to draw your
characters:

• Add a drawing layer

• Sketch the model

You have the choice to sketch your model as a bitmap or vector drawing. If you like the feel of drawing
with bitmap lines, you can set your layer as bitmap. If you like drawing with vectors, you can set your
layer as vector. If you use vector, you will be able to enlarge your drawing and zoom into it without
losing quality or resolution. You can also use the Contour Editor and Select tools to resize and modify
lines. If you draw with bitmap, you will not be able to scale the drawing beyond 100% of its resolution
without encountering pixelization issues.

If you would like to separate your lines and colours on separated art layers, see Art Layers on
page 434

How to add a drawing layer

1. In the Timeline view, click the Add Layers button.

2. In the Name field, name your new layer.

3. Set the Line Art option to Vector to get a vector layer or to Bitmap to have a bitmap layer.

4. Click OK.

A new drawing layer is added to the Timeline view.
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How to sketch a model

1. In the Tools toolbar, select the Brush tool or press Alt + B.

2. In the Tool Properties view, select a brush preset and adjust its parameters.

3. In the Timeline or Xsheet view, click in the first cell of the drawing layer.

4.

5. In the Camera view, enable the Grid (Field Chart). You can press Ctrl + ' (Windows/Linux) or ⌘ + '
(Mac OS X).

‣ Make sure the Camera view is the active view while using the keyboard shortcut.

6. In the Camera view, start drawing.

7. To select a different colour, in the Colour view, select a different colour swatch. Double-click on the
colour swatch to open the Colour Picker window and modify the colour. Remember that anything
already painted with that colour swatch will update to the new colour.
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8. In the Camera view, use the Rotary Table to rotate your workspace.You can press Ctrl+Alt
(Windows/Linux) or Ctrl+⌘ (Mac OS X).

‣ The default keyboard shortcut to reset the workspace rotation is Shift + X.

9. If you decide to draw in the next cell and need to see your previous drawing, enable the Onion Skin
by pressing Alt + O.

202



Toon Boom Harmony 11.1 Sketch Module Network User Guide

Cleaning and Inking the Model

When your rough models are ready, it is time to clean and ink them. You can still use the default
palette and colours to do so, especially if you are not the one doing the colour styling. If you have
already created a palette for your model, you can add new colours for tracing.

If you want to keep your roughs and sketches, add a new drawing layer and trace in it using the Light
Table. This is the equivalent of adding a sheet of paper and tracing over the rough using the animation
disk light table. You only need to disable the rough layer to prevent it from appearing in the final scene
render.

If you would like to separate your lines and colours on separated art layers, see Art Layers on
page 434

How to trace your character in a new layer

1. In the Timeline view, add a new drawing layer and name it: clean.

2. Do one of the following:

‣ In the Tools toolbar, select a drawing tool.

3. In the Timeline or Xsheet view, select the cell in which you want to draw.

4. Trace the model.

5. To make perfect points and corners, you can intersect the two strokes to create a point. Using the
Cutter tool, you can automatically trim the excess portion. In the Tool Properties view, enable
the Lasso selection type. Make sure the Use Mouse Gesture button is enabled. In this
mode, you can automatically delete any extra sections of line in your artwork by simply clicking,
holding and dragging your mouse over it.
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6. If you are using the Pencil tool to clean your drawing, you will need to merge your pencil lines
together after cropping the points.

‣ In the Tools toolbar, select the Select tool.

‣ In the Camera view, select the two strokes to be merged.

‣ In the Tool Properties view, click the Merge Pencil Lines button.

‣ You can also set the Join option toMitre.
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Drawing Tasks

Harmony has a wide variety of drawing tools for all kinds of drawing tasks. This section covers how to
use these tools. For the complete details on their options in the Tool Properties view, see Drawing
Tool References on page 242.

In this topic, you will learn about:

• Current Drawing on Top below

• Drawing with the Pencil Tool on the next page

• Drawing with the Brush Tool on page 191

• Drawing with Textured Brushes on page 197

• Viewing the Final Lines as You Draw on page 210

• Selecting the Current Colour of a Tool on page 211See "Selecting the Current Colour of a Tool
" on page 211

• Selecting Drawing Objects on page 213

• Erasing Parts of a Drawing on page 217

• Reshaping a Drawing Using the Contour Editor Tool on page 219

• Reshaping Pencil Lines with the Pencil Editor Tool on page 221

• Drawing with Shapes on page 223

• Drawing with the Polyline Tool on page 224

• Drawing with Invisible Lines on page 225

• Deforming a Drawing with the Perspective Tool on page 227

• Warping a Drawing with the Envelope Tool on page 228

• Cutting Drawing Parts on page 230

• Smoothing Lines on page 231

• Working With Text on page 232

• Working with Tool Presets on page 232

• More Drawing Tools on page 236

Current Drawing on Top
In Harmony, when you draw on a layer, the artwork is displayed in the correct order. For example, if
the layer on which you are drawing is located behind an object on another layer, the lines you are
drawing will be hidden behind that object.
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This lets you display the selected drawing on top of everything while you draw. By enabling this
option, each time you select a drawing tool, the selected drawing is displayed in front of everything in
the Camera view.

The Show Current Drawing on Top status (enabled or disabled) is remembered when you exit
Harmony. When you restart the application, the last status will be used.

You only need to enable this option once, it is not necessary to do it each time you select a drawing
tool.

How to display your drawing on top

1. Do one of the following:

‣ In the Camera bottom toolbar, click the Current Drawing on Top button.

2. In the Tools toolbar, select a drawing tool.

3. In the Camera view, start drawing.

Drawing with the Pencil Tool

The Pencil tool is for drawing the final images, such as character modules, cut-out puppet and clean
animation. The pencil creates a central vector shape. Pencil lines support pressure sensitivity and
texture.
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How to draw with the Pencil tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar, select the Pencil tool or press Alt + /.

3. In the Colour view, click a colour swatch to select a colour.

4. In the Camera view, start drawing.

‣ When you get close to an existing pencil line, hold Alt to draw and connect your stroke to
the existing one. Pencil lines are central vector lines and you might think your line is
connected, but in fact, only the contour is touching the other one. Also, make sure the
central vector crosses the other one.
To connect the start or end of your stroke, hold Alt when you start or finish drawing a line.

‣ To draw a straight line, press Shift + Alt as you draw.

How to modify the pencil settings

1. In the Tools toolbar, select the Pencil tool or press Alt + /.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.
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The Pencil Properties window opens.

This is where you set the minimum and maximum sizes of your drawing tool which will produce
the thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

Parameter Description

Maximum Size Sets the maximum width of the line.

Minimum Size Sets the minimum width of the line in relation to the maximum size.

Smoothness
Lets you modify the central line smoothness of the line. This parameter
smooths the initial movement of your line. Increasing the value will result
in a smoother line with fewer control points.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter will
smooth the contour of the line once it has been traced; the higher the
value, the fewer control points will compose your line.
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Shape

You can adjust the start, end, and joint style of a selected
pencil line.

• Start: Lets you select the style of the start tip, which is the
first tip you drew. You can choose between Round or Flat
style.

• End: Lets you select the style of the end tip, which is the
last tip you drew. You can choose between Round or Flat
style.

• Join: Lets you select the joint style. The joints are where
the line curves abruptly. You could also define the Join
style as the corner style. You can choose between Round,
Mitre and Bevel style.

Texture See Pencil Line Texture on page 188.

Working with Pencil Presets

A preset is a pencil with specific properties. You can work with regular pencil presets and thickness
stencils.

Regular pencil presets allow you to set the size and smoothing of the line or shape. As you draw, the
thickness of the line varies according the amount of pressure you apply with a pen and tablet.

Thickness stencils that are indicated with this icon are also set with specific properties, but
disregards the pressure you use with your pen and tablet. The line thickness varies. You can access
thickness stencils from the list of presets on the Tool Properties view or create your own.

How to select a pencil preset

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Tool Properties view, use the Presets menu to select a pencil preset.
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3. In the Camera view, draw your pencil line or shape.

How to select a pencil thickness stencil

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Tool Properties view, use the Presets menu to select a thickness stencil. They are marked

with this icon.

3. In the Camera view, draw your pencil line or shape.

How to create a pencil preset

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Tool Properties view, adjust your pencil settings—see How to modify the pencil settings on
page 183.

3. In the Tool Properties view, click the New Brush button.
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The New Preset dialog box opens.

4. Type in a name for your new pencil thickness stencil and clickOK.

5. Start drawing in the Camera view.

How to create a pencil thickness stencil

1. In the Tools toolbar, select the Select tool.

2. In the Camera view, select the pencil line or shape from which you want to take the style.

3. In the Tool Properties view, click the New Thickness Stencil button.

A new thickness stencil is added to the end of the list in the Presets menu.

4. In the Presets menu, select a new thickness stencil and click on a line or shape in the Camera view
to apply the thickness stencil you created.

How to apply a thickness stencil to a pencil line or shape

1. In the Tools toolbar, select the Select tool.

2. In the Camera view, select the pencil line or shape on which you want to apply a style.

3. In the Tool Properties view, select the style you want to apply from the Presets list.
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The style you selected is applied to your selection.

How to rename a thickness stencil or pencil preset

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Presets menu, select the thickness stencil or preset you want to rename.

3. From the Brush menu, select Rename Brush.

The Rename Preset dialog box opens.

4. In the Name field, type in the new name.

How to delete a thickness stencil or pencil preset

1. In the Tools toolbar, select the Pencil tool.

2. In the Presets menu, select the thickness stencil or preset to delete.

3. Click the Delete Preset button.

Pencil Line Texture

You can apply a texture to a pencil line.

Pencil lines support texture. Before drawing, you can select or import a texture and apply it to your
lines. You can also change it afterwards using the Select tool. Textures are independent from pencil
templates.

When you import a texture in your pencil styles, it is saved in your scene. If you want to add that
texture to a bank that you will reuse in different scenes, you can add that texture to your preferences.
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How to apply a preset texture to a pencil line

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.

In the Pencil Properties display.

3. In the Texture section, select a texture for the pencil.

4. In the Camera view, draw a pencil line.

How to create a pencil texture template with the Pencil tool

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Pencil Properties editor, click the New Texture button or select New Texture from the
Texture menu.

‣ To delete a preset style, click the Delete Texture button.

4. Browse for your bitmap texture file.

The file must be a TGA or PSD. Your texture MUST HAVE an alpha channel.
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5. Click Open.

The imported texture is saved in your scene texture list.

6. In the Pencil Properties editor, select your new texture.

7. In the Tool Properties view, click the Texture menu and select Rename Texture.

The Rename Opacity Texture dialog box opens.

8. In the Name field, type the template name and click OK.

9. In the Camera view, draw your pencil lines.

How to add a texture to your preferences

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Pencil Properties property editor, select a texture from the Textures area to add to your
preferences.
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4. Click the Copy to Preference button.

How to apply a preset texture to a pencil line

1. In the Tools toolbar, select the Select tool.

2. In the Camera view, select a pencil line.

3. In the Tool Properties view, select a texture from the Textures area to apply to the selected
stroke.

Drawing with the Brush Tool
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The Brush tool is pressure sensitive and can create a contour shape which gives a thick and thin line
effect, as if the drawing was made with a paint brush.

With the Brush tool, you can draw as vector or bitmap, depending on your preference. When you add
your drawing layer, you can simply select the vector or bitmap option. If you use vector, you will be
able to enlarge your drawing and zoom into it without losing quality or resolution. You can also use
the Contour Editor and Select tools to resize and modify lines. If you draw with bitmap, you will not be
able to scale your drawing beyond 100% of its resolution without encountering pixelization issues.

You can create your own brush styles. A variety of brush styles are provided allowing you to create and
save your own.This way you can create brushes with precise sizes and parameters and save them so
you can draw and design. Renaming a brush can make it easier to identify and access the brushes you
use most frequently.

A dynamic brush can be created for drawing using patterns created from your artwork. Create a new
dynamic brush to copy a pattern you have drawn to reproduce it quickly. You can create dynamic
brushes using a single or multiple patterns that will automatically switch through the patterns as you
draw.

To draw with the Brush tool

1. In the Timeline view, click the Add Layers button.

2. In the Name field, name your new layer.

3. Set the Line Art option to Vector to get a vector layer or to Bitmap to have a bitmap layer.

4. Click OK.

A new drawing layer is added to the Timeline view.

5. In the Timeline or Xsheet view, select the cell on which you want to draw.

6. In the Tools toolbar, select the Brush tool or press Alt + B.

7. In the Colour view, click a colour swatch to select a colour.
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8. In the Camera view, start drawing.

‣ Hold Ctrl (Windows/Linux) or ⌘ (Mac OS X) to force a line to join the start and end of the
shape while drawing.

The last colour you select while using the Brush tool is recalled the next time you select the Brush tool.

How to select a brush style

1. In the Tools toolbar, select the Brush tool or press Alt + B.

2. In the Tool Properties, select a brush style from the Brush Presets section.

How to modify the brush settings

1. In the Tools toolbar, select the Brush tool or press Alt + B.
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2. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.

The Brush Properties window opens.

This is where you set the minimum and maximum sizes of your drawing tool which will produce
the thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

Parameter Description

Maximum Size Sets the maximum width of the line.

Minimum Size Sets the minimum width of the line in relation to the maximum size.

Smoothness
Lets you modify the central line smoothness of the line. This parameter
smooths the initial movement of your line. Increasing the value will result
in a smoother line with fewer control points.
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Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter will
smooth the contour of the line once it has been traced; the higher the
value, the fewer control points will compose your line.

Tip Shape

Lets you select a tip shape from round and square ones to
star shaped.

Texture See How to draw with textured lines on page 198

How to create a brush preset

1. Make sure your current brush has the settings you want in the preset you are will create.

2. Do one of the following:

‣ In the Brush view, click the New Brush button.

‣ From the Brush menu, select New Brush Preset.

‣ In the Properties window of the tool you are using, click the button in the upper-left
corner.

3. In the New Preset window, type a name for your new brush preset.

The new brush is added to the end of the list of brush preset.

Brush presets cannot be updated. However you can select a preset, which applies those properties to the
current brush. Then you can modify the properties, and create a new preset with the new properties. If
desired, you can delete the old preset.

How to rename a brush

1. In the Tool Properties view, select a brush to rename.

2. From the Brush menu, select Rename Brush.

3. Type in a new name for the brush.

How to delete a brush preset

1. Select the brush preset you want to delete.

2. Do one of the following:

‣ In the Brush Preset view, click the Delete Brush button.

‣ From the Brush Preset menu , select Delete Brush.

How to create a new dynamic brush

1. In the Tools toolbar, select a drawing tool.

2. In the Camera view, draw the pattern you want to use as your dynamic brush stamp.
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3. In the Tools toolbar, click the Select tool and select the parts of the drawing you want to
repeat.

4. In the Tools toolbar, select the Brush tool or press Alt + B.

5. In the Tool Properties view, click the Add Dynamic Brush button to add your selection as a new
dynamic brush preset.

6. From the Brush menu, select Rename Brush.

The Rename Preset dialog box opens.

7. Type in a name for the new dynamic brush and click OK.

8. In the Camera view, start drawing with your dynamic brush to quickly repeat a pattern.

9. To adjust the scale of your pattern to make it bigger or smaller as you stamp it, adjust the
Maximum Size value in the Tool Properties view.

How to create a dynamic brush with multiple drawings

1. In the Timeline view, click the Add Layers sbutton to create the layers you want to use as
patterns in your dynamic brush. Make sure to rename your layers.

2. In the Camera view, draw your individual pattern on a separated layer.
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3. In the Tools toolbar, select the Select tool.

4. In the Tool Properties view, disable the Works on Single Drawing option to allow the Select
tool to grab artwork on multiple layers.

5. In the Camera view, select all the drawings you want to add to your new dynamic brush.

6. In the Tools toolbar, select the Brush tool or press Alt + B.

7. Click the Add Dynamic Brush button to add your selection as a new Dynamic Brush preset.

8. From the Brush menu, select Rename Brush.

The Rename Preset dialog box opens.

9. Type in a name for the new dynamic brush and click OK.

10. In the Camera view, start drawing with your dynamic brush to quickly repeat a pattern. When you
use this brush, you will cycle through the drawings.

Drawing with Textured Brushes
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In Harmony, you can use the Brush tool to draw with bitmap textured lines.

In the Brush Tool Properties view, you will find a series of default textured brushes, but you can also
create your own collection by importing PSD or TGA files in the Preset list.

To create your own texture brush, you must prepare your texture file in a third-party software, such as
Adobe Photoshop. If your image has transparency in it, it will be supported. The texture file must be
either a PSD or TGA file. It is recommended that you maintain your texture resolution between 100 x
100 pixels and 400 x 400 pixels.

When you use the Eraser tool to erase a portion of a textured line, the vector frame is cut straight and
you lose the feather created while drawing with the Brush tool. In Harmony, a special option in the
Eraser tool lets you create a soft edge on your textured lines. You can also cut or keep the vector
frame as is.

Sometimes you need to hide the line texture to see the complete vector frame around your lines. This
is useful to help you see any dirt floating around your drawing.

At some point, you may want to modify the look of a textured drawing. Maybe you find that your line
is too smooth or too faint. You can adjust those parameters by using the Adjust Line Texture Opacity
command.

To hide the line texture in the Camera view, you must enable the Show Drawing on Top option. From
the top menu, select View > Show > Current Drawing on Top—see Current Drawing on Top on
page 181.

To draw with textured lines, use the Brush tool and the correct pen in the list. You can also draw with
pencil line texture—see Pencil Line Texture on page 188

How to draw with textured lines

1. In the Tools toolbar, select the Brush tool or press Alt + B.

2. In the Tool Properties view, select a brush and click the Arrow button to open the Brush Properties
view.

3. In the Texture section, select the Select Texture option.
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4. Set the following parameters:

‣ Hardness: The hardness value corresponds to the smoothness of the line edge. The lower
the value, the more blurry and smooth the line edge will be. The higher the value, the
sharper the line edge will be.

‣ Minimum Opacity: This value corresponds to the transparency of the brush when the
pressure is very light. Values closer to 0 produce a more transparent line.

‣ Maximum Opacity: This value corresponds to the transparency of the brush when the
pressure is heavy. Values closer to 1 produce a more opaque line.

‣ Select Texture: Lets you use and select a texture for your brush. The thumbnail displays the
current texture. You can also browse for a texture file to import. Browsing for a texture file
in a brush already using texture will replace the file currently in use, although it will not
replace the texture in the lines already drawn. If your image has transparency in it, it will be
supported. The texture file must be either a PSD or TGA file. It is recommended that you
maintain your texture resolution between 100 x 100 pixels and 400 x 400 pixels.
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‣ Texture Scale: Changes the size of the texture in the lines you draw. If you are using a plaid
texture, the squares will be larger if you increase the value and smaller if you decrease it.

5. In the Camera view, start drawing.

How to erase textured lines

1. In the Tools toolbar, select the Eraser tool, press Alt + E.

2. In the Tool Properties view, click the arrow button.

The Brush Properties window opens.
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3. Adjust the following:

‣ Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.

‣ Contour Smoothing: Defines the number of control points added to the contour
boundaries (around the line). Lower values mean that the line will appear as you draw it
(with more control points added along the centre line). Higher values mean that the line will
be smoothed out (removing control points from the centre line).

‣ Tip Shape: Lets you select a shape for the tip of the eraser. There are a variety of tips to
choose from: round, square, oval, star-shaped, and more. This option is only available when
the textured tip is not in use.

‣ Soft Tip: Gives the tip of your stroke a soft edge.

‣ Keep Vectors: Keeps your vector frames and does not cut them.

‣ Hardness: The smoothness of the line edge. The lower the value, the more blurry and
smooth the line edge will be. The higher the value, the sharper the line edge will be.

‣ Saturation: The intensity of line colour.

‣ Maximum Opacity: The transparency of the brush when the pressure is heavy. Values closer
to 1 produce a more opaque line.

‣ Minimum Opacity: The transparency of the brush when the pressure is very light. Values
closer to 0 produce a more transparent line.
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4. In the Camera view, erase your textures lines.

How to adjust the line texture opacity

1. If you are in Camera view, select theCurrent Drawing on Top option—see Current Drawing on
Top on page 181.

2. In the Timeline or Xsheet view, select the drawing that contains the opacity you want to adjust.

3. In the Camera view menu, select Drawing > Adjust Line Texture Opacity.

The Adjust Line Texture Opacity dialog box opens.

4. Drag the sliders toward the middle to increase the contrast and opacity of the textured lines.

5. If you want to apply the changes to all drawings exposed on the layer, select theApply to All
Drawings option and click OK.
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Drawing with Bitmap Brushes

With Harmony, you have the choice to draw with vector or bitmap brushes. When adding a new
drawing layer in , you can set your art layers (Line, Art, Colour Art) to vector or bitmap. This way, you
can draw in bitmap and paint in vector, draw everything in bitmap, or whatever other combination
suits you.

Not all drawing tools are available when working on a bitmap layer. You can use the following tools:
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• Brush

• Cutter

• Dropper

• Ellipse

• Eraser

• Line

• Paint

• Paint Unpainted

• Pivot

• Rectangle

• Repaint

• Reposition All Drawings

• Select

• Text

• Unpaint

In , when adding a new drawing layer to the Timeline view, you can select the art mode for each art
layer. You can set the Line Art layer to vector while setting the Colour Art as bitmap. You also have the
opportunity to adjust them later by converting them from one to the other. If you are using the
Overlay and Underlay layers, you can also set them to either bitmap or vector.

If you selected the incorrect art mode for your layers, you can open the Layer Properties view and
modify them there directly. If you switch the art mode for a layer that already has strokes on it, the
artwork will NOT be converted. You will be able to add new strokes. A drawing with bitmap strokes
will be converted to a vector layer but the bitmap artwork will remain as bitmap. You will be able to
use vector drawing tools to continue drawing on it. A drawing with vector lines switched to a bitmap
layer will allow you to draw new bitmap strokes and move the vector strokes with the Select tool, but
you will not be able to edit the vector art further. You need to convert the drawings in order to pass
the artwork from one mode to the other.

To always reuse the same art mode settings, you can adjust them in the Preferences dialog box.

Before you start drawing in bitmap, it is important to understand that your artwork will now be
resolution dependent. If you zoom in your scene, you artwork will be enlarged. It is important to plan
ahead and decide how high of a resolution you need your artwork to be. If you plan to zoom in your
scene, the smallest section of the image that the camera will frame must be 100% the size of your
scene resolution. For example, if your scene resolution is set to 1920 x 1080 and you zoom in at 300%,
then the resolution of the bitmap also has to be set to 300%. It is important to change the bitmap
layer resolution before you start drawing.
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The bitmap resolution can be set at the scene level or drawing level. The setting at the scene level
affects newly created bitmap art layers.

Note that even if your drawing resolution is set to be very large, it doesn't mean that your file will be
very heavy. It depends on the amount of artwork your draw in it.

There is a function to change the resolution of bitmap art for individual drawings. You can reduce the
resolution of your bitmap file as well as increase it. Be careful because enlarging the bitmap resolution
on an existing drawing will result in a loss of quality.Harmony will perform a pixel smoothing pass
(resampling) and create additional pixels to avoid losing too much quality, but only to a certain extent.
For example, you used the default scene’s resolution for bitmap art but then discover you are zooming
quite close into the lines. If you do not want to see the pixels appear too much when you are zoomed
in, you can set the bitmap resolution to 200% and the bitmap art will have a higher resolution with
smaller pixels, but will NOT retain 100% of its quality. You can use this function on multiple drawings
using the Apply to All Drawings option. Changing this option will affect existing and selected bitmap
art layers.

If you drew an outline drawing on a bitmap layer, you can vectorize your artwork. Using a vector
drawing layer, you can simply select your bitmap drawing and the vector cell on which you want your
new vector layer to be, and use the Vectorize Line Art in Selected Drawing function.

You should avoid scaling up your bitmap strokes using the Select tool. If you do, keep in mind that
when you continue drawing, your image will be resampled and your new strokes will be at the original
resolution and not the scaled up size.
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Your drawing should be scaled up using the Transform tool instead of the Select tool to avoid creating
very large bitmap layers.

How to add a bitmap layer

1. In the Timeline view, click the Add Drawing Layer button,

The Add Drawing Layer dialog box opens.

2. For the layer, select theVector or Bitmap option.

3. Click OK.
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How to convert drawings to match the art mode

1. In the Timeline view, select the layer that contains the drawings you want to convert.

2. From the Timeline view menu, select Layers > Convert Drawings toMatch Art Layer Type.

You can also right-click on the selected layer and select Convert Drawings toMatch Art Layer
Type.

All drawings in the layer are converted to the selected art mode. Note that bitmap strokes are not
vectorized when converted to a vector art layer. They are simply inserted in a square vector frame
containing a bitmap texture.

How to change the bitmap layer resolution at the scene level

1. From the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.

2. Select theBitmap Resolution tab.

3. Change the bitmap resolution settings and click OK.

The bitmap resolution settings at the scene level affects newly created bitmap art layers.

Parameter Description

Scene Resolution This is the scene resolution preset name and size in pixel.

Width

This is the width of the resolution for the bitmap that will be created.
This is not the actual size of the bitmap. TVG drawings (Toon Boom
drawing native format) have an infinite size. Bitmap TVGs are composed
of small tiles. Therefore it does not mean that because you have art-
work at the four corners of your camera frame or even quite far outside
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of your drawing that your bitmap image will be very large and heavy. By
default, it is set to the same width as the scene resolution.

Height
This is the height of the resolution for the bitmap that will be created.
By default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene res-
olution. If you increase the percentage, the width and height fields will
increase accordingly. If you plan to animate the camera and zoom into
your background, you will need to set a higher resolution so that the
smaller area in which you will zoom will be 100% of the scene resolution.

How to draw with bitmap brushes

1. In the Timeline view, add a bitmap drawing layer—see How to add a bitmap layer on page 206.

2. In the Tools toolbar, select the Brush tool or press Alt + B.

3. In the Colour view, select a colour.

‣ To switch the bitmap colour picker from HSV to RGB, in the Colour view menu, select
Colour > Bitmap Colour Sliders > HSV Sliders or RGB Sliders. You can also right-click on
the colour sliders and select RGB Sliders or HSV Sliders.

When using bitmap colours, there is no longer a link between the painted zones and selected colour.
You can modify the colour picker as much as you want. Your drawing will not be affected. You can
still select colours from your vector colour palette to use the same tint, but you will not create links
between your drawing and the swatches.

4. In the Camera view, start drawing.
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How to vectorize a bitmap drawing

1. In the Timeline view, add a vector drawing layer BELOW the bitmap drawing layer containing the
drawing to vectorize. In your bitmap drawing, the artwork to vectorize must be placed on the Line
Art layer (default drawing layer).

If you place the vector drawing on top of the bitmap layer, you will not be able to
perform the operation. A warning dialog box will display.

2. On the right side of the Timeline view, select the bitmap drawing and corresponding cell in the
vector drawing layer.

3. Right-click and select Drawing > Vectorize Line Art in SelectedDrawing.

The Convert to Vector Drawing dialog box opens.

233



Chapter 7: Character, Prop and Location Design Drawing Tasks

4. In the Vectorization section, select a vectorization preset. You can customize your own preset
using the Add or Edit buttons—see Custom Vectorization Parameters on page 472.

5. Click OK.

Your vectorized drawing is created in the vector drawing layer. Your bitmap drawing remains
intact.

Viewing the Final Lines as You Draw

Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap.
Although, when you draw in the Camera view, notice that your lines may appear jagged. This is caused
by the fast real-time display called OpenGL. If you prefer to see smooth lines as you draw, you can
enable the antialiasing preference.

Full Scene Antialiasing

Full scene antialiasing is generated by your computer’s graphics card. This antialiasing will not only
antialias your drawings, but all your different views in the interface. Full scene antialiasing is an option
you can turn on and off; by default, it is disabled.

There is no need to modify your graphic card settings.

Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be rendered
to 100% of its resolution regardless of your preference settings or graphic card panel.

How to customize the full scene antialiasing parameters

For Mac OS X, you must restart Harmony after you change the parameters.
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1. In the Harmony, do one of the following:

‣ Windows/Linux: Select Edit > Preferences.

‣ Mac OS X: Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

The Preferences dialog box opens.

2. In the OpenGL tab, go to the Full Scene Antialiasing section.

‣ Enable: Select this option to enable/disable the Full Scene Antialiasing.

Number or samples (For MacOS): If you are using a Mac OS X computer, enter the number of samples
you want to be used for the antialiasing process. The number of samples is basically equivalent to the
amount of times a pixel will be enlarged to calculate the antialiasing. This technique is called
supersampling. The higher the number of samples, the better the antialiasing quality will be, but the
longer it will take to calculate.

3. Restart Harmony.

Selecting the Current Colour of a Tool

While drawing and painting, you can let Harmony retain the last colour you selected for each one of
the following tools:

• Brush

• Paint

• Pencil, Ellipse, Line, Rectangle, Polyline

The Colour view has three swatches where you can set a colour for the Brush , Paint, and Pencil tools.

How to unlink the storage swatches

1. In the Colour view, if the storage swatches are linked, click the Link button to unlink them.

2. Click on the Brush storage swatch.
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3. In the Colour list, select the desired colour.

4. Click the Pencil storage swatch.

5. In the Colour list, select a colour.

6. Click the Paint storage swatch.

7. In the Colour list, select a colour.

If you prefer to have Toon Boom Harmony use the same colour swatches regardless of the selected tool,
you can link the three swatches together.

How to link the storage swatches

1. In the Tools toolbar, select one of the following tools:

‣ Brush

‣ Paint

‣ Pencil

‣ Polyline

‣ Line

‣ Ellipse
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‣ Rectangle

2. In the Colour view, if the storage swatches are unlinked, click the Link button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.

Using Independent Colours when Working with Bitmap Layers
When working in the Colour view, by default the current colour is active for both vector and bitmap
layers. You can however, use different reference colours for each layer.

When using bitmap colours, there is no longer a link between the painted zones and selected colour.
You can modify the colour picker as much as you want. Your drawing will not be affected. You can
still select colours from your vector colour palette to use the same tint, but you will not create links
between your drawing and the swatches.

How to use independent colours

‣ From the Colour view menu, select Colours > Independent Bitmap Colour.

Whichever colour you choose as the reference color is retained for that layer type.

Selecting Drawing Objects

The Select tool is used to select strokes in the Camera view, and apply basic transformations, such as
repositioning, rotating, scaling or skewing using the different handles of the bounding box.
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Sometimes, when you want to select multiple objects while leaving one unselected, it can be handy to
select only the stroke or line that you do not want included in your selection. Then, you can invert the
selection so that everything else becomes selected. This can be quite a time saver.

By default, when you draw a selection box, the Select tool will select only the drawing strokes of the
current drawing. If you prefer the Select tool to select all the strokes on all layers, you can disable the
Works on Single Drawing option in the Tool Properties view or the Select Tool Works on Single
Drawing option in the Preferences dialog box.

Some of the transformations, such as rotation, scale, skew, and flip are done relative to the position of
the pivot point. You can temporarily reposition this pivot point for a transformation using the Select
tool.

How to select with the Select tool

1. In the Timeline view, select the cell on which you want to select drawing objects.

2. In the Tools toolbar, select the Select tool or press Alt + S.

3. In the Camera view, select the drawing objects.

‣ You can select all the drawing objects in a drawing by using Edit > Select All or by pressing
Ctrl + A (Windows/Linux) or ⌘ + A (Mac OS X).

4. To deform or reposition a selection:

‣ To reposition, click the selected drawing object and drag the selection to a new area.

‣ To rotate, grab the selection box handle and rotate it.

‣ To scale, pull or push on the top, side, bottom or corner control point. Hold down Shift to
lock the selection’s ratio.
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‣ To skew, drag sideways or up and down the sides or top and bottom segments, between
the control points.

How to invert a selection

1. From the top menu, select Edit > Invert Selection or press Ctrl + Shift + I (Windows/Linux) or ⌘ +
Shift + I (Mac OS X).

‣ You can also find the Invert Selection option in the Camera View menu by selecting Edit >
Invert Selection.

How to enable and disable the Select Tool Works on Single Drawing preference

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS
X).

The Preferences dialog box opens.

2. In the Camera tab, go to the Tools section and select or deselect the Select ToolWorks on Single
Drawing option and click OK.

3. In the Tools toolbar, select the Select tool or press Alt + S.

4. In the Camera view, make your selection. It is possible that you will have to restart Harmony
depending on your system.
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How to temporarily reposition the pivot point

1. In the Camera view, select the drawing object you want to transform.

The pivot point appears in the middle of your selection.

2. Click the pivot point and drag it to a new position.

This becomes the new position of the pivot point for the current transformation and will remain
there until you make a new selection.
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Erasing Parts of a Drawing

The Eraser tool is pressure sensitive, like the Brush tool, giving you more precision when erasing parts
of a drawing. You can also use the Select tool to select drawing objects and delete them instead of
erasing.

How to erase with the Eraser tool

1. In the Timeline or Xsheet view, select the cell that contains objects you want to erase.

2. In the Tools toolbar, select the Eraser tool or press Alt + E.

3. In the Camera view, start erasing.

How to modify the eraser settings

1. In the Tools toolbar, select the Eraser tool .

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.

The Brush Properties window opens.
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This is where you set the minimum and maximum sizes of your drawing tool which will produce
the thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

Parameter Description

Maximum Size Sets the maximum width of the line.

Minimum Size Sets the minimum width of the line in relation to the maximum size.

Smoothness
Lets you modify the central line smoothness of the line. This parameter
smooths the initial movement of your line. Increasing the value will result
in a smoother line with fewer control points.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter will
smooth the contour of the line once it has been traced; the higher the
value, the fewer control points will compose your line.

Tip Shape

Lets you select a tip shape from round and square ones to
star shaped.

Texture See How to draw with textured lines on page 198

242



Toon Boom Harmony 11.1 Sketch Module Network User Guide

Reshaping a Drawing Using the Contour Editor Tool

The Contour Editor tool is a powerful tool that allows you to add, remove or modify points on a
vector line and control them with Bezier handles. It is used to correct line shapes and modify a single
part of a colour zone. If a line is too thin or has a gap in it, you can modify and correct it with the
Contour Editor tool. You can also use this tool to create elaborate shapes.

The Contour Editor displays vector points around a shape and the central vector points in a pencil line.
Pulling or pushing on these points adjusts the brush’s line thickness. Points can be selected and
deleted. Each point has two Bezier handles for correcting the curves between two points. Shapes can
be modified by pulling and pushing directly on the segment between the points. You can use it to
perfect a central shape pencil line, a contour shape brush line, or even create an elaborate shape from
a basic ellipse or square.

How to reshape with the Contour Editor tool

1. In the Timeline or Xsheet view, select the cell in which you want to draw.

2. In the Tools toolbar, select a shape tool: .

3. In the Tool Properties view, click the Ellipse button, click the Auto Fill button and set the
pencil size to 0.

4. In the Camera view, draw a circle.

5. In the Tools toolbar, select the Contour Editor tool.

6. In the Camera view, click the line to reshape it.
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7. Select one or several points by clicking on them or circling around.

8. Press Delete to delete a selected point.

Press Ctrl (Windows/Linux) or ⌘ (Mac OS X)and click on the contour to add a new point to adjust
the contour.

9. To modify the shape, you can:

‣ Pull on the Bezier handle. Both point’s handles will move as one.

‣ Hold down Alt and pull on one of the Bezier handles. The point’s handle will move
independently from the other one.

‣ Move the selected points to a new area.

‣ Pull directly on the line between two points. No selection is necessary. Holding down Shift
will limit the contour modification to the curve between the two first points.

‣ If an anchor point has no visible Bezier handles, hold down the Alt key to display them.

‣ To add control points, press Ctrl (Windows/Linux) or ⌘ (Mac OS X) and click the line.
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‣ To remove control points, select the control point and press Delete.

Reshaping Pencil Lines with the Pencil Editor Tool

The Pencil Editor tool is used to modify the thick and thin contour of a pencil line. A pencil line is a central vector
shape. The shape control points are located all along the central spine allowing you to adjust the stroke curve
and position. When using the Contour Editor tool, you can reposition the spine of the stroke. When using the
Pencil Editor tool, you can adjust the thick and thin areas of lines.

How to use the Pencil Editor tool

1. In the Tools toolbar, select the Pencil Editor tool or press Alt + W.

2. In the Camera view, select a pencil line and click the line to reshape it.

3. Select one or several points by clicking them or circling around.

245



Chapter 7: Character, Prop and Location Design Drawing Tasks

4. Press Delete to delete a selected point.

5. Press Ctrl (Windows/Linux) or ⌘ (Mac OS X) and click the central spine to add a set of points to
adjust the contour.

6. To modify the shape, you can:

‣ Move the selected points to a new area. If you select matching points on each side of the
line, holding the Shift key will move them both. This way you can thicken or thin a line from
both sides at the same time.

‣ Pull on the Bezier handle to move both points’ handles as one.

‣ Hold down Alt and pull on one of the Bezier handles. It moves the handle independently
from the other one.
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‣ Pull directly on the line between two points. No selection is necessary. Holding down the
Shift key will limit the contour modification to the curve between the two first points.

‣ If an anchor point has no visible Bezier handle, hold down Alt to display them.

Drawing with Shapes

In Harmony, you can use the shape tools to draw circles, lines and squares. You can also easily reshape
a square or circle into a much more complex drawing such as these butterfly wings—see Reshaping a
Drawing Using the Contour Editor Tool on page 219 and Reshaping Pencil Lines with the Pencil Editor
Tool on page 221.

How to draw with a Shape tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar, select a shape tool: .

3. To automatically fill the shape, in the Tool Properties view, select the Auto Fill option.

4. In the Camera view, click and drag to draw the shape.
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‣ Hold down Shift to lock the rectangle or the ellipse ratio to 1:1.

‣ Hold down Alt to draw the rectangle or ellipse from its centre.

‣ Hold down Shift to snap the line every 15 degrees.

‣ Hold down Alt to snap the start or end of the line to a nearby stroke.

5. Use the Contour Editor tool to deform the shape and create your drawing.

Drawing with the Polyline Tool

The Polyline tool is used to draw shapes with a central vector type of line. To form a shape, you click to
add a point and then, without releasing the mouse, pull the handle in the desired direction before
adding the next point and repeat the operation. To edit the shape, you can use the Contour Editor
tool.

How to draw with the Polyline tool

1. In the Timeline view, select the cell on which you want to draw.

2. In the Tools toolbar, select the Polyline tool or press Alt + _.
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3. In the Camera view, click and drag to create a point and a Bezier handle to shape your line.

‣ Press Alt to pull only one handle, instead of two.

‣ Press Shift to snap the handles to 45, 90, or 180 degrees.

4. Click a new area and drag to create a second point and Bezier handle.

5. Repeat the previous step until your shape is completed.

6. Press Ctrl (Windows/Linux) or ⌘ (Mac OS X) and click to release the Polyline tool from the current
path or shape that it is creating. Continue to use the tool to make multiple, independent paths or
shapes.

7. If necessary, reshape the lines using the Contour Editor tool—see Reshaping a Drawing Using
the Contour Editor Tool on page 219.

Drawing with Invisible Lines

There are two different ways to draw invisible lines.

Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be
useful for drawing tones and highlights directly on the character.

The Stroke tool draws invisible lines only. You cannot add thickness to the line, unlike the Close Gap
tool that creates a short, straight line between two points. The stroke line will stay exactly where you
draw it. This tool can be useful for closing a zone in a particular way or creating some hard shadows or
highlight areas.

249



Chapter 7: Character, Prop and Location Design Drawing Tasks

Sometimes, it may be difficult to see your strokes, especially if your colours are similar to the blue
stroke colour. In Harmony, you can display the strokes and washed-out the colours of your drawings
so that the invisible lines stand out.

How to draw invisible lines with the Pencil tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar, select the Pencil tool or press Alt + /.

3. From the top menu, select View > Show Strokes or press K.

4. In the Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.

5. In the Camera view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first
stroke, a Message dialog box opens.

Select theDon’t Show This Message Again option if you do not want the dialog box to notify you
about the Show Strokes option.

6. Click OK.

7. You can modify the stroke shape with the Contour Editor tool.

How to draw invisible lines with the Stroke tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar from the Paint drop-down menu, select the Stroke tool or press Alt + V.

3. From the top menu, select View > Show Strokes or press K.

4. In the Tool Properties view, you can adjust the smoothness.

5. In the Camera view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first
stroke, a Message dialog box opens.
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Select theDon’t Show This Message Again option if you do not want the dialog box to notify you
about the Show Strokes option.

6. Click OK.

7. You can modify the stroke shape with the Contour Editor tool.

Deforming a Drawing with the Perspective Tool

The Perspective tool lets you deform a drawing selection and alter its perspective.

How to deform a drawing with the Perspective tool

1. In the Tools toolbar, select the Perspective tool from the Contour Editor drop-down menu or
press Alt + 0.

2. In the Camera view, select a drawing to deform.

3. Click and drag the different anchor points to deform the shape.
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Warping a Drawing with the Envelope Tool

The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier
handles.

How to warp a drawing with the Envelope tool

1. In the Tools toolbar, select the Envelope tool from the Contour Editor drop-down menu.

2. In the Timeline view, select a drawing to deform.

3. In the Camera view, select the region you want to deform
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4. Click and drag the different anchor points and handles to deform the image.

5. To display more controls, in the Tool Properties view, click the Show Advanced Controls
button.

6. Increase the height and width of the grid to get more control points to deform your image.
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Cutting Drawing Parts

The Cutter tool lets you cut a drawing area to move, copy, cut or delete it.

How to cut with the Cutter tool

1. In the Tools toolbar, select the Cutter tool or press Alt + T.

2. In the Camera view, make a selection around an area to cut away.
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‣ To delete the selected zone, press Delete.

‣ To move the selection, click the selection and drag it to a new area.

‣ Use the bounding box controls to scale, skew, or rotate the cut piece.

Smoothing Lines

When drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines
you draw may look as if they were drawn with an unsteady hand. When this occurs, you may need to
correct the look of your lines.

Harmony has a very powerful tool you can use to optimize contours and reduce the number of points
on the lines, the Smooth Editor tool.

How to optimize lines with the Smooth Editor tool

1. In the Tools toolbar, select the Smooth Editor tool or select Drawing > Tools > Smooth
Editor.

2. In the Camera view, place your pointer over the lines to smooth. You may need to pass over the
same line several times to remove more points and make the line smoother. Note that by default,
the Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity—see
Smooth Editor Tool Options on page 277 to learn about the various settings available.
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Working With Text

With the Text tool, you can type text in your project using various fonts and texts attributes. Text
objects are part of a drawing, so you can manipulate them in the same way. OTF fonts are also
supported.

How to add text to drawings

1. Do one of the following:

‣ In the Tools toolbar, select the Text tool.

‣ From the top menu, select Drawing > Tools > Text.

‣ Press Alt + 9.

2. In the Timeline view, select the cell containing the drawing on which you want to add text.

3. In the Camera view, click on the location you want the text to begin.

4. You can use the Tool Properties view to select the font, font size and format of the text you will
type—see Text Tool Options on page 279.

5. Type in the desired text.

6. Click outside the text box to exit the typing mode.

If you want to create another text object, click outside the currently active text box. You can always
return to edit the text by selecting the Text tool and clicking in the text.

Working with Tool Presets
Tool presets let you save a variety of settings and are very handy and efficient for accessing the tools
you use most often. That way, the tool is already set with the desired properties, such as colour, line
thickness, whether to enable Draw Behind or Auto Flatten mode, and so on. You can create presets
for these tools and many more: Brush, Pencil, Eraser, Rectangle, Ellipse, and Line. First, select a tool,
adjust the properties, and then create a tool preset for it. Once you have created a tool preset, you
can always make adjustments to fine-tune it, as well as create a keyboard shortcut for it.

The Tool Presets Toolbar

The Tool Presets toolbar lets you create new tool presets and manage them. There are four default
brush presets to get you started—Rough Brush, Clean Pencil, Fill Paint, and Inking Brush. By default,
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this toolbar is not displayed.

How to display the Tool Presets toolbar

‣ SelectWindows > Toolbars > Tool Presets.

‣ Right-click an empty area below the top menu and select Tool Presets.

How to create a tool preset

1. In the Tools toolbar, select a tool, for example the Brush tool.

2. Use the Tool Properties view to customize the tool.

3. To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the
tool. Note that when using this preset in another scene not using that colour palette, upon
selecting this new preset, a colour recovery dialog box will appear asking to add this colour to
your scene.

4. In the Tool Presets toolbar, click the New Tool Preset button.

5. In the New Tool Preset dialog box, in the Name field, type a name for your new preset.

6. From the icon list, select an icon to quickly identify your preset or upload your own by clicking the
File button.
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7. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset.

8. When you select any of the following options, they will take effect when you use the tool preset. If
an option is deselected, then using a tool preset will not override your current settings.

‣ Colour: Saves the current colour into the tool preset.

‣ Tool: Only the colour will be associated. You could, for example, set three different colours
with shortcuts. It would use the current tool with the chosen preset colour.

9. Click OK.

How to select a tool preset

‣ In the Tool Presets toolbar, click the tool preset icon you assigned when creating the
preset. Note that when using this preset in a new scene not using the assigned colour
swatch, a colour recovery dialog box appears asking to add this colour to your scene.

How to delete a tool preset

1. In the Tool Presets toolbar, click the Manage Tool Presets button.
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2. From the list of tool presets on the left, select a preset to delete and click the Trash icon.

How to import a tool preset

1. In the Tool Presets toolbar, click the Manage Tool Presets button.

The Manage Tool Presets dialog box opens.

2. Click Import.

3. In the Select Folder window that opens, locate and select the preset(s) to import and click Select
Folder.

How to export a tool preset

1. In the Tool Presets toolbar, click the Manage Tool Presets button.

The Manage Tool Presets dialog box opens.

2. Click Export.

3. In the Export Brush Presets window that opens, click Export.

4. Select a folder and click Select Folder.

How to update a tool preset

1. To update the colour of your preset, you must first select it in the Colour view.

2. In the Tool Presets toolbar, click the Manage Tool Presets button.

3. In the Manage Tool Presets dialog box that opens, select the tool preset from the left side of the
dialog box.

4. Make any changes you would like to the preset.

5. Click Update.
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More Drawing Tools
Harmony offers a wide variety of useful tools to optimize your drawings and work more efficiently;
tools such as Group, Arrange, and the animation disk to rotate your workspace.

• Arrange below

• Convert Brush Strokes to Pencil Lines on the facing page

• Pencil Lines to Brush Strokes on the facing page

• Strokes to Pencil Lines on page 238

• Optimize on page 238

• Remove Extra Strokes on page 238

• Reduce Drawing Texture Resolution on page 239

• Crop Brush Textures on page 239

• Grid on page 240

• Group/Ungroup on page 241

• Hand on page 241

• Rotate View on page 241

Arrange

The different Arrange options let you reorder drawing objects inside a single layer in the Camera view.

Name Button Description Access Method

Bring to Front
Moves the selected art to the front
(on top)

From the top menu,
select Drawing >
Arrange > Bring to
Front.

Press Ctrl + Shift +
PgUp
(Windows/Linux) or
⌘ + Shift + PgUp
(Mac OS X).

Bring Forward
Moves the selected art one level for-
ward (closer to the front)

From the top menu,
select Drawing >
Arrange > Bring
Forward.

Press Ctrl + PgUp
(Windows/Linux) or
⌘ + PgUp (Mac OS
X).

Send Backward
Moves the selected art one level
lower (behind)

From the top menu,
select Drawing >
Arrange > Send
Backward.

Press Ctrl + PgDown
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(Windows/Linux) or
⌘ + PgDown (Mac
OS X).

Send to Back

Moves the selected art
behind everything (bottom
/ back)

From the top menu,
select Drawing >
Arrange > Send to
Back.

Press Ctrl + Shift +
PgDown
(Windows/Linux) or
⌘ + Shift + PgDown
(Mac OS X).

Convert Brush Strokes to Pencil Lines

The Brushes Strokes to Pencil Lines operation converts selected contour strokes into centreline pencil
strokes. This command is only available from the top menu.

How to convert brush strokes to pencil lines

‣ Right-click on the selection, select Convert > Brush Strokes to Pencil Lines or press ^

Pencil Lines to Brush Strokes

The Pencil Lines to Brush Strokes operation converts the selected centreline pencil strokes into
contour strokes brush lines.

How to convert pencil lines to brush strokes

‣ Right-click on the selection, select Convert > Pencil Lines to Brush Strokes or press &
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Strokes to Pencil Lines

The Strokes to Pencil Lines operation converts the selected invisible line to a pencil line.

How to convert strokes to pencil lines

‣ Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift + F12
(Windows/Linux only)

Optimize

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the
selected drawing objects. Drawing objects will only be flattened and optimized if the selected objects
do not change the appearance of the final image when they are merged.

For example, if you have selected a number of partially transparent objects, which you layered to
create an additive colour effect, the selected transparent drawing objects will not be merged. This is
because merging the transparent drawing objects will cause them to lose the effect of the layered
transparent colours.

How to optimize

‣ Use the Select tool to select the drawing objects you want to optimize.

‣ From the Camera view menu, select Drawing > Optimize > Optimize.

Remove Extra Strokes

The Remove Extra Strokes option let you remove the invisible lines in your selection.

How to remove extra strokes

1. In the Tools toolbar, select the Select tool.
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2. In the Camera view, use the Select tool to select the drawing objects you want to remove invisible
lines from.

‣ From the Camera view menu, select Drawing > Optimize > Remove Extra Strokes.

Reduce Drawing Texture Resolution

If you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be
heavy. This option is used to reduce the size and resolution of the textures in your drawing. When you
import and vectorize drawings using the grey or colour preset styles, you don't have control on the
size of the bitmap texture. This tool allows you to reduce that bitmap texture.

How to reduce the drawing texture resolution

1. In the Tools toolbar, select the Select tool.

2. In the Camera view, use the Select tool to select the drawing objects you want to reduce the
texture resolution for.

‣ From the Camera view menu, select Drawing > Optimize > Reduce Drawing Texture
Resolution.

3. In the dialog box, drag the slider toward the left to reduce the texture resolution.

4. Enable theApply to All Drawings option if you want the modification to be applied to all the
drawings in your layer.

5. Click OK.

Crop Brush Textures

The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies unseen
beneath the vector contour of a textured line. This often occurs when you cut and paste textured lines
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from one drawing into another. If you cut a portion from a textured line and paste it into a different
drawing, Harmony pastes the entire unseen texture bitmap from the source drawing into the new one,
even if you only took a small portion of the source drawing. Using the Crop Brush Texture command
will crop away extraneous texture that does not touch the vector area. If there are many textured lines
in your scene, this will greatly reduce the file size.

In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At
first, it appears as if only a cropped section of the underlying texture bitmap was cut and pasted as
well. However, using the Contour Editor tool to expand the vector envelope of the textured line, it is
revealed that more texture bitmap exists beyond the cropped boundary. If you use the Crop Brush
Texture command, the bitmap texture is cropped to the boundaries of the textured line’s vector
contour (as seen in the fourth image where the vector envelope has been pulled out to reveal empty
space).

How to crop the brush texture

1. In the Timeline or Xsheet view, select the drawing whose texture you want to crop.

2. From the Camera view menu, select Drawing > Optimize > Crop Brush Textures.

Grid

Use the Show Grid option to display a grid in the Camera view.

Name Button Description Keyboard Shortcut

Show
Grid Displays the grid

From the top menu,
select View > Grid >
Show Grid

Press Ctrl + '
(Windows/Linux) or
⌘ + ' (Mac OS X).

Square Displays a standard square grid
From the top menu,
select View > Grid >
Square.

12 Field Grid Displays a 12-field size grid
From the top menu,
select View > Grid >
12 Field Grid.

16 Field Grid Displays a 16-field size grid
From the top menu,
select View > Grid >
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16 Field Grid.

Underlay
Displays the grid under the drawing
elements

From the top menu, select View
> Grid > Underlay

Overlay
Displays the grid over the drawing
elements

From the top menu, select View
> Grid > Overlay

Group/Ungroup

Use the Group option to group selected drawing objects. This can help in the selection, repositioning,
re-scaling and other transformations to be applied to multiple objects of a drawing.

• From the Camera view menu, select Edit > Group > Group or Edit > Group > Ungroup.

• Press Ctrl + G and Ctrl + Shift + G (Windows/Linux) or ⌘ + G and ⌘ + Shift + G (Mac OS X).

Hand

Use the Hand tool to pan through the Camera view.

• In the Tools toolbar, select the Hand tool, click in the Camera view and drag.

• You can also Hold down the Spacebar, click in the Camera view and move your mouse in the
direction you want to pan the view.

Rotate View

The Rotate View tool lets you rotate the Camera view, the same way as you would do with a real
animation disc. This tool can also be used in the Perspective view.

How to use the Rotate View tool

1. Do one of the following:

‣ Press Ctrl + Alt (Windows/Linux) or ⌘ + Alt (Mac OS X).

‣ In the Tools toolbar, select the Rotate View tool.

‣ In the Camera view, right-click and select Drawing Tools > Rotate View.

2. In the Camera view, click and drag to rotate the space.
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Drawing Tool References

Harmony has a wide variety of drawing tools and each one of them has a series of options and modes
available. This section covers these options. For details on how to use these tools, see Drawing Tasks
on page 181.

• Pencil Tool Options below

• Brush Tool Options on page 247

• Select Tool Options on page 249

• Eraser Tool Options on page 257

• Contour Editor Options on page 259

• Pencil Editor Options on page 262

• Shape Tool Options on page 265

• Polyline Tool Options on page 269

• Stroke Tool Options on page 270

• Perspective Tool Options on page 271

• Envelope Tool Options on page 272

• Cutter Tool Options on page 275

• Smooth Editor Tool Options on page 277

• Text Tool Options on page 279

Pencil Tool Options
When you select the Pencil tool, its properties and options appears in the Tool Properties view.
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Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,

Maximum Size and Smoothing

This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

‣ Maximum andMinimum Size: Defines the maximum and minimum width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.

Adjusting the Pencil Line Style
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You can adjust the start, end, and joint style of a selected pencil line.

• Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose
between Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose
between Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could
also define the Join style as the corner style. You can choose between Round, Mitre and Bevel
style.

Thickness Stencils

Harmony provides a variety of thickness stencils and also lets you create and save your own. It is a
good idea to create and save pencils with precise sizes and parameters when you draw and design.

A thickness stencil saves a preset of how the thickness information looks across the length of the
line. When drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order
to apply the thickness stencil.

A thickness stencil can be used while drawing, or applied afterwards.

You also have the possibility to apply different textures to your lines by either using the preset ones
or importing your own—see Working with Pencil Presets on page 185 and Pencil Line Texture on
page 188.

Pencil Line Texture

You can apply a bitmap texture on your pencil line and adjust it as needed—see Pencil Line Texture
on page 188

Draw Behind

Auto-Flatten Mode

When drawing on vector layers, lines do not usually become one object. The Auto-Flatten mode
automatically merges lines created with the existing ones into one single object as you draw.

When drawing on a bitmap layer, you are laying down the bare pixels, so they are always flattened.
You can no longer access the individual stroke after you draw it.

Using the Select tool, you can use the middle mouse button to select a segment of a
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flattened pencil line to create a nice finish on the lines and corners of your artwork.

Auto-Close Gap

When using the pencil tool, you can automatically close strokes with an invisible stroke.

It is recommended to keep this option enabled when drawing with the Pencil tool.

Line Building Mode

The Line Building mode is very useful when drawing long lines and curves in small increments
with pencil lines. As the pencil lines are central vector lines and it may be difficult to align the line tips
perfectly to create a uniform stroke and close all gaps.

In this mode, you can draw lines in small increments and the tips are merge into one single stroke.

This mode only works with pencil lines.
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Auto Adjust Thickness

The Auto Adjust Thickness tool is useful when you want to render a portion of a line thicker.
When tracing a drawing on paper, you will often go back to a section of a curve to make it thicker to
add dynamism to the line. Using the Auto Adjust Thickness tool, you can draw highlight strokes over
the section to make thicker. Once you release the pen or mouse, the line becomes thicker following
the shape and curve of the original stroke. This way is much faster and smoother than using the
Pencil Editor tool. You do not have to add extra points and adjust the position and Bezier handles.

The default overlay colour is light yellow. If this colour is difficult to see because of the background or
drawing colour, you can adjust the colour.

How to change the Auto Adjust Thickness Colour

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, click the Auto Adjust Thickness button.

3. Click the colour swatch.

The Colour Picker window opens.

4. In the Colour Picker window, select a new colour.

Line Pushing Mode

The Line Pushing Mode option lets you draw highlight strokes over existing pencil lines. You can
reshape the curves. Depending how you draw the pushing stroke over your line, the highlighted
section will be reshaped in one direction or the other.

The default overlay colour is light yellow. If this colour is difficult to see because of the background or
drawing colour, you can adjust the colour.

To change the Line Pushing Mode colour

1. In the Tools toolbar, select the Pencil
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tool.

2. In the Tool Properties view, select the Line Pushing Mode button.

3. Click the colour swatch.

The Colour Picker window opens.

4. In the Colour Picker window, select a new colour.

Brush Tool Options
When you select the Brush tool, its properties and options appear in the Tool Properties view.

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,
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Maximum Size and Smoothing

This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

‣ Maximum andMinimum Size: Defines the maximum and minimum width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.

Brush Presets

Brush presets are created by saving the properties of the current brush to a new preset, which you
can reuse for repeated tasks. You can create as many brush presets as you need—see Drawing with
the Brush Tool on page 191.

Draw Behind

When the Draw Behind mode is enabled, the lines you draw will appear behind the art that
already exists.

Repaint Brush Mode

The Repaint Brush is used to repaint zones that have already been painted, it will not affect
empty zones or pencil lines. It also automatically flattens each of its brush lines so it does not add
new brush lines on top of existing ones. You can use this mode to paint tones or highlights onto your
character.
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Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically option automatically
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the
Advanced Art mode.

Auto-Flatten Mode

When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing
artwork as you draw in the Camera view. Brush strokes will flatten with brush strokes and pencil lines
will flatten with pencil lines.

Respect Protected Colour

The Respect Protected Colour option prevent the colours you marked as protected in the
Colour view to be repainted using the Repaint Brush mode or any of the painting tools.

Use Stored Colour Gradient

The Use Stored Colour Gradient option makes your tool use the previously stored gradient
position. This way, every new brush line or colour fill will use the stored gradient position.

Select Tool Options
When you choose the Select tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso and Marquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.
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Snap Options

You can enable different snapping modes to help you when repositioning drawings using the Select
tool.

• Snap to Contour: Snaps your selection or point to any line you position it on. As soon as
you move it close enough to another line, your point or selection will snap to it.

• Snap andAlign: Snaps the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor point to.

• Snap to Grid: Snaps your selection following the currently enabled grid.

How to snap to grid

1. Do one of the following:

• Select View > Grid > Show Grid to display the grid in the Camera or Drawing view or press
Ctrl + ' (Windows/Linux) or ⌘ + ' (Mac OS X).

• Select View > Grid > Square Grid, 12 Field Grid or 16 Field Grid for your current needs.

2. In the Tools toolbar, select the Contour Editor tool or press Alt + Q.

3. In the Contour Editor Tool Properties view, click the Snap to Grid button.

4. In the Camera or Drawing view, click on the anchor point you want to snap following the grid,
drag it to the desired position and release.
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Select by Colour

The Select by Colour mode lets you select all the zones in your drawing painted with the same
colour.

Only the zones painted with the SAME colour swatch will be selected. If another zone is coloured with the
exact same RGB value (same colour), but not painted with the same colour swatch, it will not be selected.

How to select areas by colour

1. In the Tools toolbar, select the Select tool or press Alt + S.

2. In the Tool Properties view, click the Select by Colour button.

3. In the Camera view, click on any zone in your drawing.

All zones of the same colour are selected.

4. Click the Select tool again to return to the regular Select mode.

Permanent Selection

The Permanent Selection option lets you maintain a selection over multiple drawings. Once this
option is enabled, the selection zone made using the Select tool will remain as you navigate through
drawings from a layer and drawings from other drawing layers. This option can be used to
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simultaneously delete artwork inside or outside of the selection on several drawings when combined
with the Apply to Multiple Drawings option.

Apply to All Drawings in Layer

The Apply to All Drawings in Layer option is used to perform an action on all the drawings
contained in a layer. For example, you could enable the option to paint a section on all the drawings
simultaneously. The Apply Tool to All Drawings option must be activated before performing the
action and will stay enabled only for the next action.

Apply to Line and Colour Art

The Apply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers. To access this option, you must be in the
Advanced Art mode.

Works on Single Drawing

By default, when you draw a selection box in the Camera view, the Select tool will select only the
drawing strokes of the current drawing. If you prefer the Select tool to select all the strokes on all
layers, you can disable the Works on Single Drawing option in the Tool Properties view or the Select
Tool Works on Single Drawing preference.
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Flip Horizontal and Vertical

The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or
vertically.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current
selection 90 degrees clockwise or counter-clockwise.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘ + 7 and ⌘ + 9 (Mac OS X).

Smooth

The Smooth operation lets you smooth out selected drawing strokes and remove extra points.

Flatten

The Flatten operation is used to merge drawing objects and brush strokes into a single layer. If
you draw new lines to fix a drawing or line with many brush strokes, it can be useful to flatten them
all into a single shape. By default, lines are drawn one on top of each other. If you intend to repaint
the lines or modify their shape, it will be easier if they are flattened.

‣ From the top menu, select Drawing > Optimize > Flatten or pres Alt + Shift + F.
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Distribute to Layers

The Distribute to Layers option is used to separate the selected art strokes and send them to
new drawing layers. In the Camera view, once you have drawn your artwork, you can select the
strokes you want to distribute using the Select tool and click on the Distribute to Layers
button; you can also select Drawing > Distribute to Layers. It will automatically take every stroke
from the drawing selection made in the Camera view and separate them into a different layer for
each. If an artwork is composed of several strokes, you must group them using Edit > Group >
Group before using the Distribute to Layers option. This option cannot be done from the Drawing
view.

Store Colour Gradient

Use the Store Colour Gradient operation to record the selected gradient’s position. This reuses
the stored position of the gradient when drawing new brush lines or painting colour zones. Enable
the Use Stored Colour Gradient option in the Paint or Brush Tool Properties view to do this.

Pencil to Brush

The Pencil to Brush operation converts the selected centre line pencil strokes into contour
strokes brush lines.

From the top menu, select Drawing > Convert > Pencil Lines to Brush or press &.

Merge Pencil Lines
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Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align
them and make it look like it is one single line. With the Select tool, you can select several pencil lines
and merge them as one single object using the Merge Pencil Lines option. The ends of your lines
are adjusted to form one single line.

Points must be close enough to be merged. If there is a large gap between the lines, they will not be
merged.

Reverse Pencil Thickness

The Reverse Pencil Thickness option inverts the thick and thin section on a selected pencil line.
This option will take the thickest size on the line and apply it to the thinnest, and it will apply the
thinnest to the thickest.

Width and Height

Use the Width and Height operation fields to enter specific values to resize the selected shape with
precision.

1. Width: Type a value in this field to resize the width of your selection.

2. Height: Type a value in this field to resize the height of your selection.

3. Up/Down arrows: Use the up and down arrows to modify the value in the Width or Height fields.

4. Lock icon: Click the lock icon to lock or unlock the ratio between the Width and Height values.

Offset X and Y

Use the Offset X and Offset Y operation fields to enter specific values and precisely reposition the
selected shape.
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1. X: Type a value in this field to reposition your selection along the X-axis.

2. Y: Type a value in this field to reposition your selection along the Y-axis.

3. Up/Down arrows: Use the up and down arrows to modify the value in the X or Y value field.

Angle

The Angle operation lets you to enter specific values and accurately rotate the selected shape.

1. Angle: Type a degree value in this field to rotate your selection.

2. Up/Down arrows: Use the up and down arrows to modify the value in the Angle value field.

Adjusting the Pencil Line Thickness

Use the Adjusting the Pencil Line Thickness operation field to resize the selected centreline strokes.
This operation is not permitted on contour line shapes, such as brush strokes or shape fills.

1. Minimum Size: Type a value in this field to set the minimum thickness of the selected centreline
stroke.

2. Maximum Size: Type a value in this field to set the maximum thickness of the selected centreline
stroke.

3. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness
value field.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.
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• Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose
between Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose
between Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could
also define the Join style as the corner style. You can choose between Round, Mitre and Bevel
style.

Pencil Stencils

Toon Boom Harmony gives you the flexibility to change the style and thickness of your pencil lines
even after they are drawn. You can apply preset pencil stencils or create your own—see Working
with Pencil Presets on page 185.

Adding Texture to a Pencil Line

Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your
own. Textures are independent from pencil stencils—see Pencil Line Texture on page 188.

Adjusting the Text Selection

When you select text with the Select tool, the tool properties will display the Text tool options on
the bottom of the view. You can also press Alt + 9 to display only the Text properties in the Tool
Properties view—see Text Tool Options on page 279.

Eraser Tool Options
When you select the Eraser tool, its properties and options appear in the Tool Properties view.
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Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,

Maximum Size and Smoothing

This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

‣ Maximum andMinimum Size: Defines the maximum and minimum width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.

Eraser Presets

Eraser presets are created by saving the properties of the current eraser to a new preset, which you
can reuse for repeated tasks. You can create as many eraser presets as you need—see Erasing Parts
of a Drawing on page 217.

The Eraser tool uses its own preset list, separated from the Brush tool. Toon Boom Harmony
provides a variety of eraser styles and allows you to create and save your own. It is a good idea to
create and save eraser with precise sizes and parameters to draw and design.

Eraser Blur Parameters

Since Harmony lets you draw with textured lines and create feathered edges on them, you may also
want to erase with smooth edges instead of the solid vector based eraser. The Eraser Blur
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Parameters allow you to adjust the smoothness of your eraser for the textured lines—see How to
erase textured lines on page 200

Apply to Line and Colour Art

The Apply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers. To access this option, you must be in the
Advanced Art mode.

Tip Style

Use the Tip Style option to customize the tip of the pencil line you are cutting.

Contour Editor Options
When you select the Contour Editor tool, its properties and options appear in the Tool Properties
view.

Lasso and Marquee

Choose between the Lasso and Marquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Snap to Contour

The Snap to Contour option will snap the selected anchor point to any line you position it on.
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How to snap two shapes together

1. In the Tools toolbar, select the Contour Editor tool or press Alt + Q.

2. In the Tool Properties view, click the Snap to Contour button.

3. In the Camera view, click on an anchor point you want to snap to the other shape, drag it on top
of the contour line area and release it.

Snap and Align

The Snap and Align option lets you snap the selected anchor point to any existing line while
displaying temporary rulers as a guide that you can also snap your anchor point to.

How to snap and align

1. In the Tools toolbar, select the Contour Editor tool or press Alt + Q.

2. In the Tool Properties view, click the Snap and Align button.

3. In the Camera view, click on an anchor point you want to snap, drag it until a ruler is displayed,
position it on the ruler or on the contour line and release.
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Show Contour Editor Controls

Use the Show Contour Editor Controls option to show the contour editor controls. You can use
these controls to scale, reposition and rotate the selected anchor points.

Smooth Selection

The Smooth operation lets you smooth out selected drawing strokes and remove extra points.

Split Pencil Line and Join Pencil Lines

When drawing with the Polyline tool, your drawing has an even line thickness. You can use the Pencil
Editor to adjust the thickness point by point, but if you want to adjust it quicker, you can use the
Split Pencil Line and Point Pencil Lines options to create segments and apply a pencil stencil to your
drawing. Note that if you did not join the pencil lines on your polyline stroke, the segments between
the points will act as separated segments.
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How to split and join pencil lines

1. In the Tools toolbar, select the Contour Editor tool.

2. In the Camera view, select the contour points you want to split or join.

3. In the Tool Properties view, click on the Join Pencil Lines or Separate Pencil Line buttons.

Pencil Editor Options
When you select the Pencil Editor tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso and Marquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Maximum Size and Smoothing

This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

‣ Maximum andMinimum Size: Defines the maximum and minimum width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.
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Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.

• Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose
between Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose
between Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could
also define the Join style as the corner style. You can choose between Round, Mitre and Bevel
style.

Preset

To work with Pencil line presets, see Working with Pencil Presets on page 185.

Textures

To work with Pencil Line Texture, see Pencil Line Texture on page 188

Smooth

The Smooth operation lets you smooth out selected drawing strokes and remove extra points.

Pump Pencil Pressure

The Pump Pencil Pressure option is used to increase the line thickness of a selected area on a
pencil line.
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Deflate Pencil Pressure

The Deflate Pencil Pressure option is used to decrease the line thickness of a selected area on a
pencil line.

Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align
them and make it look like it is one single line. With the Select tool, you can select several pencil lines
and merge them as one single object using the Merge Pencil Lines option. The ends of your lines
are adjusted to form one single line.

288



Toon Boom Harmony 11.1 Sketch Module Network User Guide

Reverse Pencil Thickness

The Reverse Pencil Thickness option inverts the thick and thin section on a selected pencil line.
This option will take the thickest size on the line and apply it to the thinnest, and it will apply the
thinnest to the thickest.

Shape Tool Options
When you select a shape tool (Rectangle, Ellipse, Line), its properties and options appear in the Tool
Properties view.

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,
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Size

Move the Size slider left to reduce the line thickness and to the right to increase its width.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.

• Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose
between Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose
between Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could
also define the Join style as the corner style. You can choose between Round, Mitre and Bevel
style.

Thickness Stencils

Toon Boom Harmony provides a variety of thickness stencils and also lets you create and save your
own. It is a good idea to create and save pencils with precise sizes and parameters when you draw
and design.

A thickness stencil saves a preset of how the thickness information looks across the length of the
line. When drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order
to apply the thickness stencil.

A thickness stencil can be used while drawing, or applied afterwards.

You also have the possibility to apply different textures to your lines by either using the preset ones
or importing your own—see Working with Pencil Presets on page 185

Draw Behind
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When the Draw Behind mode is enabled, the lines you draw will appear behind the art that
already exists.

Snap Options

When drawing a shape, you can enable different snap modes to help you create your shape.

• The Snap to Contour option snaps your shape to any line you position it on.

• The Snap and Align option snaps the selected anchor point to any existing line, while
displaying temporary rulers as a guide that you can also snap your anchor point to.

• The Snap to Grid snaps your shape to the currently enabled grid.

Automatic Filling

Use the Automatic Filling option to automatically fill your shape with the selected colour as you
draw. By default, the Shape tool creates the contour of an empty shape that you can later fill using
the Paint tool.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically option automatically
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the
Advanced Art mode.

Auto-Flatten Mode

When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing
artwork as you draw in the Camera view. Brush strokes will flatten with brush strokes and pencil lines
will flatten with pencil lines.

Using the Select tool, you can use the middle mouse button to select a segment of flattened pencil
line. This creates a nice finish on the lines and corners of your artwork.
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Auto-Close Gap

When enabled, the Auto-Close Gap mode automatically connects, with an invisible stroke, the
pencil lines you draw close to each other in the Camera view.

It is recommended to leave this option enabled when drawing with the Pencil tool.

Use Stored Colour Gradient

The Use Stored Colour Gradient option makes your tool use the previously stored gradient
position. This way, every new brush line or colour fill will use the stored gradient position.

Line Building Mode

The Line Building mode is very useful when drawing long lines and curves in small increments
with pencil lines. As the pencil lines are central vector lines and it may be difficult to align the line tips
perfectly to create a uniform stroke and close all gaps.
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In this mode, you can draw lines in small increments and the tips are merge into one single stroke.

This mode only works with pencil lines.

Keep Proportion

When the Ellipse or Rectangle mode is enabled in the Tool Properties view, the Draw Circle or Draw
Square option appears. When selecting these options, the shape produced will be a circle or square.
Holding down the Shift key as you create your shape will maintain proportion.

Polyline Tool Options
When you select the Polyline tool, its properties and options appear in the Tool Properties view.

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,
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Size

The Size parameter lets you set the size of the polyline that you will draw.

Thickness Stencils

Harmony provides a variety of thickness stencils and also lets you create and save your own. It is a
good idea to create and save pencils with precise sizes and parameters when you draw and design.

A thickness stencil saves a preset of how the thickness information looks across the length of the
line. When drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order
to apply the thickness stencil.

A thickness stencil can be used while drawing, or applied afterwards.

You also have the possibility to apply different textures to your lines by either using the preset ones
or importing your own—see Working with Pencil Presets on page 185

Snap to Contour

The Snap to Contour option will snap your selection to any line you position it on.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically option automatically
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the
Advanced Art mode.

Auto-Flatten Mode

When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing
artwork as you draw in the Camera view. Brush strokes will flatten with brush strokes and pencil lines
will flatten with pencil lines.

Stroke Tool Options
When you select the Stroke tool, its properties and options appears in the Tool Properties view.
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Draw Stroke as Straight Lines

Enable the Draw Stroke as Straight Lines option if you want the new strokes you draw to be a
perfect straight line. Disable the option if you want the stroke to follow the mouse gesture.

Connect Line Ends

Enable the Connect Line Ends option if you want the start or end point of your new stroke to
connect to your existing strokes to make sure no gaps are left in your drawing.

Auto-Flatten Mode

When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing
artwork as you draw in the Camera view. Brush strokes will flatten with brush strokes and pencil lines
will flatten with pencil lines.

Smoothness

You can modify the central line smoothness of your line using this option. This parameter smooths
the initial movement of your line. Increasing the value will result in a smoother line with fewer control
points. Use the left and right arrows to increment the value by one full unit. Use the Up - Down slider
to quickly increment the value.

Perspective Tool Options
Selecting the Perspective tool displays its properties and options in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso and Marquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.
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Snap Options

• The Snap to Contour option will snap the selected anchor point to any line you position it
on—see Contour Editor Options on page 259.

• The Snap and Align option lets you snap the selected anchor point to any existing line
while displaying temporary rulers as a guide that you can also snap your anchor point to—see
Contour Editor Options on page 259.

• The Snap to Grid option snaps your selection according to the currently enabled grid.

Flip Horizontal and Vertical

The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or
vertically.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current
selection 90 degrees clockwise or counter-clockwise.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘ + 7 and ⌘ + 9 (Mac OS X).

Envelope Tool Options
Selecting the Envelope tool displays its properties and options in the Tool Properties view.
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Width and Height

Increase the width and height values to add more columns and rows to the deformation grids.

Lasso and Marquee

Choose between the Lasso and Marquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options

• The Snap to Contour option will snap the selected anchor point to any line you position it
on—see Contour Editor Options on page 259.

• The Snap and Align option lets you snap the selected anchor point to any existing line while
displaying temporary rulers as a guide that you can also snap your anchor point to—see
Contour Editor Options on page 259.

• The Snap to Grid option snaps your selection according to the currently enabled grid.
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Show Advanced Controls

To display more controls,you can click on the Show Advanced Controls button.

Apply to Line and Colour Art

The Apply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers. To access this option, you must be in the
Advanced Art mode.

Flip Horizontal and Vertical

The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or
vertically.
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Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current
selection 90 degrees clockwise or counter-clockwise.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘ + 7 and ⌘ + 9 (Mac OS X).

Smoothness

You can modify the central line smoothness of your line using this option. This parameter smooths
the deformed lines. Increasing the value will result in a smoother line with fewer control points. The
more you increase the value, the less details and curves you will get. Use the left and right arrows to
increment the value by one full unit. Use the Up - Down slider to quickly increment the value.

Cutter Tool Options
When you select the Cutter tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso and Marquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Apply to Line and Colour Art

The Apply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers. To access this option, you must be in the
Advanced Art mode.

Use Mouse Gesture

When using the Lasso selection type, the Use Mouse Gesture option lets you automatically
delete any extra sections of line in your artwork by simply dragging your mouse over it.
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For this operation to work, you lines CANNOT be flattened.

Use Mouse Gesture Breaker Mode

When using the Lasso selection type, the Use Mouse Gesture Breaker Mode option lets you
draw an invisible stroke on a pencil line to cut it in two individual objects. Once a pencil line is cut with
this option, you will be able to select the two portions independently with either the Cutter tool,
Pencil Editor tool or Select tool.

This option only works with pencil lines.

Tip Style

Use the Tip Style option to customize the tip of the pencil line you are cutting.

Antialiasing

When drawing on a bitmap layer, lines are no longer clean vector shapes. For the edges to be
smooth, a slight amount of antialiasing is used. When using the Cutter tool, you can cut a portion of
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your drawing with or without antialiasing. By default, the option is enabled. If you want to cut your
drawing using a hard edge, you can select the Antialiasing Off option.

Flip Horizontal and Vertical

The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or
vertically.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current
selection 90 degrees clockwise or counter-clockwise.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘ + 7 and ⌘ + 9 (Mac OS X).

Smooth Editor Tool Options
When you select the Smooth Editor tool, its properties and options appear in the Tool Properties
view.

Brush, Marquee and Lasso Smoothing Style

The Smoothing Style options allow you to smooth a portion of your drawing by tracing a smoothing
stroke over the zone to optimize or by selecting an area of the drawing with the Marquee or Lasso.
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Note that by default, the Smooth Editor tool colour is yellow, it was changed to orange for screen
grab clarity.

Show Control Points

The Show Control Points option allows you to show or hide the Bezier points around lines.
When the Bezier points are displayed, you can see the result of your smoothing and the number of
points left on the curve. When it is turned off, only the original artwork is displayed.

Minimum Size and Maximum Size

This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

This options is available while using the Brush Smoothing style.

‣ Maximum andMinimum Size: Defines the maximum and minimum width of the stroke.

• Up/Down arrows: Use the up and down arrows to set the minimum and maximum size value.

Smoothness

The Smoothness impacts the strength of the smoothing result. The higher the value, the more
points are removed and the smoother the curve. The Smoothness range is from 0 to 100; the default
value is 20.
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Colour

You can modify the colour of the control points displayed on the artwork while working with the
Smooth Editor tool by double-clicking on the colour swatch.

Text Tool Options
Use the Text tool's properties to select the font type and other formatting options you want to apply
to the text.

If you already wrote your text, you must first use the Text tool and select the text portion you want to
format.

Font Type

Use the Font drop-down menu to select a font. OTF fonts are supported.

Font Style

Use these buttons to select a style for your text:

• Bold
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• Italic

Alignment

Use these buttons to align the paragraph.

Left Centered

Right Justified

Font Size

Enter a size for the text.

Kerning

Use the kerning field to modify the spacing between letters and characters. You can select the Auto
Kern option to set the kerning automatically based on the font’s predefined standard. A negative
value decreases spacing between each character, creating a letter overlap and a positive value
increases it.
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Indent

Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A
positive value sets the first line of your paragraph farther to the right and a negative value sets it
farther to the left.

Line Spacing

Enter a value in the Line Spacing field to decrease or increase the space between each line of text.

Resizing the Text Box

You can resize the text box by selecting your text box with the Text tool and moving the anchor
point right or left. Using the Select tool will distort and scale your text itself rather than changing the
width and height of your text box.

Converting Text into Separate Objects

Text contained in a text field is treated as a single drawing object. You can easily separate the text
so each character becomes an individual drawing object that you can select and modify
independently.
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How to break a text object

1. In the Tools toolbar, click the Select tool or press Alt + S.

2. In the Camera view, select the text object you want to break.

‣ From theCamera view menu, select Drawing > Convert > Break ApartText Layers.

Each character is surrounded by a bounding box that you can modify; they remain text objects
that you can edit.

3. If you want to convert your independent letter to a complete vector object that you can deform,
use the Select tool to select the letters to convert.

‣ From the Camera view menu, select Drawing > Convert > Break Apart Text Layers to
break the selection into a regular drawing object, with no more text attributes.
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Chapter 8: Colour Styling and Colour Models

Once the characters, props and locations are designed, it is time for the colour styling and colour
models creation. This is when the colours and moods are determined. The line models created during
the design step are painted and organized as colour models for the colourists.

Harmony has a great concept of colour palettes. Each character can have its own set of colours that is
carried through the entire project called themaster palette. If the master is modified, the colours in
the entire project are updated simultanously.

By doing the colour styling in Harmony, your master palette will be created at the same time, so you
do not need to use third party software. Also you will not have to recreate the colour palette again in
Harmony. It is possible to create this step in an external software, but it is a great time saver to do it
directly in Harmony.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. Sketch is a subset of
Harmony Stage.

To create the colour style and colour models, follow these steps:

• Preparation on the next page

• Working with Palettes on page 289

• Colours on page 310

• Painting the Model on page 322
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Preparation

Before painting, you need to organize the colour model scenes and bring in your references. The
colour styling preparation is done in five steps:

• Colour Model Storage below

• Scene Creation below

• Setting Up the Workspace on the facing page

• Naming on page 286

Colour Model Storage
First, you will need to create a storage location for all your models and palettes. The best way to do
this is to create a colour model scene. There are different possibilities available to structure your
designs and colour model scenes. We strongly recommend that you put all of your colour models in
the same scenes. It is important to maintain a structure for your models so they do not end up
scattered throughout the project.

There are four main model categories:

If you have a small project, such as a short or an advertising contract, you can always place all the
characters, props, effects, and locations in the same scene. For large projects such as feature-length
productions or series, you should create four separate model scenes following these categories.

Scene Creation
In order to create colour models, you need to create your scenes.

When working on a paperless or cut-out animation project, if you have designed your characters,
props, effects and locations directly in Harmony, you can paint your models directly in your design
scene. You can also create a new colour model scene and import your designs in that one. Refer to the
Fundamentals Guide to learn more about creating a scene.
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If you have not already done so, refer to the Fundamentals Guide to learn about production structure,
file organization, and how to create a Project root directory. We recommend storing your colour
model scenes in the root directory or in a colour models subdirectory for even better organization.

A useful way to name your colour model scene is to include the project name, then the colour model
type such as characters, props, effects, or locations, and finally colourmodel. For example, a
character colour model scene for the Adventure project would be named adventure_characters_
colourmodel. This ensures that you always know what scene corresponds to what.

To learn how to create environment, job, and scene for your colour models, refer to the Control
Center and Server Guide.

Colour Model Scene Structure

To store your colour models in a scene, it is recommended that you create one drawing layer for each
character, prop, effect, or location. You should name these according to the model.

You can also load other colour references in the scene to balance your overall colours. For example, if
you work in a character colour model scene, it is a good idea to import some of the key locations to
compare and adjust the colours so they match well.

Setting Up the Workspace
Now that your scenes are created and structured, you can open the corresponding colour model
scene. For the optimal workspace for inking and painting, set up your workspace with these views:
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• Xsheet

• Camera

• Colour

Naming
Now that your models are imported, you can rename them appropriately. You should rename
elements (layers) and drawings corresponding to the model. This will help keep the work organized
and make it easy for others to follow.

For example, if there is a black and white character model called Erik in one drawing element and its
colour models in another one, rename your elements to include the character's name. For example,
the colour model for Erik's armour could be named: erik_armour_colour.

How to rename a drawing element

1. Do one of the following:
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‣ In the Xsheet view, double-click on the column header of the drawing element.

‣ In the Timeline view, double-click on the drawing element's layer.

The Layer Properties window opens.

2. Type in a new name.

How to rename a drawing

1. In the Xsheet view, click on a drawing name.
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2. Do one of the following:

‣ From the Xsheet menu, select Drawings > Rename Drawing.

‣ Right-click on the drawing name and select Drawings >Rename Drawing.

‣ Press Ctrl + D (Windows/Linux) or ⌘ + D (Mac OS X).

The Rename Drawing dialog box opens.

3. Type in a new name and click OK.
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Working with Palettes

In animation, specific colours are used to paint each particular character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production.
These are referred to asmaster palette1s.

Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.

Using a master colour palette has many benefits, including:

• Each character consistently retains their dedicated colours.

• You cannot accidentally use a colour which is not in the master palette.

• Standardization and colour consistency throughout the production

• Multiple artists can use the same colour palette and produce the same results.

Toon Boom Harmony uses palettes to hold all the colours needed to paint your elements, allowing
complete control and consistency in your painting process.

A palette2 is created by assigning a set of colours to each character, prop or effect. You will create a
new palette and add a new colour, known as a colour swatch, for each zone of the character, such as
the skin, hair, tongue, shirt, pants, and so on.

In Harmony, palettes are individual files that you can copy, transfer, and store. Palettes have a *.plt
file name extension—see Palette File Storage on page 293.

When a zone on the character is painted with the colour contained in a colour swatch, a link is
automatically created between that colour swatch and the zone. This means that if the tint of the
colour in the colour swatch is changed, any zone linked to it will update to the new tint. This is one way
that colour palettes can save time and money in your production.

Another advantage of this system is that you can create complete palettes for different lighting
situations. For instance, in addition to the regular palette for a character, you could have one for that
character in the rain using colours that are duller and less vibrant than the dry daytime colours, or yet
another for using in a night scene. Using palettes linked to your character in this way allows you to
instantly change its colouring to suit the mood and atmosphere of the scene without tediously
repainting each element.

1A master palette is a group of colours attributed to a character or a prop. The palette is used throughout the
entire production to maintain consistency in the look and to ensure that the same colours are used throughout
the production. Also known as palette.
2A palette or master palette is a group of colours attributed to a character or a prop. The palette is used
throughout the entire Toon Boom Studio project to maintain a consistency in the look and avoid the colour
changing during the animation. Also referred to as a master palette.
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This section is divided as follows:

• Palette Lists below

• Palette File Storage on page 293

• Creating a Colour Palette on page 296

• Duplicating a Colour Palette on page 300

• Cloning a Colour Palette on page 302

• Importing and Linking Palettes on page 304

Palette Lists
The Colour view has two modes: basic and advanced.
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• BasicMode

The Colour view’s basic mode only shows the Colour list. When you open Toon Boom Harmony,
you only see the colours available in the Default palette which contains six basic colour swatches
and is automatically named the same as your scene. For simple projects, you can manage with the
default palette, but for movies, series, or shorts it is recommended that you create palettes for
your characters. To create a palette, you have to switch to the Advanced mode of the Colour view
and show the Palette list.

• AdvancedMode

The Advanced mode displays the list of all palettes that are linked to the scene. To create palettes
for your characters, you must display the Palette list.

A palette list is a file containing all of the links to the original palette files. Every drawing layer has a
palette list. The scene also has a palette list. For example, a drawing layer can use three different
palettes stored in three different locations, while another drawing layer can use two of these palettes
plus another one coming from another scene. The palette list keep track of the locations of the
palettes.

There are two types of palette lists:

• Scene Palette List

The Scene Palette list is mainly used with cut-out animation, but is also very useful for paperless
and traditional animations. A cut-out character will often be divided into 20 to 30 different drawing
elements that use the character’s master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes
linked to this list will appear in every drawing element created in the scene. There is no need to
manually load the palette in each element.

The Scene Palette list is the simplest one to use. By default, Toon Boom Harmony is set to use only
Scene Palette lists.

• Element Palette List

In Toon Boom Harmony, you can switch to Advanced Palette List mode and choose to save your
palette at an element’s level. The Element Palette list is mainly used with traditional and paperless
animation. Unlike cut-out animation, all columns (drawing elements) contain different characters,
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props, backgrounds, and effects. The Element Palette list is used when you do not necessarily
want all of the palettes for all of your elements linked in every column.

The palette list is stored in the drawing element’s directory instead of directly in the Scene level.
This ensures that the links to the palettes appear only in the appropriate element. If you prefer to
access a global palette list, link your palettes to the Scene Palette list.

To prevent users from accidentally removing a link to a palette, the palette lists are locked. To link or
create a new palette, the palette list must first be unlocked.

When you are using several cloned palettes that are related to the same original palette, Toon Boom
Harmony uses the highest palette in the list to determine the colour of the painted zones—see Cloning
a Colour Palette on page 302.

How to show or hide the Palette list

‣ In the Colour view, click the Show/Hide Palette List View button to expand or collapse
the Palette List area.

The Palette List window opens and displays all your palettes.
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How to lock and unlock to the palette list

‣ From the top menu, select Edit > Edit Palette List Mode.

A grey pencil appears on the top-right corner of the Palette list to indicate that it can be modified.

How to set the Advanced Palette Lists mode

1. Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences
(Mac OS X).

‣ Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. Select theAdvanced tab.

3. Select theAdvanced Palette Lists option.

4. Click OK.

How to reorder palettes in the Palette list

Do one of the following:

‣ From the Colour View menu, select Palettes >Move Up orMove Down.

‣ In the Palette list, click the Up and Down buttons.

Palette File Storage
In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a
palette is created from Harmony, it needs to be stored somewhere. By default, the palette file is
stored in the scene directory in a palette-library folder unless you specify a different location. There are
four locations where you can find palette-library folders:
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• Element

The Palette Library folder is stored directly in the drawing Element folder.

• Scene

The Palette Library folder is stored directly in the Scene folder.

• Job

The Palette Library folder is stored in a Job folder contained in the Scene folder.

• Environment

The Palette Library folder is stored in an Environment folder contained in the Scene folder.

By default, the palette is stored at the scene level. For simple projects and standalone projects, it is
recommended to keep it as is. If you work with a larger studio, it is recommended to verify with them
on the file structure.

This existing structure is compatible with Toon Boom Harmony Server. Toon Boom Harmony’s
database has a leveled structure starting from the Environment down to the Element. Its client-server
configuration allows all data, such as palettes and scenes, to be shared between a series of client
machines.

Element Level

Working with Harmony as a stand alone, the Element level is very useful when there are a lot of
different palettes. When a colour model drawing is created, it is stored in its element folder. By
storing the corresponding palette file with the colour model, the colourist can load them both from
the same location. This also creates a more organized structure.

Scene Level

Working with Toon Boom Harmony as a stand alone, a palette file can also be saved at the scene level,
so that all of the palettes from the scene are stored together. The palette naming must be structured
so the colourist or character builders can find the correct one. Saving the palettes at the scene level
makes it very easy to back up the palettes and retrieve their location.
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The scene level can also be useful for cut-out animation. Instead of creating a colour model scene that
includes all of the characters, props, effects, and location, the colour palette or model will often be
directly imported to, or created in, the character building scene. Just as with a cut-out character
building scene, each element uses the same palette so it would not be efficient to save the palette
inside one element. Instead, it is saved at the scene level. This prevents a palette overload because all
of the models are in different scenes. It also allows each scene to have its own set of palettes
corresponding to its model.

When working on a cut-out animation production, it is highly recommended that you work with the
Scene level.

Where to Save the Palette File
The palette storage location depends on the type of production and the backup plan being used.
Some studios like to store their palettes at the Element level and others at the Environment level as
this will not create a problem so long as the scene is in the Harmony structure. In fact, as long as the
Harmony structure is maintained it can be stored at any level. However, difficulties may occur when the
scene is backed up or transferred to another studio or database and removed from the structure.

What happens when you export a palette file?
It is important to understand what is happening to a palette file when the scene is exported.

Because of the Harmony client-server configuration, all of the data can be shared through all of the
scenes in the database. This also includes the palette files, even if they are stored at the Element,
Scene, Job, Drawing or Environment level. The palette files can be accessed from any scene of any
project.

When you export scenes from Harmony to either archive or send them to other users or studios, the
palettes stored in external scenes, jobs or environment will NOT be exported.

An exported scene will carry palettes stored in its own Element’s Palette Library, scene’s palette
library, the Job and the Environment where it is stored. Any other palette from other Environments,
Jobs, Elements or Scenes (even from the same job) willNOT follow. Instead a recovery palette will be
created when the scene is reopened in another Harmony system. A recovery palette is a local palette
created by the system when palettes and colours are missing. This palette is no longer shared with the
rest of the project.

For example, in the following chart, if you export Scene 2 from Job 1, the package will carry the
palettes from Scene 2, Job 1 and Environment. ItWILL NOT carry the palettes from Element 3 in
Scene 1, Scene 1 and Job 2. If Scene 2 was linked to any of these, the system will create a recovery
palette the next time Scene 2 is opened in another Harmony system.
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The best place to store your palette is:

• Environment level for a movie or series

• Job level for a publicity or small project

• Scene level for a student exercise

To store your palette with their colour models, you can use the Element level, however, it will require
more structure when exporting the scenes. The scene will have to be exported along with its colour
model scene. The other studio you are working with must recreate an identical structure to yours, then
import the received scenes into the same location as you have them in order to maintain the links.

Palette Backup
When sharing palettes between scenes, some users may accidentally modify the colours, even though
the palettes are locked by default. That is why it is a good idea to copy and back up your palette
libraries and master palette directories.

When a palette file is copied, it automatically becomes a clone palette, so there will not be any trouble
replacing an altered file. Harmony automatically updates all of the files and drawings linked to it.

Creating a Colour Palette
You can create a palette in either Basic or Advanced mode.
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By default, Toon Boom Harmony is set to the Basic mode. For simple productions, it is recommended
to use the Basic mode. This setting stores the palettes automatically for you and saves them at the
Scene level. When you use the Advanced Palette Lists mode, you can decide at which level you want to
store your palettes: Environment, Job, Scene, or Element.

If you are using Harmony Network, see Palette File Storage on page 293.

Before you can create a palette in the Advanced Palette Lists mode, you must first set your
preferences to Advanced Palette Lists mode in the Preferences dialog box. You also need to have the
rights to modify the palette list. If you do not, select Edit > Edit Palette List Mode from the top menu.

You can remove palettes from your Palette list if they are not needed in your scene. The actual palette
file will not be deleted and you can reimport it in your Palette list later on.

How to set the Advanced Palette Lists mode

1. Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences
(Mac OS X).

‣ Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. Select theAdvanced tab.

3. Select theAdvanced Palette Lists option.

4. Click OK.

How to create a new palette (Basic Palette Lists mode)

1. From the Colour View menu, select Palettes >New or click the New Palette button.

‣ Make sure that you have the necessary rights to modify the palette list. If you do not, select
Edit > Edit Palette List Mode.

The Create Palette window opens.

2. Enter the palette name according to the model.

3. Click OK.

The palette appears in the drawing element’s palette list.

321



Chapter 8: Colour Styling and Colour Models Working with Palettes

How to create a palette from the Advanced Palette Lists mode

1. In the Timeline or Xsheet view, select the drawing that requires a palette.

2. Make sure that you have the necessary rights to modify the palette list. If you do not, select Edit >
Edit Palette List Mode.

3. In the Colour view, click the Show Palette List View button to display the palette list.

4. Do one of the following:

‣ From the Colour view menu, select Palettes > New.

‣ Click the Create Palette button.

The Palette Browser: Create Palette dialog box opens.

5. Select the level to store the palette file.

‣ Environment: The palette-library folder is stored in the scene's parent environment folder.

‣ Job: The palette-library folder is stored in the scene's parent job folder.

‣ Scene: The palette-library folder is stored directly in the scene folder.

‣ Element: The palette-library folder is stored directly in the drawing element folder.

When you select a level that has a palette stored in it, the palette names are displayed in the
Palette field.

322



Toon Boom Harmony 11.1 Sketch Module Network User Guide

6. Name the palette. There is no need to add the suffix "palette"  to the name as it is always
recognized as a palette file.

7. Select a Palette List option.

‣ The Scene Palette List is mainly used with cut-out animation. A cut-out character will often
be divided in twenty to thirty different drawing elements that use the character's master
palette.

The palette list is stored at the scene level instead of the Element directory. This way, all
palettes linked to this list will appear in every drawing element created in the scene. There is no
need to manually load the palette in each element.

‣ The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-
out animation, all columns (drawing elements) contain different characters, props,
backgrounds and effects. The Element Palette List is used because you do not necessarily
want all of the palettes for all of your elements linked in every column.

The palette list is stored in the drawing element's directory instead of directly in the Scene level.
This ensures that the links to the palettes appear only in the appropriate element. If you prefer
to access a global palette list, link your palettes to the Scene Palette List.

8. Click OK.

The new palette appears in the palette list.

How to rename a palette

1. In the Colour view, select the palette to rename.
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2. Do one of the following:

‣ Right-click and select Rename.

‣ From the Colour View menu, select Palettes > Rename.

3. In the Rename dialog box, give the palette a new name and click OK.

How to remove a palette

1. In the Colour view, select the palette to remove.

2. Do one of the following:

‣ From the Colour View menu, select Palettes > Remove.

‣ Right-click on the selected palette and select Remove.

‣ Click the Remove Palette button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.

Duplicating a Colour Palette
A duplicated palette is a simple copy of the original palette. It uses the same names, colour values, but
has a different ID and is independent from the original palette. This ensures that both palettes are
completely independent.

This option is used when there are similar models and you want to avoid recreating and naming all of
the colours. You can change the values and the names afterward without affecting the original palette.
You can also keep some RGBA values, such as the eyes, teeth, tongue, inside mouth, etc.
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How to duplicate a palette

1. In the Colour view, select the palette to be duplicated.

2. Do one of the following:

‣ From the Colour View menu, select Palettes > Duplicate.

‣ Right-click on the selected palette and select Duplicate.

The Palette Browser: Duplicate Palette window opens.

3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage
on page 293.

4. In the New Palette Name field, name the palette.

5. In the New Palette Name field, name the palette.

6. Click OK.

The palette appears in the palette list.
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Cloning a Colour Palette

A character usually has only one master palette, although there are times when the characters are
placed in different lighting conditions and require a different colour shading. The night palette is a
popular choice when a scene or sequence changes from day to night. It can be difficult and time-
consuming to repaint everything and creating two independent palettes can be quite complex. As an
alternative, Toon Boom Harmony provides clone palettes.

The clone palette is a copy of the master palette. The colours in each palette have the same
properties. The colours have the same identification number pointing to the same colour zones, but
they can have different names and RGBA values. Depending on the activated palette (night or day), the
painted drawing will update. So there is no need to repaint the animation, but to create or import a
clone palette (palette style).

How to clone a palette

1. In the Colour view, select a palette to clone.

2. From the Colour View menu, select Palettes > Clone or right-click and select Clone.

The Palette Browser: Clone Palette dialog box opens.
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3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage
on page 293.

4. In the New Palette Name field, name the palette. It is recommended that you keep the "-clone" in
the name.

5. Click OK.

The cloned palette appears in the palette list.

6. In the Palette list, select the clone palette you created to offset or blend colours—see Mixing
Colours on page 319.

7. From the Colour View menu, select Palettes> Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.
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8. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A
(Windows/Linux) or ⌘ + A (Mac OS X).

9. Offset, blend, or mix the colours using the sliders and increasing the Amount value.

10. Select the Preview option to see a preview of the colours while you adjust them.

You can also modify the colours individually with the Colour Picker window.

Importing and Linking Palettes
Before starting colouring work such as Ink and Paint or even creating new colour models, you may
want to load existing colour palettes to your scene. You can do so by linking colour palettes to your
palette lists.

You may encounter a case where only a colour palette is visible when a layer is selected. If you need
that palette in a second layer, you can link the palette to the second layer's palette list, A good
example would be a scene where there is a character on one layer and its arm is on another. In order
for both layers to access the palette, you must link both Element Palette lists to that palette. If you
palette is linked to the Scene Palette list, it will be accessible by all layers.
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If you created a palette in another project and you want to import it in your current project, you can
browse for the palette file on your computer and add it to your scene. When the palette is imported in
your scene, the file is copied in the project’s directory. It is not linked to the original file.

Harmony lets you link an external palette to your scene without copying it in your project. This method
is not recommended. It is always safer to have the palettes contained within the database to avoid
data loss if the source palette were to be deleted or the project exported without including the
external palettes.

You will notice that when you create or link a palette, a small icon appears on its left. These icons
represent the palette linkage status.

Icon Description

Indicates that the palette is safe.

There won’t be any trouble once the scene will be exported. For example,
the palette file is stored in the scene folder and is linked to the Scene Palette
List.

Indicates that the palette file is stored in a directory external to the scene’s
structure.

The palette file is probably stored in a Master Palette directory on a hard
drive external to the palette-libraries planned for the palette storage. The
warning in this case is that if you move your Master Palette directory to
another location, you may loose the palette in your scene.

Indicates that a palette file stored in a level such as Element, Scene, Job or
Environment is linked to a Palette list that is not on the same level.

For example, a palette file is stored into the Environment folder and is linked
to the Element Palette list. The palette is shared.

How to link a colour palette

1. Do one of the following:

‣ From the Colour View menu, select Palettes > Link.

‣ Right-click and select Link.

‣ Click the Import button.

The Palette Browser: Link Palette dialog box opens.
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2. Select the level where the palette file is stored—see Palette File Storage on page 293.

3. Select the palette list linking level by enabling either Scene Palette List or Element Palette List—
see Palette Lists on page 290.

The palette appears in the Colour view.

How to import a palette into your project

4. Do one of the following:

‣ From the Colour View menu, select Palettes > Import.

‣ Right-click and select Import.

The Browser window opens.

5. Browse for a palette file located (*.plt) on your hard drive. You will generally find the palettes in
your project's palette-library directory.

6. Click Open.

The Palette Browser opens.
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7. If you are in Advanced Palette mode, select the level where the palette file is stored—see Palette
File Storage on page 293.

8. If you are in Advanced Palette mode, select the palette list linking level by enabling either Scene
Palette List or Element Palette List—see Palette Lists on page 290.

9. In the New Palette Name, name the imported palette.

The palette appears in the Colour view and the file is copied in your project.

How to link to an external palette

1. In the Colour view, click on theCreate Palette button to create your palette to be used as
external.

2. Save your scene by selecting File > Save from the top menu or by clicking the Save button or
press Ctrl + S (Windows/Linux) or ⌘ + S (Mac OS X).

3. On your computer or server, create a master directory. Ideally, this should be created in your Root
folder to keep it within the project directory. You could also place it inside your Colour Model’s
subdirectory. Refer to the Fundamentals Guide to learn more about project organization.

4. Name the folder appropriately, for example: Joe_master_palette.

5. From your operating system, browse to your Toon Boom Harmony scene and open the palette-
library folder.

331



Chapter 8: Colour Styling and Colour Models Working with Palettes

6. Select and copy your palette *.plt file to copy it to the master palette directory.

7. Create a new Toon Boom Harmony scene or open the scene where you will link this palette.

8. In the Timeline or Xsheet view, select the element to link the palette to.

9. From the Colour View menu, select Palettes > Link to External.

The Link to External Palette dialog box opens.

10. Click Browse to search for your master palettes folder and select the palette *.plt file you want
to link.

11. In the Palette list section, select how you want to load the palette; at the scene or element level.

12. Click OK.

The linked palette appears in the Colour view.

If a palette is outside the scene, the External icon appears beside the palette name.
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To link an element (such as a colour model) to the palette that is stored in the external palette directory,
you must remove the original palette from the element’s palette list. You will then load the duplicated
palette into the palette list using the Link to External command, like you did for the other elements.
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Colours

Toon Boom Harmony has some very powerful colouring features when it comes to painting. To paint
your drawings, you will use different colour swatches, unlike some other painting programs where you
modify the main swatch each time you want to paint with a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your
drawing. You can add as many swatches as you want. You can also rename them and modify existing
ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with
this swatch throughout the entire project. The colour swatch has a unique ID number that associates it
with the painted zones. This way, you can change the look of your character at any time without having
to repaint it!

This section is divided as follows:
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• Adding a Colour Swatch below

• Colour Display Modes on page 317

• Copying and Pasting Colours on page 318

• Mixing Colours on page 319

Adding a Colour Swatch
You can use several different types of colour swatches.

A colour palette is an actual file that is on the hard drive. These palette files can be stored in a different
location on the server. They can be stored in the Environment, Job, Scene, or Element folder and
linked to any palette list. This means that if the original palette file is modified, it will update in every
drawing element the palette is linked to.

To avoid accidentally modifying the palette, the palette files can be locked. If a palette must be
modified, you must get the rights to modify them before doing so.s

In Toon Boom Harmony, when you click on the Add Colour button, a new colour swatch is created
using the colour of the currently selected swatch from your palette. However, you can set a default
colour to be used every time you create a new colour in your colour palette. This might be useful if you
want to create different shades of the same basic colour.

The default colour is also the colour used when you choose to vectorize images that you are scanning
into your scene, however you add the Default colour swatch to your palette in a different way, so that
it is unique. It has a unique ID number that makes it recognizable from all the other colours in your
colour palettes. Being able to change this colour allows you to change the basic colour of all scanned
drawings. This can be useful on more than just an aesthetic level as sometimes when you go to NTSC
or PAL, pure colours, such as pure black, can create problems.

How to lock or unlock the palette list

‣ In the Colour view, click the Edit Palette Mode button.
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A grey pencil icon appears in the top-right corner of the Palette list.

How to add or modify a solid colour swatch

1. In the Colour view, click the New Colour button.

2. From the Colour View menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens.

3. To set your colour, do one of the following:

‣ In the colour wheel, select a colour.

‣ Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options
to change the look of the colour picking area.

‣ Click the Dropper button to select any colour on your screen. It can be from the Toon
Boom Harmony interface, your operating system or any other open application.
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You can also clickMultiWheelMode to open the Multiwheel Colour dialog box. This displays all
the picking area styles together and also contains a picking undo list. To return to the regular
Colour Picker window, click Single WheelMode.

4. Click on the Shade Scale swatches to modify the shade of the selected colour.

5. Adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha
field.
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6. Click theAdd button to add the current selected colour to the Colour Storage Library, so you can
quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by
double-clicking on its name.

How to change the default swatch colour for all your colour palettes

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS
X).

2. In the Preferences dialog box, select theDrawing tab.

3. In the New Colour Pots section, select theCreate New Colour Pot Using the Default Colour
option. You can also click on the colour swatch beside the option to change the Default colour.

How to add a new colour swatch using the default colour

‣ From the Colour View menu, select Colours > New.

A new swatch is added to your palette using the default colour swatch colour. The new swatch
created with the New command will be named New 0.

How to create a gradient colour swatch

1. In the Colour view, select a colour to modify .

2. Do one of the following:

‣ Click the new colour and from the Colour View menu, select Colours > New.

‣ Double-click on the colour swatch.

The Colour Picker window opens.
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3. Select theGradient option.

4. Select the Linear or Radial option.

5. Adjust the Gradient arrows to modify the colours.

‣ Add extra colours by clicking between the arrows below the gradient bar. Then click on the
Colour Preview to select a colour.

‣ Pull down the arrows to remove them.

‣ Move the arrows left and right to modify the gradient distance.

Refer to the Editing Gradients and Textures on page 359 topic to learn how to reposition the gradient
zones in your drawings.

How to create a texture colour

1. From the Colour View menu, select Colours > New Texture or click the New Texture button.

The Browser window opens.

2. Browse for a PSD or TGA bitmap file created with a third party software and clickOpen.

The texture is added to the colour list.

339



Chapter 8: Colour Styling and Colour Models Colours

Refer to the Editing Gradients and Textures on page 359 topic to learn how to reposition your textured
zones in your drawings.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool
instead of plaid, just update the texture file in the swatch and the entire project updates. Any
transformation previously applied to the texture’s position in your drawings will be kept.

How to replace a texture swatch

1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

2. From the Colour View menu, select Colours > Edit Texture or double-click on the swatch.

The Browser window opens.

3. Browse for the new PSD or TGA bitmap file created in a third party software.

4. Click Open to update the colour swatch.
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How to delete a colour swatch

1. In the Colour view, select the colour swatches to delete.

2. Do one of the following:

‣ From the Colour View menu, select Colours > Delete.

‣ Click the Delete Colour button.

‣ Right-click and select Delete.

‣ Press Delete.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

3. Click OK to delete the colours or click Cancel to abort the operation.

‣ If you delete colour swatches already in use, the zones painted with them turn red so you
can easily identify them.

Colour Display Modes
The Colour view has two display modes:

• List

• Swatch

You can alsodisplay the RGB values and names of your solid colour swatches instead of only the name.
This option is not available when displaying the colours in Swatch mode.
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How to switch between the display modes

1. From the Colour View menu, and do one of the following:

‣ Select Colours > Swatch Mode to display the swatches.

‣ Deselect Colours > Swatch Mode to display the colour list.

How to display the swatch colour values

‣ From the Colour View menu, select Palettes > Display Colour Values.

The solid colour swatches’ RGB values will be displayed between the colour swatch and its name.
The gradient colour swatches will be identified as (gradient).

Copying and Pasting Colours
When you are creating palettes, you may want to copy colour swatches or their values and paste them
in other palettes to save time. You can also quickly copy a colour value from a palette in your scene to
a selected colour swatch in a different palette.

You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch,
it is impossible to use the Paste as Clone command in the same palette as you copied the original
colour swatch from.

If you would like to keep a reference file of some colour IDs or use them with custom plug-ins, you can
copy the colour swatch IDs. Here is an example of colour ID: 075cf5b552401130.
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How to copy and paste colours

1. In the Colour view, select one or more colours to copy.

‣ In the Colour view, click the Edit Palette Mode button to be able to edit the colour list.

2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘ + C (Mac
OS X).

3. In the Palette list, select the palette in which you want to paste the colours.

4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V
(Windows/Linux) or ⌘ + V (Mac OS X).

‣ To paste the colour values of the copied swatch over an existing colour swatch, select
Colours > Paste Colour Values.

How to clone a colour swatch

1. In the Colour view, select the colour swatch you want to clone.

‣ In the Colour view, click the Edit Palette Mode button to be able to edit the colour list.

2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘ + C
(Mac OS X).

3. In the Colour view, select the colour palette you want to paste the clone into or create a new
palette.

4. From the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

How to copy a colour ID

1. In the Colour view, select the colour swatch you want toget the ID from.

‣ In the Colour view, click the Edit Palette Mode button to be able to edit the colour list.

2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux)
or ⌘ + C (Mac OS X).

3. Paste the copied value as plain text in the desired document.

Mixing Colours
If you want to modify a series of colours at once to blend a tint in them or offset their RGBA values, you
can use the Tint panel. This panel is quite useful when creating palette styles such as night and day
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styles.

How to mix colours

1. In the Colour view, select the palette that contains the colours you want to offset or blend.

2. Do one of the following:

‣ From the Colour View menu, select Palettes > Tint Panel.

‣ Right-click and select Tint Panel.

The Blend/Offset Tint panel opens.

3. Select one or more colours to modify in the colour list. To select all the colours, press Ctrl + A
(Windows/Linux) or ⌘ + A (Mac OS X).

4. Select Preview option.

5. Select theOffset, Blend, orMix option.
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Parameter Description

Offset

Offsets the selected colours by the adjustments made using
the HSB and RGB sliders. Use the Amount slider to adjust the
degree of offset. Use the Alpha slider to adjust the opacity of
the selected colour.

Blend

Blends the selected colours with the colour swatch in the top-right
corner. Use the Amount slider to adjust the degree of blend. A blend of
100% turns the selected colours into the same colour as the swatch.
Adjusting the HSB and RGB sliders affect the swatch colour, which in
turn affects the selected colours on the left. Use the Alpha slider to
adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch.
Use the slider just beneath to mix the Base and Tint colours
by different amounts. This will affect the mixed swatch
whether it is selected or not. Select either the Tint or Base
swatch and use the HSB and RGB sliders to adjust its colour.
This will affect the mixed swatch colour, which in turn affects
the selected colours on the left.

6. Click Apply.

345



Chapter 8: Colour Styling and Colour Models Painting the Model

Painting the Model

Now that you have created the colours and the palette, you are ready to paint your model.

The colour model needs to be painted in order to adjust the colours with the other elements in the
production. You can paint your model regardless of the colour RGBA and adjust them later when all
the elements are together.

For paperless and cut-out animation, it is a good idea to provide a line-up template with the colour
model to show the scale ratio between the characters, props and backgrounds.

Once your colour model is completed, create a line-up template by pasting one of the production's
main characters, or even just a hand, beside the colour model to show the relative size. This allows the
animator, layout artist, or scene setup artist to retain the correct scaling throughout the entire project
when setting the elements in the scene. You can store your template in the Library.

How to paint a colour model

1. From the Camera View menu, select View > Switch to Colour Art/Switch to Line Art or press L.

2. Create your master colour palette—see Creating a Colour Palette on page 296

3. Add new colours to the palette—see Adding a Colour Swatch on page 311.

4. Select your Paint Bucket tool. We recommend the Paint Unpainted tool.
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5. In the Colour view, select the colour you need to paint your drawing.

6. Paint the model by selecting colour swatches in the palette and clicking on your drawing. Note that
only closed zones will be painted. If there is a gap in your artwork, you will need to close it in order
to paint it.

7. If you would like to separate your lines and fill zones on separated art layers, see Art Layers on
page 434.

8. Adjust the colours—see Mixing Colours on page 319.
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Chapter 9: Painting the Background

Not only does Toon Boom Harmony give you the ability to animate and composite, you can also use it
to paint your backgrounds. You can use solid, gradient or textured colours to create vector-based
and bitmap colouring.

If you create multiplane moves, a vector background will generally be lighter and will allow extreme
truck-ins.
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The background painting process consists of painting the black and white production backgrounds,
also known as background layouts. For traditional animation, the background layouts are usually
drawn on paper and then scanned in. For paperless and cut-out animation, the background layouts
can either be drawn on paper or designed directly in Harmony.

This chapter is divided as follows:

• Preparation on the facing page

• Importing the Background Layout on page 329

• Painting the Background on page 331
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Preparation

Before you begin painting, prepare by organizing your work and bringing in your references.

Setting the Scene

Once you chose your technique, it is time to open or create your scene and get ready to import your
background layouts.

Working Directly in the Production Scenes

You can decide to import the background layout directly in the corresponding production scene
and paint it there. This way, the background exists only in the production scene and not in a central
storage scene, saving space on the hard disc drive and avoiding duplicate files.

Working in a Special Background Scene

You can decide to create a new scene, import all your background layouts and paint them in that
scene. This scene will become the colour background storage scene.

It is useful to keep all the backgrounds in the same scene to compare the style and colours, use the
same master palette, and keep track of the work and all existing backgrounds.

We recommend that you store this scene in the project root folder.
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Importing the Background Layout

When the background painting or production scene is ready, import your background layout in it.
Designing your backgrounds and locations directly in Harmony can be a time saver and allows you to
keep all your project materials in the same software.

Refer to Chapter 2: Import in the Compositing Guide to learn how to import bitmap images and the Scan
Guide to learn how to scan the layout.

Importing a Bitmap Layout

If your background layout was drawn on paper and scanned in a third-party software or simply
drawn in a bitmap third-party software, you can import them using the Import Drawings command.

Scanning the Layout from a TWAIN Device

If your models were drawn on paper, you can also scan and import them using a TWAIN Device.
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Painting the Background

Now that your background layout, master palette and location colour model are imported in your
scene, you are ready to paint your background.

A Harmonydrawing is composed of several art layers. Lines and colours can be separated or joined,
depending on the animation process. When a traditional drawing is scanned in, strokes are
automatically created in the Colour Art from the Line Art. For paperless drawings, once the drawing
sequence is completed, create your Colour Art strokes if you plan to paint your animation in the
Colour Art layer. Use the Create Colour Art from Line Art option to create strokes from your lines—
see Art Layers on page 434.

How to create strokes once the drawing is completed

You may prefer to create strokes once the drawing is cleaned up. In this case, select the full drawing
and create the strokes in Colour Art.

1. Skip this step if you are creating strokes for a single drawing. Do one of the following:
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‣ In the Select Tool Properties view, click the Permanent Selection tool.

‣ PressCtrl + Shift + P (Windows/Linux) or ⌘ + Shift + P (Mac OS X).

2. Do one of the following:

‣ In the Drawing Tools toolbar, click the Select tool.

‣ Press Alt + S.

3. Select the entire animation sequence.

4. Do one of the following:

‣ In the Camera view, select Drawing > Create Colour Art from Line Art.

‣ Press *

5. Repeat steps 1 to 4 for each drawing in the animation sequence.

How to create strokes while drawing in Line Art mode

If you have some traditional drawings that need to be fixed, for example, need extra lines to patch
gaps, the strokes can be created in the Colour Art layer at the same time as the lines are drawn using
the Auto-Create Colour Art from Brush feature. This feature creates strokes from the lines and brush
strokes created in the Line Art layer as you draw.

You can use it to fix drawings, but if you draw a sketch from scratch it is better to create the strokes
afterward using the Create Colour Art from Line Art option.

1. Do one of the following:

‣ In the Camera View toolbar, click the Automatically Create Colour Art from Brush
button. You may have to customize the toolbar to display it.

‣ When the Brush, Pencil or any shape tool is enabled, in the Tool Properties editor, click the
Automatically Create Colour Art from Brush button.

2. Draw the extra lines required.

3. Once you are done, deselect theAutomatically Create Colour Art option.

You are now ready to paint your background.

How to paint your background

1. Do one of the following:

‣ In the Camera view, switch to the Line Art or Colour Art to paint your model.

‣ Press L.
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2. Select one of the Paint Bucket tools. The Paint Unpainted tool is recommended.

3. Paint the background by selecting the colours from the colour model or the palette, and clicking on
the different drawing zones.

How to use the Stroke tool to create tone and highlight zones

You can use the Stroke tool to draw invisible vector strokes and separate some of the drawing
sections to create tone and highlight zones.

1. Do one of the following:

‣ In the Camera view menu, select Drawing Tools > Stroke.

‣ Press Alt + V.

2. Do one of the following:

‣ In the Camera view menu, select View > Show Strokes.

‣ Press K.

The strokes appear.
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3. Draw the stroke on the background drawing.

4. In your colour palette, select the colour needed to paint the new zone.

5. In the Tools toolbar, click the Repaint button.

6. Do one of the following:

‣ In the Camera View toolbar, select View > Show > Show Strokes to hide the strokes.

‣ Press K.
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How to use gradient colour

Using a gradient colour adds more depth and variation to your drawings.

1. In the Colour view, select the colour to be modified.

2. Do one of the following:

‣ In the Colour view menu, select Colour > Edit Colour.

‣ Double-click on the colour swatch.

The Colour Picker window opens.

3. Select theGradient option.

4. Select the Linear or Radial option.

359



Painting the Background

5. Select the Gradient arrows to modify the colours.

‣ Click between the arrows to add extra colours.

‣ Pull down the arrows to remove them.

‣ Move the arrows left and right to modify the gradient distance.

6. Use the Edit Gradient/Texture tool to set your gradient's position.

How to use the Edit Gradient and Texture tool

1. Do one of the following:

‣ In the Camera view menu, select Drawing Tools > Edit Gradient/Texture.

‣ Press Shift + F3.

2. Click on the gradient or texture colour to be modified.

The Edit Gradient/Texture selection frame appears.

3. Move the edit texture's parameters to the desired result.

4. If the same modification needs to be applied to another gradient or texture zone, do one of the
following:
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‣ Select the modified zone and select Edit > Copy.

‣ Press Ctrl + C (Windows/Linux) or ⌘ + C (Mac OS X).

5. Select the zone you want to modify.

6. Do one of the following:

‣ From the top menu, select Edit > Paste.

‣ Press Ctrl + V (Windows/Linux) or ⌘ + V (Mac OS X).
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Chapter 12: Ink and Paint

When traditional animation is traced, cleaned up, scanned in and properly exposed, it is time for the
ink and paint process. This consists of cleaning all dirt and hair (for example, dust that was in the
scanner, dots that do not belong in the drawing, extra floating artwork around the drawing that must
be removed), painting the lines and filling the colours in the empty zones on an entire animation
sequence.

For paperless animation, the drawings are cleaned up directly in Harmony, so there is generally no dirt
to clean, only painting and inking.

For cut-out animation, once the character builder paints the pieces, there is no more ink and paint
process because the same parts are always reused and moved around. The ink and paint process
applies only to traditional and paperless animation workflows.

Harmony is optimized to ink and paint drawings efficiently. Since most of the drawings are vector-
based, the colour zones are completely filled and there are no scattered spots left blank. Also, there
are some actions that can be applied on an entire animation sequence at once, like dirt removal, some
colour filling, line repainting, and so on.

Harmony uses palettes to hold all the colours you need to paint your elements. A palette is created by
assigning a set of colours to each character, prop or effect. The colour styling artist will create a new
palette and add a new colour for each zone of the character, such as the skin, hair, tongue, shirt,
pants, and so on. Each colour is known as a colour swatch—see Working with Palettes on page 289.

When a zone on the character is painted with the colour contained in a colour swatch, a link is
automatically created between that colour swatch and the zone. This means that if the tint of the
colour in the colour swatch is changed, any zone linked to it will update to the new tint. This is one way
that colour palettes can save time and money in your production.
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Another advantage of this system is that you can create complete palettes for different lighting
situations. For instance, in addition to the regular palette for a character, you could have one for that
character in the rain using colours that are duller and less vibrant than the dry daytime colours, or yet
another for using in a night scene. Using palettes linked to your character in this way allows you to
instantly change its colouring to suit the mood and atmosphere of the scene without tediously
repainting each element.

The ink and paint process is divided into the following steps:

• Preparation on the facing page

• Dirt Clean Up on page 344

• Art Layers on page 434

• Creating Strokes on page 351

• Painting on page 353

• Inking the Lines on page 368

• Verifying the Zones are Painted on page 372

• Ink and Paint Tool Properties on page 374
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Preparation

The optimal workspace for creating colour models and inking/painting in traditional animation
includes the following views:

• Xsheet

• Camera

• Colour

As there is no default workspace for these tasks you will need to create a custom workspace for
yourself—refer to the Fundamentals Guide.

You may have a character or element palette that has colours that are very similar to the Drawing and
Camera view's background colour. For example, a white eyeball colour on a white background which
makes it difficult to know if the zone was painted. You can change the background colour of the
Camera or Drawing view in the Preferences dialog box.

How to change a view's background colour

1. Do one of the following:

‣ From the top menu, select Edit > Preferences.

‣ Mac OS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

The Preferences dialog box opens.

2. Select theGeneral tab.

3. In the Colours section, click Edit Colours.

The Colours dialog box opens.
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4. Select theCamera or Drawing tab.

5. Change the background colour of:

‣ Camera View: Click theClear colour swatch.

‣ Drawing View: Click theBackground colour swatch.
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The Select Colour dialog box opens.

6. Select a colour by clicking a colour swatch, clicking a colour in the colour gradient, or entering a
HSV/RGB Value.

7. Click OK in the three opened dialog boxes to apply your changes.

When you need to paint drawings with similar colours throughout the palette, you can
create a clone of that palette and change all the colours to very bright tints to facilitate
the paint process—see .

367



Chapter 12: Ink and Paint Dirt Clean Up

Dirt Clean Up

When paper drawings are passed through a scanner, there can be some hair and dirt scattered across
them. These lines and dots need to be cleaned. Harmony provides different tools to help get rid of
them quickly.

The Remove Dirt tool selects small dots and hairs on the drawing. Raising the Remove Dirt level will
select bigger dots. When selecting larger dots, be careful not to lose small details like pupils and
nostrils. Once you have chosen the level, you can apply it to the current drawing or the entire
animation sequence. This is a quick way to get rid of most dirt and dust.

During this process, the dirt that will be removed is highlighted in red.

The Remove Art Outside Selection option lets you remove any art existing outside a selection. It is
recommended that you clean your Colour Art level as well. If you have a stroke accumulation in your
Colour Art, it can result in large output files, especially if you work in high-definition resolutions.
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If there are some marks that cannot be removed with the automated tools, you can erase them with
the Eraser tool or select them with the Select tool and then delete them. It is always safer to select and
delete them than to erase them, so you do not overlook anything.

How to use the Remove Dirt tool

1. Do one of the following:

‣ From the top menu, select Drawing > Clean Up > Remove Dirt.

‣ From the Camera View menu, select Drawing > Clean Up > Remove Dirt.

‣ Press Shift + D.

2. Increase the Remove Dirt value by moving the slider to the right.

3. Enable the Apply to All Drawings if you want to operation to be apply to all drawings in the layer.

How to clean dirt with Remove Art Outside Selection

1. In the Tools toolbar, select the Select tool.

2. In the Tool Properties view, enable the Permanent Selection option.

3. Draw a selection around the animation making sure to include the entire animation sequence.
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4. In the Camera View menu, select Drawing > Clean Up and one of the following options:

‣ Remove Art Outside Selection to delete artwork outside your selection on a single
drawing.

‣ Remove Art Outside Selection on All Drawings to delete artwork outside your selection
on all the drawings.

The art outside the selection is removed.

How to access the Eraser tool

‣ From the Tools toolbar, click the Eraser button.

‣ From the top menu, select Drawing > Drawing Tools > Eraser.

‣ From the Camera View menu, select Drawing Tools > Eraser.

‣ Press Alt + E.

How to access the Select tool

‣ From the Tools toolbar, click the Select button.

‣ From the top menu, select Drawing > Drawing Tools > Select.

‣ From the Camera View menu, select Drawing Tools > Select.

‣ Press Alt + S.
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Art Layers

Art layers give you the possibility to divide the artwork in your drawing on different layers. For
example, you can separate the outline and colour fill on two art layers, similar to 1950s traditional cell
animation. These art layers are contained within a single drawing as opposed to the timeline layers or
Xsheet columns where individual drawings with individual timing are stacked one on top of the other—
see Creating Strokes on page 351.

Toon Boom Harmony drawings include two layers in Advanced Art mode.

• Line Art below

• Colour Art on the next page

You can access the Art layers through the Camera and Drawing views bottom toolbar. By default, the
art layers are hidden. Everything is drawn on the Line Art layer. You need to enable the Use Advanced
Art Mode option.

Each layer can be used for separate hand-drawn animation tasks, letting you organize your work and
facilitate creation and revision.

Line Art
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In hand-drawn animation, the Line Art layer is mainly used to trace and clean up animation. The
outline is drawn in the Line Art layer and colour is painted in the Colour Art layer.

Colour Art

In hand-drawn animation, you use the Colour Art layer to paint your animation. The outline is drawn
in the Line Art layer and colour is painted in the Colour Art layer. Strokes (invisible lines) are
generated from Line Art to contain the painted area.

When you are doing rough animation, you may want to send a clip to somebody for feedback or
approval before carrying on with your work. If you have several characters in your project that are
overlapping, it may be difficult to understand what is going on as you can see through the
characters. Toon Boom Harmony can generate a matte automatically in the Underlay, or even in the
Colour Art layer, and fill all the zones inside your characters making them opaque. This process is
fast and easy and allows you to send easy-to-understand movies.

How to enable the Use Advanced Art Mode preference

1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( Mac
OS X ).

2. In the Preferences dialog box, select theGeneral tab.

3. In the Advanced section, select theUse AdvancedArt Mode option.

4. Click OK.

How to switch between drawing layers

1. In the Art Layer toolbar, click the Line Art or Colour Art buttons. When switching art layer,
it will allow you to edit the select layer without affecting the other one.

372



Toon Boom Harmony 11.1 Sketch Module Network User Guide

2. Click the Preview All Enabled Art Layers button to display both layers together. Even when the
Preview mode is enabled, you will only be able to edit the select art layer. The other ones are only
displayed as a reference. By default, the Preview mode is always enabled in the Camera view. You
will only be able to see the select art layer by itself if you enable the Current Drawing on Top
option located in the Camera bottom toolbar.

To edit both Line Art and Colour Art at the same time, you must enable the Apply to
Line Art and Colour Art button in the Tool Properties of the tools supporting the
operation.

How to generate a matte

1. Do one of the following:

‣ In the Tools toolbar, select the Select tool.

‣ Press Alt + S.

2. In the Camera view, select the drawing you want to create a matte for.

You can also apply the operation to all the drawings in the layer at the same time.

3. Do one of the following:

‣ In the Camera view menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

4. If you want to create a matte for all the drawings included in your layer, select theApply to
Multiple Drawings option.

5. Depending on how precise or rough your line is, increase or decrease the radius value. The lower
the value is, the closer to your lines’ contours the matte will be shaped. The higher the value is, the
looser the matte will be shaped.
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6. In the Source Art menu, select the layer from which you want the matte created: Line Art or Colour
Art.

7. In the Destination Art menu, select the layer you want the matte to be created on: Line Art or
Colour Art.

8. If you already have artwork on the destination layer and you want the content to be deleted before
the matte is added into it, select theClear Destination Art First option.

9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case
you ever need to keep them for later), select theCopy Stroke in Destination option.

10. Click OK.
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Creating Strokes

A drawing is composed of Line and Colour filling layers. Lines and colours can be separated or kept
together, depending on which animation process you use. The following diagram presents Line Art
and Colour Art recommendations based on the selected animation workflow.

When a traditional drawing is scanned, strokes are automatically created in the Colour Art from the
Line Art when drawings are vectorized unless you specified otherwise.

When working with Cut-out animation, we recommend that you do all of the work in the Line Art.

Once the drawing sequence is completed for paperless drawings, you can proceed with creating
Colour Art strokes if you plan to paint the animation in the Colour Art. Use the Create Colour Art from
Line Art option to create strokes from your lines.

You can create strokes in the Colour Art during the following stages:

• After the full drawing is completed in Line Art

• While drawing in Line Art

You may have some traditional drawings that need to be fixed; for example, needing extra lines to
patch gaps. Use the Auto-Create Colour Art from Brush option to create the strokes at the same time
as the lines are drawn. This creates strokes from the lines and brush strokes created in the Line Art
while you draw and is useful for fixing drawings. However, if you are drawing a new sketch, it is better
to create the strokes afterward using the Create Colour Art from Line Art option.

How to create Colour Art zones out of the Line Art content

1. In the Tools toolbar, select the Select tool or press Alt + S.

2. In the Tool Properties view, enable the Permanent Selection option if you want to apply the
operation on all drawings in the layer.

3. In the Camera view, select the artwork to transfer to the Colour Art. Create a selection around the
entire animation sequence if you want to apply the operation to all your drawings.
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4. From the Camera View menu, select Drawing> Create Colour Art from Line Art or press *.
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Painting

You can choose to paint your animation in the Line Art or Colour Art level. You can paint in Line Art,
but for traditional and paperless animation, you should fill your colour zones in Colour Art. You can
access the art layers through the Art Layer toolbar—see Art Layers on page 434.

There are many advantages to separating the lines and colour zones, but the main one concerns the
painting process. To paint very quickly, it is useful to not worry about painting over the lines. If the
lines are separated, you can fill the zones very quickly and you will never accidentally paint the lines.
Conversely, if you are inking the lines, you will not repaint the colour zones either.

If you have transparent lines, bitmap lines or textured lines with transparency, it is better to have your
colour zones bleeding under your lines to avoid seeing the backgrounds and other elements through
the lines.

To avoid painting in Line Art by mistake, turn off the Preview mode. Press P to turn the mode on or
off.

This section is divided as follows:

• Painting Using the Paint Tool on the next page

• Advanced Painting Features on page 355

• Selecting a Colour in a Drawing on page 358

• Editing Gradients and Textures on page 359

• Closing Gaps on page 364

• Protecting Colours on page 366

• Highlighting the Selected Colour on page 366

• Inverting a Colour Selection on page 367
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Painting Using the Paint Tool

The main tool you will use to paint your drawings with is the Paint tool. The Paint tool can be used in
several different modes, which can be customized in the Tool Properties view.

The Paint tool paints closed zones, including brush strokes and pencil lines. If there are gaps in the
lines defining a zone, you must close them using the Brush, Pencil, or Close Gap tools or the Automatic
Close Gap option.

How to paint with the Paint tool

1. In the Timeline or Xsheet view, select the cell on which you want to paint.

2. Do one of the following:

‣ In the Tools toolbar, click the Paint tool.

‣ Press Alt + I.

3. In the Colour view, select a colour.

4. In the Camera view, start painting. You can click on a zone or pencil line to paint it, or you can trace
a lasso or marquee selection to paint several zones or pencil lines at once.

The last colour you select while using the Paint tool will be remembered the next time you select the Paint
tool if you are using the unlocked painting tools in the Colour view.
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Advanced Painting Features
The following advanced painting features are available in Toon Boom Harmony and are described in
this section:

• Repaint Selection

• Repaint Selection On All Drawings

• Repaint Outside Selection

• Repaint Outside Selection On All Drawings

• Unpaint Selection

• Unpaint Selection On All Drawings

• Unpaint Outside Selection

• Unpaint Outside Selection On All Drawings

The Repaint Selection command is used to repaint any art inside a selection. You must first draw a
selection using the Select tool in order for this command to be available.

The Repaint Selection On All Drawings command is used to repaint any art inside a selection on all the
drawings contained within the same layer. You must enable the Permanent Selection option in the
Select tool Tool Properties view and then select an area of your drawing using the Select tool in order
for this command to be available. The Permanent Selection option lets you maintain the same
selection throughout the drawings of a same layer.
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The Repaint Outside Selection command is used to repaint any art outside a selection. If no selection
has been drawn using the Select tool, the entire drawing will be repainted.

The Repaint Outside Selection On All Drawings command is used to repaint any art outside a selection
on all the drawings contained within the same layer. You must enable the Permanent Selection
option in the Select tool Tool Properties view and then select an area of your drawing using the Select
tool in order for this command to be available. The Permanent Selection option lets you maintain the
same selection throughout the drawings of a same layer.

The Unpaint Selection command is used to unpaint any art existing inside a selection. You must first
draw a selection using the Select tool in order for this command to be available.

The Unpaint Selection on All Drawings command is used to unpaint all art contained inside a selection
on all the drawings within the same layer.
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You must enable the Permanent Selection option in the Select tool Tool Properties view and then
select an area of your drawing using the Select tool in order for this command to be available. The
Permanent Selection option lets you maintain the same selection throughout the drawings of a same
layer.

The Unpaint Outside Selection command is used to unpaint any art existing outside a selection. If no
selection have been drawn using the Select tool, the entire drawing will be unpainted.

The Unpaint Outside Selection on All Drawings command is used to unpaint all art outside a selection
on all the drawings within the same layer. You must enable the Permanent Selection option in the
Select tool Tool Properties view and then select an area of your drawing using the Select tool in order
for this command to be available. The Permanent Selection option lets you maintain the same
selection throughout the drawings of a same layer.

How to access the Repaint Selection command

‣ From the Camera view menu, select Drawing > Paint > Repaint Selection.

How to access the Repaint Selection On All Drawings command

‣ From the Camera view menu, select Drawing > Paint > Repaint Selection On All
Drawings.

381



Chapter 12: Ink and Paint Painting Using the Paint Tool

How to access the Repaint Outside Selection command

‣ From the Camera view menu, select Drawing > Paint > Repaint Outside Selection.

How to access the Repaint Outside Selection on All Drawings command

‣ From the Camera view menu, select Drawing > Paint > Repaint Outside Selection on All
Drawings.

How to access the Unpaint Selection command:

‣ From the Camera view menu, select Drawing > Paint > Unpaint Selection.

How to access the Unpaint Selection On All Drawings command:

‣ From the Camera view menu, select Drawing > Paint > Unpaint Selection On All
Drawings.

How to access the Unpaint Selection command

‣ From the Camera view menu, select Drawing > Paint > Unpaint Outside Selection.

How to use the Unpaint Outside Selection On All Drawings command

‣ From the Camera view menu, select Drawing > Paint > Unpaint Outside Selection On All
Drawings.

Selecting a Colour in a Drawing

While working in your Camera view, you can use the Dropper tool to pick a colour from your drawing
without going to the Colour view.

How to use the Dropper tool

1. Do one of the following:

‣ In the Tools toolbar, select the Dropper tool.

‣ Press Alt + D.
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2. In the Camera view, click on the desired colour.

‣ If you are using another drawing tool such as the Paint tool, you can temporarily hold down
the D key and click in your drawing before releasing the key to pick your colour. When you
release the key, Toon Boom Harmony will return to your previous tool. You may also want
to select the zones painted with the colour currently selected in the Colour view. This can be
useful for removing rough lines from a clean drawing.

How to select the zones painted with the current colour

1. In the Colour view, select the colour you want to select the corresponding zones from.

2. Do one of the following:

‣ Press Ctrl + Shift + A (Windows/Linux) or ⌘ + Shift + A (Mac OS X).

Editing Gradients and Textures

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to
modify its position in the zone. You can move, scale, rotate and skew. If you want to match the colour
to the animation, set the first texture position and copy the Edit Gradient/Texture position. When
moving to the next drawing, you can select the next texture and paste the previous position to
continue the modifications.

If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool to use your
gradient’s position, angle and scale settings instead of the default ones, you can store your own
settings and reuse them afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn
with textured “brushes”. If you then paint your textured pencil line with a gradient, you can do so and
then edit both elements independently at the same time.

How to use Edit Gradient/Texture tool

1. Do one of the following:

‣ In the Tools toolbar, click the Edit Texture tool.

‣ From the Camera View menu, select Drawing Tools > Edit Gradient/Texture
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‣ Press Shift + F3.

2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.

3. Edit the gradient or texture by adjusting the control handles around the selection frame.

How to store your gradient and texture settings

1. In the Tools toolbar, select the Select tool or press Alt + S.

2. In the Camera view, select the gradient or texture zone to store.

3. In the Tool Properties view, click the Store Colour Gradient button.
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How to use the stored gradient and texture settings

1. In the Tools toolbar, select the Brush or Paint tool.

2. In the Tool Properties view, click the Use Stored Colour Gradient button.

3. In the Camera view, draw and paint.

How to use Pencil Editor tool to edit the texture or gradient on a pencil line

1. Do one of the following:

‣ In the Tools toolbar, select the Pencil Editor  tool.

‣ Press Alt + W.

2. Click on the pencil line to be modified to bring up its contour envelope.

3. Select one of the contour points around the envelope and move its position to change the size of
the tiled texture or gradient. You can also pull directly on the lines of the contour envelope or play
with the Bezier handles of any given point in order to continue to modify the envelope form.

Expanding the width of the envelope parallel to the pencil line’s central vector will cause the tiled
texture to be stretched. Conversely, reducing the envelope’s width will cause the tiled texture to
look squashed.

Reducing the contour’s width perpendicular to the pencil line’s central vector will reduce the
number of tiles, while expanding it will increase the number of tiled images.
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This editing technique does not just work on texture fills, but can also be applied to pencil lines
drawn with a textured “brush”.

How to use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line

1. In the Tools toolbar, select the Edit Gradient/Texture  tool. You can also press Shift + F3.

2. Click on the pencil line to be modified to bring up the editor controls.

3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull
on the top of the editor controls to stretch the tiled texture throughout the length of the stroke.

As gradients are parallel to the stroke’s central vector, this will stretch the way that the gradient is
distributed in the pencil line’s envelope. The envelope still acts as a boundary for the texture or
gradient.
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4. Drag the editor control perpendicular to the stroke. You will feel it glide along the strokes central
vector line. This is another way to resize the texture tile. Instead of stretching or shrinking it
vertically, this motion stretches or shrinks it vertically. As gradients are parallel to the pencil line’s
central vector, stretching them vertically gives no visual result.

How to use Edit Gradient/Texture tool to edit both the texture and the gradient of a
pencil line

1. Do one of the following:

‣ In the Tools toolbar, select the Edit Gradient/Texture  tool.

‣ Press Shift + F3.

2. Click on the pencil line to be modified to bring up the editor controls.

3. Use the top editor controls edit the gradient.

4. Use the bottom controls edit the “brush” texture.
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Closing Gaps

When painting, you may notice that some drawing areas are not closed. To close the zone, you can
either draw the missing line with the Brush or Pencil tool, or close the gap with an invisible line using
the Close Gap tool.

The Close Gap tool lets you close small gaps in a drawing by creating small, invisible strokes between
the two closest points to close the colour zone. You do not need to trace directly over the gap. You
can draw it a few millimeters away. The two closest points automatically close the gap.

How to close gaps

1. From the top menu, select View >Show Strokes or press K to see a preview of the result.

2. Enable the Auto-Flatten option in the Tool Properties view if you want the strokes you draw to
be flattened in your drawing instead of being on top.

The Close Gaps dialog box opens.

3. Adjust the slider to set the size of the gap you want to be closed.
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4. In the Tools toolbar, select the Close Gaps tool.

5. In the Camera view, trace a line near the gap to be closed. Your strokes will be invisible

The gap automatically closes.
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Protecting Colours

When you are finished painting some zones, you can protect the colour swatch they are associated
with, so the work cannot be accidentally painted over.

When you are done inking one colour, you can lock it so that if you ever paint over it accidentally, the
work already done will not be affected. You can also use the Protect Colour feature to block the filling
colours if you painted all of the animation in Line Art and you plan to repaint the lines.

How to protect colours

1. In the Colour view, select the colour to be protected.

2. Do one of the following:

‣ Right-click and select Protect Colour.

‣ From the Colour view menu, select Colours > Protect Colour.

A red bar appears beside the colour to indicate that it is locked.

Respecting Protected Colours
When painting, the Respect Protected Colour option is enabled by default. In the Colour view, you
can protect a colour swatch to avoid repainting or unpainting the zones linked to that swatch. If you
disable this option, the Paint tool will not follow the protect colour rule and you will repaint or unpaint
the protected colours on your drawings until you enable the option again.

How to toggle the Respect Protected Colours option

Do one of the following:

‣ Paint tool properties, click the Respect Protected Colour button.

‣ Press Shift + S.

Highlighting the Selected Colour
The Highlight Selected Colour option is used to identify colour swatch used in a drawing. For example,
if you have unnamed colours in your palette and want to know if a particular colour was used on the
current model or drawing, you can select the colour and use the Highlight Selected Colour option.
Harmony will dim all the colours in the drawing except the selected one, so it stands out and can be
identified. You can rename it accordingly.
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How to use the Highlight Selected Colour option

1. In the Colour view, select the colour you want to highlight.

2. From the Camera menu, select View > Show > Highlight Selected Colour.

Inverting a Colour Selection
When you need to select all colour swatches but one, or select only a few swatches here and there, it
might be faster to select the only colour you do not need, in order to select and invert the selection.

How to invert a colour swatch selection in the Colour view

1. In the Colour view, select the colour swatch youDO NOT want to have in your final selection.

2. Do one of the following:

‣ From the Camera View menu, select Edit > Invert Selection

‣ Press Ctrl + Shift + I (Windows/Linux) or ⌘ + Shift + I (Mac OS X).
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Inking the Lines

Some animation styles require you to paint the lines, a process also be called inking. To ink your lines,
you must be in Line Art mode. You can repaint any type of lines including the texture lines—see Art
Layers on page 434.

Unless you are repainting all of the lines on the whole animation sequence, do not use the Apply Tool
to All Drawings option. Since the line positions change a lot over time, you risk painting lines that are
not supposed to be painted.

These are the main tools used to ink the lines:

• Repaint Tool

• Repaint Brush Tool

• Ink Tool

• Protecting Colours

The main tool used to ink the lines is the Repaint tool. As the colour filling is probably done in the
Colour Art, you will not have to worry about not touching it. The Repaint tool will not paint empty
zones either.

During the vectorization process on traditional scanned drawings, triangles are added on the lines'
intersections to break the artwork in segments. This way, when you paint a line, it will not repaint the
whole drawing, only the relevant segment.

The Repaint Brush tool is used to paint a section by manually painting over the lines. This is useful
when the vectorization triangles are not placed as you would like or you simply need to repaint a
section of a segment. It is also useful for paperless animation, where there are no triangles. So, the
Repaint Brush is used to paint a certain area. It acts like the Brush tool, but will only show on painted
areas that are already painted.

Unlike the Brush tool, the Repaint Brush flattens automatically. The brush strokes are not added one
on top of each other.

When you are done inking one colour, you can lock it so if you ever paint over it accidentally, the work
already done will not be affected. You can also use the Protect Colour feature to block the filling
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colours if you painted all of the animation in Line Art and you plan to repaint the lines—see Protecting
Colours on page 366.

The Brush tool is often the most intuitive and rapid tool for creating rough sketches and clean lines. A
single colour, such as black, is often used when tracing a clean version of a rough sketch. However,
when it comes time to soft trace the lines in different colours, the flattened or unflattened clean brush
strokes can suddenly become time consuming to ink.

Toon Boom Harmony lets you create triangular breaks at natural line intersections. These
intersections are the probable locations where colour line breaks may occur, such as where a sleeve
meets a hand.

Although pencil lines can be painted in much the same way as closed zones, you can use the Paint,
Repaint, Repaint Brush, and Ink tools to make painting segmented lines easier. Normally when you
have a drawing, such as the one below, and you use the Paint tool to paint one of the lines, the entire
line is painted.

However, if you select the Ink tool instead and click on the same pencil line, only the segment that
you clicked on between two intersections will be painted.

The newly inked segment will always be moved to the front of all other pencil strokes, even if it was
behind all other pencil strokes before it was inked.

That is, unless you hold down Alt while clicking a segment. Then the opposite becomes true. The inked
segment will be sent to the back, even if it was in front of all other segments to begin with.
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Painting and Inking can be used in combination depending on what it is that you need to paint. If you
need to ink a character’s outline in black, it might be easier to use the Paint tool. If you need to paint
the outline of a character’s neck with a tan colour and its shirt outline blue and both the neck and shirt
belong to the same continuous outline, then the Ink tool might prove more useful.

How to select the Repaint Tool

1. In the Tools toolbar, select the Repaint tool located in the Paint tool drop-down menu.

How to select the Repaint Brush

1. In the Tools toolbar, select the Brush tool.

2. In the Tool Properties view, enable the Repaint Brush mode.

How to select the Ink Tool

1. In the Tools toolbar, select the Ink tool located in the Paint tool drop-down menu.

How to protect colours

1. In the Colour view, select a colour to lock.

2. Do one of the following:
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‣ Right-click and select Protect Colour.

‣ From the Colour view menu, select Colours > Protect Colour.

A red bar appears beside the colour to indicate that it is locked.
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Verifying the Zones are Painted

When the ink and paint process is completed, it is always a good idea to verify that every zone was
painted properly.

The first step to check your ink and paint is to go through all your drawings and verify that there are no
colour mistakes. You can use the F and G keyboard shortcuts or the Preview option available in the
Xsheet.

How to preview drawings from the Xsheet

1. First, save your scene.

2. Do one of the following:

‣ From the top menu, select File> Save.

‣ Click the Save button.

‣ Press Ctrl + S (Windows/Linux) or ⌘ + S (Mac OS X).

3. In the Xsheet view, select the range of drawings or the whole column to preview.

4. In the Xsheet View menu, select View > Preview SelectedDrawings or press Alt + P.

The Play window opens.
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5. Play your drawings.

6. Select the Preroll option to see blank frames at the beginning and end of the animation sequence
while looping the playback.
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Ink and Paint Tool Properties

The Ink and Paint tool properties contain many options that will help you along with your task.

• Ink Tool Properties below

• Paint Tool Properties on the facing page

Ink Tool Properties
When you select the Ink tool, its properties and options appear in the Tool Properties view.

Icon Tool Name Tool

Lasso and Marquee

The Lasso and Marquee options let you
choose the type of selection the current tool
will perform. The default selection mode is
Marquee.

• Lasso lets you draw a custom selection
box around zones.

• Marquee makes a rectangle selection
box.

Hold down the Alt key to switch
to the opposite mode of your
selection.

How to invert a selection

1. Do one of the following:

‣ From the top menu, select Edit >
Invert Selection.

‣ From the Camera menu, select
Edit > Invert Selection.

‣ Press Ctrl + Shift + I
(Windows/Linux) or ⌘ + Shift + I
(Mac OS X).

Show Inkable Lines

Highlights all pencil lines (no brush strokes)
on the selected layer. Pencil line segments
that are already inked with the selected
swatch colour from the colour palette are
also not highlighted.
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Be Smart on Con-
necting Lines

As you hover and move the cursor across
intersecting pencil lines, the path that you
create will be highlighted. When you click on
your mouse or stylus the highlighted
segments are inked.

With this option disabled, all the intersecting
segments that your cursor comes near will
be highlighted and become part of the
selection, even if they were not situated in
the direction of the chosen path.

Note: This option only works if the Ink tool
is in Hover mode.

Select Mode

Use this mode instead of the Hover
Mode. In the Hover Mode, any potentially
inkable pencil line will have its central vector
line highlighted as the Ink tool’s cursor
hovers over it. Use Ctrl (Windows/Linux) or
⌘ (Mac OS X) to toggle between the two
modes.

Select Newly Painted,
Repainted, Unpainted
Contours and Lines

Keeps a selection highlighted around the
latest painted zone after using the Paint,
Repaint, Unpaint, or Paint Unpainted tool.

Arrange Ink Lines
Brings all newly-inked lines to the front. Disable this
option if you want all newly-inked lines to be sent to
the back. Press Alt to toggle between the two options.

Mitre

As you hover over two perpendicular or
nearly perpendicular segments, a
highlighted path with a corner is created.
Clicking on these highlighted segments inks
both segments and makes them appear as a
single stroke with a corner or bend.

Click the Mitre button to choose from
As is, Round, Mitre, and Bevel.

Tip Style

Lets you customize the edge of the Ink tool.
Options include: Round, Flat, and Bevel.

Paint Tool Properties
When you select the Paint tool, its properties and options appears in the Tools Properties view.

399



Chapter 12: Ink and Paint Ink and Paint Tool Properties

Icon Tool

Lasso and Marquee below

Painting Modes below

Paint and Remove Texture on page 378

Apply to Multiple Drawings on page 378

Paint Tool Properties on the previous page

Respect Protected Colour on page 379

Select Newly Painted/Repainted/Unpainted Contours/Lines on
page 379

Automatic Close Gap on page 380

Lasso and Marquee

The Lasso and Marquee options let you choose the type of selection the current tool will perform. The
default selection mode is Marquee.

• Lasso lets you draw a custom selection box around zones.

• Marquee makes a rectangle selection box.

Hold down the Alt key to switch to the opposite mode of your selection.

How to invert a selection

1. Do one of the following:

‣ From the top menu, select Edit > Invert Selection.

‣ From the Camera menu, select Edit > Invert Selection.

‣ Press Ctrl + Shift + I (Windows/Linux) or ⌘ + Shift + I (Mac OS X).

Painting Modes

The Paint tool has four different modes available:

400



Toon Boom Harmony 11.1 Sketch Module Network User Guide

You can also find these tools directly in the Tools toolbar and in the Drawing Tools menu.

Paint Mode

The Paint mode paints everything it touches, including empty and filled zones.

Paint Unpainted Mode

The Paint Unpainted mode paints only empty zones. Any line or filled zone will remain unchanged.

Repaint Mode

The Repaint mode paints everything it touches except empty zones. Any zone that is not painted
will remain intact.
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Unpaint Mode

The Unpaint mode unpaints everything it touches, including empty and filled zones.

Paint and Remove Texture

The Paint and Remove Texture option is used when you vectorized images as greyscale texture
style. An image vectorized as texture is a mix of bitmap filling encapsulated in a vector-based frame.
Painting a textured zones with the Paint tool will change the tint of the textured lines. Painting the
textured zones using the Paint and Remove Texture option transforms the bitmap filling into a 100%
vector based zone and fills it with a solid colour.

Apply to Multiple Drawings
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The Apply to Multiple Drawings option is used for fast painting in hand-drawn animation. When
you want to paint several drawings in a same layer at once, such as a walk cycle, you can enable this
option and make a selection in your Camera or Drawing view. All the closed zones located within your
Paint tool selection are painted with the selected colour swatch.

You do not need to enable the Onion Skin preview to use this option. The option will stay enabled only
for the next action. If you want to use it again, you must click on the Apply to Multiple Drawings
button again, or press Alt + A.

The Apply to All Visible Drawings option is used to paint several drawings on separated layers on
the current frames. If you have a character broken in several layers, you can enable this option to paint
all your layers at once. The operation is only applied on the current frame. This option will stay enabled
only for the next action. If you want to use it again, you must click on the Apply to All Visible Drawings
button again.

This option is only available in the Camera view and does not affect symbols.

Respect Protected Colour

The Respect Protected Colour option is enabled by default. In your Colour view, you can protect
some colour swatches to avoid repainting or unpainting the zones linked to that swatch.

If you disable this option the Paint tool will not follow the protect colour rule and will repaint or
unpaint the protected colours on your drawings until you enable the option again—see Protecting
Colours on page 366.

When you paint a zone with a gradient or textured colour swatch, the gradient or texture’s position is
set relative to the size of the zone your are painting. If you want the Paint tool to use a particular size
and position, you must first store your desired position and size using the Select tool and then
enable the Use Stored Colour Gradient option in the Paint tool Tool Properties view—see Editing
Gradients and Textures on page 359.

Select Newly Painted/Repainted/Unpainted Contours/Lines

In the Paint tool Tool Properties view, enabling this option will keep a selection highlighted
around the latest painted zone after using the Paint, Repaint, Unpaint, or Paint Unpainted tool.
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Automatic Close Gap

The Automatic Close Gap option has four modes available:

The Automatic Close Gap options are used while painting drawings with small gaps.
Instead of having to close them manually with the Brush tool or Close Gap tool, Toon Boom Harmony
will analyze the drawing and close the gaps while you paint according to the selected mode. The
automated gap closing should be done using the zoom function setting of your Camera or Drawing
view. If your eye does not see the gap, Toon Boom Harmony won’t either—see Closing Gaps on
page 364.
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Chapter 13: Paperless Animation

Toon Boom Harmony is a powerful paperless animation software that incorporates animation and
drawing tools to make your work easier and more efficient.

Although it is a digital process, paperless animation is still hand-drawn and the fundamental principles
of animation still apply.

One of the advantages of working with paperless animation is that you do not lose time scanning
elements in and testing them because everything is already digital. You can simply draw your
animation and play back your line test right away. This also saves the substantial amount of paper
required by traditional animation. Another practical advantage is the ability to undo and redo some
actions that are often difficult on paper, such as erasing brush strokes.

This chapter is divided as follows:

• Preparation on page 383

• Rough Animation on page 393

• Secondary Animation on page 397

• Bringing Your Animation on Model on page 401

• Animation Clean-up on page 403

• Tools on page 409

• Advanced Tools on page 425

• Paperless Animation Preferences on page 441
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Preparation

To prepare for paperless animation with Harmony, you will need to complete the following tasks.

• Setting Up Your Workspace below

• Setting the Scene Resolution and Length below

• Importing the Layout, Storyboard and Animatic on page 385

• Importing the Background Elements on page 388

• Creating the Drawing Elements on page 388

Setting Up Your Workspace
To sketch the animation directly in Harmony, you will mostly frequently need the Camera or Drawing
view, the Xsheet or Timeline view, and the Tool Properties and Colour views.

While drawing and animating paperless animation, you can use the Workspace Manager to save a
frequently used layout and name it Paperless Animation, for example.

For more information on setting up your workspace, refer to Chapter 2: Interface in the Fundmentals
Guide.

Setting the Scene Resolution and Length
If the scene resolution was not already set by the digital layout artist or by a Toon Boom Storyboard
Pro import, it is the next step to be accomplished. The layout artist, scene planner or animator will
often take care of this task prior to the animation when working with paperless and cut-out animation.

How to set the resolution and frame rate

1. From the top menu, select Scene > Scene Settings.
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The Scene Settings dialog box opens.

2. Choose a resolution from the list or enter a new one.

3. Set your frame rate.

4. Click OK.

It is important to set the resolution before you begin to set positioning and camera moves, as it may affect
the ratio and composition.

Once you have set the resolution and frame rate, you must set the scene length by adding the right
number of frames to the scene. You can set the scene length from the top menu. If you do not yet
know the number of frames that will be needed, simply add some frames so you can draw different
poses. However, if you only need to draw a background and one pose, you do not need to add more
frames.

You do not need to do this step if you are importing your animatic in the QuickTime movie file
format. The QuickTime import feature takes care of the scene length at the same time as the movie
import.

How to set the scene length

1. From the top menu, select Scene > Scene Length.

The Set Scene Length dialog box opens.
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2. Type the scene duration in the Number of Frames field.

3. Click OK.

Importing the Layout, Storyboard and Animatic

To animate a scene, you need to import your layout, storyboard or animatic, depending on which
technique you are using. The most popular method is the animatic.

If you created a digital layout prior to the scene animation, you will animate directly in that scene. In
this case, there is no need to import references since they are already there.

Importing the Animatic

If you have an animatic available, you can import it. The animatic will give you the right timing to
expose your animation poses.

There are three ways to import an animatic in a scene.

How to import a QuickTime animatic

Toon Boom lets you import QuickTime movie files in the scene, cut them as image sequences and
import the sound as an independent soundtrack.

1. From the top menu, select File > Import > Movie.

The Select QuickTime Movie window opens.
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2. Browse to your animatic.

3. Click Open.

4. The Import Movie window displays the conversion progress.

When the conversion is complete, the Import Images dialog box opens.

5. Click OK.
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How to import an image sequence animatic

You can also import an animatic composed of a sequence of bitmap images that were created in a
third-party software by using the Import Images feature.

Use the same technique to import layouts and poses that were created on paper and scanned in
third-party software.

1. From the top menu, select Import > Images.

2. The Import Images dialog box opens.

3. Click OK.

How to import a Toon Boom Storyboard Pro animatic

If the animatic was created with Toon Boom Storyboard Pro, you need to create an Export to Toon
Boom function from that software. This will create your scenes and import your layout and posing
and camera moves. This must be done at the beginning of the production. When you work in
Harmony, use the same technique as you would in any QuickTime animatic.

If your project was created using Toon Boom Storyboard Pro, the animatic and camera moves are
already set in your scene and you can go ahead and import the background elements.
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Importing the Background Elements

Once the layout or animatic is set, you can import the background elements.

There are two types of background elements you can import: bitmap and vector-based.

Bitmap background

You can import external bitmap background elements to your scene using the Import Images dialog
box. Be sure to deselect the Convert to Toon Boom Vector Drawing option to retain your elements
as bitmaps and preserve your colours.

To import a bitmap background, follow the procedure to import an image sequence animatic—see
Importing the Animatic on page 385. For in-depth information on importing bitmap images, refer to
Chapter 7: How to Import Bitmap Images in the Getting Started Guide.

Creating the Drawing Elements
Before beginning to draw in the Camera view, you must add a drawing element to the Xsheet or
Timeline view. You will also need to select the appropriate cell in your drawing element.

How to add a drawing element from the Timeline view

1. Do one of the following:

‣ In the Timeline View menu, select Insert > Drawing.

‣ In the Timeline view toolbar, click the Add Layers button.

‣

‣ Press Ctrl + R (Windows/Linux) or ⌘ + R (Mac OS X).

The Add Drawing Layer dialog box opens.
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2. In the Name field, enter a relevant element name.

3. Do one of the following:

‣ Click OK to add the layer and close the dialog box.

‣ Click Apply to add the layer and keep the dialog box open to add another layer.

‣ Click Close to cancel the operation.

The new drawing element appears in the Timeline and Xsheet Views.

To learn more about creating new elements, see See "Adding New Drawing Elements" on page 106.

How to add a palette to your element

1. In the Timeline view or Xsheet view, select the cell in the drawing element that you plan to animate.

2. Do one of the following:

‣ From the Colour view menu, select Palettes > Link.

‣ Click the Link Palette button.

The Palette Browser window opens.
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3. Select the level in which the palette file is stored (usually Element or Scene).

4. Select the palette from the list.

5. Click OK.
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Creating the Drawings

Once your drawing elements have been created and your palettes are loaded, you are ready to create
drawings for your animation. But before creating the drawings, you should familiarize yourself with the
following operations.

There are two different ways to create drawings. You can create drawings automatically by letting
Harmony do it for you or by typing names (Typing mode) in the Xsheet cells.

How to automatically create a drawing

1. From the Timeline or Xsheet view, select the appropriate cell and start drawing in the Camera
view.

Harmony creates the drawing and names it using the next available number. If there is no existing
drawing, then it will be named "1", then "2"  and so on—see Paperless Animation Preferences on
page 441 to learn more about the Use Current Frame As Drawing Name option.

How to create a drawing using the Typing mode

1. To insert a drawing name in a column cell, double-click on the cell and type the name using
alphanumeric values: 0-9, a-z, underscore (_) and dash (-). By default, if you press the
Enter/Return key, the cursor will move on to the next cell. If you press the Esc key, it will quit the
typing mode and return to normal mode—see See "Typing Exposure" on page 121 to learn more
about the Typing mode.

Drawing Concept

When you add a drawing element to your scene, a folder is automatically added to the scene
directory. This folder is named the same as the drawing element. Its purpose is to store all the
drawings related to this drawing element. For example, when working with cut-out animation, a
character can have many hands available. All of these hand drawings will be contained in this folder
even if they are not exposed in the Timeline or Xsheet view. In other words, there is always a drawing
container associated with a drawing element (layer, column).

All the drawings that were scanned in or created directly in Harmony will be saved in this directory.
This means that when a value or drawing name is entered in the column, the Harmony will search the
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directory for the corresponding drawing to display. If it is unable to find it, a new drawing will be
created. The column cells are not storage places, but simply links to the corresponding directory. If
you remove a drawing from the column exposure, it will not be deleted; it is simply not displayed.
You can always access it again.

When you create a drawing cycle, all repeated drawings are linked to the same original files. So when
you modify, repaint or correct drawing 1, the entire cycle will be updated; every time drawing 1
appears, it is accessed from a single file.

Renaming a Drawing

When you want to rename a drawing, use the Rename Drawing command. Do not double-click on
the frame and write a new name, as this will create a new drawing and hide your actual drawing.
Note that your drawing will not be deleted; it is still contained inside the element folder. Simply re-
enter the name and it will reappear.

To learn how to rename a sequence of cells by prefix or by frame position, see See "Renaming a Drawing"
on page 142.
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Rough Animation

The first step to complete a traditional paperless animation is the rough construction, which is the
skeleton of your animation. You would usually start with the main action. For example, to animate a
walk cycle, you will start with the torso motion and the legs. Head, arms and clothes will be added
later during the secondary animation.

For a satisfactory animation, complete the main action before adding all the details. If you start
animating all the details right away, you will lose a lot of time if you have to make corrections. Your
animation will often look too rigid.

How to animate

1. Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X) to open the Preferences dialog box.

2. Select the Exposure Sheet tab.

3. Select theUse Current Frame as DrawingName option. When this preference is enabled,
drawings will be named like the frame they are created on (frame number).

4. In the Tools toolbar, select the Brush tool or press Alt + B.

5. In the Colour view, select a colour for the brush. It is a good idea to choose a light colour for your
rough animation. This will help you in the task that follows, the clean up process.

6. In the Timeline or Xsheet view, select the cell where the first drawing will appear.

7. In the Camera view, draw the first key drawing.
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8. With your first cell still selected, do one of the following to mark your drawing as a key drawing.
This will help you stay organized.

‣ In the Mark Drawing toolbar, click the Mark Selected Drawings as Key button.

‣ In the Xsheet view, select Drawings > Mark Drawing As > Key Drawing.

‣ In the Timeline view, select Drawings > Mark Drawing As > Key Drawing.

9. In the Tools toolbar, click the Onion Skin button. The Onion Skin feature displays your previous
and next drawings as visual references to help you draw your new pose.

10. In the Camera view, press either the Onion Skin Reduce One Drawing or Onion Skin Add One Next
Drawing to reduce or increase the number of previous and next visible drawings. The red icons

are for the previous drawings and the green icons are for the next drawings.

11. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.

12. In the Camera view, draw your second key drawing.
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13. In the Xsheet or Timeline view, identify the drawing as a key drawing.

14. In the Xsheet view, select a cell between the two key drawings.

15. From the Timeline View toolbar, click to create an empty drawing or press Alt + Shift + R.

‣ In the Xsheet view, right-click and select Drawings > Create Empty Drawing or press Alt +
Shift + R.

16. In the Camera view, draw your new pose.
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17. If necessary, in the Xsheet or Timeline view, identify the new drawing as a key, breakdown or in-
between drawing using the Mark Drawing toolbar.

18. In the Timeline or Xsheet view, select a new cell and repeat the previous steps for each new
drawing.

19. In the Timeline view, disable the layers you do not want to show during playback by disabling the
check box.

20. In the Playback toolbar, click the Loop button if you want the playback to loop.

21. In the Playback toolbar, click the Play button to start the animation.
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Secondary Animation

Once your rough animation is correct, you can start adding extra details, such as arms, clothes or hair.

You can add the extra details on the same layer with the same colour or you can also create a new
colour so that you can always see your original sketch.

If you want to keep your rough animation as it is to avoid any mistakes, you can add an extra drawing
element and use the Light Table feature to draw over the first drawing element. This technique can also be
used if you want to reuse your rough animation for other characters. For example, if you have a rough walk-
cycle, you can reuse it for another character and add its personal features in a new layer. This way, you only
need to animate the secondary animation instead of the whole body again.

How to create secondary animation on the same layer

1. In the Xsheet View, select the cell in which you want to add new details.

2. In the Colour view, create a new colour (give it the same name and add the prefix _2 or _sec, for
example) or select the same rough colour as before.

3. In the Drawing Tools toolbar, select your drawing tool.

4. In the Camera view, draw the secondary animation.
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5. Do one of the following:

‣ In the Xsheet View, select the next cell in which you want to draw.

‣ In the Camera or Xsheet view, press F and G to navigate between your drawings.

6. Do one of the following:

‣ In the top, Camera View menu, select View > Onion Skin > Show Onion Skin.

‣ In the Timeline view menu, selectOnion Skin > Show Onion Skin.

‣ Press Alt + O.

7. In the Camera view, draw the secondary animation.

8. Use the Flip and Easy Flipping toolbars to review your animation. You can also use the Playback
toolbar to play the animation in real time.

How to create your secondary animation on an extra layer

1. In the Xsheet view or Timeline view, add a new drawing element and name it properly.

2. In the Timeline or Xsheet view, select the rough layer's timing.

3. Copy the timing and in the top menu, select Edit > Paste Special or Ctrl + B (Windows/Linux) or ⌘
+ B (Mac OS X).

4. Choose Never create drawing files from the options to paste the timing but not the drawing files.
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5. Do one of the following:

‣ In the Xsheet view, click the Columns List Panel button to view and disable columns.

‣ In the Timeline view, on its left-hand side, disable the extra columns.

6. In the Xsheet View, select the cell where you want to add the new details.

7. In the Colour Palette, create a new colour (give it the same name and add the prefix _2 or _sec, for
example) or select the same rough colour as before.

8. In the Drawing Tools toolbar, select your drawing tool.

9. In the Camera view, draw the secondary animation.

10. Do one of the following:

‣ In the Xsheet View, select the next cell in which you want to draw.

‣ In the Camera or Xsheet view, press F and G to navigate between your drawings.

11. Do one of the following:

‣ In the top or Camera View menu, select View > Onion Skin > Show Onion Skin.

‣ In the Timeline view menu, selectOnion Skin > Show Onion Skin.

‣ Press Alt + O.

12. In the Camera view, draw the secondary animation.
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13. Use the Flip and Easy Flipping toolbars to review your animation.

You can also use the Playback toolbar to play the animation in real time.
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Bringing Your Animation on Model

If your primary and secondary animation were done as a rough drawing, it is now time to put your
drawing on model. This means that you have to review your animation and ensure that every single
detail is on model and there is no volume distortion. You can do this directly on the original sketch
layer or on a new layer.

If your primary and secondary animation was done quite on model, you can proceed directly to the
animation clean-up. If not, proceed the same way as you did for the secondary animation task to bring
your animation on model.
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Animation Clean-up

When your rough animation is ready, it is time to clean it up and ink it. The clean-up is also called
tracing. It consists of tracing solid and clean lines over the rough animation to get closed zones. This is
the final paperless animation step before the ink and paint step.

You will need to add a new drawing layer to create your cleaned up drawing. This is the equivalent of
adding a sheet of paper and tracing the rough using the animation disk.

Tracing in a New Layer

How to trace your animation in a new layer

1. In the Timeline View toolbar, click the Add Drawing Layer button.

2. In the Timeline view, click the Lock button of the layer containing your rough animation to avoid
selecting the layer in the Camera view.

3. In the Timeline or Xsheet view, in the new layer, select the cell corresponding to the first key
drawing of your rough animation.

4. In the Tools toolbar, select the drawing tool of your choice. The Pencil tool is recommended.

5. In the Colour view, select a colour for tracing your animation. A dark bold colour, such as black,
would ensure that it contrasts well with the light colour of your rough animation.

6. In the Camera view, start tracing the first key drawing.
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7. If you have some other layers in the way, you can disable them temporarily from the Timeline view
so that only the rough animation and clean-up layer are displayed in the Camera view.

8. In the Camera view, press either the Onion Skin Reduce One Drawing or Onion Skin Add One Next
Drawing to reduce or increase the number of previous and next visible drawings. The red icons

are for the previous drawings and the green icons are for the next drawings.

9. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.

10. In the Camera view, trace your next drawing.

11. Repeat the previous steps for each drawing.

This method allows you to keep the roughs and the cleans intact. You only need to disable the rough layer
to prevent it from appearing in the scene.
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Tracing Directly Over

Tracing or cleaning directly over means to clean your drawing in the same cell. This method avoids
adding too many layers to your scene or demanding too much power from a low performance
graphics card when using the light table or onion skinning. However, the rough animation has to be
removed.

This technique is the equivalent of sketching on paper with a blue animator pencil and then inking
directly onto it in black. Harmony allows you to select all the zones using a certain colour from your
palette. Then you can trace over your sketch with a different colour. Once you are done, you can select
all the zones painted with the sketch colour and delete them, keeping only the clean drawing.

How to trace directly over your rough animation

1. In the Timeline or Xsheet View, select the first rough drawing to clean.

2. Do one of the following:

‣ In the Colour view, if you have already made a palette for this character, select its outline
colour.

‣ Create a new colour in your palette and select it. It is recommended to name it Clean or
Trace.

3. Select a drawing tool.

4. In the Camera View, trace over your rough model.
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5. Do one of the following:

‣ In the Camera view menu, select View > Onion Skin > Show Onion Skin.

‣ In the Timeline view menu, selectOnion Skin > Show Onion Skin.

‣ Press Alt + O.

6. In the Camera view, press either the Onion Skin Reduce One Drawing or Onion Skin Add One Next
Drawing to reduce or increase the number of previous and next visible drawings. The red icons

are for the previous drawings and the green icons are for the next drawings.

7. Do one of the following:

‣ In the Xsheet View, select the next cell in which you want to draw.

‣ In the Camera or Xsheet view, press F and G to navigate between your drawings.

8. In the Camera view, trace your next drawing.

9. Repeat steps 6 and 7 for each drawing.

10. Use the Flip and Easy Flipping toolbars to review your animation. You can also use the Playback
toolbar to play the animation in real time.

11. Once the drawings are completed, select the rough colour from the Colour view.

12. Do one of the following:

‣ In the Camera View menu, select Edit > Select Strokes With Current Colour.
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‣ Press Ctrl + Shift + A (Windows/Linux) or ⌘ + Shift + A (Mac OS X).

13. In the Camera View, Press Delete to delete the selected zone.

14. Repeat steps 10 to 13 for each drawing.

431



Toon Boom Harmony 11.1 Sketch Module Network User Guide

432



Toon Boom Harmony 11.1 Sketch Module Network User Guide

Tools
To understand paperless animation, you must first discover the tools available. There are, of course,
drawing tools, but also practical features such as setting a drawing as a key, breakdown or in-
between.

When you create hand-drawn animation digitally, there are certain tools you require in order to work
efficiently, as you would with an animation table, paper and pencils.

The onion skin and light table are used to preview previous and next drawings, cells, elements and
frames. When designing or animating, it is very useful to see your previous drawings. Just as if you
were building a cut-out puppet, you want to view other drawing elements to know where to draw the
new element.

Onion Skin

The Onion Skin tool lets you preview the previous and next drawings. By default, the previous
drawings appear in a shade of red and the next drawings are displayed with a shade of green. You
can change these colours in the Preferences dialog box. 

In the Drawing view, onion skinned drawings are based on the actual number of drawings before and
after the current drawing. In the Camera view, onion skinned drawings can be based on actual
drawings or the drawings in the frames before and after the current drawing.

How to enable onion skinning

1. Do one of the following:

‣ From the top menu, select View > Onion Skin > Show Onion Skin.

‣ In the Timeline view, click the Onion Skin button on a layer. When enabled, the icon
turns red .
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‣ In the Tools toolbar, click the Onion Skin button.

‣ Press Alt + O.

How to onion skin by drawing in the Camera view

1. Do one of the following:

‣ From the top menu, select View > Onion Skin > Onion Skinning by Drawing.

‣ In the Camera view menu, select View > Onion Skin > Onion Skinning by Drawing.

‣ In the Timeline view menu, selectOnion Skin > Onion Skinning by Drawing.

2. Click an icon, menu operation or keyboard shortcut to edit the display.

View > Onion Skin
Menu Command

Tools toolbar
icon

Keyboard Shortcut

No Previous Drawing ~

Previous Drawing !

Previous Two Draw-
ings

@

Previous Three Draw-
ings

#

No Next Drawing Ctrl + ` (Windows/Linux) or ⌘ + ` (Mac OS X)

Next Drawing Ctrl + 1 (Windows/Linux) or ⌘ + 1 (Mac OS X)

Next Two Drawings Ctrl + 2 (Windows/Linux) or ⌘ + 2 (Mac OS X)

Next Three Drawings Ctrl + 3 (Windows/Linux) or ⌘ + 3 (Mac OS X)

3. In the Camera view, the previous and next drawings appear with the current one.
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Onion skinning by frame in the Camera view

1. If they are not visible, display the blue onion skin markers in the Timeline view by doing one of the
following:

‣ From the top menu, deselect View > Onion Skin > Onion Skinning by Drawing.

‣ In the Camera view menu, deselect View > Onion Skin > Onion Skinning by Drawing.

‣ In the Timeline view menu, deselectOnion Skin > Onion Skinning by Drawing.

2. In the Timeline view, drag the blue onion skin markers to select the number of previous and next
drawings to display.

3. In the Camera view, the previous and next drawings appear with the current one.

Using the top light to modify onion skin settings

1. In the Camera or Drawing View toolbar, click the Top Light button.

The Top Light dialog box opens.

2. Adjust theOnion Skin Opacity slider to modify the opacity value of the onion skin display.

3. Click OK.
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Using the Light Table

The light table is used to preview the previous and subsequent active layers in washed-out colours. It
is useful for seeing the other layers when designing, animating or cleaning up your animation.

In the Camera view, when the light table is activated, all layers but the currently selected one are
shown washed-out. The display returns to the normal mode when the Select tool or a scene setup
tool is selected.

Only the currently selected drawing is displayed by default in the Drawing view. When enabling the
light table, the other layers appear as a washed-out display and are used as a reference. You can not
select or manipulate them.

How to enable the light table

1. Do one of the following:

‣ In the top menu, select View > Light Table.

‣ In the bottom Camera View toolbar, click the Light Table button.

‣ Press Shift + L.

2. The drawings for the other layers are displayed as washed-out colours in the Camera view.
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3. In the Timeline view, you can deselect the layers you want to hide from the light table.

Using the top light to modify light table settings

1. In the Camera View toolbar, click the Top Light button.

The Top Light dialog box opens.

2. Adjust the Light Table Opacity slider to modify the opacity value of the light table display.

3. Adjust the Light Table Wash slider to modify the washed-out value of the light table display.

4. Use the Bitmap BackgroundWash to modify the washed-out value of bitmap images in the
scene.

5. Click OK.

Using the Rotary Table

Use the rotary table (animation disk) to rotate your Camera view while you draw for increased
flexibility. The rotary tables in each view are independent; if you switch to the Camera view, you can
use the rotary table in that view and rotate it to a different angle without affecting the settings in the
other view.
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How to use the rotary table

1. Do one of the following:

‣ In the Camera view, press Ctrl + Alt (Windows/Linux) or ⌘ + Alt (Mac OS X)

‣ In the Tools toolbar, click the Rotate View button.

The rotary table appears.

2. Rotate the view to the desired angle.

3. Release the keyboard shortcut or switch to a new drawing tool.

4. Press Shift + X to reset the rotation.

Drawing Identification

The Drawing Identification tool can help you stay well organized and save time when identifying key,
breakdown or in-between drawings in the Xsheet and Timeline view.

With this tool, you the animator can retain some habits from traditional paper animation, but feel
just as comfortable animating in a paperless environment.

When working with several animators, directors, or even other studios, the necessity for retakes will
often arise. You can also mark your new drawings as either Retake Key, Retake Breakdown, or
Retake In-betweens.
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If your production requires that you mark your drawing with a custom marker, you also have the
option to create your own.

Key Drawing

A key drawing is a visually significant pose in a movement, often an extreme position. For example,
if a character that is sitting down falls on his back, the key poses would be the character sitting and
the character on his back. Of course, it may vary from one animation to another.

Breakdown Drawing

A breakdown drawing is a pose somewhere between two key poses that better shows the
movement. Most animation moves are arcs, such as an arm waving, somebody bending, or a leg
walking. All of these movements are rotations. The breakdown pose is used to describe this curve
better.

The breakdown drawing is then used to indicate secondary poses, also called the follow-through.
These actions can be a big stomach jiggle as somebody jumps, a cloak floating behind somebody
that is running, or arms moving after the main body action. These moves will generally have a
different timing than the primary action. They will mainly start later and finish later. So, the
breakdown drawings are used to complete the key drawings.

Note that a breakdown drawing is not always placed exactly in the middle of two keys. It will often
be closer to one or the other depending on the timing and the action. Also, you can have more
than one breakdown pose between two keys.
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In-between Drawing

In-between drawings can be considered the filling drawings. Once the timing is established by the
key and breakdown poses, the in-between drawings will be added to complete the animation and
make it more fluid.

In-betweens do not necessarily need to be placed exactly in the middle of two other poses. They
can be placed closer to one or the other to create ease in or ease out of the movement.
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How to display the Mark Drawing toolbar

1. In the top menu, selectWindows > Toolbars > Mark Drawing.

The Mark Drawing Toolbar appears.

How to mark a drawing as a key, breakdown or in-between

1. In the Xsheet view or Timeline view, select the cell that you want to mark.

2. Do one of the following:

‣ In the Mark Drawing toolbar, select an icon.

‣ In the Xsheet or Timeline view menu, select a command inDrawing > Mark Drawing.

‣ Right-click the selection and select Drawings > Exposure > Mark Drawing.

Mark Drawing Commands Mark Drawing toolbar icon
Colour of marker in
Timeline

Key Drawing Red (default)

Breakdown Drawing Blue (default)

In-between Drawing Not applicable

Retake Key Green

Retake BD Yellow

Retake IB Purple
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If you mark an in-between drawing, there is no icon displayed in the cell since it is used to remove
a key or breakdown marker.

You can change the colour of the key and breakdown markers in the Timeline view.
Refer to the Preferences Guide to learn how to customize timeline markers.

You can create your own custom shortcuts for the Drawing Identification options. Refer to the
Preferences Guide to learn how to customize keyboard shortcuts.

Custom Marks in the Xsheet View

Make custom marks for the Xsheet by creating your own icons, then cutting, pasting and changing
a bit of code. Not only is it possible to have your custom mark appear in the Xsheet and Mark
Drawing toolbar, but also in the Onion Skin and Flip toolbars.
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How to create your custom markers

1. With a bitmap editing software, create the following icons in PNG format:

‣ Mark Drawing Toolbar icon (24 x 24 pixel)

‣ Onion Skin Toolbar icon (24 x 24 pixel)

‣ Flip Toolbar icon (24 x 24 pixel)

‣ Xsheet Column icon (16 x 16 pixel)

2. Close Harmony.

3. Once your icons are ready, go to the Toon Boom Harmonyresources/drawingTypes.d
directory:

• Network

‣ Mac OS X: /Users/*username*/Library/Preferences/Toon Boom
Animation/Toon Boom Harmony/full-1100-pref/drawingTypes.d

‣ Linux:~/Toon Boom Animation/Toon Boom Harmony/full-1000-
pref/drawingTypes.d

‣ Windows: C:/Users/*username*/AppData/Roaming/Toon Boom
Animation/Toon Boom Harmony/full-1100-pref/drawingTypes.d

4. Paste your icons in the resources/drawingTypes.ddirectory.

5. In that same directory, open the drawingTypes.xml file in a text editor.

6. For each custom icon you want to create, add the following line. Ensure it is placed before the
closing </DrawingTypes> tag.
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‣ <DrawingType text="NewButtonName" pixmapFile="XsheetIcon.png"
commandIcon="MarkDrawingIcon.png" flipIcon="FlipIcon.png"
onionIcon="OnionIcon.png" />

7. In that line, replace the following information with your new icon information:

‣ NewButtonName: Write the name of your new marker. This name will appear in the
button tooltip.

‣ XsheetIcon.png: Write the name of the icon that you created to appear in the Xsheet
column. Include the file extension.

‣ MarkDrawingIcon.png: Write the name of the icon that you created to appear in the
Mark Drawing toolbar. Include the file extension.

‣ FlipIcon.png: Write the name of the icon that you created to appear in the Flip toolbar.
Include the file extension.

‣ OnionIcon.png: Write the name of the icon that you created to appear in the Onion Skin
toolbar. Include the file extension.

8. Save the file and close it.

9. Start Harmony.

Note that no marker will appear in the Xsheet view for an in-between drawing. The in-between drawing
is a regular drawing. The option is mainly used to remove a key or breakdown identification marker from
a drawing.

Create Empty Drawing

The Create Empty Drawing command automatically creates a drawing in the selected cell, replacing
any drawing that may already be exposed in that cell and the following ones until it meets another
drawing or a blank cell.

How to create an empty drawing

1. In the Timeline or Xsheet view, select the cell in which you want to create an empty drawing.

2. Do one of the following:

‣ In the Xsheet view menu, select Drawings > Create Empty Drawing.

‣ In the Xsheet View toolbar, click the Create Empty Drawing button.

‣ Press Alt + Shift + R.

The new drawing is created in the Xsheet and Timeline views.

444



Toon Boom Harmony 11.1 Sketch Module Network User Guide

Reposition All Drawings

The Reposition All Drawings option is used to reposition, scale, rotate or skew all drawing
strokes on every drawing included in a layer.

How to reposition all drawings

1. From the Tools toolbar, select the Reposition All Drawings tool. This also automatically
selects every stroke in your drawing in the Camera view.

2. Do any of the following:

‣ To reposition, click and drag your selection to a new area.
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‣ To rotate, rotate the selection box handle.

‣ To scale, pull or push on the top, side, bottom or corner control points. Hold down Shift
to maintain the selection’s ratio.

‣ To skew, drag the sides or top and bottom segments, between the control points.
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3. When you release your cursor, every drawing in the drawing layer you repositioned, scaled,
rotated or skewed will follow the same transformation.

Tips and Tricks

Here are some tips and tricks that you can use to feel more comfortable while drawing:

Texture Pen and Transparent Pen

Use the texture pen or a transparent colour for a paper sketch effect.

Pen Tablet

Use a pen tablet to draw with a pen instead of the mouse. This allows for increased dexterity and
speed, and accounts for pressure sensitivity.
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Field Chart

Toon Boom Harmony also has a field chart included in its Camera view. It is a useful tool to set the
height of characters and props.
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Advanced Tools

Harmony has many useful features such as the Flipping toolbar, enhanced onion skin, extra drawing
layers, and automated matte generation.

This section is divided as follows:

• Flipping and Easy Flipping Toolbars on page 427

• Onion Skin Toolbar on page 429

• Drawing Identification on page 430

• Art Layers on page 434

• Previewing Drawings on page 439
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Flipping and Easy Flipping Toolbars

Toon Boom Harmony allows you to rapidly flip through drawings in the Drawing view just as you do
with paper drawings. You can flip through the key, breakdown or in-between drawings individually, or
view a combination.

How to flip through drawings

1. Do one of the following:

‣ In the top menu, selectWindows > Toolbars > Easy Flipping.

‣ SelectWindows > Toolbars > Flip.

2. In the Easy Flipping toolbar, click the Previous or Next button to see the previous or next
drawing of your animation.

3. To display drawings in the first frame after you reach the last frame of your animation, select the
Loop option.

4. Move the slider to the right to flip forward and to the left to flip backward through your drawings.

‣ The further you move the slider to the left or right, the faster the drawings will flip.

5. If you marked some of your drawings, you can flip through the markers and avoid seeing all the in-
betweens. Enable the Flip Key, Breakdown or In-between buttons in the Flip toolbar to see only
one type or a combination—see See "Drawing Identification" on page 414
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Onion Skin Toolbar

How to display marked drawings in the onion skin

1. From the top menu, selectWindows > Toolbars > Onion Skin.

2. In the Tools toolbar, click the Show Onion Skin button.

3. In the Camera view, press either the Onion Skin Reduce One Drawing or Onion Skin Add One Next
Drawing to reduce or increase the number of previous and next visible drawings. The red icons

are for the previous drawings and the green icons are for the next drawings.

4. In the Onion Skin toolbar, enable the markers you want to see in your Onion Skin preview.

How to enable the onion skin in other layers

You might need to refer to previous and next drawings in other layers than the current one.

1. In the top menu, selectWindows > Toolbars > Onion Skin.
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2. In the Tools toolbar, click the Onion Skin button.

3. In the Camera view, press either the Onion Skin Reduce One Drawing or Onion Skin Add One Next
Drawing to reduce or increase the number of previous and next visible drawings. The red icons

are for the previous drawings and the green icons are for the next drawings.

4. In the Onion Skin toolbar, enable the Enable Onion Skin in Other Elements option.

‣ The current layer is displayed by default in shades of green and red.

‣ Drawings in timeline layers above the current layer are displayed by default in shades of
blue.

‣ Drawings in timeline layers below the current layer are displayed by default in shades of
yellow.

You can change default onion skin display colours in the Preferences dialog box.

Drawing Identification
In the Xsheet view, you can identify drawings as Key, Breakdown or In-between. This helps to keep the
Xsheet well organized while animating.

When working with several animators, directors, or even other studios, the necessity for retakes will
often arise. Harmony also gives you the possibility to mark new drawings as either Retake Key, Retake
Breakdown, or Retake Inbetweens.

If your production requires you to mark drawings with a custom marker, you also have the option to
create your own.

454



Toon Boom Harmony 11.1 Sketch Module Network User Guide

Make custom marks for the Xsheet by creating your own icons, then cutting, pasting and changing a
bit of code. Not only is it possible to have your custom mark appear in the Xsheet and Mark Drawing
toolbars, but also in the Onion Skin and Flip toolbars.

You can create custom shortcuts for the Drawing Identification options in the Preferences dialog box.

How to mark a drawing as Key, Breakdown or In-between

1. From the top menu, selectWindows > Toolbars > Mark Drawing.

The Mark Drawing toolbar displays.

2. In the Xsheet view, select the cell you want to identify. This option is not available in the Timeline
view.

3. In the Mark Drawing toolbar, click one of these buttons: Mark as Key Drawing , Mark as
Breakdown Drawing  or Mark as In-between Drawing . In the Xsheet View menu, you can
also select Drawing > Mark Drawing As > Key Drawing, Breakdown Drawing, In-between
Drawing, Retake Key, Retake BD and Retake IB.

‣ If you selected Mark as Key Drawing, a icon appears in the cell.

‣ If you selected Mark as Breakdown Drawing, a icon appears in the cell.

‣ If you selected Mark as In-Between Drawing, there is no icon displayed in the cell since it is
used to remove a Key or Breakdown marker.
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How to create custom markers

1. With a bitmap editing software, create the following icons in PNG format:

‣ Mark Drawing Toolbar icon (24 x 24 pixel)

‣ Onion Skin Toolbar icon (24 x 24 pixel)

‣ Flip Toolbar icon (24 x 24 pixel)

‣ Xsheet Column icon (16 x 16 pixel)

2. Close Harmony.

3. When your icons are ready, open the Toon Boom Harmony drawingTypes.d folder.

If the drawingTypes.d folder does not exist, you must create it. To do so, copy the
resources folder from the following location.

• Windows: C:/Program Files (x86)/Toon Boom Animation/Harmony
11.1/resources/drawingTypes.d

• Mac OS X: /Applications/Harmony 11.1/resources/drawingTypes.d

• Linux:
/usr/local/ToonBoomAnimation/ProductNameVersion/resources/drawingTypes.d

Stand-alone

‣ Windows: C:\Users\USERNAME\AppData\Roaming\Toon Boom Animation\Toon
Boom Harmony\full-1100-pref\drawingTypes.d

‣ Mac OS X: /Users/USERNAME/Library/Preferences/Toon Boom
Animation/Toon Boom Harmony/full-1100-pref/drawingTypes.d
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The Library folder is usually hidden in the Finder. To see all the hidden folders and files,
type the following in a terminal window:

defaults write com.apple.Finder AppleShowAllFiles YES

‣ Linux: /home/USERNAME/Toon Boom Animation/Toon Boom Harmony/full-
1100-pref/drawingTypes.d/

Network

In Harmony Network, the path is global for all users so you must create the folder and place in
/USA_DB.

‣ /USA_DB/drawingTypes.d

4. Paste your icons in the drawingTypes.d directory.

5. In the same directory, open the drawingTypes.xml file in a text editor.

6. For each custom icon you want to create, add the following line. Make sure to place it before this
closing tag: </DrawingTypes>.

‣ <DrawingType text="NewButtonName" pixmapFile="XsheetIcon.png"
commandIcon="MarkDrawingIcon.png" flipIcon="FlipIcon.png"
onionIcon="OnionIcon.png" />

7. In that line, replace the following information with your new icon information:

‣ NewButtonName: Write the name of your new marker. This name will appear in the button
tooltip.

‣ XsheetIcon.png: Write the name of the icon that you created to appear in the Xsheet
column. Include the file extension.

‣ MarkDrawingIcon.png: Write the name of the icon that you created to appear in the Mark
Drawing toolbar. Include the file extension.

‣ FlipIcon.png: Write the name of the icon that you created to appear in the Flip toolbar.
Include the file extension.

‣ OnionIcon.png: Write the name of the icon that you created to appear in the Onion Skin
toolbar. Include the file extension.

8. Save the file and close it.

9. Start Harmony.
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Art Layers

Art layers give you the possibility to divide the artwork in your drawing on different layers. For
example, you can separate the outline and colour fill on two art layers, similar to 1950s traditional cell
animation. These art layers are contained within a single drawing as opposed to the timeline layers or
Xsheet columns where individual drawings with individual timing are stacked one on top of the other—
see Creating Strokes on page 351.

Toon Boom Harmony drawings include two layers in Advanced Art mode.

• Line Art below

• Colour Art on the facing page

You can access the Art layers through the Camera and Drawing views bottom toolbar. By default, the
art layers are hidden. Everything is drawn on the Line Art layer. You need to enable the Use Advanced
Art Mode option.

Each layer can be used for separate hand-drawn animation tasks, letting you organize your work and
facilitate creation and revision.

Line Art
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In hand-drawn animation, the Line Art layer is mainly used to trace and clean up animation. The
outline is drawn in the Line Art layer and colour is painted in the Colour Art layer.

Colour Art

In hand-drawn animation, you use the Colour Art layer to paint your animation. The outline is drawn
in the Line Art layer and colour is painted in the Colour Art layer. Strokes (invisible lines) are
generated from Line Art to contain the painted area.

When you are doing rough animation, you may want to send a clip to somebody for feedback or
approval before carrying on with your work. If you have several characters in your project that are
overlapping, it may be difficult to understand what is going on as you can see through the
characters. Toon Boom Harmony can generate a matte automatically in the Underlay, or even in the
Colour Art layer, and fill all the zones inside your characters making them opaque. This process is
fast and easy and allows you to send easy-to-understand movies.

How to enable the Use Advanced Art Mode preference

1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( Mac
OS X ).

2. In the Preferences dialog box, select theGeneral tab.

3. In the Advanced section, select theUse AdvancedArt Mode option.

4. Click OK.

How to switch between drawing layers

1. In the Art Layer toolbar, click the Line Art or Colour Art buttons. When switching art layer,
it will allow you to edit the select layer without affecting the other one.
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Art Layers

2. Click the Preview All Enabled Art Layers button to display both layers together. Even when the
Preview mode is enabled, you will only be able to edit the select art layer. The other ones are only
displayed as a reference. By default, the Preview mode is always enabled in the Camera view. You
will only be able to see the select art layer by itself if you enable the Current Drawing on Top
option located in the Camera bottom toolbar.

To edit both Line Art and Colour Art at the same time, you must enable the Apply to
Line Art and Colour Art button in the Tool Properties of the tools supporting the
operation.

How to generate a matte

1. Do one of the following:

‣ In the Tools toolbar, select the Select tool.

‣ Press Alt + S.

2. In the Camera view, select the drawing you want to create a matte for.

You can also apply the operation to all the drawings in the layer at the same time.

3. Do one of the following:

‣ In the Camera view menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

4. If you want to create a matte for all the drawings included in your layer, select theApply to
Multiple Drawings option.

5. Depending on how precise or rough your line is, increase or decrease the radius value. The lower
the value is, the closer to your lines’ contours the matte will be shaped. The higher the value is, the
looser the matte will be shaped.
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6. In the Source Art menu, select the layer from which you want the matte created: Line Art or Colour
Art.

7. In the Destination Art menu, select the layer you want the matte to be created on: Line Art or
Colour Art.

8. If you already have artwork on the destination layer and you want the content to be deleted before
the matte is added into it, select theClear Destination Art First option.

9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case
you ever need to keep them for later), select theCopy Stroke in Destination option.

10. Click OK.
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Previewing Drawings

It is a good idea to preview your drawings to check your animation ink and paint, verify that there are
no colour mistakes, or to play your animation in real time. You can do this by scrolling through your
drawings or pressing F and G. You can also use the Preview option in the Xsheet view.

How to preview drawings from the Xsheet view

1. Save your scene.

2. Do one of the following:

‣ From the top menu, select File > Save.

‣ Click the Save button.

‣ Press Ctrl + S (Windows/Linux) or ⌘ + S (Mac OS X).

3. In the Xsheet view, select the range of drawings or the whole column to preview.

4. In the Xsheet view menu, select View > Preview SelectedDrawings.

Toon Boom Play opens.

5. In the Play window, press the Play button to play back your drawings.

6. Select the Preroll option to see blank frames at the beginning and end of the animation sequence
while looping the playback.
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Paperless Animation Preferences

When working in paperless animation, there are some preferences you can set in the Preferences
dialog box to make your work easier and faster.

How to open the Preferences dialog box

‣ Windows/Linux: Select Edit > Preferences.

‣ Mac OS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

Task Tab Section
Option, button or
parameter

You can change the colours for
the onion skin and other
elements. You can also change
the colour of the key and
breakdown markers displayed
in the Timeline view.

General Colours Edit Colours

Drawing Colours Edit Colours

When naming your drawings in
the Xsheet or Timeline view,
you can set a preference to
name your drawings based on
their frame positions, which
facilitates the creation of key
poses (for example, a drawing
created on frame 1 is named
"1", a drawing created on
frame 5 is named "5").

Exposure Sheet Drawing Creation
Use Current
Frame as Drawing
Name

In the Camera view, you can
work in Line Art and Colour Art
once you enable the Advanced
Art mode.

Advanced Advanced Options

Support
Line
and
Colour
Arts

Refer to the Preferences Guide for complete descriptions of each option, button and parameter.
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Chapter 1: Import

Toon Boom Harmony allows you to import external content as well as being able to draw directly in
the software. This means that characters, backgrounds and videos created in other drawing, painting
and multimedia programs can be brought in and animated. You can import QuickTime videos,
pictures, multilayered PSD files, as well as AI, SWF and PDF files. You can also scan your images and
import them as bitmap or vectorize them.

This chapter contains the following topics:

• Importing Bitmap Images on the next page

• Importing PSD Files as Separate Layers on page 455

• Importing QuickTime Movies on page 470

• Custom Vectorization Parameters on page 472

For sound import, refer to Importing a Sound File on page 488.
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Importing Bitmap Images

Images can come in many different file formats and are usually saved in a format that retains the
original specifications set by the image creator. Some formats can preserve the transparency or
transparent layers, while others are not resolution dependent due to their vector nature. Toon Boom
Harmony supports the following formats: JPEG, BMP, PNG, TGA, PSD, TIFF, SGI, TVG, OMF, PAL,
SCAN.

When importing images and 3D models and linking images, your settings are saved in your user
settings.

In this section, you will cover the following topics:

• Importing a Bitmap Image Without Vectorization below

• Importing and Vectorizing Bitmap Images on page 452

Importing a Bitmap Image Without Vectorization

How to open the Import Images dialog box

1. Do one of the following:

‣ From the top menu, select File > Import > Images.

‣ In the File toolbar, click the Import Images button.

‣ In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

The Import Images dialog box opens.
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How to import a bitmap image in its original format

1. In the Files section of the Import Images dialog box, click Browse to find and select one or more
images on your computer.

2. Decide if the bitmap image will go on a new layer or an existing layer. To add the bitmap image to
a new layer, go to step 4. To add the bitmap image to an existing layer, go to step 5.

3. Add the bitmap image to a new layer by selecting theCreate Layer(s) option and one of the
following options:

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix.
For example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b",
where "a" has two drawings and "b" has one. When creating a single layer from these three
filenames, all three drawings will be inserted in the new layers.

4. Select theAdd to Existing Layer option if you want to place the bitmap image on a layer you select
from the list. If only vector layers are available in your scene, they will not be displayed in the
list. You can choose to encapsulate the bitmap in a symbol by selecting theCreate Symbols for
Imported Items option.

5. In the Import Options section, select theKeepAs Original Bitmap option. In the Alignment
section, decide on the size and placement of your image within the camera frame. Depending on
the Scene Settings (the height and width in pixels that you chose for your project), an image that
you import may be scaled to the point where all its individual pixels become visible. There are three
options available in the Alignment section:

Parameter Description

Fit
Enlarges or shrinks (but not distorts) the image height to
match the full height of the scene grid.
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If the image orientation is landscape, this will enlarge or
shrink (but not distort) your image width to match that of
the scene grid.

Note that the Fit alignment rule equals the Center Fit rule in
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image
orientation is portrait, its width will be made to match the
width of the scene grid. As a result, part of the image’s
height will extend beyond the height of the frame. This can
be useful if you want to make your background move up and
down, or from left to right to make it appear as if the
camera is panning, or to actually perform a camera pan.
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The opposite will apply to a landscape image. Its height will
be fit to the scene grid, therefore it is possible that the
image will extend beyond the scene grid's boundaries.

Note that the Pan alignment rule equals the Center First
Page rule in the layer properties.

Project Res-
olution

Scales the image in proportion to the scene's resolution.
The system looks at the resolution of the bitmap image, for
example 4000 x 2000, then compares it to the scene's
resolution, for example 1920 x 1080, and adjusts the scale
factor in proportion. So, in this example, the bitmap would
appear at 208% (4000/1920). If you import a bitmap that is
960 x 540, it will be displayed at 50% (960/1920) of the size
of the project resolution.
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Note that the Project Resolution alignment rule is equal to
the As Is rule in the layer properties.

6. In the Transparency section, select one of the following from the Alpha menu:

Parameter Description

Premultiplied with
White

Individual pixels at the edge of an image are
blended with white.

Premultiplied with
Black

Semi-transparent pixels in the original image
are blended with black.

Straight
Pixels at the edge of an image are blended with
black, white and greys.

Clamp Colour to
Alpha

Premultiplies the colour value with the alpha
value. When the colour is clamped to the alpha,
the colour value cannot be higher than the alpha
value. It calculates the real colour value faster.
When the RGB values are multiplied with the
alpha value, that is, if you have a pixel of value
R=247, G=188, B=29 and the alpha is 50% or
the image has a 50% transparency, then the
actual RGB values that are output would be half
of the amounts listed above.

7. Click OK.

Adding Images to a Bitmap Layer

How to add more bitmap images to an existing bitmap layer

1. In the Timeline view, if the bitmap image is contained in a symbol, double-click on the bitmap
symbol cell to edit the symbol. Otherwise, if the bitmap image is on a bitmap layer, leave it as is.

2. If necessary, in the Timeline view, pull on the red bracket to extend the exposure.

3. From the top menu, select File > Import > Images or click the Import Image button.

The Import Images dialog box opens.
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4. Click Browse to find and select one or several images on your computer.

5. In the Layer section, select theAdd to Existing Layer option and select an existing bitmap layer
from the menu.

6. Deselect theCreate Symbol for Imported Items option.

7. In the Import Options section, select theKeepAs Original Bitmap option. In the Alignment
section, decide on the size and placement of your image within the camera frame. Depending on
the Scene Settings (the height and width in pixels that you chose for your project), an image that
you import may get scaled to the point where all its individual pixels become visible. There are
three options available in the Alignment section:

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to
match the full height of the scene grid.

If the image orientation is landscape, this will enlarge or
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shrink (but not distort) your image width to match that of the
scene grid.

Note that the Fit alignment rule equals the Center Fit rule in
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image
orientation is portrait, its width will be made to match the
width of the scene grid. As a result, part of the image’s height
will extend beyond the height of the frame. This can be useful
if you want to make your background move up and down, or
from left to right to make it appear as if the camera is
panning, or to actually perform a camera pan.

The opposite will apply to a landscape image. Its height will
be fit to the scene grid, therefore it is possible that the image
will extend beyond the scene grid's boundaries.
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Note that the Pan alignment rule equals the Center First Page
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The
system looks at the resolution of the bitmap image, for
example 4000 x 2000, then compares it to the scene's
resolution, for example 1920 x 1080, and adjusts the scale
factor in proportion. So, in this example, the bitmap would
appear at 208% (4000/1920). If you import a bitmap that is
960 x 540, it will be displayed at 50% (960/1920) of the size of
the project resolution.

Note that the Project Resolution alignment rule is equal to
the As Is rule in the layer properties.

8. In the Transparency section, select one of the following from the Alpha menu:

Parameter Description

Premultiplied with
White

Individual pixels at the edge of an image are blended with
white.

Premultiplied with
Black

Pixels at the edge of an image are blended with black.

Straight
Pixels at the edge of an image are blended with black, white
and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the colour is
clamped to the alpha, the colour value cannot be higher than the alpha
value. It calculates the real colour value faster. When the RGB values are
multiplied with the alpha value, that is to say, if you have a pixel of value
R=247, G=188, B=29 and the alpha is 50% or the image has a 50% trans-
parency, then the actual RGB values that are output would be half of the
amounts listed above.
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9. Click OK.

Bitmap Image Quality
If the bitmap images that you imported look blurry or slightly pixelated, you can clean up the image.
You can change the quality of the preview in the Camera view and it will not affect the final render.

How to change the bitmap image quality

1. In the Camera view, double-click on the bitmap image to enter its symbol if the image is
encapsulatesd or simply select the bitmap image layer in the Timeline view if it is not.

2. From the Camera menu, select View > Bitmap File Quality or press Ctrl + Q (Windows/Linux) or ^
+ Q (Mac OS X).

The Bitmap Image Quality dialog box opens.

3. Drag the slider to the right to improve the quality.

4. Click OK.

5. If you are inside a symbol, go to the top of the Camera view and click Top to exit the symbol and
return to your scene.

Importing and Vectorizing Bitmap Images

You can turn bitmap images into vector drawings, while maintaining the sketchiness of a pencil line or
into vector images with a bitmap fill. Both options can add life to an animation, which straight
vectorization with smoothing does not usually afford.

How to import and vectorize a bitmap image

1. From the top menu, select File > Import > Images or click the Import Image button in the File
toolbar.

The Import Images dialog box opens.
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2. Click Browse to locate images.

3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or
existing layer.

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following
options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For
example, the filenames a-1.tga, a-2.tga and b-1.tga will create
layers named "a" and "b", where "a" has two drawings and
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix
bitmap images with vector drawings on the same layer, the bitmap image must be
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the
Symbol folder in the Library view.

4. In the Import Options section, select theConvert to Toon Boom Vector Drawing option.

5. In the Vectorization section, decide whether you want to import your image in colour, black and
white, or grey.In the Vectorization section, decide whether you want to import your image in colour,
black and white, grey, or if you want to add a new preset.
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‣ Black andWhite: Vectorizes drawings as a solid black line; creates a 100% vector-based
drawing.

‣ Grey: Vectorizes your image as a mix of vector contour and greyscale bitmap filling. Lines
keep the texture from the scan, and the white of the paper becomes transparent.

‣ New Preset: The New Preset button lets you create custom vectorization parameters via
the Vectorization Parameters interface.

The vectorized images are painted with the Vectorize Line colour swatch from the colour palette.

6. Click OK.

A symbol or new layer contains the vector drawing. For images contained in a symbol, double-click
on the image’s first cell in the Timeline view to enter the symbol so you can edit the image.
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Importing PSD Files as Separate Layers

PSD files (a format exportable exclusively from Adobe Photoshop) are unique in that they are able to
retain multiple layers. This is advantageous as the image remains fully editable in terms of any colour
correction, effects, masking, transparency, or compositing that were made to the PSD file in Adobe
Photoshop.

Note that your PSD image file must be set to RGB mode within Adobe Photoshop prior to being imported
into Harmony.

How to import the separated layers of a PSD file

1. Organize your Adobe Photoshop file so that all your layers are “grouped” into individual folders,
or that all the elements you want to import as a single layer in Harmony are grouped together in
their own folder. Any layer that is not in a folder group, by itself or otherwise, will not be imported.

2. In Harmony, go to the top menu and select File > Import > Images or click the Import Image
button.

The Import Drawings dialog box opens.
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3. In the Files section, click Browse to find and select the PSD image on your computer.

4. In the Layer section, select theCreate Layer(s) option, then select one of the following options:

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix.
For example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b",
where "a" has two drawings and "b" has one. When creating a single layer from these three
filenames, all three drawings will be inserted in the new layers.

5. In the Import Options section, select one of the following:

‣ KeepAs Original Bitmap: Retains an imported image as a bitmap. In the Alignment
section, decide on the size and placement of your image within the camera frame.
Depending on the Scene Settings (the height and width in pixels that you chose for your
project), an image that you import may get scaled to the point where all its individual pixels
become visible. There are three options available in the Alignment section:

Parameter Description

Fit
Enlarges or shrinks (but not distorts) the image height to
match the full height of the scene grid.
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If the image orientation is landscape, this will enlarge or
shrink (but not distort) your image width to match that of the
scene grid.

Note that the Fit alignment rule equals the Center Fit rule in
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image
orientation is portrait, its width will be made to match the
width of the scene grid. As a result, part of the image’s height
will extend beyond the height of the frame. This can be useful
if you want to make your background move up and down, or
from left to right to make it appear as if the camera is
panning, or to actually perform a camera pan.
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The opposite will apply to a landscape image. Its height will
be fit to the scene grid, therefore it is possible that the image
will extend beyond the scene grid's boundaries.

Note that the Pan alignment rule equals the Center First Page
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The
system looks at the resolution of the bitmap image, for
example 4000 x 2000, then compares it to the scene's
resolution, for example 1920 x 1080, and adjusts the scale
factor in proportion. So, in this example, the bitmap would
appear at 208% (4000/1920). If you import a bitmap that is
960 x 540, it will be displayed at 50% (960/1920) of the size of
the project resolution.
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Note that the Project Resolution alignment rule is equal to
the As Is rule in the layer properties.

‣ Import As BitmapDrawing: Imports a drawing into a vector layer where you can edit the
image using the drawing tools. In the Alignment section, select one of the following:

Parameter Description

Vertical Fit

Enlarges or shrinks (but not distort) to your image height to match
the full height of the scene frame (alignment grid).

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match
the full width of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system
looks at the resolution of the bitmap image, for example 4000 x
2000, then compares it to the scene's resolution, for example 1920 x
1080, and adjusts the scale factor in proportion. So, in this example,
the bitmap would appear at 208% (4000/1920). If you import a
bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the
size of the project resolution.
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‣ Convert to Toon Boom Vector Drawing: Imports a drawing and converts it to a Toon
Boom vector drawing. In the Vectorization section, select one of the following:

Black andWhite: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines keep the
texture from the scan, and the white of the paper becomes transparent.

New Preset: Lets you create a new preset.

Delete Preset: Lets you delete any preset in the list.

Custom vectorization: Lets you set custom vectorization parameters—see Creating a
Vectorization Style on page 480.

6. Decide whether to select Vectorize Imported Items option.

If you decide to use the Vectorize Imported Items option, see Importing and Vectorizing Bitmap Images on
page 452 to learn more about vectorization settings.

If you disable the Vectorize Imported Items options, the Transparency and Alignment settings will appear in
place of the Vectorization settings—see Importing a Bitmap Image Without Vectorization on page 444.

7. Click OK.

The Multilayer Image Import Settings dialog box opens.

8. From the Create menu, select one of the following:

‣ Single Layer: To import the Camera and Layout layers merged together.

‣ Separated Layers: To keep your Camera and Layout layers separated.

9. From the Transparency menu, select one of the following if applicable:
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Parameter Description

Premultiplied with
White

Individual pixels at the edge of an image are blended with
white.

Premultiplied with
Black

Pixels at the edge of an image are blended with black.

Straight
Pixels at the edge of an image are blended with black, white
and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the colour is
clamped to the alpha, the colour value cannot be higher than the alpha
value. It calculates the real colour value faster. When the RGB values are
multiplied with the alpha value, that is to say, if you have a pixel of value
R=247, G=188, B=29 and the alpha is 50% or the image has a 50% trans-
parency, then the actual RGB values that are output would be half of the
amounts listed above.

10. Click OK.

Your image appears as separate layers in the Timeline view, corresponding to the PSD layer group
folders.

The artwork displayed in every one of your layers as a result of a multilayer PSD file import is linked to the
same source image. This means that if you use the Drawing > Delete Selected Drawings command to
physically delete the drawing from the project folder, the exposed drawing will be deleted in all layers at
once. Once deleted from the project folder, the image cannot be retrieved unless you reimport your psd
file.
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Scanning Images

Toon Boom Harmony can receive images from any TWAIN device such as scanners and digital
cameras. These images can either be loaded into your scene as bitmaps or converted into vector-
based images that can be edited using Toon Boom Harmony.

If your operating system does not automatically recognize your device after it has been connected, you
must install the correct TWAIN drivers in order to access its contents. You can usually download the
drivers from the device manufacturer’s website.

How to open the Scan Drawings window and set your scanner

1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens.

2. In the Scan Drawings window, select your scanner or other supported TWAIN device from the
Scanner menu. If none are available, check your device to ensure that it is properly connected to
your computer. If your device still does not appear in the menu, you may have to shut down and
restart the software.

How to scan an image in its original format

3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or
existing layer.
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‣ Create Layer: Scans or imports the image into a new layer. Select one of the following
options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For
example, the filenames a-1.tga, a-2.tga and b-1.tga will create
layers named "a" and "b", where "a" has two drawings and
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix
bitmap images with vector drawings on the same layer, the bitmap image must be
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the
Symbol folder in the Library view.

4. In the Import Options section, select theKeepAs Original Bitmap option.

5. In the Alignment section, decide on the size and placement of your scanned image within the
camera frame. Depending on the scene settings (the height and width, in pixels, that you chose for
your project), an image that you scan may be scaled to the point where all its individual pixels
become visible.

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to
match the full height of the scene grid.

If the image orientation is landscape, this will enlarge or
shrink (but not distort) your image width to match that of the
scene grid.
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Note that the Fit alignment rule equals the Center Fit rule in
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image
orientation is portrait, its width will be made to match the
width of the scene grid. As a result, part of the image’s height
will extend beyond the height of the frame. This can be useful
if you want to make your background move up and down, or
from left to right to make it appear as if the camera is
panning, or to actually perform a camera pan.

The opposite will apply to a landscape image. Its height will
be fit to the scene grid, therefore it is possible that the image
will extend beyond the scene grid's boundaries.

488



Toon Boom Harmony 11.1 Sketch Module Network User Guide

Note that the Pan alignment rule equals the Center First Page
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The
system looks at the resolution of the bitmap image, for
example 4000 x 2000, then compares it to the scene's
resolution, for example 1920 x 1080, and adjusts the scale
factor in proportion. So, in this example, the bitmap would
appear at 208% (4000/1920). If you import a bitmap that is
960 x 540, it will be displayed at 50% (960/1920) of the size of
the project resolution.

Note that the Project Resolution alignment rule is equal to
the As Is rule in the layer properties.

6. In the Drawing Options section, set the following options if desired:

‣ DrawingName: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.

‣ Scan andAdvance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

7. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the
view.
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8. Click Scan to scan your drawing.

9. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next
letter to capture your next frame.

10. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until
you have finished scanning all your drawings.

How to scan an image as a Toon Boom bitmap drawing

1. In the Import Options section, select the Import as Toon Boom BitmapDrawing option.

2. In the Layer section, decide if the scanned or imported image will be placed on a new layer or
existing layer.

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following
options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For
example, the filenames a-1.tga, a-2.tga and b-1.tga will create
layers named "a" and "b", where "a" has two drawings and
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix
bitmap images with vector drawings on the same layer, the bitmap image must be
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the
Symbol folder in the Library view.

3. In the Alignment section, decide on the size and placement of your scanned image within the
camera frame. Depending on the scene settings (the height and width, in pixels, that you chose for
your project), an image that you scan may be scaled to the point where all its individual pixels
become visible.

Make sure you are in the Camera view’s Render Mode when judging an imported image, otherwise it may
appear blurry.

The following three Alignment Rules options are available:

Parameter Description

Vertical Fit
Enlarges or shrinks (but not distort) to your image height to match
the full height of the scene frame (alignment grid).

490



Toon Boom Harmony 11.1 Sketch Module Network User Guide

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match
the full width of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system
looks at the resolution of the bitmap image, for example 4000 x
2000, then compares it to the scene's resolution, for example 1920 x
1080, and adjusts the scale factor in proportion. So, in this example,
the bitmap would appear at 208% (4000/1920). If you import a
bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the
size of the project resolution.

4. In the Drawing Options section, set the following options if desired:

‣ DrawingName: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.
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‣ Scan andAdvance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the
view.

6. Click Scan to scan your drawing.

7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next
letter to capture your next frame.

8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until
you have finished scanning all your drawings.

How to scan an image and convert it to a Toon Boom vector drawing

1. In the Import Options section, select theConvert to Toon Boom Vector Drawing option. You can
choose to encapsulate the image in a symbol by selecting theCreate Symbols for Imported Items
option.

2. In the Layer section, decide if the scanned or imported image will be placed on a new layer or
existing layer.

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following
options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For
example, the filenames a-1.tga, a-2.tga and b-1.tga will create
layers named "a" and "b", where "a" has two drawings and
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix
bitmap images with vector drawings on the same layer, the bitmap image must be
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the
Symbol folder in the Library view.

3. In the Vectorization section, decide whether you want to import your image in black and white or
grey.
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Parameter Description

Black and White
Vectorizes drawings as a solid black line; creates a 100% vector-based
drawing.

Grey
Vectorizes your image as a mix of vector contour and greyscale bitmap
filling. Lines keep the texture from the scan, and the white of the paper
becomes transparent.

4. In the Drawing Options section, set the following options if desired:

‣ DrawingName: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.

‣ Scan andAdvance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the
view.

6. Click Scan to scan your drawing.

7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next
letter to capture your next frame.

8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until
you have finished scanning all your drawings.
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Importing QuickTime Movies

When creating an animation, it is not unusual to embed moving elements saved as videos within the
animation. Toon Boom Harmony allows you to import QuickTime movies into your project.

How to import a QuickTime movie

1. From the top menu, select File > Import > Movie.

2. Browse for the QuickTime movie to import and click Open.

The Import Drawings dialog box opens.

Do not browse for the movie file again. Leave the automatically generated field text as “many files
selected”.

494



Toon Boom Harmony 11.1 Sketch Module Network User Guide

3. Make your decisions for the Layer, Alignment and Transparency sections of this dialog box—see
Importing a Bitmap Image Without Vectorization on page 444.

4. Click OK.

The QuickTime video appears in the Timeline view as an image sequence. You can scroll through
the film frame-by-frame just as you would scroll through your animation drawing-by-drawing.

495



Chapter 1: Import Custom Vectorization Parameters

Custom Vectorization Parameters

You can create your own vectorization settings with Harmony.

The vectorization parameters you will create here can be saved, shared and also inserted into the
VectOptions.conf file used by the Harmony Scan and Control Center modules when scanning or
vectorizing a series of drawings.

You can use an interface to select and test the different options and you can also type in some
advanced settings.

How to open the Vectorization Parameters dialog box

1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization
parameters (i.e. from the scanner).

2. Select your file, decide on the layer options, and click Preview.

3. In the Vectorization section, click the New Preset button.

The Vectorization Parameters dialog box opens.
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• Options Tab below

• Help Tab on page 475

Options Tab

The Options tab contains the main vectorization settings. More settings are available in the Help tab.

Parameter Description

Input

The input filters are applied to the bitmap image before it is
vectorized.

One Pass: One threshold value is applied to both the Line and
Colour Art. For drawings with distinct vector-style lines of
mattes, you only need one pass.

Two Passes: Applies a different threshold value to each layer.

For greyscale drawings, you may want to perform the
vectorization process twice to apply different threshold values
to the Line and Colour Art layers.

Threshold: Determines which values in the scanned image are
considered part of the Line or Colour Art layer and what will be
eliminated from the vectorized drawing; 0% is white and 100%
is black. The threshold is between these two values.

Expand Bitmap: Lets you enter a value to scale the bitmap to
detect small variations in the line. Use this option if you scanned
a greyscale image and want to preserve small variations in the
texture to apply to the line art.

Jag Filter: Lets you enter a value to scale back the bitmap to
remove some of the line’s roughness. This is useless when you
have a drawing that appears quite rough; the Jag filter will
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eliminate excess strokes in the final drawing.

Output

The output filters are applied during the vectorization process.

No Colour Art: Does not generate filling zones in the Colour
Art layer.

No Texture: Does not generate texture in the Line Art in the
final images. Select this option to create solid lines in the final
line art.

Generate Matte in Underlay Layer: Creates an opaque zone
behind your drawing’s lines to avoid seeing through the layers.

Colour as Texture: Converts colour values into a texture layer.

Optical Registration

The optical registration options are used to automatically align
drawings based on the position of the peg holes on the
animation paper. The peg holes must appear in the scanned
drawings for the optical registration to work.

DPI: Lets you enter the dots-per-inch value of your image. You
must enter the same value as the DPI used to scan the image.

Peg Side: Lets you select the position of the peg holes on your
drawings. Identify whether they are on the top, bottom, left or
right.

Strictness: Determines how exact the location of the peg holes
must be for the software to recognize them. You have two
values to choose from:

• Strict: The peg holes must be in a tightly defined area to
be recognized.

• Loose: The peg holes can be recognized somewhere in a
larger area. This is the recommended setting.

Field Chart: Lets you indicate the size of the animation paper;
12 or 16.

Post Processing

The Post Processing filters are applied to the final vector
images.

Remove Holes: Removes holes of a specified value that might
make painting difficult.

Remove Dirt: Removes stray marks and dirt of a specified
value. Try a value around 500.

Remove Hair: Removes small strokes that have no line art.

Remove Hair: Number of Passes: The number of times the
drawing will be analyzed to identify hair marks.

Miscellaneous

Close Gaps: Closes gaps in the Colour Art so that you can
paint it.

Smooth Passes for Line Art before Breaking Triangles: The
number of times the smoothing operation runs before creating
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the triangles that break lines in your drawing. If unnecessary
triangles are appearing in your drawing, increase this value.

Smooth Passes for Line Art: The number of times the
smoothing operation is performed after the triangles have
been created. This further smooths the Line Art.

Preview

Show Strokes: Shows the strokes in the Vectorized Image
panel.

Stroke Thickness: Shows the size of the strokes.

Help Tab

The Help tab contains the most advanced vectorization settings which you type in the Advanced
Option fields at the bottom of the Options tab.

File IO Options

-file <filename (including extension)> [ options ]

-infile <filename (including extension)>; same as -file

-outfile <filename>; alternate output file

-informat <format>; the input format. Used if reading from stdin

-debug; turn on debug mode

-noforce; don't force output if image is inconsistent

-version; print version information and quit

-output_version <version>; output files of this version. Valid versions can be: 0 or 604

-force_unamed_palette_for_texture; will generate a texture in TVG's internal palette

Registration Options

-register <dpi side strictness>; perform optical registration.
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• Side can be one of left, right, top, bottom or l, r, t, b.

• Strictness can be either loose, strict or l, s.

-register_center_peg_holes; will use only round holes in 16 fields page

-rcph; short form of register_center_peg_holes

-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)

-rlf; short form of registration_looseness_factor

-rdebug; output registration debug messages

-pegpitch <inch (default 8.000000)>; distance between peg bars

-threshr < (default 0.500000)>; threshold for optical registration; range 0.0 to 1.0

-rmargin <inch (default 1)>; region size where to look for peg bars

-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image

-pdfc; short form of -peg_distance_from_center

-out_peg_position <side (default same)>; wanted position of the peg on the drawing.

• Can be one of right, left, top, bottom (or r, l, t, b) or same.

• A rotation will be performed if it is different from the side passed to -register.

-output_peg_matrix; output the peg transformation matrix on standard output.

-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.

Filtering Options

-pixel<pixel_shape (default '4x3')>; Valid values: 4x3

-gap<worldUnits (default 10)>; close gaps up to this big

-pencil; generate line art only

-keep_dirt; don't filter out dirt

-thresh <threshold (default 0.2)>; range 0.0 to 1.0

-rmv_hairs <worldUnits (default 1)> <passes (default 1)>

• remove hairs of size smaller than "size" in "passes" passes

-rmv_holes <area (default 7)>; remove holes smaller than "area"

-rmv_dirt <area (default 1)>; remove dirt smaller than "area"

• try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared

-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels"

• distance from each other. Use -no_break to remove all triangles

-no_texture; don't generate textured strokes

-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour

-noclosegap; disable all gap closing algorithms

-no_break; disable the breaking of line art

-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap
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-expand_bitmap<pixels (default 0>; expand the pixels in the vectorization bitmap

-fit_errorc<error (default 1.000000>; fitting error for the colour art

-fit_errorl<error (default 1.000000>; fitting error for the line art

-smoothl<passes (default 1>; number of smooth passes for line art

-smoothc<passes (default 1>; number of smooth passes for colour art

-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothl<passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothc<passes (default 0>; number of smooth passes for line art in colour art pass (needs -
2pass)

-2pass; specify two sets of parameters; one for line art "l", one for colour art "c"

(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,

-rmv_holesc, -rmv_dirtl and -rmv_dirtc)

-threshl<threshold for line art (default 0.5)>; range 0.0 to 1.0

-threshc<threshold for color art (default 0.5)>; range 0.0 to 1.0

-jag_filterl<pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-jag_filterc<pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-expand_bitmapl<pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-expand_bitmapc<pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-rmv_holesl<area (default 7)>; remove line art holes smaller than "area"

-rmv_holesc<area (default 7)>; remove colour art holes smaller than "area"

-rmv_dirtl<area (default 1)>; remove line art dirt smaller than "area"

-rmv_dirtc<area (default 1)>; remove colour art dirt smaller than "area"

try values between 100 and 500 for rmv_holesl, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are
in world units squared

-margins <inch (default 0.25)>; remove margin around bitmap

-top_margin <inch (default 0.25)>; remove margin at top of bitmap

-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap

-left_margin <inch (default 0.25)>; remove margin at left of bitmap

-right_margin <inch (default 0.25)>; remove margin at right of bitmap

-remove_peg_bars; remove the peg bar holes

-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size

-fs; short hand for -field_size

-peg_bar_size <inch (default 1)>; the size of the peg bar region

-noframe; do not put a frame around the colour art

-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art
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-downscale_input <default 1>; downscale the raw input by this integer factor

-downscale_texture <default 1>; downscale the output texture by this integer factor

-buildmatte; generate a matte on underlay for line test

-buildmatte_colourart; generate a matte on colour art for line test

Note: -buildmatte and -buildmatte_colourart are mutually exclusive

-copystrokes; copy original strokes when building matte.

Options for bitmap that has no registration information

-pixel_margins <inch (default 0)>; remove margin around bitmap

-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap

-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap

-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap

-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap

-dpi<(default -1)>; dpi information of input bitmap

RGB Keying Options

-rgb; generate separate zones for red, green and blue lines

-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value

-no_red; ignore red colour in vectorization

-no_green; ignore green colour in vectorization

-no_blue; ignore blue colour in vectorization

-flatten; flatten the drawing after generating colours

-rmv_rgb_dirt <threshold area default 0.0>; remove red, green and blue regions smaller than area

-expand_bitmap_rgb<pixels (default 0>; expand the pixels in the vectorization bitmap for rgb

-threshrgb<value> <threshold for rgb vectorization default 0.200000>;

-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>; thresholds on
saturation and value to consider a pixel to be grey

Colour Vectorization Options

-color_vectorize; perform a colour vectorization

-file2 <colour art filename>; specify the colour art bitmap

-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)><centre pressure effect
(0.0-1.0)> <edge pressure effect (0.0-1.0)><texture bitmap downscaling (0.2-20)> <texture bitmap
file (valid filename or "" if no file)>; generate brush texture for the line art

-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max
variation (0.0-1.0)>; specify a pressure strategy for the centre line.

-blur_radius <pixels (default 0)>; blur the penstyle texture generated
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-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour
before computing texture

-ccsp<times (default 3)>; short for -color_contour_smooth_passes

-color_rmv_holesl<world units (default 0.000000)>; remove holes of this size when computing
texture

-color_fill_holesl<world units (default 0.000000)>; fill holes of this size for colour line art

Bubble Usage (implemented only for colour vectorization's line art)

-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only

-bubble_gap<value (default 3)>; max number of colour art points between 2 bubbles

-bubble_length <value (default 10)>; max number of circles in a bubble

-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness
(must be >= 1.0)

-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness
(must be >= 1.0)

-uniform_gap; the space between bubbles is constant

4 Colour Vectorization

-4colours [key:value] ... [key:value] ; The key value list can be empty. The list of keys is:

rgbdiff:value ; between [0.0-1.0] or [0-255]

dark:value ; between [0.0-1.0] or [0-255]

grey:value ; between [0.0-1.0] or [0-255]

white:value ; between [0.0-1.0] or [0-255]

dirt:value ; dirt area. 200 is a good value

rt:value ; between [0.0-1.0] or [0-255]

gt:value ; between [0.0-1.0] or [0-255]

bt:value ; between [0.0-1.0] or [0-255]

There must be no space between the colon and the key/value. For example: -4colours
rgbdiff:20 dark:20 grey:120 white:250 dirt:200 rt:240 gt:240 bt:240

The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue
or green pencil marks you may have used to indicate highlights and shadows. The drawing will be
vectorized into pure red, blue, green and black (RGB values), while creating colour art zones wherever
lines connect. After painting in your tones and highlights, change your pure RGB colours to
transparent (0 Alpha) in the Colour Picker window and watch the indicator colour zone lines
disappear.
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Creating a Vectorization Style
With Harmony, you have the possibility to create custom vectorization parameters that can be saved
and reused.

You can vectorize drawings using one of the following methods:

• Black andWhite: All the lines become vector based and 100% black. The white areas become
completely transparent.

• Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image
contained inside a vector frame. The white areas become completely transparent.

• Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black
lines and turn them into 100% vector lines, preserving their original colours—see Custom
Vectorization Parameters on page 472.

How to create or modify the vectorization parameters

1. Set the different options available in the Vectorization Parameters dialog box.

504



Toon Boom Harmony 11.1 Sketch Module Network User Guide

2. Click theVectorize button to update the Vectorized Image preview.

The vectorized image is just a preview. The actual vectorization happens when you click OK in the
Import Images dialog box. There are many options to try in the Vectorization Options dialog box.
These are applied during the vectorization process.

3. To set advanced parameters, read the information on the Help tab, then type in the Advanced
Options field at the bottom of the Options tab.

4. To save your vectorization parameters to reuse them later, share them, or use them to set the
Harmony Scan module vectorization style list, click Save.

5. In the Browser window, name and save the file.

6. To save the current settings as your default settings, click Save As Default. To restore the default
settings, click Restore Defaults.

7. To load a vectorization style, click Load and locate the existing *.vof file.

8. Click OK.

Setting the VectOptions.conf File
Toon Boom Harmony Server uses a file called VectOptions.conf to get the vectorization style
when batch vectorizing a series of drawings. A series of default styles is available in this file, but you
will certainly want to create your own to fit your production style.

This section deals with setting the VectOptions.conf file on:
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• Setting the VectOptions.conf File on Windows and Mac OS X below

• Setting the VectOptions.conf File on Linux on page 484

Setting the VectOptions.conf File on Windows and Mac OS X

How to set the VectOptions.conf file on Windows or Mac OS X

1. Open the vectOptions.conf file:

‣ Windows: Select Programs / All Programs > Harmony 11.1 > Tools > Configuration
Editor.

‣ Mac OS X: Select Applications > Harmony 11.1 > Tools > Configuration Editor.

The Configuration Editor window opens.

2. In the bottom section of the window, select theVectOptions.conf tab.

3. Scroll down the VectOptions.conf file to see all the different options available for creating your
custom vectorization style. These options are the same as in the Vectorization Parameters dialog
box. It is recommended that you create your vectorization style using Harmony and the
Vectorization Parameters window and copy the result parameters in this file—see Creating a
Vectorization Style on page 480

4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add
new ones to the list using the parameters you got using the Vectorization Parameters window.
Notice that some of the lines have a “#” sign at the beginning to indicate that the line is a comment
and will not appear in the style list. The lines that have no sign at the beginning appear in the style
list.
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5. To create a new style, type the following below the existing styles:

style_name:

This should be followed by the name of your new style. For example: style_name: Black
Lines.

6. Under the style name line, type the following:

options:

7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization
Parameters window.

‣ To open the *.vof file, use any plain text editor application.

8. In the Configuration Editor’s top menu, select File > Save.

9. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify
that the new style appears in the Vectorization Style list under Edit > Vectorization Style.
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If you are using the batch processing method available with Toon Boom Harmony Server
to scan and vectorize your drawings, the selected style must be available on all the
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch
processing.

Setting the VectOptions.conf File on Linux

These are the two methods used to edit the VectOptions.conf file on Linux.

• Using the “vi” text editor

• Using the “gedit” text editor

How to set the VectOptions.conf file on Linux using the “vi” text editor

1. Open a Terminal window:
Menu: Applications > System Tools > Terminal

2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_11.0/etc

3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to See "Open
the 'VectOptions.conf using the "vi" text editor:" on page 484:

$ sudo vi VectOptions.conf

4. Enter the "root" password.

5. Open the 'VectOptions.conf using the "vi" text editor:

$ vi VectOptions.conf

6. To start editing, press the [i] key on your keyboard to enter Insert mode.

7. Once you are done editing the file, press Esc to exit Insert mode.

8. To save the changes made to the file, type the following and press Enter/Return:

$ :w!

508



Toon Boom Harmony 11.1 Sketch Module Network User Guide

9. To exit the "vi" editor and return to the Terminal, type the following and press Enter/Return:

$ :q

10. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify
that the new style appears in the Vectorization Style list under Edit > Vectorization Style.

If you are using the batch processing method available with Toon Boom Harmony Server
to scan and vectorize your drawings, the selected style must be available on all the
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch
processing.

How to set the VectOptions.conf file on Linux using the “gedit” text editor

1. Open a Terminal window:
Menu: Applications> System Tools> Terminal

2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_11.0/etc

3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to See "Open
the 'VectorOptions.conf using the "gedit" text editor:" on page 485:
$ sudo gedit VectOptions.conf

4. Enter the root password.

5. Open the 'VectorOptions.conf using the "gedit" text editor:

$ gedit VectOptions.conf

6. Edit the parameters of the VectOptions.conf file like you would do in most text editor
application.

7. Select File > Save.

8. Select File > Quit.
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9. If you have Harmony Scan on your computer, you can start the application and verify that the new
style appears in the Vectorization Style list under Edit > Vectorization Style.

If you are using the batch processing method available with Toon Boom Harmony Server
to scan and vectorize your drawings, the selected style must be available on all the
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch
processing.
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Chapter 2: Sound

With Harmony, you can import soundtracks and dialogue into your animation to make it more
engaging and entertaining.There are several sound editing features you can use to synchronize sounds
to individual frames or moments in time. You can also use them to trim unwanted seconds from the
beginning and end of your sound files, as well as loop sounds that you want to continue throughout
your animation.

Your ability to add dialogue to animation is greatly enhanced with the Harmony lip-sync tools.
Harmony can analyze voice tracks to determine which of the eight animation phonemes (lip positions)
would best apply to each frame of sound. With the mouth chart that is generated, you can easily draw
lip positions for your character. Furthermore, Harmony can automatically apply drawings of lip
positions to each frame of your animation based on the mouth chart.

This chapter contains the following topics:

• Importing a Sound File on the next page

• Sound Element Editor on page 489

• Sound Displays on page 490

• Sound Playback on page 492

• Sound Scrubbing on page 493

• Editing a Sound File on page 496

• Adding an Empty Sound Layer on page 504
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Importing a Sound File

If you decide to add sound to your movie, you must first prepare the sound outside of Harmony. Once
this is done, you must add a sound element in Harmony to the organize the sound files in your
animation. Sound will play in the movie until it reaches the end of the file or a stop frame that you have
created in the Sound Element Editor.

You can import WAV, AIFF or MP3 sound files.

How to import a sound file

1. Do one of the following:

‣ From the top menu, select File > Import > Sounds.

‣ In the Xsheet view, right-click anywhere in the frame area of the Xsheet view and select
Import > Sounds.

‣ From the Xsheet view menu, select File > Import > Sounds.

‣ From the Timeline view menu, select Import > Sounds.

The Select Sound File dialog box opens.

2. From the Select Sound File dialog box, find and select a sound file.

The sound file appears as a layer in the Timeline and Xsheet views.
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Sound Element Editor

When you select a sound layer in the Timeline view, the options related to that layer appear in the
Sound Element Editor when you double click on the layer.

• Layer Name: This field displays the layer's name.

• Start Frame/End Frame: These fields determine the start and end frame of the sound file.

• Mouth Shapes: This section shows the automated lip-sync detection during the scene play back. Click
on the thumbnail image of each mouth to change the phoneme assigned to the current frame.
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Sound Displays

Within the Xsheet view, you can display the sound file in different ways, depending on your sound
editing needs.

You can show or hide the waveform in the Timeline view by selecting the Waveform button in the
Timeline View toolbar. You must customize the toolbar to display this button because it is not
included in this toolbar by default.

How to change the sound display in the Timeline view

1. In the Timeline view's right area, right-click in the frame section and select Show Sound
Waveforms.

‣ You can change the waveform scale using the Zoom Waveform icon on individual sound
layers in the Timeline view's left side.

How to change the sound display in the Xsheet view

1. Right-click in the sound column or on the sound column header, and select SoundDisplay and one
of the following:

‣ SoundName: Shows the name of the sound file, as well as the file format. The line running
vertically through the column frames between the same file name indicates a continuity of
the same sound file in these frames.

‣ Mouth Shapes: Shows the letter (or name depending on the way you named your
character's different mouth positions) in the column's frames. There is only one mouth
position allotted per frame and this position should correspond to the sound file after
performing a lip-sync.

‣ Waveform: Shows a vertical display of the sound file's actual waveform. In the column
header, in the field under the column name, you can type in a percentage to zoom in or
zoom out on the waveform, or pass the scroll cursor over the Zoom Waveform
icon.
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Sound Playback

Before playing back any sound, click the Enable Sound  button in the Playback toolbar or enable it
through the Play menu (in the top menu). This will ensure that you can hear the sound layers in your
scene, even the ones included within symbols.

How to play back sound

1. To select a starting point:

‣ In the Xsheet view, click on a cell in the sound column.

‣ In the Timeline view, click on a cell in the sound layer. You can also slide the red playhead to
the correct cell.

2. In the Playback toolbar, activate the the Enable Sound  button.

3. Do one of the following:

‣ Click the Play  button in the Playback toolbar.

‣ From the top menu, select Play > Play Scene Forward or click on the Enter/Return key.

4. To hear the sound played back again and again, do one of the following:

‣ Click the Loop  button in the Playback toolbar

‣ From the top menu, select Play >Loop.

Mute
If there are two or more sound layers and you want to listen to them independently, you can disable
the unwanted sound by clicking the Mute Sound  button on the sound name layer in the Timeline
view.
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Sound Scrubbing

Harmony uses a process known as Sound Scrubbing to let you hear sound in real-time while you move
the playback pointer forward or backward. This is very useful for finely-tuned lip-synching. You can
scrub sounds from the Timeline view.

How to scrub a sound from the Timeline view

1. Do one of the following:

‣ In the Playback toolbar, enable the Sound Scrubbing  button.

2. At the top of the Timeline view, drag the red playhead to hear the sound at each frame.

Analog Sound Scrubbing
Harmony is set to the digital sound scrubbing mode by default. This means that all sounds are played
in real time. It also means that as you scrub over a frame, you will hear the section of your sound file
that is allotted to that frame. As you are scrubbing, although it is accurate, the sound can sound
clipped. It can also be difficult to hear nuances in pitch and tone.

Harmony has an analog sound scrubbing option. When sound scrubbing in this mode, the sound is
played back according to the speed that the playhead or jog is manually adjusted. Harmony's
interface offers shuttle and jog sliders to perform analog sound scrubbing, however, external
hardware and their corresponding software can be used in conjunction with Harmony for improved
analog sound scrubbing results.
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Refer to the device's manual to configure its functionality with Harmony.

Performing an Analog Sound Scrub in Harmony

Before you can perform an analog sound scrub in Harmony, you have to learn about the Shuttle and
Jog controls.

• Shuttle: Pull the Shuttle control backward or forward to make the red playhead in the Timeline
view jump by large increments in the direction you are moving the shuttle.

• Jog: Drag the Jog control to make the "dial" rotate. The Jog controls finer incremental
movements along the soundwave. Use the Frame field to see the frame number which you are
on. As you rotate the dial, your speed in fps appears directly after the FPS field.

How to perform an analog sound scrub

1. Do one of the following:

‣ In the Playback toolbar, enable the Sound Scrubbing  button.
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2. In the top menu, select Edit > Preferences (Windows/Linux) or Stage> Preferences (Mac OS X).

3. In the Sound tab, select theAnalog Sound Scrubbing option.

4. Click OK.

5. Do one of the following:

‣ In the Playback toolbar, use the Shuttle to find the general location of where you want to
start your sound scrub.

‣ In the Timeline view, drag the red playhead to the desired location.

6. In the Playback toolbar, use the Jog to fine-tune your scrub to just a few frames.
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Editing a Sound File

Now that you have successfully imported a sound file into Harmony, it is time to familiarize yourself
with the sound editing interface. The Sound Element editor makes it possible to edit sounds that were
created outside of Harmony and imported into your scene.

How to open the Sound Element editor

1. Double-click on the sound layer name in the Timeline view or the sound column header in the
Xsheet view.

The Sound Element Editor dialog box opens.

The Sound Element editor consists of three main parts.
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‣ Sound Element: The waveform in the Sound Element Editor is the actual sample that will be
heard when the final movie is rendered. It may be shorter than the original sound sample
due to the length of the scene. If any edits are made to the sound sample, they can be heard
here. In the Sound Element panel, notice the coloured tabs that indicate the start and end
frames of a sound segment. The frame number is displayed in the tab.

‣ Current Sound: Displays the original sound file in its entirety and is where you can edit its
properties. This window remains empty until you click inside the Sound Element Editor.

‣ Lip-sync Preview: Lets you preview the automated detection and to manually insert
different mouth positions to correspond with the sound sample.

You can accomplish the following tasks in the Sound Element Editor:

• Changing the Start or End Frame of a Sound below

• Trimming the Start and End of a Sound File on page 499

• Looping a Sound on page 500

• Mixing the Sound Volume on page 501

• Customizing the Playback Range on page 502

• Recomputing the Mouth Chart on page 511

Changing the Start or End Frame of a Sound
To synchronize the sound with specific images in your scene, you must set a start frame for your
sound. To make sure the sound ends by a certain frame, you must set an end frame.

In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The
frame number is shown inside the tab flag marker. These tabs indicate the start and end frames of a
sound segment.
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How to change start or end frame of a sound

1. Double-click on the sound layer name in the Timeline view or the sound column header in the
Xsheet view.

2. In the Sound Element Editor, select a sound sample from the Sound Element panel. To distinguish
one sound section from another on the same sound layer, check the frame numbers that appear on
tabs flanking the start and stop lines of each waveform section.

Click the Play  button in the Current Sound panel (only the selected sound plays).

3. Within the Sound Element panel, drag the selected clip to the frame number where you want it to
start playing.

You can only move the clip to a section that does not already contain a clip; you cannot overlap two
clips in the same element.

4. To change the end frame, drag the yellow marker at the end of the waveform to the frame
position.

522



Toon Boom Harmony 11.1 Sketch Module Network User Guide

5. To hear how all the clips fit together in the element, click the Play button in the Sound Element
panel.

If you only want to hear the selected clip, click the Play button in the Current Sound panel.

6. Click Apply/Next.

The Xsheet and Timeline views display the sound clip at the start frame you selected.

Trimming the Start and End of a Sound File
To play only a section of a sound file, use the Sound Element Editor to select the exact part you want
to use. For example, if there is a bit of noise at the start of the sound, use the Sound Element Editor to
cut the noise.

The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring
the rest. This means that the entire sound file is included on export. If you need to be mindful of file
size, it is better to edit sound files completely in a sound editor before bringing them into Harmony.

How to trim the start and end of a sound file

1. Double-click on the sound layer name in the Timeline view or the sound column header in the
Xsheet view.
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2. In the Sound Element Editor, select a sound sample from the Sound Element panel. To distinguish
one sound section from another on the same sound layer, check the frame numbers that appear on
tabs flanking the start and stop lines of each waveform section. Or select a soundwave and click
the Play  button in the Current Sound panel (only the selected sound plays).

3. Using the Current Sound panel, decide on the part of the file you want to play by dragging the left
and right boundaries of the selection area.

4. Click the Play  button in the Current Sound panel to check that you have trimmed the desired
sections. Use the Zoom slider at the bottom of the panel to zoom in on the waveform so you can
trim it more accurately.

5. Click Apply/Next.

The trimmed sound sample appears in both the Timeline and Xsheet views at the start and end
positions you selected.

Looping a Sound
To repeat a sound, specify the number of times that you want it to loop in the Sound Element editor.

How to loop a sound sample

1. Double-click on the sound layer name in the Timeline view or the sound column header in the
Xsheet view.

2. From the Sound Element panel, select the sound section you want to loop.

3. In the Current Sound panel, type the number of times you want the sound to play in the Number of
Loops field.
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4. Press the Enter/Return key.

The looped sound appears after the current sound. They are indicated by their grey waveforms, as
opposed to black.

When you loop a sound, the looped sections fill the cells in the sound element (column or layer)
until the next sound sample starts or until the scene ends. This means that the looping could be cut
if the next sound sample starts too soon or if the scene ends too quickly.

Mixing the Sound Volume
You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the
fade-in and fade-out times, otherwise known as sound envelopes. The fade edit only affects the
playback; the original sound file is not affected.

How to adjust the overall volume of the entire sound clip

1. Double-click on the sound layer name in the Timeline view or the sound column header in the
Xsheet view.

2. In the Sound Element panel, select the sound you want to work on.

A more detailed version of the selected sound appears in the Current Sound panel.

3. In the Current Sound panel, use the Volume slider to adjust the volume.

4. Click the Play  button in the Current Sound panel to verify the volume.

How to create the fade in/out effect on a sound clip

1. Double-click on the sound layer name in the Timeline view or the sound column header in the
Xsheet view.

2. In the Sound Element panel, select the sound you want to work on.

3. In the Current Sound panel, click on the thin blue line above the waveform to add an envelope
marker.
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4. Drag the envelope markers to adjust the volume at that frame and to create the time of the
transition. The line from the edge of the clip to the envelope marker identifies how the volume
increases (fades-in) or decreases (fades-out) over time.

Dragging the marker to the bottom of the channel mutes the volume, while dragging it upwards
increases the volume.

To create an even effect, be sure to adjust the envelope markers uniformly in both the left and right
(bottom and top) channels.

5. Click the Play  button in the Current Sound panel to check the fade envelopes.

Customizing the Playback Range
To hear a specific section of the sound element, adjust the playback range in the Sound Element Editor
to start or stop at specific frames. This customized playback range does not affect the actual sound in
the Sound element.

How to change the playback range in the Sound Element Editor

1. Drag the start or end range markers in the Sound Element panel to the boundary frames you want.
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2. When you click the Play  button to play back your sound in the Sound Element editor, it only
plays the sound which exists between the two markers.
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Adding an Empty Sound Layer

When performing sound editing tasks, it can be useful to chop up a sound sample into different layers.
For example, when performing a lip-sync, only a single view of the various mouth positions for a
character can exist on one layer. Therefore, if you want to have a character turn its head from a profile
view to a three-quarter view and have mouth position changes to fit with the sound sample from these
two different views, you would need to cut up the sound samples needed for the profile view mouth
positions on one layer and the sound samples needed for the three-quarter view on another.

For this task, you will need an empty sound layer.

How to add an empty sound layer

1. From the top menu, selectWindows > Toolbars > Timeline View.

The Timeline view toolbar appears at the top of the Timeline view.

2. Right-click on the Timeline View toolbar and select Customize.

3. Choose theAdd Sound  button from the Available Tools column on the left and add it to the
Toolbar column on the right. Click Ok to accept the change.

4. Click the Add Sound  button.

An empty (silent) sound layer appears in both the Timeline and Xsheet views.

5. Rename the layers accordingly by double-clicking on the layer name and renaming it in the Sound
Element Editor. Click Apply/Next to accept the change.
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6. Click the cell where you want to start the cut and Shift + click on the final cell of the cut. The sample
to be cut becomes highlighted.

7. Drag the selection into the empty sound layer below.

8. You can now continue to cut-up and distribute the sound sample between the two layers or carry
on to the lip-synching process for each layer and its corresponding facial view.

If you need to duplicate your sound layer to keep an unedited copy for safety, select the Duplicate
Selected Layers button in the Timeline View toolbar. You must customize the toolbar to display this button
because it is not included in this toolbar by default.
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Lip-sync

Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to
shape a character's mouth to match the sound at a precise frame.

To solve this problem, Harmony provides a lip-sync feature which analyzes the contents of a sound
element and generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D,
E, F, G, and X, which is used to represent silence).

The mouth shapes used by Harmony are based on the conventional mouth chart used in the animation
industry.

The letters used to represent the shapes do NOT correspond to an actual sound.

If you are doing cut-out animation, refer to the Cut-out Animation Guide, Character Building chapter,
"Adding Extra Drawings" topic to learn how to add extra drawings to your character.
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Here is an approximation of which sound each mouth shape can produce:

• A: m, b, p, h

• B: s, d, j, i, k, t

• C: e, a

• D: A, E

• E: o

• F: u, oo

• G: f, ph

• X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection.

You can refer to the mouth chart positions as you draw the shape of your character's mouth.

Generating a Lip-sync Detection
There are two places where you can perform a lip-sync detection: Timeline or Xsheet views and Sound
Element Editor.
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How to generate a sound detection for lip-sync using the Xsheet or Timeline view

1. To show the mouth chart letters, if they are not already present in the Xsheet view,right-click on
the sound column and select Lip-Sync > SoundDisplay > Mouth Shapes from the pop-up menu.

2. In the Xsheet view or Timeline view, right-click on the sound layer's cells and select Lip-Sync > Auto
Lip-Sync Detection. You can also select Animation > Lip-Sync > Auto Lip-Sync Detection from
the top menu.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each frame. The X
markers in the frame are replaced by these designated letters.

How to generate a sound detection for lip-sync using the Sound Element Editor

1. Do one of the following:

‣ In the Timeline view, double-click on the sound layer.

‣ In the Xsheet view, double-click on the sound column header.

The Sound Element Editor opens.

2. In Sound Element panel, select the waveform for which you want to generate a mouth chart.

3. Right-click on the sound file and select Auto Lip-Sync Detection.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync
letter to each sound cell.

Mapping the Lip-Sync Detection
Harmony can automatically map drawings in an element to the mouth chart you have generated for a
sound. This can save time when you are lip-synching a voice track.

In the Lip-Sync Mapping dialog box, you can identify each lip drawing of a character. Harmony then
automatically labels all of the cells in the character's element with the appropriate name.

How to automatically map lip-sync drawings to a mouth layer

1. To open the Lip-Sync Mapping dialog box, do one of the following:
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‣ In the Timeline view, right-click on any cell in the sound sample layer and select Lip-Sync >
Map Lip-Sync.

The Lip-Sync Mapping dialog box opens.

2. From the Destination Layer menu, select the layer that contains the mouth positions for the
character's voice track.

3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on
the layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you
want to use the drawings or select the desired symbol from the drop-down menu.

4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the
phoneme it represents. If your drawings are already named with the phoneme letters, you do not
have to do anything.

5. Click OK.

6. Press the Play  button in the Playback toolbar to see and hear the results in the Camera view.
To play back your scene with sound, enable the Sound  button in the Playback toolbar.

Modifying the Lip-sync
You can change the mouth position assigned to a frame if you think another position is more
appropriate.

For example, you may have a character who says nothing for 10 frames between two speeches.
Harmony would normally assign an X image for the silent period. However, if you want your
character's mouth to hang open in astonishment for these 10 frames, you can change the lip
assignment for these frames from an X to an F.

You can also change the mouth assignment of a sound in the Sound Element editor.
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How to change the lip assignment of a sound in the Xsheet

1. Right-click in the cell that contains the mouth position you want to change.

2. From the pop-up menu, select Lip-Sync > Change Mouth Shape to and choose the letter that
reflects the mouth position you want to use for that sound. You can also select Animation > Lip-
Sync > Lip-Sync > the desiredmouth shape from the top menu.

The drawing is automatically updated in the Camera view.

How to change the mouth position assignment of a sound from the Sound Element
editor

1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
View to open the Sound Element editor.

2. In the Sound Element panel, drag the frame slider to the frame you want to change the mouth
position assignment on.

In the Lip-sync image area, the image on top represents the lip position assigned to the current
frame.

3. To change the image assigned to the frame, click on the image of the mouth position you want
from below the preview image. The preview image changes to the mouth position image you
select. You can perform the same operation in the Layer Properties view.

The position is updated in the Timeline and Xsheet views.

Note that if you modify the lip-sync detection you must remap the detection to your mouth latyer. See See
"Mapping the Lip-Sync Detection" on page 508
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Recomputing the Mouth Chart

When you generate the mouth chart for a sound in a sound element, you can either accept the mouth
positions assigned by Harmony or assign your own lip-sync images.

However, if you change the sound's start frame or reassign its mouth position, you must reanalyze the
sound and regenerate the mouth chart for it. This erases any manual modifications you may have made
to the mouth assignments in the mouth chart.

To recompute the mouth chart for a selected sound from the Sound column

1. In a Sound column in the Xsheet or Timeline view,right-click on a cell that contains the sound file you
want to recompute the lip-sync for. Select Lip-Sync > Auto Lip-Sync Detection from the pop-up
menu. The mouth position assignment for each frame is recomputed, erasing any modifications you
have made.

To recompute the mouth chart for a selected sound from the Sound Element Editor

1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view to open the Sound Element editor.

2. Click on the waveform in the Sound Element section in the Sound Element editor.

3. Right-click and select Auto-Lip Sync Detection.

Manual Lip-sync
Harmony allows for the manual swapping of mouth position drawings to match a voice track. For this
process, both sound scrubbing (listening to a soundwave broken up frame-by-frame) and drawing
substitutions from the Library View are used.

How to perform a manual lip-sync

1. In the Playback toolbar, enable the Sound Scrubbing  button.

2. In the Timeline view, drag the red position indicator along the sound layer waveform.

3. When you reach a frame where a mouth position should go, for example, an open mouth with
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

4. In the Timeline view, click on the Expand  button to display the Data view.

5. Staying on your mouth shapes layer, place your cursor on top of the drawing name (often a letter)
until it changes to the swapping pointer.

6. Pull the cursor to see the list of mouth shape names and choose the one you want. The current
drawing automatically changes to the new selection.

You can also use the Library view to swap drawings.

How to perform a manual lip-sync using the Library view

1. In the Playback toolbar, enable the Sound Scrubbing  button.

2. In the Timeline view, drag the red playhead along the waveform of your sound layer.
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3. When you reach a frame where a mouth position should go, for example, an open mouth with
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

4. In the Drawing Substitution window of the Library view, click and drag the slider to choose a mouth
shape. The current drawing is swapped for the one in the preview window.
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Chapter 3: Export

Now that you have finished your animation, it is time to render your movie. Depending on whether you
plan to further edit your movie in a third party software, composite the movie in a larger body of work
or put it up directly on the web, Harmony supports several formats for all your rendering needs.

This chapter contains the following topics:

• Exporting a QuickTime Movie on the next page

• Exporting OpenGL Frames on page 519

• Batch Rendering on page 521
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Exporting a QuickTime Movie

If you require a video file, you can export your animation as a QuickTime movie. To render a
QuickTime movie with transparency, you need to set the Depth setting to Millions of Colours +.

If your exported video is too small or too large, change the project size from the top menu in Scene >
Scene Settings. This will change the size of the video output.

How to export a QuickTime Movie

1. From the top menu, select File > Export > Movie.

The Export to QuickTime Movie dialog box opens.

2. Click Browse and select a folder in which to save your movie and give it an appropriate file name
for the export.

3. Click OK.

4. In the Display Source section, select the Display module to use for rendering your project.

5. From the Export Range section, decide whether you want to export the entire scene (All) or a
specific frame range. If you decide on the latter, enter the frame range.

6. In the Resolution section, select one of the following from the menu:

‣ A preferred resolution ratio.

‣ Custom: Enables the Width and Height fields so you can enter a specific size.

538



Toon Boom Harmony 11.1 Sketch Module Network User Guide

7. In the Options section, clickMovie Options.

Parameter Description

Video

Enables the customization of the video settings, filters and
size.

Settings: Opens the Standard Video Compression Settings
dialog box (see below).

Filter: Opens the Choose Video Filter dialog box, where
you can select from a range of filters to apply to your video
export.

Size: Opens the Export Size Settings dialog box. The size
settings are overridden by the Harmony's scene settings.

Sound

Check this box to enable the customization of the sound set-
tings.

Settings: Opens the Sound Settings dialog box (see
below).

Prepare for Internet Stream-
ing

Select this option to enable the customization of the Inter-
net streaming options.

8. In the Video section, click Settings.

The Standard Video Compression Settings dialog box opens.
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9. From the Compression Type menu, select a codec. The availability of certain compression settings
depends on the Compression Type selected. For example, Animation is the default compression
type and as a result the Data Rate option is greyed out.

10. In the Motion section, choose a Frame Rate from the list.

By default, it is set to match the frames-per-second (fps) of your Harmony project. If you choose a
lower frame rate, your export playback will be faster than your actual project. The reverse is also
true for a higher frame rate.

11. If you want key frames inserted, select the Every option and set the number per frame.

This is the option is recommended by QuickTime. Refer to the QuickTime documentation for further
details.

12. In the Compressor section, choose a Depth based on your movie’s needs. For example, Millions of
Colours+ houses an alpha channel.

13. In the Quality section, use the slider to choose a quality setting. Remember that the better the
quality of the export, the larger the file.

14. From the Data Rate section, either choose to allow the program to automatically select the most
optimal bit rate, or enter a Restricted rate to save space and allow for faster downloading at a cost
to the quality of the export.

15. In the same section, from the Optimized For menu, select the intended viewing method for the
export.

16. Click OK.

17. From the Movie Settings dialog box, click Sound Settings.

The Sound Settings dialog box opens.
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18. From the Compressor menu, select a compression type.

The default setting is None. This will preserve your original sound file without the loss of information.
However, an uncompressed sound file will inevitably add “weight” to the overall size of your video
export.

19. Select a Rate by pressing the arrow button next to kHz.

It is best to check and match the original properties of your sound file. For example, if your file has an
audio sample rate of 48 kHz and you choose a conversion rate of 22.05 kHz, the sound will play at
the same speed, but with higher frequencies missing.

For a standard film sound quality, choose 44.1 kHz, or 48 kHz for DVD quality. Anything less will
make the sound “dull” or less bright. For things like recorded voice this doesn't matter so much, but
for music it can make an audible difference.

If file size is a consideration, such as with videos for the Internet, then a lower rate might be more
practical.

20. Next, choose the Size and theUse, which are related. Once again, it is advisable to check your
original sound file properties. If the file was recorded in one channel (mono), there is little point in
choosing the two channel (stereo) option. Although Mono can support a 16-bit channel, the extra
information is unnecessary. Mono is generally paired with 8-bit and Stereo with 16-bit.

21. Click OK.

22. In the Export to QuickTime Movie dialog box, click OK.

A progress bar appears.

23. Browse to the location on your computer where you saved your QuickTime video and double-click on
it to view the export.

How to set the depth to Millions of Colours + to export a QuickTime movie with
transparency

‣ In the Standard Video Compression Settings dialog box, selectMillions of Colors+ from the Depth
menu—see Exporting a QuickTime Movie on page 514.
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Exporting OpenGL Frames

You can export the OpenGL frames (fast display mode) if you need a quick render for your scene.
Some heavier scenes containing 3D, multiple effects and camera moves can be fairly long to export.

Use the Export OpenGL Frames dialog box to select the frames you want to render from the OpenGL
Camera view, then save the rendered frames as image files or as a QuickTime movie.

Frames saved from OpenGL view have neither antialiasing nor special effects. To render final frames
with effects, export Images or a Movie.

How to export OpenGL Frames

1. From the top menu, select File > Export > OpenGL Frames.

The Export OpenGL Frames dialog box opens.

2. In the Output section, in the Location field, click Browse to select a folder for the frames.

3. In the Filename field, enter a name (prefix) for the frames or revert to the default name by clicking
Default.

4. In the Format section, decide if you want to export individual image frames or a movie.

‣ Suffix: Lets you select the desired suffix. If you intend to render only a few frames, use 1 or
01, whereas if you intend to render 1000 frames, you can select 0001.

‣ Drawing Type: Lets you select the file type to render, such as TGA or SGI.

5. ClickMovie Options to customize the Audio and Video settings for the *.mov export—see
Exporting a QuickTime Movie on page 514.

6. From the Resolution section, select a resolution for export. If you are running some quick tests,
then you might want to reduce the resolution to save time and space. You also have the option to
set a Custom width and height to produce smaller or larger frames.

7. In the Range section, decide whether you want to render all your frames, a range of frames, the
current frame or selected frames.
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8. Use the Display menu to select a Display module to use for rendering your OpenGL frames from.

9. Click OK.
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Batch Rendering

Harmony Network has the possibility to render your scene locally or send it to a render farm so other
computers can render your scenes while you continue working on your station. This option is not
available with Harmony Stand Alone. The Harmony Network rendering processed are named:

• Local Rendering is done directly on the user machine using its CPU. To perform local rendering
you must use Harmony Stage.

• Batch Rendering lets you send a scene to render while you continue working in Harmony Stage.
This way, you do not have to wait for the application to complete the render process.

Batch rendering is a background process divided over several machines, or a render farm. Sending
your scene to batch render will share the rendering load with other machines in the render farm and
lessen the amount of work required by your computer.

Refer to the Control Center and Server Guide to learn how to send scenes to batch render and check the
status of the Render queue.

How to send a scene to the batch rendering queue

1. Save all the contents of your scene, all drawings, colour palettes and the palette list.

2. Select File > Save or press Ctrl + S (Windows/Linux) or ⌘ + S (Mac OS X).

3. From the top menu, select File > Export > Export Images or press Ctrl + Shift + Y
(Windows/Linux) or ⌘ + Shift + Y (Mac OS X).

If the system administrator did not complete the resolution configuration tasks, a warning
message will open. This message notifies you that the resolution.conf file was not properly
inserted in the configuration folder.
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4. Click OK to continue. You will still be able to render your scene.

The Export Images dialog box opens.

5. In the Output section, add a prefix to the images to be output and the path to the location in which
the files will be stored.

6. In the Format section, select a file type from the File Type list.

7. In the Colour Mode list, select an option to export your images: Colour, Colour with
Transparency, or Greyscale.

8. In the Colour Depth menu, select the number of bits you want for your images.

9. In the Range section, select the frames you want to render:

‣ All Frames: Sends all the frames in the scene to be rendered.

‣ Selected Frames: Sends a range of frames to be rendered.

10. Select theBatch Composite option.

11. Select theChunk option if you want to split the frames into sets of frames or QuickTime movie into
small chunks. Note that when the render farm (server) is done rendering all the small movie chunks,
it will put them all back together to create one single movie file.

12. In the Size (Frames) field, enter the number of frames for each chunk. For example, if your scene is
100 frames long and you enter a value of 20, there would be five entries in the queue of 20 frames
each.
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13. From the Camera menu, select the camera for rendering the scene's images. These are the Camera
modules you created in your scene.

14. Click OK to start the rendering process.

A confirmation dialog box opens to inform you that the frames have been sent to the Render
queue.

‣ If the selected frames were already sent to the Render queue, a notification dialog box
opens to inform you that these frames were already in the queue, but that they have been
updated with the latest rendering request.

You can also send scenes to batch rendering and check the status of the rendering queue from the
Control Center module.
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