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Chapter 1: Introduction

What is Toon Boom Harmony?
Toon BoomHarmony is a revolutionary team-based infrastructure for animation production. Its array of cutting-
edge features increases productivity and encourages creativity. Developed in conjunction with the leading
studios worldwide, Toon BoomHarmony is specifically designed for long-term episodic and feature length
projects, providing a true animation pipeline. Several animators can work simultaneously on the same scene
while the asset library provides users with easy access to up-to-datemedia assets.

Toon BoomHarmony is truly scalable; more than 100 staging clients can share animation just as easily as a few
can. Whether you are a start-up studio or a large established animation facility, Toon BoomHarmony serves as
the animation backbone ensuring sustainable growth.

Toon BoomHarmony is a powerful solution that brings together multiple teams working on the same project,
whether in-house or remotely. The Toon BoomHarmony solution offers a robust asset management system that
enables users to quickly locate assets, share tasks on complex scenes and centralize all assets in a common
repository. Tremendous gains in efficiency and quality aremade by the teams, who enjoy a smooth flow between
each task, and more time dedicated to their creative assignments.

What is the Harmony Paint Module?
The Harmony Paint module is mainly used in large productions where there is an Ink and Paint or Colour Stylist
team. The Harmony Paint module includes theDrawing and Colour views as well as drawing tools. By using this
module the Ink and Paint team does not need to learn the entire application, but can focus on the Ink and Paint
process.
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The Harmony Paint module can only be used with a connection to the Harmony database, unlike the
Toon Boom Harmony application which can be used as a standalone application. To start the ink and
paint process, you need to first fill in your scene’s exposure sheets and import the drawings that
need to be coloured.

Refer to the Harmony Xsheet and Harmony Scan Guides to learn more about the previous steps of
the production.

In this guide, the default keyboard shortcuts that are used are the Adobe Flash set.

Topics Covered

• Getting Started on page 19

• Interface on page 29

• Clean Up and Drawing Tools on page 55

• Colour on page 205
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Chapter 2: Getting Started
Once the software is installed and setup, you are ready to launch the application and ink and paint!

Topics Covered

• Launching Harmony Paint on the next page

• Loading Drawings and Elements on page 22

• Extra Commands on page 26



Chapter 2: Getting Started Launching Harmony Paint

20

Launching Harmony Paint
Before using Harmony Paint, you have to start the program. You can run the software onMacOS X or
Windows/Linux operating systems.

To open Harmony Paint, do one of the following:

1. Launch Toon BoomHarmony:

‣ MacOS X: Double-click on the Harmony Paint icon or select

Applications > Toon Boom Harmony 10.0 > Paint

‣ Windows: Double-click on the Harmony Paint icon or select

Start > Programs > Toon Boom Harmony 10.0 > Paint

‣ Linux: Double-click on the Harmony Paint icon or select

Applications > ToonBoom-Harmony_10.0 > Paint
or type in the command line:-
cd /usr/local/ToonBoomAnimation/harmony_10.0/lnx86/bin

Launch Stage -paint:
./Stage -paint

Harmony Paint opens, displaying the Login Screen.

2. Enter your Harmony user name to login to the Database. To work on Harmony Paint, you need to be
connected to the database to have access to the scenes stored in the central database of Toon Boom
Server. You cannot open offline scenes with Harmony Paint.

3. Click on Login. Harmony Paint Opens.

Harmony user names are created via the Control Center. If you do not have a user name, contact your IT
department.
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Refer to the Control Center and Server Guide to learn how to create Harmony user names.

Related Topics

• Loading Drawings and Elements on the next page
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Loading Drawings and Elements
Once you launch Harmony Paint, you need to load a scene’s drawings from the Database Selector, in order to
start the ink and paint process. The drawings must have previously gone through the Xsheet and Scanning
processes.

There are two ways of loading drawings:

• Open Drawings
This option will let you load drawings from one element at a time, for quick ink and paint on a single layer
animation.

• Open Elements
This option will let you load drawings from several elements at once. This can be useful when an animation
is separated inmany layers, to insure that they are well aligned and that the painted shapes and lines fit
together. A good example of this would be a dialogue with the chin and mouth separated from the rest of
the head.

Related Topics

• OpenDrawings below

• Open Elements on the facing page

Open Drawings
To open drawings in Paint:

1. Once Harmony Paint is launched and you are logged in, select File > Open Drawings. The [Ctrl] + [O]
(Windows/Linux) or [⌘ ] + [O] (MacOS X).

TheDatabase Selector opens, displaying the Environments available from the Harmony database.

2. Select the Environment, Job, Scene and Element where the drawings you need to paint are located.

3. Choose the version you want to open from the Version drop-downmenu.
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‣ The Saved By and SavedDate fields display the user who was the last to save the selected scene and
the date of the last save.

Refer to the Harmony Network to learn more about scene versions.

4. Click on theOpen button.

TheDrawings Selector dialog box opens.

5. Select the desired drawings from the drawings list:

• Click on a single drawing to select it.

• You can create a continuous multiple selection by holding the [Shift] key.

• You can create a multiple selection by holding the [Ctrl] (Windows/Linux) or [⌘ ] (MacOS X) key.

• Click on the All button to select all the drawings that are listed in theDrawings Selector.

• Click on the Unpainted button to select all the drawings whose status appears as UNPAINTED.

• Click on the Painted button to select all the drawings whose status appears as PAINTED.

6. Click on theOK button.

The selected drawings appear in theDrawing Thumbnails view

7. Use the Control panel to navigate between the previous and next drawings. The [F] and [G].

You are now ready to ink and paint!

Related Topics

• Open Elements below

Open Elements
To open elements in Paint:

1. Once Harmony Paint is launched and you are logged in, select File > Open Elements. The[Ctrl] + [E]
(Windows/Linux) or [⌘ ] + [E] (MacOS X).
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TheDatabase Selector opens, displaying the Environments available from the Harmony database.

2. Select the Environment, Job and Scene where the elements containing the drawings you need to paint are
located.

3. Choose the version you want to open from the Version drop-downmenu.

‣ The Saved By and Saved Date fields display the user who was the last to save the selected scene and
the date of the last save.

4. Click on theOpen button.

TheOpen Elements dialog box opens.

5. Select the elements you need to paint from the Elements list:

• You can create a continuous multiple selection by holding the [Shift] key.

• You can create a multiple selection by holding the [Ctrl] (Windows/Linux) or [⌘ ] (MacOS X) key.

6. Select the frames you wish to load from the Frames list:

• You can create a continuous multiple selection by holding the [Shift] key.

• You can create a multiple selection by holding the [Ctrl] (Windows/Linux) or [⌘ ] (MacOS X) key.

• Click on the All Frames button to load all the frames of the scene.

7. Click on theOK button.

The Drawing Thumbnails view will be hidden and your selected elements will be loaded in Harmony Paint.
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8. Enable the Light Table option from the Drawing view toolbar to display all the drawing layers.

• The selected layer will be displayed in original colours.

• The other layers will be displayed as washed out colours.

9. Use the Control Panel to navigate between previous and next layers. The [H] and [J].

10. Use the Control panel to navigate between previous and next drawings. The [F] and [G].

You are now ready to ink and paint!

Related Topics

• OpenDrawings on page 22
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Extra Commands
This table lists themost common commands used in Harmony Paint.

Command Action Shortcut

File > Add/Revert Use theAdd/Revert command
to load new drawings to the
already existing selection or to
reload drawings to revert the
modifications to the last save.

This option does not work when
several elements are loaded.

Windows > Colour Use theColour command to
display the Colour view.

Windows > Colour
Editor

Use theColour Editor command
to display the Colour Editor
view.

Windows > Model Use theModel command to
display theModel view.

Windows > Tool
Properties

Use the Tool Properties
command to display the Tool
Properties view.

File > Load
Background File

Use the Load Background File
command to import a
background image in Paint to
compare your drawing's colours
with it.

File > Move
Background

Use theMove Background
command to move the
background image in the stage.

File > Open
Drawings

Use theOpen Drawings
command to open the Database
Selector dialog box to select a
set of drawings.

The [Ctrl] + [O] (Windows/Linux)
or [⌘ ] + [O] (MacOS X).

File > Open
Elements

Use theOpen Elements
command to open theOpen
Elements window and select a
series of drawing elements and
a frame range to work on.

The [Ctrl] + [E] (Windows/Linux)
or [⌘ ] + [E] (MacOS X).

Options > Play by
Frame

Use the Play by Frame
command to flip between the
frames instead of the drawings.
If a drawing is exposed on two
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Command Action Shortcut

frames, you will have to flip
twice beforemoving on to the
next drawing.

File > Reset
Background
Position

Use the Reset Background
Position command to restore
the background image original
size and position.

File > Scale
Background Down

Use the Scale Background
Down command to scale down
the size of the background
image.

File > Scale
Background Up

Use the Scale BackgroundUp
command to scale up the size of
the background image.

File > Unload
Background

Use theUnload Background
File command to remove the
background image from Paint.
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Chapter 3: Interface

Knowing how to manage the Paint module interface helps you to work efficiently and organize your workspace
conveniently. There are a series of views and toolbars you can use as you perform different operations. Each user
has a preferred way of working in the interface and which views and toolbars they will use. In this chapter, you
will learn about themain elements of the interface and how to manage them.

Topics Covered

• User Interface on the next page

• Managing the Views on page 47

• Managing the Toolbars

• Interface Navigation on page 49

• Preferences on page 50
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User Interface
This section takes you through themost common elements of the user interface. Throughout the user guide, you
will learn about each view and toolbar and how and when to use them.

Related Topics

• Views and Toolbars below

• Interface Highlights below

• Extra Views on page 44

Views and Toolbars
Harmony Paint has different views and toolbars.The top toolbars are available at the top of the interface and the
View toolbars are in individual windows. View toolbars are only shown if the particular view is displayed in the
workspace.

This is a complete list of the views and toolbars which are available in Harmony Paint.

Views
• Colour view

• Colour Editor view

• Drawing Thumbnails view

• Drawing view

• Model view

• Tool Properties view

Toolbars
• Drawing View Toolbar

• Edit Toolbar

• File Toolbar

• Tools Toolbar

Interface Highlights
It’s important that you become familiar with the following elements of the user interface, this will help you to
start using Harmony Paint. You can learnmore about the highlights described here, and how to use them in a
production context, throughout this guide.

This is Harmony Paint’s default workspace, it is restored every time you launch a session.
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1. Menus below

2. Toolbars on the next page

3. Drawing and Drawing Thumbnails Views on page 33

4. Controls on page 35

5. Colour View on page 40

• Extra Views on page 44

Menus
You can access the commands from the following menus:

• TopMenu

• Quick Access Menu

Top Menu

The top menu contains most of the commands. This menu is always located at the very top of the user interface.

The top menu contains the following categories:

• File

• Edit
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• Drawing

• Selected

• View

• Tools

• Options

• Colours

• Palettes

• Windows

• Help

In theMacOS X version, there is a Stage category containing the following commands:

• Preferences

• About

• Quit

Quick Access Menu

Each view has a Quick Access Menu containing recurring actions. This menu is accessed by right-clicking
anywhere in the view.

Toolbars
Here are themain toolbars in Harmony Paint:

• Drawing View Toolbar

• Tools Toolbar

Drawing View Toolbar
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TheDrawing View toolbar contains themain options and features you will use while working in Harmony Paint.
You can customize this toolbar to display the features you use themost. Refer to the Managing the Toolbars on
page 1 to learn how.

Tools Toolbar

The Tools toolbar contains all of themain tools you will use while working in Harmony Paint.

Drawing and Drawing Thumbnails Views

1. Drawing Area

2. Drawing Thumbnails View

3. Overlay, Line Art, Colour Art, Underlay and Preview Modes

4. Drawing Name

5. Tool Name

6. Frame Number

Drawing Area

This is theDrawing view’s main space, it is where you draw, and where the drawings are displayed.
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Drawing Thumbnails View

TheDrawing Thumbnails view display a list with thumbnails of the loaded drawings. The highlighted drawing is
the one displayed in the drawing area. You can select the drawing youwant to paint directly from this list.

Overlay, Line Art, Colour Art, Underlay and Preview Modes

Overlay

Click on this button to switch to the drawing’s Overlay layer. This layer is located above the Line Art layer. The
shortcut is [:].

Line Art

Click on this button to switch to the Line Art layer of the drawing. The shortcut is [L].

Colour Art

Click on this button to switch to theColour Art layer of the drawing. The shortcut is [L].

Underlay

Click on this button to switch to the drawing’s Underlay layer. This layer is located under theColour Art layer.
The shorcut is [:].

Preview mode

Click on this button to switch to Previewmode. This lets you see both Line Art and Colour Art layers
simultaneously. The shortcut is [Shift] + [P]. Hold the Previewmode button to display a drop-down list in which
you can enable theUnderlay orOverlay layers to include them in the preview.

Drawing Name

TheDrawingName field displays the name of the selected drawing as well as the layer containing it. If the cell
does not contain any drawings, an Empty Cell text is shown in the field.

Tool Name

The Tool Name field displays the name of the selected tool. If you override a tool using an overriding keyboard
shortcut, the tool’s namewill be highlighted in red letters.

Refer to the Override Tool on page 197 to learn how to temporarily override a tool.

Frame Number

The Frame Number field displays the number of the current frame.
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Controls
The controls are used to quickly have access to common commands:

Previous and Next Drawing

These buttons let you switch to the previous or next drawings. The shortcuts are [F] and [G].

Previous and Next Layer

These buttons are used to switch to the previous or next layer when you have different layers loaded. The
shortcuts are [H] and [J].

Line Art, Colour Art, Preview Mode

Use these buttons to switch from Line Art to Colour Art. The shortcut is [L]. You can also enable or disable the
Previewmode. The shortcuts are [Shift] + [P].

Extra Views
There are three extra views, that are not part of the workspace when the Harmony Paint module is launched:

• Tool Properties View on page 44

• Model View on page 46

• Colour Editor View on page 46

Related Topics

• Open Elements on page 23

• Drawing and Drawing Thumbnails Views on page 38

• Interface Navigation on page 49
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• Managing the Views on page 47

Menus
You can access the commands from the following menus:

• TopMenu

• Quick Access Menu

Top Menu

The top menu contains most of the commands. This menu is always located at the very top of the user interface.

The top menu contains the following categories:

• File

• Edit

• Drawing

• Selected

• View

• Tools

• Options

• Colours

• Palettes

• Windows

• Help

In theMacOS X version, there is a Stage category containing the following commands:

• Preferences

• About

• Quit
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Quick Access Menu

Each view has a Quick Access Menu containing recurring actions. This menu is accessed by right-clicking
anywhere in the view.

Toolbars
Here are themain toolbars in Harmony Paint:

• Drawing View Toolbar

• Tools Toolbar

Drawing View Toolbar

TheDrawing View toolbar contains themain options and features you will use while working in Harmony Paint.
You can customize this toolbar to display the features you use themost. Refer to the Managing the Toolbars on
page 1 to learn how.

Tools Toolbar

The Tools toolbar contains all of themain tools you will use while working in Harmony Paint.
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Drawing and Drawing Thumbnails Views

1. Drawing Area

2. Drawing Thumbnails View

3. Overlay, Line Art, Colour Art, Underlay and Preview Modes

4. Drawing Name

5. Tool Name

6. Frame Number

Drawing Area

This is theDrawing view’s main space, it is where you draw, and where the drawings are displayed.

Drawing Thumbnails View

TheDrawing Thumbnails view display a list with thumbnails of the loaded drawings. The highlighted drawing is
the one displayed in the drawing area. You can select the drawing youwant to paint directly from this list.

Overlay, Line Art, Colour Art, Underlay and Preview Modes

Overlay:

Click on this button to switch to the drawing’s Overlay layer. This layer is located above the Line Art layer. The
[:].

Line Art:

Click on this button to switch to the Line Art layer of the drawing.The [L].

Colour Art:

Click on this button to switch to theColour Art layer of the drawing. The [L].
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Underlay:

Click on this button to switch to the drawing’s Underlay layer. This layer is located under theColour Art layer.
The [:].

Preview mode:

Click on this button to switch to Previewmode, this will let you see both Line Art and Colour Art layers
simultaneously. The [Shift] + [P]. Hold the Previewmode button to display a drop-down list in which you can
enable theUnderlay orOverlay layers to include them in the preview.

DrawingName

TheDrawingName field displays the name of the selected drawing as well as the layer containing it. If the cell
does not contain any drawings, an Empty Cell text is shown in the field.

Tool Name

The Tool Name field displays the name of the selected tool. If you override a tool using an overriding keyboard
shortcut, the tool’s namewill be highlighted in red letters.

Refer to the Override Tool on page 197 to learn how to temporarily override a tool.

Frame Number

The Frame Number field displays the number of the current frame.

Controls
The controls are used to quickly have access to common commands:

Previous andNext Drawing

These buttons are used to switch to the previous or next drawings. The [F] and [G].

Previous andNext Layer

These buttons are used to switch to the previous or next layer when you have different layers loaded. The [H] and
[J].
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Line Art, Colour Art, Preview Mode

Use these buttons to switch from Line Art to Colour Art. The [L]. You can also enable or disable the Preview
mode. The [Shift] + [P].

Related Topics

• Open Elements on page 23

• Drawing and Drawing Thumbnails Views on page 38

Colour View

1. Add Colour on the facing page

2. Remove Colour on the facing page

3. Add Texture on page 42

4. Set Current Brush Colour on page 42

5. Set Current Pencil Colour on page 42

6. Set Current Paint Colour on page 42

7. Link/Unlink Three Colours on page 42

8. Show/Hide Palette List View on page 43
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9. Colour Swatch Name on page 43

10. Colour Swatch on page 43

11. Colour View Menu on page 44

The Colour View is where you create colours and palettes and import existing palettes into your project. The
Colour View is also necessary for drawing, painting and creating colour styling.

The Colour View has two displaymodes:

• List Mode

• SwatchMode

To toggle between the display modes:

1. In the Colour View menu, select Colours > Swatch Mode.

‣ Enable the option to display the swatches.

‣ Disable the option to display the colour list.

Add Colour

The Add Colour button is used to add a colour swatch to your palette. Click on the Add Colour button to

add a new swatch to the bottom of your colour list.

Remove Colour

The Remove Colour button is used to delete the currently selected colour swatches. If the colour swatch is

used in your project, the Delete Colour dialog box will pop and will ask you to confirm the operation.

‣ Click OK to confirm the operation or Cancel to cancel it.

Zones painted with colour swatches which have been deleted will turn red, easily identifying them so you can
repaint themwith another colour swatch.
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Add Texture

The Add Texture button is used to add a bitmap colour swatch to your palette. Use this to load photos and

textures and paint your drawings with it. The bitmap imagemust be a TGA or PSD file format.

Set Current Brush Colour

The Set Current Brush Colour button is used to set the currently selected colour swatch as the colour used

by the Brush tool. If you select a new colour in the Colour view while using the Brush tool, the Set Current

Brush Colour swatch will be updated.

Set Current Pencil Colour

The Set Current Pencil Colour button is used to set the currently selected colour swatch as the colour used

by the Pencil , Polyline , Ellipse , Rectangle and Line tools. If you select a new colour in the

Colour view while using any of these tools, the Set Current Pencil Colour swatch will be updated.

Set Current Paint Colour

The Set Current Paint Colour button is used to set the currently selected colour swatch as the colour used by

the Brush tool. If you select a new colour in the Colour view while using the Paint tool, the Set Current Paint

Colour swatch will be updated.

Link/Unlink Three Colours
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The Link/Unlink Three Colours button is used to link the Set Current Brush Colour, Set Current Pencil

Colour and Set Current Paint Colour swatches to the currently selected colour swatches in the Colour view.

Show/Hide Palette List View

The Show/Hide Palette List View button is used to display the Palette List view in the Colour view. This

option is for the advanced user who wants to create colour palettes for their props and characters.

Colour Swatch Name

Each colour swatch available in the Colour view can have its own name, making it easy to identify which colour is
used to paint what part of your character or background.

Two colours can have the same name.

Colour Swatch

A colour swatch is a specific colour used to paint a certain zone of a character or background. Colour palettes
are composed of colour swatches. They can also be called colour pots. When you paint a zone with a colour
swatch, the zone is linked to the swatch. So if you update the swatch’s tint, the zone will be updated along with
it. This allows you to modify your animation colours even after it is completely painted.
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Colour View Menu

The Colour View menu allows you to access commands that are specifically related to the Colour view such

as creating new palettes, adding new colour swatches and displaying the Tint panel. The commands listed in the
Colour View menu can also be found following a similar path from the top menu categories Colours and Palettes.

Edit Palette Mode

In Network mode, to avoid accidentally modifying the palette, the palette files can be locked. Enable the Edit
PaletteMode to get the rights to modify the palette.

Related Topics

• Colours on page 208

Extra Views
There are three extra views, that are not part of the workspace when the Harmony Paint module is launched:

• Tool Properties View below

• Model View on page 46

• Colour Editor View on page 46

Tool Properties View
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The contextual Tool Properties view contains themost common options and operations related to the currently
selected tool. As soon as you select a tool from the Tools toolbar, the Tool Properties view will be updated.

For example, if you choose the Select tool in the Tools toolbar, the Tool Properties view will display the

options and operations related to the Select tool such as Snap to Contour, Apply to All Drawings, Flip
Horizontal and Flatten.

To open the Tool Properties view:

‣ SelectWindows > Tool Properties.

The content of the Tool Properties view is explained in detail in the following chapters:

• Drawing

• Traditional Animation

• Colour on page 205

• Scene Setup

• Cut-out Animation
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Model View

You can load a colour model in theModel view to have a quick reference when doing ink and paint. You can also
pick the colour directly from theModel view instead of from the Colour view. See Colour Model on page 288.

Colour Editor View

You can use theColour Editor view to modify the tint of selected colours from a palette.

Related Topics

• Mixing the Colours on page 281
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Managing the Views
The Harmony Paint user interface is composed of different views, each one designed for a specific purpose.

This section explains how you canmodify your workspace by adding or closing views, as well as resizing or
temporarily hiding a view.

Refer toManaging the Views in the Managing the Views section in the Harmony Stage User Guide to
learn how to manage views.
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Managing the Toolbars
The Toon BoomHarmony user interface contains toolbars which, by default, are located at the top of the
interface. Some of the workspace’s views also have their own toolbars. These toolbars can bemoved around.
You can reposition the toolbars to suit your work style or hide unused ones.

Refer toManaging the Views in the Managing the Views section in the Harmony Stage User Guide to
learn how to manage views.
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Interface Navigation
Toon BoomHarmony supports zoom in, zoom out, rotate, pan and reset view position for easy interface
navigation.

• Zoom In: Zooms into the view. From the top menu, select View > Zoom In or press [2].

• Zoom Out: Zooms out of the view. From the top menu, select View > Zoom Out or press [1].

• To zoom in and zoom out, hold down [Spacebar] and your middlemouse button while moving themouse
up or down.

• To pan the view, hold down the keyboard shortcut [Spacebar] and drag your mouse in the direction you
want to pan the view.

• To Recentre the view: recentres the view on your mouse cursor or press [N].

• Reset View: Resets the view to its default position. From the top menu, select View > Reset View or
press [Shift] + [M].

• Reset Rotation: Resets the view’s rotation to its default position. From the top menu, select View >
Reset Rotationor press [Shift] + [X].

• Reset Pan: Resets the view’s pan to its default position. From the top menu, select View > Reset Pan or
press [Shift] + [N].

• Reset Zoom: Resets the view’s zoom to its default position. From the top menu, select View > Reset
Zoom.

• Toggle Full Screen: Enlarges the selected view to full screen. The full screen process is done in three
stages. From the top menu, select View > Toggle Full Screen or press [Ctrl] + [F] (Windows/Linux) or [⌘ ]
+ [F] (MacOS X).

• First, the selected view enlarges to themaximumwidth or height, but keeps the tool views such as
Colour or Tool Properties view.

• Second, the view enlarges to full screen.

• Third, the view returns to its original size.

• Rotate 90 CW: Rotates the Camera view 90 degrees clockwise, like an animation table. From the top
menu, select View > Rotate View CW.

• Rotate 90 CCW: Rotates the Camera view 90 degrees counter-clockwise, like an animation table. From
the top menu, select View > Rotate View CCW.

Related Topics

• Zoom
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Preferences
An important feature of Harmony Paint is the Preferences panel. From here you can customize your interface,
tool behaviour and shortcuts. Throughout this guide, you are often required to go to the Preferences panel to
set parameters and options.

To access the Preferences panel:

‣ In the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS X). The
[Ctrl] + [U]Windows/Linux) or [⌘ ] + [U] (MacOS X).

The Preferences panel is divided into the following tabbed sections:

• Shortcuts Tab below

• General Tab below

Some preferences require you to exit and restart the application or to close a view and reopen it.

Shortcuts Tab
To speed up your work, all of Harmony Paint’s keyboard shortcuts can be customized and you can even choose
other software keyboard shortcut sets.

Refer to the following sections in the Harmony Stage User Guide.

• Selecting a Keyboard Shortcut Set

• Customizing a Keyboard Shortcut

General Tab
Use theGeneral tab to set general software behaviour and user interface.
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Save
The Save preferences are used to specify if you want the following elements to be saved or not when using the
Save command:

• Save Palette Lists
When this option is enabled, the Palettes Lists will be save when saving your work with the Save
command. Disabling this option prevents the Palette Lists from being saved without specifically using the
Save Palette Lists command from the Colour view.

• Save Palettes
When this option is enabled, the Palettes will be save when saving your work with the Save command.
Disabling this option prevents the Palettes from being saved without specifically using the Save Palette
command from the Colour view.

• Save Drawings
When this option is enabled, the drawings will be save when saving your work with the Save command.
Disabling this option prevents the drawings from being saved.

Options/Settings
Cycle Exposure

This optionmakes the navigation wrap-around from the last cell or column to the first.

HTML Browser for Unix

This option is used to view the online help on Linux machines. Enter the command to launch the browser,
including the path if necessary.

Level of Undo

The Levels Of Undo preference determines the number of actions retained by the Undo List. By default, the
system stores 50 actions in the list. You can alter the number if you want to.
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Colours
The Colours preference allows you to modify the colours of the different User Interface views and elements. For
example, you can change the Drawing view’s background colour fromwhite to any other colour. This can be
useful to easily and quickly distinguish details that are painted white which would not show on a white
background, for example a character’s white eyeballs.

Altering these preferences require you to restart the application or to close a view and reopen it for the
modifications to be applied.

Current View Border

The Current View Border preference sets the colour of the frame around the workspace view you are currently
using, also known as focus. By default, the colour is red. Click on the red colour swatch to select a new colour in
the Colour Picker window.

Edit Colours Button

Click on the Edit Colours button to open theColours window.

In theColours window, you canmodify any of the colours from the list. Most of themodifications will require you
to restart the application or close the view and reopen it to see them.

Click on any of the colour swatches and select a new colour from theColour Pickerwindow.

Onion Skin

• Onion Skin After
Changes the colour display of the next drawing when using theOnion Skin feature.

• Onion Skin Before
Changes the colour display of the previous drawing when using theOnion Skin feature.

Others

• Background
Changes the background colour of theDrawing andModel view.

• Backlight
Changes the display colour of the Backlight option.

• Grid
Changes the display colour of the grid when using the Show Grid option.
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• Colour View Background
Changes the background colour of the colour list area of theColour view.

• Colour Highlight Mode Opacity
Changes the opacity value of the washed out art when using theHighlight Selected Colour option.

To restore all of the default interface’s colours, click on the Restore All Defaults button.
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Clean Up and Drawing Tools

In Toon BoomHarmony, many powerful tools, views and features are available so you can design, draw and
animate with ease. This chapter explains themain assets needed when drawing and animating in the software as
well as tips on how to start and use these tools efficiently.

Topics Covered

• How to Draw on page 61

• Tool Properties View on page 63

• Drawing View on page 65

• Drawing with the Brush or the Pencil on page 68

• Viewing the Final Lines as you Draw on page 70

• Drawing Using the Pencil Tool on page 73

• Drawing with the Brush Tool on page 101

• Drawing with Line Texture on page 115

• Selecting Drawing Objects on page 127

• Erasing Parts of a Drawing on page 144

• Reshaping a Drawing Using the Contour Editor Tool on page 149

• Reshaping Pencil Lines with the Pencil Editor Tool on page 155

• Drawing with Shapes on page 162

• Drawing with the Polyline Tool on page 170
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• Drawing Using Invisible Lines on page 176

• Deforming a Drawing Using the Perspective Tool on page 180

• Cutting Drawing Parts on page 184

• Smoothing Lines on page 188

• WorkingWith Text on page 192

• Override Tool on page 197

• More Drawing Tools on page 198
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Cleaning Scanned Drawings

As paper drawings are passed through a scanner theymay pick up dirt, hairs or dust. These foreign bodies
register as part of the drawing and will appear as unwanted marks on the scanned drawing. Thesemarks need
to be cleaned. Toon BoomHarmony provides different features to remove them quickly.

Each of the removal features are described in the following sections:

• RemoveDirt below

• Remove Art Outside Selection on the next page

• Remove Art Inside Selection on page 59

• Remove Hair on page 60

Remove Dirt

The RemoveDirt tool selects small dots and hairs on the drawing. Increasing the RemoveDirt level selects larger
dots for removal, but be careful not to lose small details like pupils and nostrils. Once the removal level is
chosen, you can apply it to either the current drawing or to the whole animation sequence.

This is a fast way to get rid of most dirt and dust.

To use the Remove Dirt tool:

1. In the Timeline or Xsheet view, select the drawing to clean.
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2. In the top menu, select Drawing > Clean Up > Remove Dirt or press [Shift] + [D].
In Harmony Paint, select Drawing > Remove Dirt.

The RemoveDirt dialog box opens.

3. Increase the RemoveDirt value bymoving the slider to the right. As you increase the tolerance, larger
speckles will become highlighted to indicate that they have been included in the selection.

4. Enable theApply to All Drawings option if you want to apply the operation to all the drawings in the
layer.

5. Click on theOK button.

Remove Art Outside Selection

The Remove Art Outside Selection option is used to delete any art existing outside a selection. If you have an
accumulation in your Colour Art, it can result in large output files, especially if you work in high definition
resolution. Simultaneously apply this operation to all of your drawings in the layer by using the Remove Art
Outside SelectionOnAll Drawings command.

To clean dirt with the Remove Art Outside Selection:

1. In the Tools toolbar, select the Select tool or press [Alt] + [S].
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2. If you want to apply the action to your entire animation, enable the Permanent Selection option in

the Tool Properties view.

3. In the Camera or Drawing view, draw a selection around the animation. (Make the area large enough to
include the whole animation sequence).

4. In the top menu, select Drawing > Clean up > Remove Art Outside Selection option to delete artwork
outside your selection on one single drawing.
In Harmony Paint, select Selected > Remove Art Outside Selection.

‣ To apply the action to all the drawings contained in the layer, select theDrawing > Clean up >
Remove Art Outside Selection on All Drawings option from the top menu.
In Harmony Paint, select Selected > Remove Art Outside Selection On All Drawings.

Remove Art Inside Selection

The Remove Art Inside Selection option is used to delete any art inside a selection.

We recommend that you clean your Colour Art level as well. If you have an accumulation of strokes (almost
invisible, accidental or leftover marks) in your Colour Art, it can result in large output files, especially if you work
in high definition resolutions.

You can simultaneously apply this operation to all of your drawings in the layer by using the Remove Art Inside
SelectionOnAll Drawings command.

To clean dirt with Remove Art Inside Selection:

1. In the Tools toolbar, select the Select tool or press [Alt] + [S].

2. If you want to apply the action to your entire animation, in the Tool Properties view, enable the
Permanent Selection option in the Tool Properties view.

3. In the Camera or Drawing view, draw a selection around the animation. (Make sure to make the area
large enough to include all the zones to be cleaned up on all drawings).

4. In the top menu, select Drawing > Clean up > Remove Art Inside Selection option to delete artwork
inside your selection on one single drawing.
In Harmony Paint, select Selected > Remove Art Inside Selection.
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‣ To apply the action on all your drawings contained in the layer, in the top menu, select Drawing >
Clean up > Remove Art Inside Selection on All Drawings option to delete artwork inside your
selection on all the drawings.
In Harmony Paint, select Selected > Remove Art Inside Selection on All Drawings.

Remove Hair

The Remove Hair command is used to remove any small strokes created in the Colour Art from very thick lines or
filled zones.

Increasing the Remove Hair level value will select larger strokes for removal from the drawing. You can also
select theApply to All Drawings option to remove them on all drawings.

To use the Remove Hair tool:

1. In the Timeline or Xsheet view, select the drawing containing the drawing to clean.

2. In the top menu, select View > Show > Show Strokes to display the invisible lines or press [K].

3. In the top menu, select Drawing > Clean Up > Remove Hair.
In Harmony Paint, select Drawing > Remove Hair.

The Remove Hair dialog box opens.

4. Move theHair Selection slider to the right to increase the number and length of hairs to be selected.

5. Enable theApply to All Drawings option if you want to apply the operation to all the drawings in the
layer.

6. Click on theOK button.

Related Topics

• Scanning Images
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How to Draw
As soon as Toon BoomHarmony is started, you can start to draw straight away using the default drawing layer.

How to draw:

1. In the Tools toolbar, select the Brush tool or press [Alt] + [B].

2. In the Timeline or Xsheet view, click in the first cell of the drawing layer.
In Harmony Paint, select a drawing in the Drawing panel.

3. In the Drawing or Camera view, start drawing.

4. To select a different colour, in the Colour view, select the a different colour swatch. Double-click on the
colour swatch to open the Colour Picker window andmodify the colour. Remember that anything already
painted with that colour swatch will update to the new colour.

If you are working in Database mode, refer to Locking Drawings to learn how to lock and unlock
drawings.
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Related Topics

• Adding a Colour Swatch on page 210

• Adding New Drawing Layers on page 1

• Tool Properties View on the facing page
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Tool Properties View
The Tool Properties view is where you can customize the currently selected tool. The options and operations
displayed changes according to each tool you select.

Manipulators
Manipulators are buttons which let you switch quickly between similar tools such as the Select tool and the
Transform tool or the Line, Rectangle and Ellipse tools.

Options
Options are different modes you can apply to a selected tool to modify its behaviour to fit the current task’s
needs.
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Operations
Operations are actual actions you can performwhile using the selected tool.

Related Topics

• How to Draw on page 61
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Drawing View
In Toon BoomHarmony, you can draw in the Drawing or Camera view. Although the two views are similar, when
it comes to drawing, there are some differences.

Only the selected drawing is displayed by default in the Drawing view. You can use features, such as the light
table to display the current frame drawing of all the enabled layers of your scene in washed-out colours, or the
Onion Skin to display the previous and next drawings of the currently selected drawing layer.

1. Drawing Area on the next page

2. ZoomDrop-downMenu on the next page

3. Drawing View above

4. Drawing Name on page 67

5. Tool Name on page 67

6. Current Frame on page 67

7. Cursor Coordinates on page 67

8. Colour Picker on page 67
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1. Drawing Area below

2. Drawing Name on the facing page

3. Tool Name on the facing page

4. Current Frame on the facing page

5. Cursor Coordinates on the facing page

6. Colour Picker on the facing page

Drawing Area
This is the Drawing view’s main space, it is where you draw, and where the drawings are displayed.

Zoom Drop-down Menu
The Zoommenu lets you enlarge or reduce the Camera or Drawing view display.

To make the camera frame size always match the size of your view, select the Fit to View option.
Click the drop-down arrow and select a zoom level or press [1] and [2].
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Drawing Name
TheDrawing Name field displays the name of the selected drawing, as well as the layer containing it. If the cell
does not contain any drawing, an Empty Cell text is shown in the field.

Tool Name
The Tool Name field displays the name of the selected tool. If you override a tool using an overriding keyboard
shortcut, the tool’s namewill be highlighted in red letters—seeOverride Tool on page 197 to learn how to
temporarily override a tool.

Current Frame
This field displays the current frame of the animation you are working on.

Cursor Coordinates
This indicates the position of your mouse cursor in the drawing area.

Drawing Name
Displays the name of the currently selected drawing.

Colour Picker
The Colour Picker allows you to select a colour to draw with.

Related Topics

• Camera View
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Drawing with the Brush or the Pencil

The Brush and Pencil tools are used to draw and sketch with. Both tools support pressure sensitivity,

allowing you to create lines with variable thickness. The Pencil and shape tools produce central vector lines. The
Brush tool produces contour vector lines. This means that a pencil line’s control points (used to deform its
shape) are located along the length of the central spine and the Brush line’s control points are located along the
contour.

• If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor tool.

• If you draw with the Brush tool and want to modify the thickness, use theContour Editor tool.

• You can also convert a brush zone into a pencil line with the Brush Stroke to Pencil Line option.

If you sketch a drawing using a semi-transparent colour to get a paper-like feel, you should use the Brush tool as
it produces a more realistic and natural feel. The pencil line is very useful for tracing, clean or final drawings.

Also, it is recommended to use brush lines when designing cut-out puppets’ articulations which use patches.
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Related Topics

• Drawing Using the Pencil Tool on page 73

• Drawing with the Brush Tool on page 101

• Reshaping a Drawing Using the Contour Editor Tool on page 149

• Drawing with Shapes on page 162

• Patch Articulation on page 1

• How to Draw on page 61
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Viewing the Final Lines as you Draw

Everything you draw in Toon BoomHarmony is vector-based. Although, when you draw in the Camera or
Drawing view, you will notice that your lines may be jagged, this is caused by the fast real-time display called
OpenGL.

If you prefer to see smooth lines as you draw, you can enable the antialiasing. There are two types of antialiasing
in Toon BoomHarmony:

• Full Scene Antialiasing below

• Real-Time Antialiasing on the facing page

Full Scene Antialiasing
Not available in Harmony Paint.

The Full Scene Antialiasing is generated by your computer’s graphics card. This antialiasing will not only antialias
your drawings, but all your different views in the interface.

Full Scene Antialiasing is a preference you can turn on and off. By default, the Full Scene Antialiasing preference is
disabled.

Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be
rendered out to 100% of its resolution regardless of your settings in the preferences or graphic card
panel.
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To customize the full scene antialiasing parameters:

This procedure requires that if you have a Mac OS you must restart the Harmony after you have
changed the parameters.

1. If you are usingWindows or Linux, youmust enable your graphic card’s antialiasing parameter. Refer to
your graphics card manufacturers user guide to learn how to do so. For example, the parameters for an
NVIDIAGeForce card may look like this:

2. In the Harmony, do one of the following:

‣ Windows/Linux: Select Edit > Preferences.

‣ MacOS X: Stage > Preferences.

‣ Press [Ctrl] + [U]Windows/Linux) or [⌘ ] + [U] (MacOS X).

The Preferences dialog box opens.

3. In theOpenGL tab, go to the Full Scene Antialiasing section.

‣ Enable: Select this option to enable/disable the Full Scene Antialiasing.

‣ Number or samples (For MacOS): If you are using a MacOS X computer, enter the number of
samples you want to be used for the antialiasing process. The number of samples is basically
equivalent to the amount of time a pixel will be enlarged to calculate the antialiasing. This technique is
called supersampling. The higher the number of samples, the better the antialiasing quality will be, but
the longer it will take to calculate.

4. Restart the Harmony.

Real-Time Antialiasing

It is highly recommended that you use Full Scene Antialiasing. The Real-Time Antialiasing method
is NOT RECOMMENDED as it is heavier to run than the Full Scene Antialiasing.

Real-Time Antialiasing is generated by . This means that when you draw your lines, the preview becomes
antialiased as you go. If you zoom inmore than 100% in theCamera view, pixels will start to appear. Your
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elements are still fully vector based. Only the preview becomes pixelated. Your drawings are antialiased to the
scene’s resolution.

Antialiasing is a preference you can turn on and off. By default, the Real-Time Antialiasing preference is
disabled.

This option lets you see the final result of your scene as you draw. You can change the value of the antialiasing
through the Preferences dialog box, to fit to the current zoom level used in theCamera or Drawing view or to
disable it.

Real-Time Antialiasing parameters are only valid while you work in your scene. The scene will be
rendered out to 100% of its resolution regardless of your settings in the Preferences panel.

To customize the antialiasing parameters:

1. Select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS X).
The [Ctrl] + [U]Windows/Linux) or [⌘ ] + [U] (MacOS X).

The Preferences dialog box opens.

2. In theOpenGL tab, go to the Real-Time Antialiasing section.

‣ Enable check box: Click on the Enable check box to enable or disable the Real-Time Antialiasing. The
[Ctrl] + [Alt] + [A] (Windows/Linux) or [⌘ ] + [Alt] + [A] (MacOS X).

‣ Render at this Factor Times the Scene Resolution: The default value is 1. This value corresponds to
how many times larger than the scene’s resolution you want your drawings to be antialiased. If you
zoom into your drawings to 200% you should set the value to 2.

‣ Tile Size: When the drawing is antialiased, the whole is broken into small tiles to make the process
faster. Only the tiles with artwork on are rendered out. When youmodify a zone on your drawing, only
themodified tiles are updated.

• Making the tiles too small results in sending more tiles to be rendered out, whichmakes the process
longer.

• Making the tiles too large results in sending bigger tiles out to be rendered out which is more of a strain
on the video card. Since the tiles are larger, they get updated more often because the artwork youmodify
may be one of these tiles.
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Drawing Using the Pencil Tool

The Pencil tool creates a centreline shape. Pencil lines now support pressure sensitivity and texture.

To draw with the Pencil tool:

In the Timeline or Xsheet view, select the cell on which you want to draw.
In Harmony Paint, select a drawing in theDrawing panel.

1. In the Tools toolbar, select the Pencil tool or press [Alt] + [/].

2. In the Colour view, click a colour swatch to select a colour.

3. In theDrawing or Camera view, start drawing.

‣ When you get close to an existing pencil line, hold [Alt] to draw connect your stroke to the existing
one. Pencil lines are central vector lines and youmight think your line is connected, but in fact, only the
contour is touching the other one. Also, make sure the central vector crosses the other one.
You can use the [Alt] key to connect the start of your stroke or the end of it by holding it when you
start drawing or when you finish your line.

‣ To draw a straight line, press [Shift] + [Alt] as you draw.
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Related Topics

• Pencil Tool Options below

• Drawing with the Brush or the Pencil on page 68

• Drawing with Shapes on page 162

Pencil Tool Options
When you select the Pencil tool, its properties and options appears in the Tool Properties view.
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These are the options available for the Pencil tool:

• Draw Behind on the next page

• Create Colour Art Automatically on the next page

• Auto-FlattenMode on the next page

• Auto-Close Gap on page 77

• Line BuildingMode on page 77

• Auto Adjust Thickness on page 78

• Line PushingMode on page 79

• Thickness Stencils on page 79

• Minimum andMaximum Size on page 79

• Central Line Smoothness on page 80

• Contour Optimization on page 80

• Changing the Line Shape on page 80

• Previewing the Stroke on page 81

• Pencil Line Texture on page 81
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Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint behind existing art. By default, strokes will
appear over your work until you release the tool. If you want to have live preview of your stroke in draw behind
mode, youmust activate the Realistic Preview option.

To activate Realistic Preview:

‣ From the top menu, select View > Realistic Preview.

Create Colour Art Automatically

As you draw in the Line Art layer, theCreate Colour Art Automatically automatically creates the

corresponding strokes in theColour Art layer.

Auto-Flatten Mode

When drawing on vector layers, lines do not usually become one object. The Auto-Flattenmode automatically
merges lines created with the existing ones into one single object as you draw.

When drawing on a bitmap layer, you are laying down the bare pixels, so they are always flattened. You can no
longer access the individual stroke after you draw it.

Using the Select tool, you can use the middle mouse button to select a segment of a flattened pencil
line to create a nice finish on the lines and corners of your artwork.
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Auto-Close Gap

When using the pencil tool, you can automatically close strokes with an invisible stroke.

It is recommended to keep this option enabled when drawing with the Pencil tool.

Line Building Mode

The Line Building mode is very useful when drawing long lines and curves in small increments with pencil

lines. As the pencil lines are central vector lines and it may be difficult to align the line tips perfectly to create a
uniform stroke and close all gaps.

In this mode, you can draw lines in small increments and the tip aremerge into one single stroke.

This mode only works with pencil lines.
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Auto Adjust Thickness

TheAuto Adjust Thickness tool is useful when youwant to render a portion of a line thicker. When tracing a

drawing on paper, you will often go back to a section of a curve to make it thicker to add dynamism to the line.
Using the Auto Adjust Thickness tool, you can draw highlight strokes over the section to make thicker. Once you
release the pen or themouse, the line gets thicker following the shape and curve of the original stroke. This way
is much faster and smoother than using the Pencil Editor tool. You do not have to add extra points and adjust
the position and Bezier handles.

The default overlay colour is light yellow. If this colour is difficult to see because of your background or drawing
colour, you can adjust the colour.

To change the Auto Adjust Thickness Colour:

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, select theAuto Adjust Thickness button.

3. Click the colour swatch.

The Colour Picker window opens.

4. In the Colour Picker window, select a new colour.
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Line Pushing Mode

The Line PushingMode option lets you draw highlight strokes over your existing pencil lines. You can

reshape the curves. Depending how you draw the pushing stroke over your line, the highlighted section will be
reshaped in one direction or the other.

The default overlay colour is light yellow. If this colour is difficult to see because of your background or drawing
colour, you can adjust the colour.

To change the Line PushingMode colour:

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, select the Line PushingMode button.

3. Click the colour swatch.

The Colour Picker window opens.

4. In the Colour Picker window, select a new colour.

Thickness Stencils
Toon BoomHarmony provides a variety of thickness stencils and also lets you create and save your own. It is a
good idea to create and save pencils with precise sizes and parameters when you draw and design.

A thickness stencil saves a preset of how the thickness information looks across the length of the line. When
drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order to apply the thickness
stencil.

A thickness stencil can be used while drawing, or applied afterwards.

You also have the possibility to apply different textures to your lines by either using the preset ones or importing
your own—seeWorking with TemplatesThickness Stencils on page 81

Minimum and Maximum Size
This is where you set theminimum andmaximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.



Drawing Using the Pencil Tool

80

1. Minimum Size field: Type a value in this field to set theminimumwidth of the line.

2. Maximum Size field: Type a value in this field to set themaximumwidth of the line.

3. Up/Down arrows: Use the up and down arrows to set theminimum size value.

4. Up/Down arrows: Use the up and down arrows to set themaximum size value.

Central Line Smoothness
You canmodify theCentral Line Smoothness of your line using this option. This parameter smoothes the

initial movement of your line. Increasing the value will result in a smoother line with fewer control points.

Contour Optimization
You can optimize theContour Line Smoothness of you line using this option. This parameter will smooth the
contour of your line once the line has been traced, the higher the value the less control points will compose your
line.

1. Smoothness field: Type a value to set the smoothness of the line.

2. Contour Optimization field: Type a value to set the contour optimization of the line.

3. Up/Down arrows: Use the up and down arrows to set smoothness value.

4. Up/Down arrows: Use the up and down arrows to set the contour optimization value.

Changing the Line Shape

There are several line shape to choose from. You can select how the start, end, and joints in the pencil line are
drawn.

To change the line shape:

In the Pencil Properties window, click a line shape in the Shape section and select a shape from themenu.

• Start: Make the beginning of the line round or flat.

• End: Make the end of the line round or flat.

• Join:Make joints round, mitred, or bevelled.
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Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

1. TheArrow button lets you show or hide the Preview area.

2. The Preview field is where the brush line is displayed.

Pencil Line Texture
You can apply a bitmap texture on your pencil line and adjust it as needed—see Pencil Line Texture on page 86

Related Topics

• Drawing with Line Texture on page 115

• Pencil Line Texture on page 86

• Working with TemplatesThickness Stencils below

• Drawing Using the Pencil Tool on page 73

Working with TemplatesThickness Stencils

A templatethickness stencil is a preset that already set with specific properties. There are two types of thickness
stencils.
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A template allowsRegular thickness stencils allow you to set the size and smoothing of the line or shape. As you
draw, the thickness of the line varies according the amount of pressure you use with a pen and tablet.

Thickness stencils that are indicated with this icon are also set with specific properties but disregards the
pressure you use with your pen and tablet. The line thickness varies

You can access templatesthickness stencils from the list of preset on the Tool Properties view, or create your
own.

• Selecting a Pencil TemplateThickness Stencil below

• Creating a Pencil TemplateThickness Stencil on the facing page

• Creating a Pencil TemplateThickness Stencil with the Select Tool on the facing page

• Renaming a Pencil TemplateThickness Stencil on page 84

• Deleting a Pencil TemplateThickness Stencil on page 84

• Locking a Pencil TemplateThickness Stencil on page 85

• Applying a Pencil Template on page 85

Selecting a Pencil TemplateThickness Stencil

Using the drop-downmenu, you can select an existing pencil templatethickness stencil.

To select a pencil templatethickness stencil:

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Tool Properties view, in the Pencil TemplatePresets drop-downmenu, select the
templatethickness stencil you want to use.
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3. In the Drawing or Camera view, draw your pencil line or shape.

Creating a Pencil TemplateThickness Stencil

To create a pencil templatethickness stencil:

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Tool Properties view, click theNew Pencil or New Brush button.

A new pencil template is added to the end of the list in the Pencil Template drop-downmenu.

TheNew Preset dialog box opens.

3. Enter a name for your new pencil thickness stencil and click OK.

4. Start drawing in the Camera or Drawing view.

Creating a Pencil TemplateThickness Stencil with the Select Tool

To create a pencil templatethickness stencil with the Select tool:

1. In the Tools toolbar, select the Select tool.

2. In the Camera view, select the pencil line or shape youwant to take the style from.
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3. In the Tool Properties view, click theNew Preset button.

A new pencil templatethickness stencil is added to the end of the list in the Presets drop-downmenu.

4. In the Tool Properties view, click theApply Pencil Template button to apply to the style to your

selection.

5. In the Presets drop-downmenu, select your new pencil templatethickness stencil and click on a line or
shape in the Camera view to apply the pencil templatethickness stencil you created.

Renaming a Pencil TemplateThickness Stencil

To rename a pencil templatethickness stencil:

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Presets drop-downmenu, select the pencil templatethickness stencil you want to rename.

3. Click the Rename Pencil button.From the Brushmenu, select Rename Pencil or Rename Brush,

depending on the tool you selected.

The Rename Preset dialog box opens.

4. In the Name field, type in a name for the selected pencil templatethickness stencil you are renaming.

Deleting a Pencil TemplateThickness Stencil

To delete a pencil templatethickness stencil:

1. In the Tools toolbar, select the Pencil tool.

2. In the Presets drop-downmenu, select the pencil templatethickness stencil to delete.

3. Click theDelete Preset button.
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Locking a Pencil TemplateThickness Stencil

To avoid modifying your pencil templatethickness stencil inadvertently, you can lock them by enabling the Lock
Pen option.

Applying a Pencil Template

To apply a pencil templateto a pencil line:

1. In the Tools toolbar, select the Select tool.

2. In the Camera or Drawing view, select the pencil line on which you want to apply a style.

3. In the Tool Properties view, select the style you want to apply from the Pencil drop-downmenu.

4. In the Tool Properties view, click theApply Pencil Template button to apply to the style to your

selection.

To apply a thickness stencil to a pencil line or shape:

1. In the Tools toolbar, select the Select tool.

2. In the Camera or Drawing view, select the pencil line or shape onwhich you want to apply a style.
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3. In the Tool Properties view, select the style you want to apply from the Presets list.

The style you selected is applied to your selection.

Related Topics

• Pencil Tool Options on page 74

• Shape Tool Options on page 163

• Select Tool Properties on page 130

Pencil Line Texture

You can apply a texture on a pencil line.

• Applying Texture to a Pencil Line below

• Creating a Pencil Texture Template with the Pencil Tool on page 88

• Adding a Texture to the Preferences on page 91

• Applying a Preset Texture to a Pencil Line on page 92

• Creating a Pencil Texture Template with the Select Tool on page 89

Applying Texture to a Pencil Line

Pencil lines support texture. Before drawing, you can select or import a texture and apply it to your lines. You
can also change it afterwards using the Select tool. Textures are independent from pencil templates.
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To apply a preset texture to a pencil line:

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, in the Texture drop-downmenu, select a texture.

3. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.

In the Pencil Properties property editor displays.

4. If you want your lines to have soft tips instead of hard ends, select the Soft Tip option.

5. In the Texture section, select a texture for your pencil.

6. In the Camera or Drawing view, draw your pencil line.
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Creating a Pencil Texture Template with the Pencil Tool

To create a pencil texture template with the Pencil tool:

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Tool Properties viewPencil Properties property editor, click theNew Texture button or select

New Texture from the Texturemenu.

‣ To delete a preset style, click theDelete Texture button.

4. Browse for your bitmap texture file.

The file must be a TGA or PSD. Your textureMUST HAVE an alpha channel.

5. Click Open.

The imported texture is saved in your scene texture list.

6. In the Tool Properties view, in the Texture drop-downmenu, select your new texture template.
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7. In the Pencil Properties property editor, select your new texture.

8. In the Tool Properties view, click the Rename Texture button.

9. In the Tool Properties view, click the Texturemenu and select Rename Texture.

The RenameOpacity Texture dialog box opens.

10. In theName field, type the template name and click OK.

11. If you want your lines to have soft tips instead of hard ends, select the Soft Tip option.

12. In the Camera or Drawing view, draw your pencil lines.

Creating a Pencil Texture Template with the Select Tool

To create a pencil texture template with the Select tool:

1. In the Tools toolbar, select the Select tool.

2. In the Camera view, select a pencil line on which to apply a texture.

3. In the Tool Properties viewPencil Properties property editor, click theNew Texture button or select

New Texture from the Texturemenu.

‣ To delete a preset style, click on theDelete Texture button. Note that you cannot delete the

textures stored in your preferences.

4. Browse for a bitmap texture file.
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The file must be a TGA or PSD. Your textureMUST HAVE an alpha channel.

5. Click Open.

The imported texture is saved in your scene texture list.

6. In the Tool Properties view, in the Texture drop-downmenu, select your new texture template.

7. In the Pencil Properties property editor, select your new texture template.

8. In the Tool Properties view, click the Rename Texture button.

9. In the Tool Properties view, click the Texturemenu and select Rename Texture.

The RenameOpacity Texture dialog box opens.

10. In theName field, type the template name and click OK.

11. If you want your lines to have soft tips instead of hard ends, select the Soft Tip option.

12. In the Tool Properties view, click theApply Texture button to apply to the texture to your selection.
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Adding a Texture to the Preferences

When you import a texture in your pencil styles, it is saved in your scene. If you want to add that texture to a
bank that you will be able to reuse in different scenes, you can add that texture to your preferences.

To add a texture to your preferences:

1. In the Tools toolbar, select the Pencil tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Pencil Properties property editor, select a texture from the Textures area to add to your
preferences.

4. Click theCopy to Preference button.

5. In the Tool Properties view, in the Texture drop-downmenu, select the texture you want to add to your
preferences.

The selected texture appears in the Scene preview. If the texture is already saved in your preferences, you
will see the texture in both the Scene and the Pref. previews.

6. To save the texture in your preferences, click theCopy Current Texture into Preference arrow. You can
save the texture as a new one or, if there is already a texture saved in the preference, you can override it.
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7. Youmight receive a scene from someone else or import a texture over your existing one bymistake. If you
want to override the Scene texture with the corresponding one available in your preferences, you can
click on theCopy Preference Texture into Current arrow.

Applying a Preset Texture to a Pencil Line

To apply a preset texture to a pencil line:

1. In the Tools toolbar, select the Select tool.

2. In the Camera view, select a pencil line.

3. In the Tool Properties view of the Select tool, select a texture from the Texture drop-downmenu.

4. In the Tool Properties view, select a texture from the Textures area to apply to the selected stroke.

5. If you want the selected lines to have soft tips instead of hard ends, select the Soft Tip option.
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6. In the Tool Properties view, click theApply Texture button to apply to the texture to your selection.

Related Topics

• Pencil Tool Options on page 74

• Select Tool Properties on page 130

• Drawing with Line Texture on page 115
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More Drawing Tools
Harmony offers a wide variety of useful tools to optimze your drawings and work more efficiently; tools such as
Group, Arrange, and the animation disk to rotate your workspace.

Related Topics

• Arrange below

• Convert Brush Strokes to Pencil Lines on the facing page

• Pencil Lines to Brush Strokes on the facing page

• Strokes to Pencil Lines on the facing page

• Optimize on page 96

• Remove Extra Strokes on page 96

• Reduce Drawing Texture Resolution on page 96

• Crop Brush Textures on page 97

• Create Contour Stroke on page 98

• Remove Contour Stroke on page 98

• Grid on page 98

• Group/Ungroup on page 99

• Hand on page 99

• Rotate View on page 99

Arrange
Use the different Arrange options to reorder drawing objects inside a single layer in theDrawing or Camera
view.

• Bring to Front button or select Drawing > Arrange > Bring to Front or press [Ctrl] + [Shift] + [PgUp]

(Windows/Linux) or [⌘ ] + [Shift] + [PgUp] (MacOS X).
The selected art is moved to the top.

• Bring Forward button or select Drawing > Arrange > Bring Forward or press [Ctrl] + [PgUp]

(Windows/Linux) or [⌘ ] + [PgUp] (MacOS X).
The selected art is moved one level higher.

• Send Backward button or select Drawing > Arrange > Send Backward or press [Ctrl] + [PgDown]

(Windows/Linux) or [⌘ ] + [PgDown] (MacOS X).
The selected art is moved one level lower.

• Send to Back button or select Drawing > Arrange > Send to Back or press [Ctrl] + [Shift] +

[PgDown] (Windows/Linux) or [⌘ ] + [Shift] + [PgDown] (MacOS X).
The selected art is moved to the bottom.
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Convert Brush Strokes to Pencil Lines

The Brushes Strokes to Pencil Lines operation converts the selected contour strokes into centreline pencil

strokes. This command is only available from the top menu.

To convert brush strokes to pencil lines:

‣ Select Drawing > Convert > Brush Strokes to Pencil Lines or press [^].

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Pencil Lines to Brush Strokes

The Pencil Lines to Brush Strokes operation converts the selected centreline pencil strokes into contour

strokes brush lines.

To convert pencil lines to brush strokes:

‣ From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes or press [&].

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Strokes to Pencil Lines

The Strokes to Pencil Lines operation converts the selected invisible line to a pencil line.
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To convert strokes to pencil lines:

‣ Select Drawing > Convert > Strokes to Pencil Lines. or press [Shift] + [F12] (Windows/Linux only).

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Optimize

TheOptimize command reduces the number of layers, such as overlapping brush strokes, in the selected
drawing objects. Drawing objects will only be flattened and optimized if the selected objects will not change the
appearance of the final imagewhen they aremerged.

For example, if you have selected a number of partially transparent objects, which you layered to create an
additive colour effect, the selected transparent drawing objects will not bemerged. This is becausemerging the
transparent drawing objects will cause them to lose the effect of the layered transparent colours.

• Use the Select tool to select the drawing objects you want to optimize.

• Select Drawing > Optimize > Optimize.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Remove Extra Strokes
The Remove Extra Strokes option is used to remove the invisible lines in your selection.

• Use the Select tool to select the drawing objects you want to remove invisible lines from.

• Select Drawing > Optimize > Remove Extra Strokes.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Reduce Drawing Texture Resolution
If you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be heavy.
This option is used to reduce the size and resolution of the textures in your drawing. When you import and
vectorize drawings using the grey or colour preset styles, you don't have control on the size of the bitmap
texture. This tool allows you to reduce that bitmap texture.
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To reduce the drawing texture resolution:

• In the Timeline or Xsheet view, Select tool to select the drawing objects you want to reduce the texture
resolution for.remove invisible lines from.

• Select Drawing > Optimize > Reduce Drawing Texture Resolution.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

1. In the dialog box, drag the slider toward the left to reduce the texture resolution.

2. Enable theApply to All Drawings option if you want themodification to be applied to all the drawings in
your layer.

3. Click OK.

Crop Brush Textures

TheCrop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies, unseen,
beneath the vector contour of a textured line. This often occurs when you cut and paste textured lines from one
drawing into another. If you cut a portion from a textured line and paste it into a different drawing, Toon Boom
Harmony pastes the entire unseen texture bitmap from the source drawing into the new one, even if you only
took a small portion of the source drawing. Using theCrop Brush Texture command will crop away extraneous
texture that does not touch the vector area. If there aremany textured lines in your scene, this will greatly reduce
the file size.

In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At first
glance, it appears as if only a cropped section of the underlying texture bitmap was cut and pasted as well.
However, using theContour Editor tool to expand the vector envelope of the textured line, it is revealed that
more texture bitmap exists beyond the cropped boundary. If you use theCrop Brush Texture command the
bitmap texture is cropped to the boundaries of the textured line’s vector contour (as seen in the fourth image
where the vector envelope has been pulled out to reveal empty space).

To crop the brush texture:

1. In the Timeline or Xsheet view, select the drawing youwant to crop the texture for.

2. Select Drawing > Optimize > Crop Brush Textures.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.
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Create Contour Stroke
TheCreate Contour Stroke option is used to add a permanent invisible line around a shape that was drawn

directly in the application. This allows you to unpaint your lines with the Paint tool but to maintain the shape

of the lines should you need to repaint later.

This command is useful when inking and painting and using theApply to All Drawings in Layer option.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Remove Contour Stroke
The Remove Contour Stroke option is used to remove any permanently invisible lines that were either created
while scanning and vectorizing drawings or manually adding contour strokes. This is useful if you want to remove
the intersection triangles created during vectorization.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Grid

Use the Show Grid option to display a grid in theDrawing or Camera view.
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• Select View > Grid > Show Grid. The [Ctrl] + ['] (Windows/Linux) or [⌘ ] + ['] (MacOS X).

• Select View > Grid > Square to display a standard square grid.

• Select View > Grid > 12 Field Grid to display a 12 field size grid.

• Select View > Grid > 16 Field Grid to display a 16 field size grid.

• Select View > Grid > Underlay to display the grid behind the drawing elements.

• Select View > Grid > Overlay to display the grid over the drawing elements.

Group/Ungroup
Use theGroup option to group the selected drawing objects. This can help in the selection, repositioning,

re-scaling and other transformations to be applied to multiple objects of a drawing.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

• Select Edit > Group > Group or Edit > Group > Ungroup.

• Press [Ctrl] + [G] and [Ctrl] + [Shift] + [G] (Windows/Linux) or [⌘ ] + [G] and [⌘ ] + [Shift] + [G] (MacOS X).

Hand
Use theHand tool to pan through theDrawing and Camera view.

• In the Tools toolbar, select theHand tool, click in theDrawing or Camera view and drag your cursor.

• You can also Hold down the keyboard shortcut [Spacebar], click in theDrawing or Camera view and
move your mouse in the direction you want to pan the view.

Rotate View
Use the Rotate View tool to rotate theDrawing or Camera view, the sameway as you would do with a real

animation disc.

• Select Drawing > Tools > Rotate View.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

• Press [Ctrl] + [Alt] (Windows/Linux) or [⌘ ] + [Alt] (MacOS X).
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This tool can also be used in the Perspective view.

Related Topics

• How to Draw on page 61
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Drawing with the Brush Tool

The Brush tool is pressure sensitive and can create a contour shapewhich gives a thick and thin line effect, as

if the drawing was madewith a brush.

To draw with the Brush tool:

1. In the Timeline or Xsheet view, select the cell on which you want to draw.
In Harmony Paint, select a drawing in theDrawing panel.

2. In the Tools toolbar, select the Brush tool or press [Alt] + [B].

3. In the Colour view, click a colour swatch to select a colour.

4.

5. In the Drawing or Camera view, start drawing.

‣ Hold [Ctrl] (Windows/Linux) or [⌘ ] (MacOS X) to force a line to join the end and start of your shape
while drawing.
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The last colour you select while using the Brush tool is recalled the next time you select the Brush
tool.

Related Topics

• Brush Tool Options below

Brush Tool Options
When you select the Brush tool, its properties and options appear in the Tool Properties view.
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These are the options available for the Brush tool:

• Normal BrushMode below

• Draw Behind on the facing page

• Repaint BrushMode on the facing page

• Create Colour Art Automatically on the facing page

• Auto-FlattenMode on page 106

• Respect Protected Colour on page 106

• Use Stored Colour Gradient on page 106

• DrawingMagnifier on page 106

• Brush Styles on page 107

• Dynamic Brush on page 107

• Minimum andMaximum Size on page 107

• Central Line Smoothness on page 107

• Contour Optimization on page 108

• Brush Tips on page 108

• Preview on page 108

• Line Texture on page 108

Normal Brush Mode
TheNormal Brush Mode creates contour lines as you draw, adding each brush lines on top of the last ones.

Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

Maximum Size and Smoothing
This is where you set theminimum andmaximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

‣ Maximum andMinimum Size: Defines themaximumwidth of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.
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Brush Presets
Brush presets are created by saving the properties of the current brush to a new preset, which you can reuse for
repeated tasks. You can create as many brush presets as you need.

Draw Behind

When theDraw Behind mode is enabled, the lines you draw will appear behind the art that already exists.

Repaint Brush Mode

The Repaint Brush is used to repaint zones that have already been painted, it will not affect empty zones or

pencil lines. It also automatically flattens each of its brush lines so it does not add new brush lines on top of
existing ones. You can use this mode to paint tones or highlights onto your character.

Create Colour Art Automatically

As you draw in the Line Art layer, theCreate Colour Art Automatically automatically creates the

corresponding strokes in theColour Art layer.



Drawing with the Brush Tool

106

Auto-Flatten Mode
When enabled, theAuto-Flattenmode automatically flattens the new lines created with the existing artwork as
you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.

Respect Protected Colour
The Respect Protected Colour option prevent the colours youmarked as protected in theColour view to

be repainted using the Repaint Brushmode or any of the painting tools.

Refer to Protecting Colours on page 250 to learn how to use the Protect Colour feature.

Use Stored Colour Gradient
TheUse Stored Colour Gradient optionmakes your tool use the previously stored gradient position. This

way, every new brush line or colour fill will use the stored gradient position.

Refer to Storing Your Favourite Gradient or Texture Settings on page 245 to learn how to use the
Store Colour Gradient option.

Drawing Magnifier

TheDrawingMagnifier tool allows you to magnify portions of your drawing. When this option is enabled,

you can hover over your drawings to see a close up of your lines in theMagnifier box.
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This feature only works in the Drawing view.

To adjust the settings for the DrawingMagnifier:

1. In the top menu, select Edit > Preferences > Drawing.

2. Adjust theMagnifierwindowWidth, Height, X-Axis Offset, Y-Axis Offset, and Zoom Factor.

Brush Styles
A variety of brush styles are provided allowing you to create and save your own. This way you can create brushes
with precise sizes and parameters and save them so you can draw and design—see Brush Styles on page 109

Dynamic Brush
ADynamic Brush can be created to allow you to draw using patterns created from your artwork—see

Dynamic Brush on page 112

Minimum and Maximum Size
This is where you set theminimum andmaximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

1. Minimum Size field: Type a value in this field to set theminimumwidth of the line.

2. Maximum Size field: Type a value in this field to set themaximumwidth of the line.

3. Up/Down arrows: Use the up and down arrows to set theminimum size value.

4. Up/Down arrows: Use the up and down arrows to set themaximum size value.

Central Line Smoothness
You canmodify theCentral Line Smoothness of your line using this option. This parameter smoothes the

initial movement of your line. Increasing the value will result in a smoother line with fewer control points.
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Contour Optimization
You can optimize theContour Line Smoothness of you line using this option. This parameter will smooth the
contour of your line once the line has been traced, the higher the value the less control points will compose your
line.

1. Smoothness field: Type a value to set the smoothness of the line.

2. Contour Optimization field: Type a value to set the contour optimization of the line.

3. Up/Down arrows: Use the up and down arrows to set smoothness value.

4. Up/Down arrows: Use the up and down arrows to set the contour optimization value.

Brush Tips

In this drop-downmenu, you can find a variety of tip shapes from round and square ones to star shaped, select
the one you need.

Preview
The Preview field lets you see a preview of the style that will be produced after you customize the different
parameters in the Tool Properties view.

1. TheArrow button lets you show or hide the Preview area.

2. The Preview field is where the brush line is displayed.

Line Texture
In Toon BoomHarmony, you can draw with a textured line. Textured lines are a mixed bitmap image contained
in a vector frame. This allows you to sketch as if you are drawing on paper.

Refer to the Drawing with Line Texture on page 115 topic to learn everything about line texture and
its parameters.
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Related Topics

• How to Draw on page 61

• Drawing with the Brush Tool on page 101

• Drawing with Line Texture on page 115

• Working with TemplatesThickness Stencils

Brush Styles

You can create your own brush styles.

• Selecting a Brush Style below

• Adding a Brush Style on the next page

• Renaming a Brush Style on page 111

• Deleting a Brush Style on page 111

• Locking a Brush Style on page 112

Selecting a Brush Style

A variety of brush styles are provided allowing you to create and save your own.This way you can create brushes
with precise sizes and parameters and save them so you can draw and design.

To select a brush style:

1. Click the arrow button to get the Brush Style drop-downmenu.

2. Select a brush style from the list.
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To select a brush style:

• In the Tool Properties, select a brush style from the Brush Presets section.

Adding a Brush Style

To create a brush style:

‣ Click the Add Brush Style button.

The new brush style appears at the end of the Brush Styles drop-downmenu list.

To create a brush preset:

Make sure your current brush has the settings you would like in your preset.

3. Do one of the following:

‣ In the Brush view, click the New Brush button.

‣ From the Brush menu, select New Brush Preset.

‣ In the Properties window of the tool you are using, click the button in the upper-left corner—see

Viewing Tool Properties on page 1.

4. In the New Preset window, type a name for your new brush preset.
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The new brush is added to the end of the list of brush preset.

Brush presets cannot be updated. However you can select a preset, which applies those properties
to the current brush. Then you can modify the properties, and create a new preset with the new
properties. If desired, you can delete the old preset.

Renaming a Brush Style

To rename a brush style:

1. Click the arrow button of the Brush Style drop-downmenu.

2. Select the brush style you want to rename.

3. Click the Rename Brush Style button.

The Rename Pen dialog box opens.

4. Type in a name for the selected brush style and click OK.

Renaming a brush canmake it easier to identify and access the brushes you usemost frequently.

To rename a brush:

1. In the Tool Properties view, select a brush to rename.

2. From the Brush menu, select Rename Brush.

3. Type in a new name for the brush.

Deleting a Brush Style

To delete a brush style:

1. In the Tools toolbar, select the Brush tool.

2. In the Tool Properties view, in the Brush Style drop-downmenu, select the brush style you want to delete
from the Brush Style list.

3. Click theDelete Brush Style button.

To delete a brush preset:

1. Select the brush preset you want to delete.

2. Do one of the following:
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‣ In the Brush Preset view, click the Delete Brush button.

‣ From the Brush Preset menu , select Delete Brush.

Locking a Brush Style

To avoid modifying your brush style inadvertently, you can lock them by clicking the Lock Brush Settings

button.

Related Topics

• Brush Tool Options on page 102

Dynamic Brush

ADynamic Brush can be created to allow you to draw using patterns created from your artwork. Create a

new Dynamic Brush to copy a pattern you have drawn to reproduce it quickly. You can create dynamic brushed
using either a single pattern or a multiple one that will automatically switch through the patterns as you draw.

To create a new dynamic brush:

1. In the Tools toolbar, select a drawing tool.

2. In the Drawing or Camera view, draw the pattern you want to use as your Dynamic Brush stamp.

3. In the Tools toolbar, click the Select tool and select the parts of the drawing youwant to repeat.

4. In the Tools toolbar, select the Brush tool.

5. In the Tool Properties view, click theAddDynamic Brush button to add your selection as a new

dynamic brush preset.

6. Click the Rename Brush Style button.From the Brushmenu, select Rename Brush.
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The Rename Pencil Rename Preset dialog box opens.

7. Type in a name for the new dynamic brush and click OK.

8. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.

9. To adjust the scale of your pattern to make it bigger or smaller as you stamp it, you can change the Scale
value in the Tool Properties view.

To create a dynamic brush with multiple drawings:

1. In the Timeline view, click theAddDrawing Layers button to create as many layers as patterns you

want in your dynamic brush. It is recommended to rename your layers.

2. In the Camera view, draw your individual pattern on a separated layer.

3. In the Tools toolbar, select the Select tool.

4. In the Camera view, select all the drawings you want to add to your new dynamic brush.
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5. In the Tools toolbar, select the Brush tool.

6. Click theAddDynamic Brush button to add your selection as a new Dynamic Brush preset.

7. Click the Rename Brush Style button.From the Brushmenu, select Rename Brush.

The Rename Pencil Rename Preset dialog box opens.

8. Type in a name for the new dynamic brush and click OK.

9. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern. When
you use this brush, you will cycle through the drawings.

Related Topics

• Brush Tool Options on page 102
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Drawing with Line Texture

In Toon BoomHarmony, you can use the Brush tool to draw with bitmap textured lines.

In the Brush Tool Properties view, you will find a series of default textured brushes but you can also create your
own collection by importing either PSD or TGA files in the Pen list.

The textured brush only work with the Brush tool. It does not work with the Pencil, Line, Ellipse,
Polyline or Rectangle tools.

Related Topics

• How to Draw with Texture below

• Adjusting the Line Texture Parameters on page 118

• Creating Texture Brushes on page 120

• Erasing Textured Lines on page 122

• Hiding the Line Texture on page 124

• Adjusting the Line TextureOpacity on page 125

How to Draw with Texture
To draw with textured lines, use the Brush tool and the correct pen in the list. You can also draw with pencil line
texture—see Pencil Line Texture on page 86

To draw with textured lines:

1. In the Tool toolbar, select the Brush tool or press [Alt] + [B].
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2. In the Tool Properties view, select a textured brush from the Pen drop-down list.

3. In the Camera or Drawing view, start drawing.

To draw with textured lines:

1. In the Tools toolbar, select the Brush tool or press [Alt]+[B].

2. In the Tool Properties view, select a brush and click the Arrow button to open the Brush Properties view.

3. In the Texture section, select the Select Texture option.
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4. Set the following parameters:

‣ Hardness: The hardness value corresponds to the smoothness of the line edge. The lower the value,
themore blurry and smooth the line edgewill be. The higher the value, the sharper the line edgewill
be.

‣ Minimum Opacity: This value corresponds to the transparency of the brush when the pressure is very
light. Values closer to 0 produce a more transparent line.

.

‣ Maximum Opacity: This value corresponds to the transparency of the brush when the pressure is
heavy. Values closer to 1 produce a more opaque line.

‣ Select Texture: Lets you use and select a texture for your brush. The thumbnail displays the texture
currently in use. You can also browse for a texture file to import. Browsing for a texture file in a brush
already using texture will replace the file currently in use, although it will not replace the texture in the
lines already drawn.
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‣ Texture Scale: Changes the size of the texture in the lines you draw. If you are using a plaid texture,
the squares will be larger if you increase the value and smaller if you decrease it.

5. In the Camera or Drawing view, start drawing.

Related Topics

• Drawing with the Brush Tool on page 101

• Pencil Line Texture on page 86

Adjusting the Line Texture Parameters
In the Brush Tool Properties view, there are a number of parameters you can use to adjust the look and feel of
your textured brush.
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1. Enable Texture: When selected, allows your brush to draw with texture. When deselected, the brush will
trace fully vector based lines.

2. Minimum Opacity: This value corresponds to the opacity of the brush when the pressure is very light. The
closer to zero the value is, themore transparent the line will be.

.

3. Maximum Opacity: This value corresponds to the opacity of the brush when the pressure is heavy. The closer
to 1 the value is themore opaque the line will be.

4. Hardness: The hardness value corresponds to the smoothness of the line edge. The lower the value, themore
blurry and smooth the line edgewill be. The higher the value, the sharper the line edgewill be.

5. Texture File: The Texture File button displays the texture currently in use or allows you to browse for a
texture file to import. Browsing for a texture file in a brush already using texture will replace the file currently in
use, although it will not replace the texture in the lines already drawn.

6. Texture Scale: This value changes the size of the texture file in the line. If you are using a plaid texture, the
squares will be larger if you increase the value and smaller if you decrease it.
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Related Topics

• Drawing with Line Texture on page 115

Creating Texture Brushes
To create your own texture brush, youmust prepare your texture file in a third-party software, such as Adobe
Photoshop. If your image has transparency in it, it will be supported. The texture file must be either a PSD or
TGA file.

It is recommended that you maintain your texture resolution between 100 x 100 pixels and 400 x
400 pixels.

To create your own texture brush:

1. In the Tools toolbar, select the Brush tool or press [Alt] + [B].

2. In the Tool Properties view, click theNew Brush button to add a new brush to your list.

In the Texture section, select the Enable Texture option.

3. Click the Texture File button and browse for your bitmap texture file.
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The image colour will not be used, only the pattern in it.

4. In the Camera view, draw some lines and adjust the parameters to fit the style you are looking for. Note:
your pen list will be automatically saved.

To create your own texture brush, youmust prepare your tiled texture file in a third-party software, such as
Adobe Photoshop. If your image has transparency in it, it will be supported. The texture file must be either a
.PSD or .TGA file.

It is recommended that you maintain your texture resolution between 100 x 100 pixels and 400 x
400 pixels.

To create a texture brush:

1. In the Tools toolbar, select the Brush tool or press [Alt]+[B].

2. In the Texture section, do one of the following:

‣ On a bitmap layer, select the Textured Tip option and then select the Select Texture option.

‣ On a vector layer, select the Select Texture option.

3. In the Texture section, select the Select Texture option.

4. Click the Folder button and browse for a bitmap texture file.

5. In the Tool Properties view, click the New Brush button to add a new brush to your list.

The colour of your texture will not be used. Instead, the dark and light areas will be used to
determine the alpha in your texture. The current colour swatch will be used in conjunction with the
pattern and alpha in your texture.

6. In the StageCamera or Drawing view, draw some lines and adjust the parameters to fit the style you are
looking for.
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Related Topics

• Drawing with Line Texture on page 115

Erasing Textured Lines
When you use the Eraser tool to erase a portion of a textured line, the vector frame is cut straight and you lose
the feather created while drawing with the Brush tool. In Toon BoomHarmony, a special option in the Eraser

tool lets you create a soft edge on your textured lines. You can also cut or keep the vector frame as is.

To erase textured lines:

1. In the Tools toolbar, select the Eraser tool, press [Alt] + [E].

2. In the Tool Properties view, select theUse Blur Parameters option.

3. While erasing, select theKeep Vectors option to keep your vector frames and not cut them.

4. AdjustMinimum Opacity andMaximum Opacity parameters of the eraser to change the transparency of
the erasing trail as you press harder on the pen tablet.

5. Adjust theHardness and Eraser Saturation parameters of the eraser to control the amount of
smoothness and the size of the feather edge.

6. In the Camera or Drawing view, erase your textures lines.

7. In the Tool Properties view, click the arrow button.
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The Brush Properties panel opens.

8. Adjust the following:

‣ Maximum/Minimum Size: Defines theminimum andmaximumwidth of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.

‣ Contour Smoothing: Defines the number of control points added to the contour boundaries (around
the line). Lower values mean that the line will appear as you draw it (withmore control points added
along the centre line). Higher values mean that the line will be smoothed out (removing control points
from the centre line).

‣ Tip Shape: Lets you select a shape for the tip of the eraser. There are a variety of tips to choose from:
round, square, oval, star-shaped andmore.

‣ Soft Tip: Gives the tip of your stroke a soft edge.

‣ Keep Vectors: Keeps your vector frames and does not cut them.

‣ Hardness: The hardness value corresponds to the smoothness of the line edge. The lower the value,
themore blurry and smooth the line edgewill be. The higher the value, the sharper the line edgewill
be.
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‣ Saturation: Corresponds to the intensity of line color.

‣ Maximum Opacity: Corresponds to the transparency of the brush when the pressure is heavy. Values
closer to 1 produce a more opaque line.

‣ Minimum Opacity: Corresponds to the transparency of the brush when the pressure is very light.
Values closer to 0 produce a more transparent line.

9. In the Camera or Drawing view, erase your textures lines.

Related Topics

• Drawing with Line Texture on page 115

Hiding the Line Texture

Sometimes you need to hide the line texture to see the complete vector frame around your lines. This is useful to
help you see any dirt floating around your drawing.

To hide the line texture, you must deselect the Real-Time Antialiasing option. In the top menu,
select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X) and in the OpenGL
tab, deselect the Enable option in the Real-Time Antialiasing section. The default shortcut is [Ctrl] +
[Alt] + [A] (Windows/Linux) or [⌘ ] + [Alt] + [A] (Mac OS X).

To hide the line texture in the Camera view, you must enable the Show Drawing on Top option. In
the top menu, select View > Show > Current Drawing on Top. Refer to the Show Current Drawing
on Top on page 1 section to learn more about this option.

To hide the line texture:

1. Make sure the real-time antialiasing is deselected. If you are in the Camera view, select the Show Current
Drawing on Top option.
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2. In the Camera or Drawing View menu, select View > Show > Hide Line Texture or press [Ctrl] +

[Shift] + [H] (Windows/Linux) or [⌘ ] + [Shift] + [H] (MacOS X).

Related Topics

• Drawing with Line Texture on page 115

Adjusting the Line Texture Opacity

At some point, youmay want to modify the look of a textured drawing. Maybe you find that your line is too
smooth or too faint. You can adjust those parameters by using theAdjust Line Texture Opacity command.

To adjust the line texture, you must deselect the Real-Time Antialiasing option. In the top menu,
select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X) and in the OpenGL
tab, deselect the Enable option in the Real-Time Antialiasing section. The default shortcut is [Ctrl] +
[Alt] + [A] (Windows/Linux) or [⌘ ] + [Alt] + [A] (Mac OS X).

To be able to adjust the line texture in the Camera view, you must select the Show Drawing on Top
option. In the top menu, select View > Show > Current Drawing on Top.

Refer to the Show Current Drawing on Top on page 1 section to learn more about this option.

To adjust the line texture opacity:

1. Make sure that real-time antialiasing is deselected. If you are inCamera view, select the Show Current
Drawing on Top option.

2. In the Timeline or Xsheet view, select the drawing whose opacity you want to adjust.

3. In the Camera or Drawing view menu, select Drawing > Adjust Line Texture Opacity.

The Adjust Line TextureOpacity dialog box opens.
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4. Drag the sliders toward themiddle to increase the contrast and opacity of the textured lines.

5. If you want to apply the changes to all drawings exposed on the layer, select theApply to All Drawings
option and click OK.

Related Topics

• Drawing with Line Texture on page 115
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Selecting Drawing Objects

The Select tool is used to select drawing strokes in both the Drawing and Camera views, and apply basic

transformations, such as repositioning, rotating, scaling or skewing, using the different handles of the bounding
box.

To select with the Select tool:

1. In the Timeline view, select the cell on which you want to select drawing objects.
In Harmony Paint, select a drawing in theDrawing panel.

2. In the Tools toolbar, select the Select tool or press [Alt] + [S].

3. In theCamera or Drawing view, select the drawing objects.

‣ You can select all the drawing objects in a drawing by using the Select All command or press [Ctrl] +
[A] (Windows/Linux) or [⌘ ] + [A] (MacOS X).

4. To deform or reposition a selection:

‣ To reposition, click on the selected drawing object and drag the selection to a new area.

‣ To rotate, grab the selection box handle and rotate it.
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‣ To scale, pull or push either on the top, side, bottom or corner control point. Hold down [Shift] to lock
the selection’s ratio.

‣ To skew, drag sideways or up and down the sides or top and bottom segments, between the control
points.

Inverting a Selection
Not available in Harmony Paint.

Sometimes, when youwant to select multiple objects, while leaving one unselected, it can be handy to select only
the stroke, or line, that you do not want included in your selection. Then, you can invert that selection so that
everything else becomes selected. This can be quite a time saver.

To invert a selection:

1. From the top menu, select Edit > Invert Selection or press [Ctrl] + [Shift] + [I] (Windows/Linux) or [⌘ ] +
[Shift] + [I] (MacOS X).
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You can also find the Invert Selection option in the Camera View or Drawing View menu by
selecting Edit > Invert Selection.

Related Topics

• Repositioning a Pivot Point below

• Selection on Single or Multiple Layers on the next page

• Select Tool Properties on the next page

Repositioning a Pivot Point
Some of the transformations such as rotation, scale, skew and flip, are done relative to the position of the pivot
point. You can temporarily reposition this pivot point for a transformation using the Select tool.

To temporarily reposition the pivot point:

1. In the Camera or Drawing view, select the drawing object you want to transform.

The pivot point appears in themiddle of your selection.

2. Click the pivot point and drag it to a new position.

This becomes the new position of the pivot point for the current transformation and will remain there until
youmake a new selection.
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Related Topics

• Selecting Drawing Objects on page 127

• Select Tool Properties below

Selection on Single or Multiple Layers

By default, when you draw a selection box in the Camera view, the Select tool will select all the drawing strokes
and symbols in its path. If you would prefer the Select tool to only select the current drawing and not the other
visible drawings, you can enable the Select Tool Works on Single Drawing preference.

To enable the Select ToolWorks on Single Drawing preference:

1. In the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS X).

The Preferences dialog box opens.

2. In the Camera tab, go to the Tools section and select the Select ToolWorks on Single Drawing
preference and click OK.

3. In the Tools toolbar, select the Select tool or select [Alt] + [S].

4. In the Camera view, select your drawing.

Related Topics

• Selecting Drawing Objects on page 127

• Select Tool Properties below

Select Tool Properties
When you choose the Select tool, its properties and options appear in the Tool Properties view.
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Related Topics

• Manipulators on the facing page

• Lasso andMarquee on the facing page

• Snap Options on the facing page

• Permanent Selection on page 134

• Apply to All Drawings in Layer on page 135

• Apply to All Visible Drawings on page 135

• Apply to Line and Colour Art on page 135

• Select by Colour on page 136

• Flip Horizontal and Vertical on page 136

• Rotate 90 Degrees CW and CCW on page 137

• Pencil to Brush on page 137

• Smooth on page 137

• Flatten on page 138

• Store Colour Gradient on page 138

• Merge Pencil Lines on page 138

• Reverse Pencil Thickness on page 139
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• Create Colour Art from Line Art on page 139

• Distribute to Layers on page 140

• Width and Height on page 140

• Offset X and Y on page 141

• Angle on page 141

• Adjusting the Pencil Line Thickness on page 141

• Adjusting the Pencil Line Style on page 141

• Pencil Stencils on page 142

• Adding Texture to a Pencil Line on page 142

• Adjusting the Text Selection on page 142

Manipulators
Choose between the Select tool and the Transform tool. This is a fast way to switch between the Select tool
and Transform tool selectionmode.

Lasso and Marquee
Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold [Alt] to temporarily switch from the current mode to the other.

Snap Options
You can enable different snapping modes to help you when repositioning your drawings using the Select tool.

• Snap to Contour: Snaps your selection or point to any line you position it on. As soon as youmove it

close enough to another line, your point or selection will snap to it.

• Snap andAlign: Snaps the selected anchor point to any existing line while displaying temporary

rulers as a guide that you can also snap your anchor point to.

• Snap to Grid: Snaps your selection following the currently enabled grid.
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To snap to grid:

• Select View > Grid > Show Grid to display the grid in theCamera or Drawing view or press [Ctrl] + [']
(Windows/Linux) or [⌘ ] + ['] (MacOS X).

• Select View > Grid > Square Grid, 12 Field Grid or 16 Field Grid for your current needs.

1. In the Tools toolbar, select theContour Editor tool or press [Alt] + [Q].

2. In the Contour Editor Tool Properties view, click the Snap to Grid button.

3. In the Camera or Drawing view, click on an anchor point you want to snap following the grid, and drag it
to the desired position and release.

Refer to the Grid on page 202 topic to learn more about the Grid feature.

Permanent Selection

The Permanent Selection option is used to maintain a selection over multiple drawings. Once this option is

enabled, the selection zonemade using the Select tool will remain as you navigate through drawings from a
layer and drawings from other drawing layers. This option can be used to simultaneously delete artwork inside
or outside of the selection on several drawings when combined with theApply toMultiple Drawings option.
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Apply to All Drawings in Layer

TheApply to All Drawings in Layer option is used to perform an action on all the drawings contained in a

layer. For example, you could enable the option to paint a section on all the drawings simultaneously. TheApply
Tool to All Drawings optionmust be activated before performing the action and will stay enabled only for the
next action.

Apply to All Visible Drawings

TheApply to All Visible Drawings option is used to perform an action on all the visible drawings in the

Camera view. This option is not available in the Drawing view.

Apply to Line and Colour Art
TheApply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use this option

to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art layers, as well as the
Overlay and Underlay layers.

To access the Apply to Line and Colour Art option, you must be in the Advanced Art mode—see
Drawing View on page 65.
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Select by Colour

The Select by Colourmode lets you select all the zones in your drawing painted with the same colour.

Only the zones painted with the SAME colour swatch will be selected. If another zone is coloured
with the exact same RGB value (same colour), but not painted with the same colour swatch, it will not
be selected.

To select areas by colour:

1. In the Tools toolbar, select the Select tool or press [Alt] + [S].

2. In the Tool Properties view, click the Select by Colour button.

3. In the view, click on any zone in your drawing.

All zones of the same colour are selected.

4. Click the Select tool again to return to the regular Select mode.

Flip Horizontal and Vertical
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The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or vertically.

From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current selection 90

degrees clockwise or counter-clockwise.

From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees CCW.

Or press [Ctrl] + [7] and [Ctrl] + [9] (Windows/Linux) or [⌘ ] + [7] and [⌘ ] + [9] (MacOS X).

Pencil to Brush

The Pencil to Brush operation converts the selected centreline pencil strokes into contour strokes brush

lines.

From the top menu, select Drawing > Convert > Pencil Lines to Brush or press [&].

Smooth

The Smooth operation lets you smooth out selected drawing strokes and remove extra points. You can also

access this feature through the top menu, by selectingDrawing > Optimize > Smooth or press [Alt] + [Shift] +
[S].
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Flatten

The Flatten operation is used to merge drawing objects and brush strokes into a single layer. If you draw

new lines to fix a drawing or a line withmany brush strokes, it can be useful to flatten them all into a single shape.
By default, lines are drawn one on top of each other, if you intend repainting the lines or modifying their shape, it
will be easier if they are flattened.

You can also access this feature through the top menu, by selectingDrawing > Optimize > Flatten. The [Alt] +
[Shift] + [F].

Store Colour Gradient
Use the Store Colour Gradient operation to record the selected gradient’s position. This reuses the stored

position of the gradient when drawing new brush lines or painting colour zones. Enable theUse Stored Colour
Gradient option in the Paint or Brush Tool Properties view to do this.

Refer to Drawing with the Brush Tool on page 101 or Painting Using the Paint Tool on page 223 to
learn how to use the Use Stored Colour Gradient option.

Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align them and
make it look like it is one single line. With the Select tool, you can select several pencil lines and merge them as
one single object using theMerge Pencil Lines option. It will take your lines and adjust the ends to form one

single line.
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Points have to be close enough to be merge. If there is a big gap between the lines, they will not be
merged.

Reverse Pencil Thickness

The Reverse Pencil Thickness option will invert the thick and thin section on a selected pencil line. This

option will take the thickest size on the line and apply it to the thinnest, and it will apply the thinnest to the
thickest.

Create Colour Art from Line Art
You can configure theCreate Colour Art from Line Art option to suit your requirements.

To access this option, you must be in the Advanced Art mode—see Drawing View on page 65.

To configure the Create Colour Art from Line Art option:

1. In the Select tool Tool Properties view, [Shift] + click theCreate Colour Art from Line Art button.

The Configure Line Art to Colour Art dialog box opens.

‣ Use rendered version of the drawing: This option will render the drawing and vectorize it to
calculate the position of the centreline that will produce the colour art stroke.
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‣ Maximum Resolution for rendered image: The size of the rendered image.

‣ Threshold for rendered image: The value of grey processed to create the rendered vectorized arts.

‣ Fitting error for rendered beziers: This value represents how precise the fitting of the colour art zone
in relation to the line art will be.

‣ Source layer: Select the layer (Line Art, Colour Art, Underlay orOverlay) you want the colour art to
be created from.

‣ Destination layer: Select the layer (Line Art, Colour Art, Underlay orOverlay) you want the colour
art to be created on.

‣ Clear Destination Art Layer First: Enable this option if you already have artwork on the destination
layer and youwant the content to be deleted before the colour art is added into it.

‣ Perform Line Art to Colour Art Operation Immediately: Enable this option to perform theCreate
Colour Art from Line Art command when you click OK.

Refer to Line Art and Colour Art Layers on page 253 to learn more about the Line Art and Colour
Art concept.

Distribute to Layers
TheDistribute to Layers option is used to separate the selected art strokes and send them to new drawing

layers. In the Camera view, once you have drawn your artwork, you can select the strokes you want to distribute
using the Select tool and click on theDistribute to Layer button, you can also select Drawing >

Distribute to Layer. It will automatically take every stroke from the drawing selectionmade in theCamera view
and separate them into a different layer for each. If an artwork is composed of several strokes, youmust group
them using Edit > Group > Group before using theDistribute to Layer option. This option cannot be done from
theDrawing view.

Refer to Break Down: Distribute to Layers to learn more about the Distribute to Layer option.

Width and Height
Use theWidth andHeight operation fields to enter specific values to resize the selected shapewith precision.

1. Width: Type a width value in this field to resize the width of your selection.

2. Height: Type a height value in this field to resize the height of your selection.

3. Up/Down arrows: Use the up and down arrows to modify the value contained in either theWidth or
Height value field.
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4. Lock icon: Click on the lock icon to lock or unlock the ratio between the width and height values.

Offset X and Y
Use theOffset X andOffset Y operation fields to enter specific values and precisely reposition the selected
shape.

1. X: Type an offset value in this field to reposition your selection along the X-axis.

2. Y: Type an offset value in this field to reposition your selection along the Y-axis.

3. Up/Down arrows: Use the up and down arrows to modify the value contained in either the X or Y value
field.

Angle
Use theAngle operation fields to enter specific values and accurately rotate the selected shape.

1. Angle: Type a degree value in this field to rotate your selection.

2. Up/Down arrows: Use the up and down arrows to modify the value contained in theAngle value field.

Adjusting the Pencil Line Thickness
Use theAdjusting the Pencil Line Thickness operation field to resize the selected centreline strokes. This
operation is not permitted on contour line shapes, such as brush strokes or shape fills.

1. Minimum Size: Type a value in this field to set theminimum thickness of the selected centreline stroke.

2. Maximum Size: Type a value in this field to set themaximum thickness of the selected centreline stroke.

3. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness value field.

4. Lock Proportions: Enable the Lock option for theminimum andmaximum size to increase and decrease in
proportion.

Adjusting the Pencil Line Style
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You can adjust the start, end, and joint style of a selected pencil line.

• Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil Stencils

Toon BoomHarmony gives you the flexibility to change the style and thickness of your pencil lines even after they
are drawn. You can apply preset pencil stencils or create your own.

Refer to Working with TemplatesThickness Stencils on page 81, Creating a Pencil
TemplateThickness Stencil with the Select Tool on page 83 andWorking with TemplatesThickness
Stencils on page 81.

Adding Texture to a Pencil Line
Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your own.
Textures are independent from pencil stencils.

Refer to Pencil Line Texture on page 86, Applying a Preset Texture to a Pencil Line on page 92 and
Creating a Pencil Texture Template with the Select Tool on page 89.

Adjusting the Text Selection
When you select text with the Select tool, the tool properites will display the Text tool options on the bottom of
the view. You can also press [Alt] + [9] to display only the Text properties in the Tool Propertie view.



Toon Boom Harmony 10.3 Paint User Guide

143

Refer to Formatting the Text on page 192 to learn more about the Text tool Tool Properties.

Related Topics

• Drawing Using the Pencil Tool on page 73

• Pencil Tool Options on page 74

• Working with TemplatesThickness Stencils on page 81

• Pencil Line Texture on page 86
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Erasing Parts of a Drawing

The Eraser tool is pressure sensitive, like the Brush tool, giving youmore precision when erasing parts of a
drawing.

To erase with the Eraser tool:

1. In the Timeline or Xsheet view, select the cell where you want to erase.
In Harmony Paint, select a drawing in theDrawing panel.

2. In the Tools toolbar, select the Eraser tool or press [Alt] + [E].

3. In the Camera or Drawing view, start erasing.

You can also use the Select tool to select drawing objects and delete them instead of erasing.

Related Topics

• Eraser Tool Options below

• Selecting Drawing Objects on page 127

Eraser Tool Options
When you select the Eraser tool, its properties and options appear in the Tool Properties view.
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Related Topics

• Tip Style on the next page

• Minimum andMaximum Size on the next page

• Central Line Smoothness on the next page

• Contour Optimization on the next page

• Eraser Tips on page 147

• Preview on page 147

• Eraser Styles on page 148

• Eraser Blur Parameters on page 148
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Tip Style

The Tip Style option affects the erased tip of pencil lines made with the Pencil, Ellipse, Rectangle, Line, and Polyline tools.

Minimum and Maximum Size
This is where you set theminimum andmaximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

1. Minimum Size field: Type a value in this field to set theminimumwidth of the line.

2. Maximum Size field: Type a value in this field to set themaximumwidth of the line.

3. Up/Down arrows: Use the up and down arrows to set theminimum size value.

4. Up/Down arrows: Use the up and down arrows to set themaximum size value.

Central Line Smoothness
You canmodify theCentral Line Smoothness of your line using this option. This parameter smoothes the

initial movement of your line. Increasing the value will result in a smoother line with fewer control points.

Contour Optimization
You can optimize theContour Line Smoothness of you line using this option. This parameter will smooth the
contour of your line once the line has been traced, the higher the value the less control points will compose your
line.
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1. Smoothness field: Type a value to set the smoothness of the line.

2. Contour Optimization field: Type a value to set the contour optimization of the line.

3. Up/Down arrows: Use the up and down arrows to set smoothness value.

4. Up/Down arrows: Use the up and down arrows to set the contour optimization value.

Eraser Tips

In this drop-downmenu, you can find a variety of tip shapes from round and square ones to star shaped, select
the one you need.

Preview
The Preview field lets you see a preview of the style that will be produced after you customize the different
parameters in the Tool Properties view.

1. TheArrow button lets you show or hide the Preview area.

2. The Preview field is where the brush line is displayed.

Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

Maximum Size and Smoothing
This is where you set theminimum andmaximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

‣ Maximum/Minimum Size: Defines theminimum andmaximumwidth of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.
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‣ Contour Smoothing: Defines the number of control points added to the contour boundaries (around
the line). Lower values mean that the line will appear as you draw it (withmore control points added
along the centre line). Higher values mean that the line will be smoothed out (removing control points
from the centre line).

‣ Tip Shape: Lets you select a shape for the tip of the eraser. There are a variety of tips to choose from:
round, square, oval, star-shaped andmore.

‣ Soft Tip: Gives the tip of your stroke a soft edge.

‣ Keep Vectors: Keeps your vector frames and does not cut them.

‣ Hardness: The hardness value corresponds to the smoothness of the line edge. The lower the value,
themore blurry and smooth the line edgewill be. The higher the value, the sharper the line edgewill
be.

‣ Saturation: Corresponds to the intensity of line color.

‣ Maximum Opacity: Corresponds to the transparency of the brush when the pressure is heavy. Values
closer to 1 produce a more opaque line.

‣ Minimum Opacity: Corresponds to the transparency of the brush when the pressure is very light.
Values closer to 0 produce a more transparent line.

Brush Presets
Brush presets are created by saving the properties of the current brush to a new preset, which you can reuse for
repeated tasks. You can create as many brush presets as you need.

Eraser Styles
The Eraser tool uses the same Brush Styles as the Brush tool. Toon BoomHarmony provides a variety of eraser
styles and allows you to create and save your own. It is a good idea to create and save eraser brushes with
precise sizes and parameters to draw and design—see Brush Styles on page 109

Eraser Blur Parameters
Since Toon BoomHarmony lets you draw with textured lines and create feathered edges on them, youmay also
want to erase with smooth edges instead of the solid vector based eraser. The Eraser Blur Parameters allow you
to adjust the smoothness of your eraser for the textured lines—see Erasing Textured Lines on page 122
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Reshaping a Drawing Using the Contour
Editor Tool

When drawing on vector layers, the Contour Editor Tool is powerful. It allows you to add, remove or modify
points on a vector line and to control themwith Bezier handles. It is used to correct line shapes and to modify a
single part of a colour zone. If a line is too thin or has a gap in it, you canmodify and correct it with the Contour
Editor tool. This tool can also be used to create elaborate shapes.

TheContour Editor tool is powerful, it allows you to add, remove or modify points on a vector line and to
control themwith Bezier handles. It is used to correct line shapes and to modify a single part of a colour zone. If a
line is too thin or has a gap in it, you canmodify and correct it with theContour Editor tool. This tool can also be
used to create elaborate shapes.

The Contour Editor displays vector points around a shape and the central vector points in a pencil line. Pulling or
pushing on these points adjusts the brush’s line thickness. Points can be selected and deleted. Each point has
two Bezier handles used to correct the curves between two points. Shapes can bemodified by pulling and
pushing directly on the segment between the points. You can use it to perfect a central shape pencil line, a
contour shape brush line or even create an elaborate shape from a basic ellipse, or square.

To reshape with the Contour Editor tool:

1. In the Timeline or Xsheet view, select the cell in which you want to draw.In the Timeline or Thumbnails
view, select the cell and layer into which you want to draw.
In Harmony Paint, select a drawing in theDrawing panel.

2. In the Tools toolbar, select a shape tool.

3. In the Tool Properties view, click the Ellipse button, click the Auto Fill button and set the pencil

size to 0.

4. In the Drawing or Camera view, draw a circle.

5. In the Stage view, draw a circle.
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6. In the Tools toolbar, select the Contour Editor tool.

7. In the Drawing or Camera view, click the line to reshape it.

8. In the Stage view, click the line to reshape it.

9. Select one or several points by clicking on them or circling around.

10. Press [Delete] to delete a selected point.

Press [Ctrl] (Windows/Linux) or [⌘ ] (MacOS X)and click on the contour to add a new point to adjust the
contour.

11. To modify the shape, you can:

‣ Pull on the Bezier handle. Both point’s handles will move as one.

‣ Hold down the [Alt] key and pull on one of the Bézier handles. The point’s handle will move
independently from the other one.

‣ Move the selected points to a new area.
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‣ Pull directly on the line between two points. No selection is necessary. Holding down the [Shift] key will
limit the contour modification to the curve between the two first points.

‣ If an anchor point has no visible Bezier, hold down the [Alt] key to get them.

To add control points, press [Ctrl] (Windows/Linux) or [⌘ ] (Mac OS X) and click the line.
To remove control points, select the control point and press [Delete].

Related Topics

• Contour Editor Tool Properties below

Contour Editor Tool Properties
When you select theContour Editor tool, its properties and options appear in the Tool Properties view.

These are the options available for the Contour Editor tool:

• Lasso andMarquee on the next page

• Show Contour Editor Controls on the next page

• Apply to Line and Colour Art on the next page

• Snap to Contour on the next page

• Snap and Align on page 153

• Smooth Selection on page 154
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Lasso and Marquee
Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold [Alt] to temporarily switch from the current mode to the other.

Show Contour Editor Controls

Use the Show Contour Editor Controls option to show the contour editor controls. You can use these

controls to scale, reposition and rotate the selected anchor points.

Apply to Line and Colour Art
TheApply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use this option

to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art layers, as well as the
Overlay and Underlay layers.

To access this option, you must be in the Advanced Art mode—see Drawing View on page 65.

Snap to Contour
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The Snap to Contour option will snap the selected anchor point to any line you position it on.

To snap two shapes together:

1. In the Tools toolbar, select theContour Editor tool or press [Alt] + [Q].

2. In the Tool Properties view, click the Snap to Contour button.

3. In the Camera or Drawing view, click on an anchor point you want to snap to the other shape, drag it on
top of the contour line area and release it.

Snap and Align

The Snap andAlign option lets you snap the selected anchor point to any existing line while displaying

temporary rulers as a guide that you can also snap your anchor point to.

To snap and align:

1. In the Tools toolbar, select theContour Editor tool or press [Alt] + [Q].

2. In the Tool Properties view, click the Snap andAlign button.

3. In the Camera or Drawing view, click on an anchor point you want to snap, drag it until a ruler is displayed,
position it on the ruler or on the contour line and release.
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Smooth Selection

The Smooth operation lets you smooth out selected drawing strokes and remove extra points. You can also

access this feature through the top menu, by selectingDrawing > Optimize > Smooth or press [Alt] + [Shift] +
[S].

Related Topics

• Reshaping a Drawing Using the Contour Editor Tool on page 149
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Reshaping Pencil Lines with the Pencil Editor
Tool

The Pencil Editor tool is used to modify the thick and thin contour of a pencil line. A pencil line is a central vec-

tor shape. The shape control points are located all along the central spine allowing to adjust the stroke curve
and position. When using theContour Editor tool, you will be able to reposition the spine of the stroke. When
using the Pencil Editor tool, you will be able to adjust the thick and thin areas of the line.

To use the Pencil Editor tool:

1. In the Tools toolbar, select the Pencil Editor tool located in theContour Editor drop-downmenu or

press [Alt] + [W].

2. In the Camera or Drawing view, select a pencil line and click the line to reshape it.

3. Select one or several points by clicking them or circling around.
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4. Press [Delete] to delete a selected point.

5. Press [Ctrl] (Windows/Linux) or [⌘ ] (MacOS X) and click the central spine to add a set of points to adjust
the contour.

6. To modify the shape, you can:

‣ Move the selected points to a new area. If you select matching points on each side of the line, holding
the Shift key will move them both. This way you can thicken or thin a line from both side at the same
time.

‣ Pull on the Bezier handle. Both points’ handles will move as one.

‣ Hold [Alt] down and pull on one of the Bezier handles. The point’s handle will move independently
from the other one.
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‣ Pull directly on the line in-between two points. No selection is necessary. Holding down the [Shift] key
will limit the contour modification to the curve between the two first points.

‣ If an anchor point has no visible Bezier, hold down the [Alt] key to get them.

Related Topics

• Pencil Editor Properties below

Pencil Editor Properties
When you select the Pencil Editor tool, its properties and options appear in the Tool Properties view.
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These are the options available for the Pencil Editor tool:

• Lasso andMarquee below

• Smooth below

• Pump Pencil Pressure below

• Deflate Pencil Pressure on the facing page

• Merge Pencil Lines on the facing page

• Reverse Pencil Thickness on the facing page

• Adjusting the Pencil Line Thickness on page 160

• Adjusting the Pencil Line Style on page 160

• Working with TemplatesThickness Stencils on page 81

• Adding Texture to a Pencil Line on page 161

Lasso and Marquee
Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold [Alt] to temporarily switch from the current mode to the other.

Smooth

The Smooth operation lets you smooth out selected drawing strokes and remove extra points. You can also

access this feature through the top menu, by selectingDrawing > Optimize > Smooth or press [Alt] + [Shift] +
[S].

Pump Pencil Pressure
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The Pump Pencil Pressure option is used to increase the line thickness of a selected area on a pencil line.

Deflate Pencil Pressure

TheDeflate Pencil Pressure option is used to decrease the line thickness of a selected area on a pencil line.

Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align them and
make it look like it is one single line. With the Select tool, you can select several pencil lines and merge them as
one single object using theMerge Pencil Lines option. It will take your lines and adjust the ends to form one

single line.

Reverse Pencil Thickness
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The Reverse Pencil Thickness option will invert the thick and thin section on a selected pencil line. This

option will take the thickest size on the line and apply it to the thinnest, and it will apply the thinnest to the
thickest.

Adjusting the Pencil Line Thickness
This is where you set theminimum andmaximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

1. Minimum Size field: Type a value in this field to set theminimumwidth of the line.

2. Maximum Size field: Type a value in this field to set themaximumwidth of the line.

3. Up/Down arrows: Use the up and down arrows to set theminimum size value.

4. Up/Down arrows: Use the up and down arrows to set themaximum size value.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.

• Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil TemplatesThickness Stencils
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Toon BoomHarmony gives you the flexibility to change the style and thickness of your lines even after they are
drawn. You can apply preset templatesthickness stencils or create your own.

Refer to Working with TemplatesThickness Stencils on page 81, Creating a Pencil
TemplateThickness Stencil with the Select Tool on page 83 andWorking with TemplatesThickness
Stencils on page 81.

Adding Texture to a Pencil Line
Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your own.
Textures are independent from Pencil templatesthickness stencils.

Refer to Pencil Line Texture on page 86, Applying a Preset Texture to a Pencil Line on page 92 and
Creating a Pencil Texture Template with the Select Tool on page 89.

Related Topics

• Reshaping Pencil Lines with the Pencil Editor Tool on page 155
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Drawing with Shapes

In Toon BoomHarmony, you can use the shape tools to draw with circles, lines and squares. You can also easily
reshape a square or circle into a muchmore complex drawing such as these butterfly wings.

The Shape tools are used to draw rectangles, ellipses and lines. You can use them on both vector and bitmap
layers. You can also easily reshape a square or circle into a muchmore complex drawing such as these butterfly
wings.

Refer to Reshaping a Drawing Using the Contour Editor Tool on page 149 and Reshaping Pencil Lines
with the Pencil Editor Tool on page 155 topics to learn more about the Contour Editor and Pencil
Editor tools.

To draw with a Shape tool:

1. In the Timeline or Xsheet view, select the cell where you want to draw.

1. In the Timeline or Thumbnails view, select the panel and layer on which you want to draw.In Harmony
Paint, select a drawing in theDrawing panel.

2. In the Tools toolbar, select a shape tool.

3. In the Tool Properties view, you can switch between the different shapes mode.In the Shape Tool
Properties view, you can switch between the different shapes mode. Select either the Ellipse or

Rectangle tool.

4. In the CameraStage view, click and drag your mouse to draw the shape.
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‣ Hold down [Shift] to lock the rectangle or the ellipse ratio to 1:1.

‣ Hold down [Alt] to draw the rectangle or ellipse from its centre.

‣ Hold down [Shift] to snap the line every 15 degrees.

‣ Hold down [Alt] to snap the starting or end point of the line to a close by stroke.

5. Use theContour Editor tool to deform your shape and create your drawing.

Related Topics

• Shape Tool Options below

Shape Tool Options
When you select a shape tool, its properties and options appear in the Tool Properties view.
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These are the options available for the shape tools:

• Line, Rectangle and Ellipse on the facing page

• Draw Behind on the facing page

• Snap Options on the facing page

• Line BuildingMode on page 166
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• Automatic Filling on the next page

• Create Colour Art Automatically on page 167

• Auto-FlattenMode on page 167

• Auto-Close Gap on page 168

• Use Stored Colour Gradient on page 168

• Keep Proportion on page 168

• Pencil Templates on page 168

• Thickness Adjustment on page 169

• Adjusting the Pencil Line Style on page 169

• Applying Texture to a Pencil Line on page 169

Line, Rectangle and Ellipse

Click on the button corresponding to the shape youwant. Click and drag your mouse to draw the

selected shape. The shape tools create centre lines.

Using the Ellipse or Rectangle option, press [Shift] to create a perfect round or a perfect square and press [Alt]
to create the shape from its centre.

Using the Line tool, press [Shift] to create a line which snaps-to every 15 degrees and then press [Alt] to connect
the start or end point of that line to another nearby line. To create a curve in the line as you draw, hold down
[Ctrl] (Windows/Linux) or [⌘ ] (MacOS X) and drag to create a bend in the line.

Draw Behind

When theDraw Behind mode is enabled, the lines you draw will appear behind the art that already exists.

Snap Options
When drawing a shape, you can enable different snap modes to help you create your shape.



Drawing with Shapes

166

• The Snap to Contour option snaps your shape to any line you position it on.

• The Snap andAlign option snaps the selected anchor point to any existing line, while displaying

temporary rulers as a guide that you can also snap your anchor point to.

• The Snap to Grid snaps your shape to the currently enabled grid.

Refer to the topic to learn more about the Grid feature.

Line Building Mode

The Line Building mode is very useful when drawing long lines and curves in small increments with pencil

lines. As the pencil lines are central vector lines and it may be difficult to align the line tips perfectly to create a
uniform stroke and close all gaps.

In this mode, you can draw lines in small increments and the tip aremerge into one single stroke.

This mode only works with pencil lines.

Automatic Filling

Use theAutomatic Filling option to automatically fill your shapewith the selected colour as you draw. By

default, the Shape tool creates the contour of an empty shape that you can later fill using the Paint tool.
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Refer to Selecting the Current Colour of a Tool on page 221to learn more about selecting a fill
colour.

Create Colour Art Automatically

As you draw in the Line Art layer, theCreate Colour Art Automatically automatically creates the

corresponding strokes in theColour Art layer.

To access this option, you must be in the Advanced Art mode—see Drawing View on page 65.

Auto-Flatten Mode
When enabled, theAuto-Flattenmode automatically flattens the new lines created with the existing artwork as
you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.

Using the Select tool, you can use themiddlemouse button to select a segment of flattened pencil line. Use this
technique to create a nice finish to lines and corners in your artwork.
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Auto-Close Gap

When enabled, theAuto-Close Gap mode automatically connects, with an invisible stroke, the pencil lines

you draw close to each other in the Camera or Drawing view.

It is recommended to leave this option ENABLED when drawing with the Pencil tool.

Use Stored Colour Gradient
TheUse Stored Colour Gradient optionmakes your tool use the previously stored gradient position. This

way, every new brush line or colour fill will use the stored gradient position.

Keep Proportion

When the Ellipse or Rectanglemode is enabled in the Tool Properties view, theDraw Circle or Draw Square
option appears. When selecting these options, the shape produced will either be a circle or a square. Holding
down the [Shift] key as you create your shapewill maintain proportion.

Pencil Templates
Toon BoomHarmony provides a variety of pencil templates and also lets you create and save your own. It is a
good idea to create and save pencils with precise sizes and parameters when you draw and design.

You also have the possibility to apply different textures to your lines by either using the preset ones or importing
your own—seeWorking with TemplatesThickness Stencils on page 81
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Thickness Adjustment

Use the Size Adjustment field to set the thickness of the shape’s line.

1. Size: Type a value in this field to set the shape’s line thickness.

2. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness value
field.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.

• Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Applying Texture to a Pencil Line
Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your own.
Textures are independent from Pencil templates.

Refer to Pencil Line Texture on page 86, Applying a Preset Texture to a Pencil Line on page 92 and
Creating a Pencil Texture Template with the Select Tool on page 89.

Related Topics

• Working with TemplatesThickness Stencils
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Drawing with the Polyline Tool

The Polyline tool is used to draw shapes. It is a central vector type of line. To form a shape, you click to add a
point and then, without releasing themouse, pull the handle in the desired direction before adding the next
point and repeat the operation. To edit the shape, you can use the Contour Editor tool.

To draw with the Polyline tool:

1. In the Timeline view, select the cell where you want to draw.
In Harmony Paint, select a drawing in theDrawing panel.

2. In the Tools toolbar, select the Polyline tool or press [Alt] + [_].

3. In the Camera view, click and drag your mouse to create a point and a Bezier handle to shape your line.

‣ Press [Alt] to pull only one handle, instead of two.

‣ Press [Shift] to snap the handles to 45, 90, or 180 degrees.

4. Click again into a new area and drag themouse to create a second point and Bezier handle.

5. Repeat the previous step until your shape is completed.

6. Press [Ctrl] (Windows/Linux) or [⌘ ] (MacOS X) and click to release the Polyline tool from the current path
or shape that it is creating. Continue to use the tool to makemultiple, independent paths or shapes.

7. If necessary, reshape the lines using theContour Editor tool.

Refer to Reshaping a Drawing Using the Contour Editor Tool on page 149 to learn more about the
Contour Editor tool.



Toon Boom Harmony 10.3 Paint User Guide

171

Related Topics

• Polyline Tool Options below

Polyline Tool Options
When you select the Polyline tool, its properties and options appear in the Tool Properties view.
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These are the options available for the Polyline tool:

• Snap to Contour on the facing page

• Create Colour Art Automatically on page 174

• Auto-FlattenMode on page 174

• Pencil Templates on page 174

• Thickness Adjustment on page 175

Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

Size
The Size parameter lets you set the size of the polyline that you will draw.
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Polyline Presets
Polyline presets are created by saving the properties of the current tool to a new preset, which you can reuse for
repeated tasks. You can create as many presets as you need.

Size and Smoothness
This is where you set theminimum andmaximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

‣ Maximum/Minimum Size: Defines theminimum andmaximumwidth of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line.

‣ Contour Smoothing: Defines the number of control points added to the contour boundaries (around
the line). Lower values mean that the line will appear as you draw it (withmore control points added
along the centre line). Higher values mean that the line will be smoothed out (removing control points
from the centre line).

Adjusting Polyline Style

You can adjust the start, end, and joint style of a selected pencil line.

• Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Working with Line Textures
Like pencil lines, polylines support texture. Before drawing, you can select or import a texture and apply it to
your lines. You can also change it afterwards using the Select tool. Textures are independent from pencil
templates—see Pencil Line Texture on page 86.

Snap to Contour
The Snap to Contour option will snap your selection to any line you position it on.
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Create Colour Art Automatically

As you draw in the Line Art layer, theCreate Colour Art Automatically automatically creates the

corresponding strokes in theColour Art layer.

To access this option, you must be in the Advanced Art mode—see Drawing View on page 65.

Auto-Flatten Mode
When enabled, theAuto-Flattenmode automatically flattens the new lines created with the existing artwork as
you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.

Pencil Templates

Toon BoomHarmony gives you the flexibility to change the style and thickness of your pencil lines even after they
are drawn. You can apply preset templates or create your own.

Refer to Working with TemplatesThickness Stencils on page 81, Creating a Pencil
TemplateThickness Stencil with the Select Tool on page 83 and Applying a Pencil Template on page
85.
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Thickness Adjustment

Use the Size Adjustment field to set the thickness of the shape’s line.

1. Size: Type a value in this field to set the shape’s line thickness.

2. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness value
field.

Related Topics

• Drawing with the Polyline Tool on page 170
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Drawing Using Invisible Lines

There are two different ways to draw invisible lines:

• Pencil Tool below

• Stroke Tool on the facing page

Pencil Tool
Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be useful to
draw tones and highlights directly on the character.

To draw invisible lines with the Pencil tool:

1. In the Timeline or Xsheet view, select the cell where you want to draw.
In Harmony Paint, select a drawing in theDrawing panel.

2. In the Tools toolbar, select the Pencil tool or press [Alt] + [/].

3. In the top menu, select View > Drawing > Show Strokes or press [K].

In Harmony Paint, select View > Show Strokes.

4. In the Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.

5. In the Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select theDon’t Show This Message Again option if you do not want the dialog box to notify you about
the Show Strokes option. Click OK.

6. You canmodify the stroke shapewith theContour Editor tool.
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Stroke Tool
The Stroke tool draws invisible lines only. You cannot add thickness to the line.

To draw invisible lines with the Stroke Pencil tool:

1. In the Timeline or Xsheet view, select the cell where you want to draw.
In Harmony Paint, select a drawing in theDrawing panel.

2. In the Tools toolbar, select the Stroke tool or press [Alt] + [V].

3. In the top menu, select View > Show Drawing > Show Strokes or press [K].

In Harmony Paint, select a drawing in theDrawing panel.

4. In the Tool Properties view, you can adjust the smoothness.

5. In the Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select theDon’t Show This Message Again option if you do not want the dialog box to notify you about
the Show Strokes option. Click OK.

6. You canmodify the stroke shapewith theContour Editor tool.

Related Topics

• Stroke Tool Options below

• Show Strokes as Washed-out Colours on the next page

Stroke Tool Options
When you select the Stroke tool, its properties and options appears in the Tool Properties view.

Here are the options available for the Stroke tool:

• Draw Stroke as Straight Lines on the next page

• Connect Line Ends on the next page

• Auto-FlattenMode on the next page
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• Central Line Smoothness below

Draw Stroke as Straight Lines
Enable theDraw Stroke as Straight Lines option if you want the new strokes that you will draw to be a

perfect straight line. Disable the option if you want the stroke to follow themouse gesture.

Connect Line Ends
Enable theConnect Line Ends option if you want the start or end point of your new stroke to connect to

your existing strokes to make sure no gaps are left in your drawing.

Auto-Flatten Mode
When enabled, theAuto-Flattenmode automatically flattens the new lines created with the existing artwork as
you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.

Central Line Smoothness
You canmodify theCentral Line Smoothness of your line using this option. This parameter smoothes the

initial movement of your line. Increasing the value will result in a smoother line with fewer control points.

Related Topics

• Drawing Using Invisible Lines on page 176

• Show Strokes as Washed-out Colours below

Show Strokes as Washed-out Colours
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Sometimes, it may be difficult to see your strokes, especially if your colours are similar to the blue stroke colour.
In Harmony, you can display the strokes and washed-out the colours of your drawings so that the invisible lines
stand out.

To show the strokes with washed-out colours:

‣ In the top menu, select View > Show > Show Stroke With ColourWash.

Related Topics

• Drawing Using Invisible Lines on page 176
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Deforming a Drawing Using the Perspective
Tool

The Perspective tool lets you deform a drawing selection and alter its perspective.

To deform a drawingwith the Perspective tool:

1. In the Tools toolbar, select the Perspective tool or press [Alt] + [0].

2. In the Camera or Drawing view, select the drawing youwant to deform.

3. Click and drag the different anchor points to deform the shape.
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Related Topics

• Perspective Tool Properties below

Perspective Tool Properties
Selecting the Perspective tool displays its properties and options in the Tool Properties view.

• Lasso andMarquee on the next page

• Apply to Line and Colour Art on the next page
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• Flip Horizontal and Vertical on the facing page

• Rotate 90 Degrees CW and CCW on the facing page

Lasso and Marquee
Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold [Alt] to temporarily switch from the current mode to the other.

Snap to Contour
The Snap to Contour option will snap the selected anchor point to any line you position it on—see Contour

Editor Tool Properties on page 151.

Snap and Align
The Snap andAlign option lets you snap the selected anchor point to any existing line while displaying

temporary rulers as a guide that you can also snap your anchor point to—see Contour Editor Tool Properties on
page 151.

Snap to Grid
The Snap to Grid option snaps your selection according to the currently enabled grid.

Apply to Line and Colour Art
TheApply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use this option

to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art layers, as well as the
Overlay and Underlay layers.

To access this option, you must be in the Advanced Art mode—see Drawing View on page 65.
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Flip Horizontal and Vertical

The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or vertically.

From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current selection 90

degrees clockwise or counter-clockwise.

From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees CCW.

Or press [Ctrl] + [7] and [Ctrl] + [9] (Windows/Linux) or [⌘ ] + [7] and [⌘ ] + [9] (MacOS X).

Related Topics

• Deforming a Drawing Using the Perspective Tool on page 180
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Cutting Drawing Parts

The Cutter tool is used to cut a drawing area to move, copy, cut or delete it.

To cut with the Cutter tool:

1. In the Tools toolbar, select theCutter tool or press [Alt] + [T].

2. In the Camera view, trace a selection around the part to cut away.

‣ To delete the selected zone, press[Delete].

‣ To move the selection, click the selection and drag it to a new area.

‣ Use the bounding box controls to scale, skew, or rotate the cut piece.

Related Topics

• Cutter Tool Options on the facing page
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Cutter Tool Options
When you select theCutter tool, its properties and options appear in the Tool Properties view.

Here are the options available for theCutter tool:

• Lasso andMarquee below

• Apply to Line and Colour Art below

• UseMouseGesture below

• UseMouseGesture Breaker Mode on the next page

• Tip Style on the next page

• Flip Horizontal and Vertical on page 187

• Rotate 90 Degrees CW and CCW on page 187

Lasso and Marquee
Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold [Alt] to temporarily switch from the current mode to the other.

Apply to Line and Colour Art
TheApply to Line and Colour Art option uses the concept of Line Art and Colour Art layers. Use this option

to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art layers, as well as the
Overlay and Underlay layers.

To access this option, you must be in the Advanced Art mode—see Drawing View on page 65.

Use Mouse Gesture
When using the Lasso selection type, theUse Mouse Gesture option lets you automatically delete any

extra sections of line in your artwork by simply dragging your mouse over it.
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For this operation to work, you lines CANNOT be flattened.

Use Mouse Gesture Breaker Mode
When using the Lasso selection type, theUse Mouse Gesture Breaker Mode option lets you draw an

invisible stroke on a pencil line to cut it in two individual objects. Once a pencil line is cut with this option, you will
be able to select the two portions independently with either theCutter tool, Pencil Editor tool or Select tool.

This option only works with pencil lines.

Tip Style

Use the Tip Style option to customize the tip of the pencil line you are cutting.
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Flip Horizontal and Vertical

The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or vertically.

From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current selection 90

degrees clockwise or counter-clockwise.

From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees CCW.

Or press [Ctrl] + [7] and [Ctrl] + [9] (Windows/Linux) or [⌘ ] + [7] and [⌘ ] + [9] (MacOS X).

Related Topics

• Cutting Drawing Parts on page 184
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Smoothing Lines

When drawing in a digital application, it is not like drawing on a sheet of paper, sometimes the lines you draw
may look as if they were drawnwith an unsteady hand. When this occurs, youmay need to correct the look of
your lines.

Toon BoomHarmony has a very powerful tool you can use to optimize contours and reduce the number of
points on the lines, the Smooth Editor tool.

To optimize lines with the Smooth tool:

1. In the Tools toolbar, select the Smooth Editor tool or select Drawing > Tools > Smooth Editor.

In Harmony Paint, select Tools > Smooth Editor.

2. In the Camera or Drawing view, place your pointer over the lines to smooth. Youmay need to pass over
the same line several times to removemore points and make the line smoother.

Related Topics

• Smooth Editor Tool Options on the facing page
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Smooth Editor Tool Options
When you select the Smooth Editor tool, its properties and options appear in the Tool Properties view.

Here are the options available for the Smooth Editor tool:

• Brush, Marquee and Lasso Smoothing Style below

• Show Control Points below

• Minimum Size andMaximum Size below

• Smoothness on the next page

• Colour on the next page

Brush, Marquee and Lasso Smoothing Style
The Smoothing Style options allows you to smooth a portion of your drawing either by tracing a smoothing
stroke over the zone to optimize or by selecting an area of the drawing with theMarquee or the Lasso.

Show Control Points
The Show Control Points option allows you to show or hide the Bezier points around your lines. When the

Bezier points are displayed, you can see the result of your smoothing and the number of points left on your
curve. When it is turned off, you will only see the original artwork.

Minimum Size and Maximum Size
This is where you set theminimum andmaximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.
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1. Minimum Size field: Type a value in this field to set theminimumwidth of the line.

2. Maximum Size field: Type a value in this field to set themaximumwidth of the line.

3. Up/Down arrows: Use the up and down arrows to set theminimum size value.

4. Up/Down arrows: Use the up and down arrows to set themaximum size value.

This options is available while using the Brush Smoothing style.

Smoothness
The Smoothness impacts the strength of the smoothing result. The higher the value, themore points are

removed and the smoother the curve is. The Smoothness range is from 0 to 100; the default value is 20.

Colour

You canmodify the colour of the control points displayed on the artwork while working with the Smooth Editor
tool by double-clicking on the colour swatch.
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Related Topics

• Smoothing Lines on page 188
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Working With Text
With the Text tool, you can type text in your project, using various fonts and texts attributes. Text objects are
part of a drawing, so you canmanipulate them the sameway.

To add text to your drawings:

1. Do one of the following:

‣ In the Tools toolbar, select the Text tool.

‣ Select Drawing > Tools > Text.

‣ Press [Alt] + [9].
In Harmony Paint, select a Tools > Text.

2. In the Timeline view, select the cell containing the drawing youwant to add text to.

3. In the Drawing or Camera view, click on the location you want your text to begin.

4. You can use the Tool Properties view to select the font, font size and format the text you will type—see
Formatting the Text below.

5. Type in the desired text.

6. Click outside the text box to exit the typing mode.

If you want to create another text object, click outside the currently active text box. You can always return
to edit the text by selecting the Text tool and clicking in the text.

Related Topics

• Formatting the Text below

Formatting the Text
Use the Text tool Tool Properties view to select the font type and other formatting options you want to apply to
the text.
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1. Font Type below

2. Font Style below

3. Alignment on the next page

4. Font Size on the next page

5. Kerning on the next page

6. Indent on page 195

7. Line Spacing on page 195

• Resizing the Text Box on page 195

• Converting Text into SeparateObjects on page 196

If you already wrote your text, you must first use the Text tool and select the text portion you want to
format.

Font Type
Use this drop-downmenu to select the desired font, from the list of fonts available in your system.

Font Style
Use these buttons to select a desired style for your text:

• Bold

• Italic
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Alignment
Use these buttons to align the paragraph.

Left Centred

Right Justified

Font Size
Type the desired size for the text in this field. You can also use the up and down arrow buttons to set the desired
value.

Kerning
Use the kerning field to modify the spacing between letters and characters. You can select theAuto Kern option
to set the kerning automatically, based on the font’s predefined standard. A negative value decreases spacing
between each character creating a letter overlap and a positive value increases it.
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Indent
Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A positive
value sets the first line of your paragraph farther to the right and a negative value sets it farther to the left.

Line Spacing
Enter a value in the Line Spacing field to decrease or increase the space between each line of text.

Resizing the Text Box
You can resize the text box by selecting your text box with the Text tool and moving the anchor point right

or left.
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Using the Select tool will distort and scale your text itself rather than changing the width and height of your text
box.

Converting Text into Separate Objects
Text contained in a text field is treated as a single drawing object. You can easily separate the text so that each
character becomes an individual drawing object that you can select and modify independently.

To break a text object:

1. In the Tools toolbar, click on the Select tool or press [Alt] + [S].

2. In theDrawing or Camera view, select the text object you want to break.

3. Select Drawing > Convert > Break Apart Text Layers.
In Harmony Paint, select Selected > Convert > Break Apart Text Layers.

Each character is now surrounded by its own bounding box that you canmodify, they remain text objects
that you can edit.

4. If you want to convert your independent letter to a complete vector object that you can deform, using the
Select tool, select the letters to convert.

5. Select Drawing > Convert > Break Apart Text Layers to break the selection into a regular drawing
object, with no more text attributes.
In Harmony Paint, select Selected > Convert > Break Apart Text Layers.

Related Topics

• WorkingWith Text on page 192
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Override Tool
TheOverride Tool lets you increase productivity by rapidly switching between tools used for short tasks and
your previous tool. Most drawing tool shortcuts are accessed using the [Alt] key followed by another key, such as
the Eraser tool which is accessed by pressing [Alt] + [E].

If you are drawing with the Brush tool and need to briefly switch to the Eraser before continuing, hold down the
[E] key while you are erasing. Once done, release [E] to return to the previous tool, in this case, the Brush tool.
You can do the same for most drawing tools that have a shortcut composed of [Alt] followed by another key.

Related Topics

• Keyboard Shortcuts

• Tools Toolbar
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More Drawing Tools
Harmony offers a wide variety of useful tools to optimze your drawings and work more efficiently; tools such as
Group, Arrange, and the animation disk to rotate your workspace.

Related Topics

• Arrange below

• Convert Brush Strokes to Pencil Lines on the facing page

• Pencil Lines to Brush Strokes on the facing page

• Strokes to Pencil Lines on the facing page

• Optimize on page 200

• Remove Extra Strokes on page 200

• Reduce Drawing Texture Resolution on page 200

• Crop Brush Textures on page 201

• Create Contour Stroke on page 202

• Remove Contour Stroke on page 202

• Grid on page 202

• Group/Ungroup on page 203

• Hand on page 203

• Rotate View on page 203

Arrange
Use the different Arrange options to reorder drawing objects inside a single layer in theDrawing or Camera
view.

• Bring to Front button or select Drawing > Arrange > Bring to Front or press [Ctrl] + [Shift] + [PgUp]

(Windows/Linux) or [⌘ ] + [Shift] + [PgUp] (MacOS X).
The selected art is moved to the top.

• Bring Forward button or select Drawing > Arrange > Bring Forward or press [Ctrl] + [PgUp]

(Windows/Linux) or [⌘ ] + [PgUp] (MacOS X).
The selected art is moved one level higher.

• Send Backward button or select Drawing > Arrange > Send Backward or press [Ctrl] + [PgDown]

(Windows/Linux) or [⌘ ] + [PgDown] (MacOS X).
The selected art is moved one level lower.

• Send to Back button or select Drawing > Arrange > Send to Back or press [Ctrl] + [Shift] +

[PgDown] (Windows/Linux) or [⌘ ] + [Shift] + [PgDown] (MacOS X).
The selected art is moved to the bottom.
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Convert Brush Strokes to Pencil Lines

The Brushes Strokes to Pencil Lines operation converts the selected contour strokes into centreline pencil

strokes. This command is only available from the top menu.

To convert brush strokes to pencil lines:

‣ Select Drawing > Convert > Brush Strokes to Pencil Lines or press [^].

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Pencil Lines to Brush Strokes

The Pencil Lines to Brush Strokes operation converts the selected centreline pencil strokes into contour

strokes brush lines.

To convert pencil lines to brush strokes:

‣ From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes or press [&].

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Strokes to Pencil Lines

The Strokes to Pencil Lines operation converts the selected invisible line to a pencil line.
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To convert strokes to pencil lines:

‣ Select Drawing > Convert > Strokes to Pencil Lines. or press [Shift] + [F12] (Windows/Linux only).

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Optimize

TheOptimize command reduces the number of layers, such as overlapping brush strokes, in the selected
drawing objects. Drawing objects will only be flattened and optimized if the selected objects will not change the
appearance of the final imagewhen they aremerged.

For example, if you have selected a number of partially transparent objects, which you layered to create an
additive colour effect, the selected transparent drawing objects will not bemerged. This is becausemerging the
transparent drawing objects will cause them to lose the effect of the layered transparent colours.

• Use the Select tool to select the drawing objects you want to optimize.

• Select Drawing > Optimize > Optimize.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Remove Extra Strokes
The Remove Extra Strokes option is used to remove the invisible lines in your selection.

• Use the Select tool to select the drawing objects you want to remove invisible lines from.

• Select Drawing > Optimize > Remove Extra Strokes.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Reduce Drawing Texture Resolution
If you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be heavy.
This option is used to reduce the size and resolution of the textures in your drawing. When you import and
vectorize drawings using the grey or colour preset styles, you don't have control on the size of the bitmap
texture. This tool allows you to reduce that bitmap texture.
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To reduce the drawing texture resolution:

• In the Timeline or Xsheet view, Select tool to select the drawing objects you want to reduce the texture
resolution for.remove invisible lines from.

• Select Drawing > Optimize > Reduce Drawing Texture Resolution.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

1. In the dialog box, drag the slider toward the left to reduce the texture resolution.

2. Enable theApply to All Drawings option if you want themodification to be applied to all the drawings in
your layer.

3. Click OK.

Crop Brush Textures

TheCrop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies, unseen,
beneath the vector contour of a textured line. This often occurs when you cut and paste textured lines from one
drawing into another. If you cut a portion from a textured line and paste it into a different drawing, Toon Boom
Harmony pastes the entire unseen texture bitmap from the source drawing into the new one, even if you only
took a small portion of the source drawing. Using theCrop Brush Texture command will crop away extraneous
texture that does not touch the vector area. If there aremany textured lines in your scene, this will greatly reduce
the file size.

In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At first
glance, it appears as if only a cropped section of the underlying texture bitmap was cut and pasted as well.
However, using theContour Editor tool to expand the vector envelope of the textured line, it is revealed that
more texture bitmap exists beyond the cropped boundary. If you use theCrop Brush Texture command the
bitmap texture is cropped to the boundaries of the textured line’s vector contour (as seen in the fourth image
where the vector envelope has been pulled out to reveal empty space).

To crop the brush texture:

1. In the Timeline or Xsheet view, select the drawing youwant to crop the texture for.

2. Select Drawing > Optimize > Crop Brush Textures.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.
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Create Contour Stroke
TheCreate Contour Stroke option is used to add a permanent invisible line around a shape that was drawn

directly in the application. This allows you to unpaint your lines with the Paint tool but to maintain the shape

of the lines should you need to repaint later.

This command is useful when inking and painting and using theApply to All Drawings in Layer option.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Remove Contour Stroke
The Remove Contour Stroke option is used to remove any permanently invisible lines that were either created
while scanning and vectorizing drawings or manually adding contour strokes. This is useful if you want to remove
the intersection triangles created during vectorization.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

Grid

Use the Show Grid option to display a grid in theDrawing or Camera view.
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• Select View > Grid > Show Grid. The [Ctrl] + ['] (Windows/Linux) or [⌘ ] + ['] (MacOS X).

• Select View > Grid > Square to display a standard square grid.

• Select View > Grid > 12 Field Grid to display a 12 field size grid.

• Select View > Grid > 16 Field Grid to display a 16 field size grid.

• Select View > Grid > Underlay to display the grid behind the drawing elements.

• Select View > Grid > Overlay to display the grid over the drawing elements.

Group/Ungroup
Use theGroup option to group the selected drawing objects. This can help in the selection, repositioning,

re-scaling and other transformations to be applied to multiple objects of a drawing.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

• Select Edit > Group > Group or Edit > Group > Ungroup.

• Press [Ctrl] + [G] and [Ctrl] + [Shift] + [G] (Windows/Linux) or [⌘ ] + [G] and [⌘ ] + [Shift] + [G] (MacOS X).

Hand
Use theHand tool to pan through theDrawing and Camera view.

• In the Tools toolbar, select theHand tool, click in theDrawing or Camera view and drag your cursor.

• You can also Hold down the keyboard shortcut [Spacebar], click in theDrawing or Camera view and
move your mouse in the direction you want to pan the view.

Rotate View
Use the Rotate View tool to rotate theDrawing or Camera view, the sameway as you would do with a real

animation disc.

• Select Drawing > Tools > Rotate View.

In Harmony Paint, this option is found in the Selectedmenu rather than theDrawingmenu.

• Press [Ctrl] + [Alt] (Windows/Linux) or [⌘ ] + [Alt] (MacOS X).
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This tool can also be used in the Perspective view.

Related Topics

• How to Draw on page 61
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Chapter 5: Colour

With Toon BoomHarmony, you can add colour to your projects and even create sets of colours for your
characters. With Toon BoomHarmony’s colour palette concept, painting and colour styling has never been
easier!

Topics Covered

• How to Paint on the next page

• Colours on page 208

• Colour DisplayModes on page 219

• Selecting the Current Colour of a Tool on page 221

• Painting Using the Paint Tool on page 223

• Painting Pencil Lines with the Ink Tool on page 231

• Selecting a Colour in a Drawing on page 239

• Editing Gradients and Textures on page 241

• Closing Gaps Manually on page 247

• Protecting Colours on page 250

• Highlighting the Selected Colour on page 251

• Line Art and Colour Art Layers on page 253

• Verifying Zones are Painted on page 258

• Palettes on page 259

• Colour Model on page 288

• Colour Preferences on page 293
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How to Paint
Learn how to paint your drawings by following these instructions.

To paint your drawings:

1. In the Tools toolbar, select the Paint tool or press [Alt] + [I].

2. In the Colour view, select a colour from the palette.

‣ Double-click on a colour swatch to open the Colour Picker window andmodify the colour.

The colour palette will only appear in the Colour view once a drawing element has been selected.

3. In the Camera or Drawing view, start painting the colours on your drawing.
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Related Topics

• Colours on the next page

• Colour View on page 40
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Colours
Toon BoomHarmony has some very powerful colouring features when it comes to painting. To paint your
drawings you will use different colour swatches, unlike some paint programs where youmodify one swatch each
time youwant to paint with a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You
can add as many swatches as you want. You can also rename them andmodify existing ones.

When youmodify the colour of an existing swatch it automatically updates all the zones painted with this swatch
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted
zones. This way, you can change the look of your character at anytimewithout having to repaint it!

Related Topics

• Adding a Colour Swatch on page 210

• Deleting a Colour Swatch on page 217
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Palette Lists and Palettes Lock

Edit Palette List Mode
Every drawing element has a palette list. The scene also has a palette list. A palette list is a file containing all of
the links to the original palette files. For example, a drawing element can use three different palettes stored in
three different locations, while another drawing element can use two of these palettes plus another one coming
from another scene. The palette list keep tracks of the location of the palettes.

To prevent users accidentally removing a link to a palette, the palette lists are locked. To add a new link to a
palette, the user must first unlock the palette list.

To enable and disable the Edit Palette List Mode:

1. Select Edit > Edit DrawingMode or Edit Palette List Mode. When the option is enabled, a check mark
appears beside it.

When in Edit Palette Lists Mode, a grey pencil appears on the top corner of theColour view palette list
to indicate that it can bemodified.

Before you can add, remove or modify colours from a palette, you need to have the right to edit palettes.

Edit Palette Mode
A colour palette is an actual file that can be found on the hard drive. These palette files can be stored in a
different location on the server machine. They can be stored in the Environment, Job, Scene or Element folder
and linked to any palette list. This means that if the original palette file is modified, it will update in every drawing
element the palette is linked to. To avoid accidentally modifying the palette, the palette files can be locked. The
user must get the rights to modify them.

To enable and disable the Edit Palette Mode:

1. In theColour view, click on the Edit Palette Mode button.

When pushed in, themode is enabled, a grey pencil icon appears in the top corner

When pushed out, themode is disabled.
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Related Topics

• Connecting to the Database on page 1

• Global Lock on page 1

• Locking Drawings on page 1

Adding a Colour Swatch
You can use three different types of colour swatches, these are described in the following sections:

• Solid Colour Swatch below

• Default Colour Swatch on page 213

• Gradient Colour Swatch on page 214

• Bitmap Texture Swatch on page 215

Solid Colour Swatch

To add or modify a solid colour swatch:

1. In the Colour view, click on theNew Colour button.

2. In the Colour View menu, select Colours > Edit. You can also double-click on the colour pot.

The Colour Picker window opens.
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3. To set your colour:

‣ In the colour wheel, select the desired colour.

OR

‣ Type in the HSV or RGB values in the corresponding fields. Click on the R,G,B,H,S or V radio buttons
to change the look of the colour picking area.

OR

‣ Click on theDropper button to select any colour on your screen. It can be from the Toon Boom
Harmony’s interface, your Operating System or any other open application.
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You can also click on theMultiWheelMode button to open theMultiwheel Colour dialog box. This
displays all the picking area styles together and also contains a picking undo list. Click on the Single
WheelMode button to go back to the regular Colour Picker window.

4. If needed, click on the Shade Scale’s swatches to modify the shade of the selected colour.

5. If necessary, adjust the desired level of transparency with the Alpha slider, or type the value directly in the
Alpha field.

6. If necessary, click on theAdd button to add the current selected colour to the Colour Storage Library, so
you can quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by double-
clicking on its name.
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Default Colour Swatch
In Toon BoomHarmony, when you click on theAddColour button, a new colour swatch is created using the

colour of the currently selected swatch from your palette. However, you can set a Default colour to be used
every time you create a new colour in your colour palette. This might be useful if you want to create different
shades of the same basic colour.

To change the default swatch colour for all your colour palettes:

1. In the top menu, go to Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS X).

2. In the Preferences panel, under the Drawing tab, enable theCreate New Colour Pot Using the Default
Colour option. In addition, You can click on the colour swatch, located just beside, to change the Default
colour.

The default colour is also the colour used when you choose to vectorize images that you are scanning into your
scene, however you add the Default colour swatch to your palette in a different way, so that it is unique. It has a
unique ID number that makes it recognizable from all the other colours in your colour palettes. Being able to
change this colour allows you to change the basic colour of all scanned drawings. This can be useful onmore than
just an aesthetic level as sometimes when you go to NTSC or PAL, pure colours, such as pure black, can create
problems.

To add a new colour swatch using the default colour:

1. In the Colour View menu, select Colours > New.

A new swatch will be added to your palette using the default colour pot colour. The new swatch created
with theNew command will be named New 0.

Refer to Colour Preferences on page 293 to learn more on the Create New Colour Pot Using The
Default Colour preference and how to customize the default colour pot colour.
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Gradient Colour Swatch

To create a gradient colour swatch:

1. In the Colour view, select the colour to bemodified.

2. In the Colour View menu, select Colours > Edit. You can also double-click on the colour pot.

The Colour Picker window opens.

3. Enable theGradient option.

4. Select the Linear or Radial option.

5. Select theGradient arrows to modify the colours.
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‣ Click between the arrows to add extra colours.

‣ Pull down the arrows to remove them.

‣ Move the arrows left and right to modify the gradient distance.

Refer to the Editing Gradients and Textures on page 241 topic to learn how to reposition your
gradient zones in your drawings.

Bitmap Texture Swatch



Chapter 5: Colour Colours

216

To create a texture colour:

1. In the Colour View menu, select Colours >New Texture or click on theNew Texture button.

The Browser window opens.

2. Browse for a PSD or TGA bitmap file created in a third party software.

3. Click on theOpen button to create the colour swatch.

Refer to the Editing Gradients and Textures on page 241 topic to learn how to reposition your
textured zones in your drawings.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool instead of
plaid, just update the texture file in the swatch and the entire project updates. Any transformation previously
applied to the texture’s position in your drawings will be kept.

To replace a texture swatch:

1. In the Colour view, select the texture swatch you want to change the embedded bitmap texture file in.
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2. In the Colour View menu, select Colours > Edit Texture. You can also double-click on the swatch.

The Browser window opens.

3. Browse for the new PSD or TGA bitmap file created in a third party software.

4. Click on theOpen button to update the colour swatch.

Related Topics

• How to Paint on page 206

• Deleting a Colour Swatch below

Deleting a Colour Swatch
To delete a colour swatch:

1. In the Colour view, select the colour swatches to delete.
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2. In the Colour View menu, select Colours > Delete. You can also click on theDelete Colour button.

The default keyboard shortcut is [Delete].

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

3. Click OK to delete the colours or click Cancel to abort the operation.

‣ If you delete colour swatches already in use, the zones painted with them turn red so you can easily
identify them.

Related Topics

• Adding a Colour Swatch on page 210
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Colour Display Modes
This section describes the colour modes.

• Switching Between Thumbnails and List Displaymodes below

• Displaying Colour Values below

Switching Between Thumbnails and List Display
modes
TheColour view has two displaymodes:

• List Mode

• SwatchMode

To toggle between the display modes:

1. In the Colour View menu, select Colours > Swatch Mode.

‣ Enable the option to display the swatches.

‣ Disable the option to display the colour list.

Displaying Colour Values
When using Toon BoomHarmony, you can display the RGB values and names of your solid colour swatches.

This option is not available when displaying the colours in Swatch mode.
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To display the swatch colour values:

‣ In the Colour View menu, select Palettes > Display Colour Values.

The solid colour swatches’ RGB values will be displayed between the colour swatch and its name. The
gradient colour swatches will be identified as (gradient).

Related Topics

• Colour View on page 40
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Selecting the Current Colour of a Tool

While drawing and painting, you can let Harmony retain the last colour you selected for each one of the following
tools:

• Brush

• Paint

• Pencil, Ellipse, Line, Rectangle, Polyline

The Colour view has three swatches where you can set a colour for the Brush , Paint  and Pencil

tools.

To unlink the storage swatches:

1. In the Colour view, if the storage swatches are linked, click on the Linking button to unlink them.

s

2. Click on the Brush storage swatch.

3. In the Colour list, select the desired colour.

4. Click on the Pencil storage swatch.

5. In the Colour list, select the desired colour.

6. Click on the Paint storage swatch.
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7. In the Colour list, select the desired colour.

If you prefer not to use this behaviour and have Toon BoomHarmony use the same colour swatches regardless
of the selected tool, you can link the three swatches together.

To link the storage swatches:

1. In the Tools toolbar, select one of the following tool:

‣ Brush tool

‣ Paint tool

‣ Pencil tools:

• Pencil tool

• Polyline tool

• Line tool

• Ellipse tool

• Rectangle tool

2. In the Colour view, if the storage swatches are linked, click on the Linking button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.

Related Topics

• How to Paint on page 206
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Painting Using the Paint Tool

Themain tool you will use to paint your drawings with is the Paint tool. The Paint tool can be used in several

different modes, these can be customized in the Tool Properties view.

The Paint tool paints closed zones, this includes brush strokes, as well as pencil lines. If you have gaps in the lines
defining a zone, you will have to close them using either the Brush, Pencil, Close Gap tools or the Automatic
Close Gap option.

To paint with the Paint tool:

1. In the Timeline or Xsheet view, select the cell where you want to paint.

2. In the Tools toolbar, click on the Paint tool or press [Alt] + [I]. You can also select the Paint tool in the

top menu under Drawing > Tools > Paint.

3. In the Colour view, select a colour.

4. In the Camera view, start painting. You can click on a zone or pencil line to paint it, or you can trace a lasso
or marquee selection to paint several zones or pencil lines at once.

The last colour you select while using the Paint tool will be remembered the next time you select the
Paint tool.
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Related Topics

• Paint Tool Properties on the facing page

Create Breaking Triangles to Paint Brush Strokes
Not available in Harmony Paint.

The Brush tool is often themost intuitive and rapid tool for creating rough sketches and clean lines. A single
colour, such as black, is often used when tracing a clean version of a rough sketch. However, when it comes time
to soft trace the lines in different colours, the flattened or unflattened clean brush strokes can suddenly become
time consuming to ink.

Toon BoomHarmony provides a solution by creating triangular breaks at natural line intersections. These
intersections are the probable locations of where colour line breaks may occur, such as where a sleevemeets a
hand.

To create breaking triangles on a drawing:

1. In the Camera or Drawing view, use the Select tool to select part or all of the drawing to be broken.

2. In the top menu, select Drawing > Create Breaking Triangles. If your brush strokes are not flattened,
they will be flattened automatically before the breaking occurs.

3. Use the Repaint tool  to paint the outline of different colour zones with different colours.
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Paint Tool Properties
When you select the Paint tool, its properties and options appears in the Tools Properties view.

• Lasso andMarquee below

• PaintingMode on the next page

• Automatic Close Gap on page 227

• Paint and Remove Texture on page 228

• Apply to Multiple Drawings on page 228

• Apply to All Visible Drawings on page 229

• Respect Protected Colour on page 229

• Use Stored Colour Gradient on page 230

• Select Newly Painted/Repainted/Unpainted Contours/Lines on page 230

Lasso and Marquee
The Lasso andMarquee options let you choose what type of selection the Paint tool will do when youwill click
and drag your cursor to paint your drawings. The default selectionmode is Marquee.

• TheMarquee optionmakes a rectangle selection box. Everything inside the selection will be painted

according to the painting mode you selected.

• The Lasso option lets you draw a custom selection box around the zones to be painted. Everything

inside the selection will be painted according to the painting mode you selected.

Hold down the [Alt] key to switch to the oppositemode of your selection.



Chapter 5: Colour Painting Using the Paint Tool

226

Painting Mode
The Paint tool has four different modes available:

Paint Mode

Paint UnpaintedMode

Repaint Mode

Unpaint Mode

You can also find these tools directly in the Tools toolbar and in the Drawing Tools menu.

Paint Mode

The Paint mode paints everything it touches, including empty and filled zones.

Paint Unpainted Mode

The Paint Unpainted mode paints only empty zones. Any line or filled zone will remain unchanged.



Toon Boom Harmony 10.3 Paint User Guide

227

Repaint Mode

The Repaint mode paints everything it touches except empty zones. Any zone that is not painted will remain

intact.

Unpaint Mode

The Unpaint mode unpaints everything it touches, including empty and filled zones.

Automatic Close Gap
The Automatic Close Gap option has four modes available:

The Automatic Close Gap option is used while painting drawings with small gaps. Instead of having to close

themmanually either with the Brush tool or Close Gap tool, Toon BoomHarmony will analyze the drawing and
close the gaps while you paint according to the selected mode.
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The automated gap closing should be done using the zoom function setting of your Camera or Drawing view. If
your eye does not see the gap, Toon BoomHarmony won’t either.

Paint and Remove Texture

The Paint and Remove Texture option is used when you vectorized some images as greyscale texture style.

An image vectorized as texture is a mix of bitmap filling encapsulated in a vector based frame. Painting a
textured zones with the Paint tool will change the tint of the textured lines. Painting the textured zones using the
Paint and Remove Texture option transforms the bitmap filling into a 100% vector based zone and fills it with a
solid colour.

Apply to Multiple Drawings
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The Apply to Multiple Drawings option is used for hand-drawn animation fast painting. When youwant to

paint several drawings in a same layer at once, such as a walk cycle, you can enable this option and make a
selection in your Camera or Drawing view. All the closed zones located within your Paint tool selection are
painted with the selected colour swatch.

You do not need to enable theOnion Skin preview to use this option. The option will stay enabled only for the
next action. If you want to use it again, youmust click on the Apply to Multiple Drawings button again, or press
[Alt] + [A].

Apply to All Visible Drawings

The Apply to All Visible Drawings option is used to paint several drawings on separated layers on the

current frames. If you have a character broken in several layers, you can enable this option to paint all your layers
at once. The operation is only applied on the current frame.

The option will stay enabled only for the next action. If you want to use it again, youmust click on theApply to
All Visible Drawings button again.

This option is only available in the Camera view and does not affect symbols.

Respect Protected Colour
The Respect Protected Colour option is enabled by default. In your Colour view, you can protect some

colour swatches to avoid repainting or unpainting the zones linked to that swatch.

If you disable this option the Paint tool will not follow the protect colour rule and will repaint or unpaint the
protected colours on your drawings until you enable the option again.

Refer to the Protecting Colours on page 250 topic to learn how to lock your colours.



Chapter 5: Colour Painting Using the Paint Tool

230

Use Stored Colour Gradient

When you paint a zone with a gradient or textured colour swatch, the gradient or texture’s position is set
relative to the size of the zone your are painting. If you want the Paint tool to use a particular size and position,
youmust first store your desired position and size using the Select tool and then enable theUse Stored

Colour Gradient option in the Paint tool Tool Properties view.

Refer to the Storing Your Favourite Gradient or Texture Settings on page 245 topics to learn how to
store your gradient or texture position.

Select Newly Painted/Repainted/Unpainted Contours/Lines

In the Paint tool Tool Properties view, engaging this option will keep a selection highlighted around the

latest painted zone after using either the Paint, Repaint, Unpaint, or Paint Unpainted tool.

Related Topics

• Painting Using the Paint Tool on page 223
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Painting Pencil Lines with the Ink Tool
Although pencil lines can be painted inmuch the sameway as closed zones, you can use the Paint, Repaint,
Repaint Brush, and Ink tools to make painting segmented lines easier.

Normally when you have a drawing, such as the one below, and you use the Paint tool to paint one of the lines,
the entire line is painted.

However, if you select the Ink tool instead and click on the same pencil line, only the segment that you

clicked on between two intersections will be painted.

The newly inked segment will always bemoved to the front of all other pencil strokes, even if it was behind all
other pencil strokes before it was inked.

That is, unless you hold down [Alt] while clicking a segment. Then the opposite becomes true. The inked segment
will be sent to the back, even if it was in front of all other segments to begin with.
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Painting and Inking can be used in combination depending onwhat it is that you need to paint. If you need to ink
a character’s outline in black, it might be easier to use the Paint tool. If you need to paint the outline of a
character’s neck with a tan colour and its shirt outline blue and both the neck and shirt belong to the same
continuous outline, then the Ink tool might provemore useful.

Related Topics

• Ink Tool Properties below

Ink Tool Properties
When you select the Ink tool, its properties and options appears in the Tools Properties view.

• Lasso andMarquee below

• Show Inkable Lines on the facing page

• Be Smart on Connecting Lines on the facing page

• Select Mode on the facing page

• Arrange Ink Lines on the facing page

• Mitre on the facing page

• Tip Style on the facing page

Lasso and Marquee
The Lasso andMarquee options let you choose what type of selection the Paint tool will do when youwill click
and drag your cursor to paint your drawings. The default selectionmode is Marquee.

• TheMarquee optionmakes a rectangle selection box. Everything inside the selection will be painted

according to the painting mode you selected.

• The Lasso option lets you draw a custom selection box around the zones to be painted. Everything

inside the selection will be painted according to the painting mode you selected.

Hold down the [Alt] key to switch to the oppositemode of your selection.
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Show Inkable Lines
The Show Inkable Lines option highlights all pencil lines (so no brush strokes) on the selected layer. Pencil

line segments that are already inked with the selected swatch colour from the colour palette are also not
highlighted.

Be Smart on Connecting Lines
With this option selected, as you hover and move the cursor across intersecting pencil lines, the path that

you create will get highlighted. When you click on your mouse or stylus the highlighted segments will get inked.

With this option disabled, all the intersecting segments that your cursor comes near will get highlighted and
become part of the selection, even if they were not situated in the direction of the chosen path.

This option only works if the Ink tool is inHoverMode and not Select Mode.

Select Mode
Use this mode instead of theHoverMode. In theHoverMode, any potentially inkable pencil line will have

its central vector line highlighted as the Ink tool’s cursor hovers over it. Use [Ctrl] (Windows/Linux) or [⌘ ] (Mac
OS X) to toggle between the two modes.

Arrange Ink Lines
Use this option to have every newly inked line be brought to the front. Disable this option to have every

newly inked line be sent to the back. Use [Alt] to toggle between the two options.

Mitre
As you hover over two perpendicular or nearly perpendicular segments a highlighted path with a corner is
created. Clicking on these highlighted segments inks both segments and makes them appear as a single stroke
with a corner or bend.

Click on theMitre button to reveal four options from its drop downmenu. Select either Round, Mitre,

Bevel or As Is before creating corner selections to make a bend in the path either round, sharp, bevelled or
gapped.

Tip Style

Use the Tip Style option to customize the edge of the Ink tool.
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Related Topics

• Painting Pencil Lines with the Ink Tool on page 231

Advanced Painting Features

The following advanced painting features are available in Toon BoomHarmony and are described in this section:

• Repaint Selection on the facing page

• Repaint SelectionOnAll Drawings on the facing page

• Repaint Outside Selection on page 236

• Repaint Outside SelectionOnAll Drawings on page 236

• Unpaint Selection on page 237

• Unpaint SelectionOnAll Drawings on page 237

• Unpaint Outside Selection on page 238

• Unpaint Outside SelectionOnAll Drawings on page 238
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Repaint Selection

The Repaint Selection command is used to repaint any art inside a selection. Youmust first draw a selection
using the Select tool in order for this command to be available.

To use the Repaint Selection command:

‣ Select Drawing > Paint > Repaint Selection.

Repaint Selection On All Drawings

The Repaint SelectionOnAll Drawings command is used to repaint any art inside a selection on all the drawings
contained within the same layer. Youmust enable the Permanent Selection option in the Select tool Tool

Properties view and then draw a selection in your drawing using the Select tool in order for this command to

be available. The Permanent Selection option is used to maintain the same selection throughout the drawings of
a same layer.

To use the Repaint Selection On All Drawings command:

‣ Select Drawing > Paint > Repaint Selection On All Drawings.
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Repaint Outside Selection

The Repaint Outside Selection command is used to repaint any art outside a selection. If no selection has been
drawn using the Select tool, the entire drawing will be repainted.

To use the Repaint Outside Selection command:

‣ Select Drawing > Paint > Repaint Outside Selection.

Repaint Outside Selection On All Drawings

The Repaint Outside SelectionOnAll Drawings command is used to repaint any art outside a selection on all the
drawings contained within the same layer. Youmust enable the Permanent Selection option in the Select

tool Tool Properties view and then draw a selection in your drawing using the Select tool in order for this

command to be available. The Permanent Selection option is used to maintain the same selection throughout the
drawings of a same layer.

To use the Repaint Outside Selection on All Drawings command:

‣ Select Drawing > Paint > Repaint Outside Selection on All Drawings.
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Unpaint Selection

The Unpaint Selection command is used to unpaint any art existing inside a selection. Youmust first draw a
selection using the Select tool in order for this command to be available.

To use the Unpaint Selection command:

‣ Select Drawing > Paint > Unpaint Selection.

Unpaint Selection On All Drawings

The Unpaint Selection on All Drawings command is used to unpaint all art contained inside a selection on all the
drawings within the same layer. Youmust enable the Permanent Selection option in the Select tool Tool

Properties view and then draw a selection in your drawing using the Select tool in order for this command to

be available. The Permanent Selection option is used to maintain the same selection throughout the drawings of
a same layer.

To use the Unpaint Selection On All Drawings command:

‣ Select Drawing > Paint > Unpaint Selection On All Drawings.
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Unpaint Outside Selection

The Unpaint Outside Selection command is used to unpaint any art existing outside a selection. If no selection
have been drawn using the Select tool, the entire drawing will be unpainted.

To use the Unpaint Selection command:

‣ Select Drawing > Paint > Unpaint Outside Selection.

Unpaint Outside Selection On All Drawings

The Unpaint Outside Selection on All Drawings command is used to unpaint all art outside a selection on all the
drawings within the same layer. Youmust enable the Permanent Selection option in the Select tool Tool

Properties view and then draw a selection in your drawing using the Select tool in order for this command to

be available. The Permanent Selection option is used to maintain the same selection throughout the drawings of
a same layer.

To use the Unpaint Outside Selection On All Drawings command:

‣ Select Drawing > Paint > Unpaint Outside Selection On All Drawings.

Related Topics

• Select Tool Properties on page 130
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Selecting a Colour in a Drawing

While working in your Camera or Drawing view, you can use the Dropper tool to pick a colour from your

drawing without going to the Colour view.

To use the Dropper tool:

1. In the Tools toolbar, select theDropper tool or press [Alt] + [D]. You can also select the Dropper tool

fromDrawing > Tools > Dropper in the top menu.

2. In the Camera or Drawing view, click on the desired colour.

‣ If you are using another drawing tool such as the Paint tool, you can temporarily hold down the [D] key
and click in your drawing before releasing the key to pick your colour. Once you let go the hot key,
Toon BoomHarmony will go back to your previous tool.

Youmay also want to select the zones painted with the colour currently selected in the Colour view. This can be
useful to remove rough lines from a clean drawing.
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To select the zones paintedwith the current colour:

1. In the Colour view, select the colour you want to select the corresponding zones from.

2. Select Drawing > Select Strokes with Current Colour.
Or press [Ctrl] + [Shift] + [A] (Windows/Linux) or [⌘ ] + [Shift] + [A] (MacOS X).

Related Topics

• How to Paint on page 206
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Editing Gradients and Textures

If you paint a zone or pencil line with a gradient or texture you can use the Edit Gradient/Texture   tool to

modify its position in the zone. You canmove, scale, rotate and skew. If you have to match the transformations
performed on a gradient or texture from one zone or pencil line to many others, you can copy and paste the Edit
Gradient/Texture position. Whenmoving to the next drawing, you can select the next texture and paste the
previous position to continue themodifications.

To use Edit Gradient/Texture tool on a zone:

1. In the Tools toolbar, select the Edit Gradient/Texture  tool. You can also select this tool from the top

menu under Drawing> Tools > Edit Gradient/Texture or press [Shift] + [F3].

2. Click on theGradient or Texture zone to bemodified.

‣ If you want to modify several areas at once, hold down the [Shift] key and click on the zones to be
modified.
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3. Move the edit texture’s anchor points to the desired result.

‣ If the samemodification needs to be applied to another gradient in another drawing or texture zone,
you can select themodified zone and select Edit > Copy. Select the zone to bemodified in the other
drawing and select Edit > Paste.

A pencil line can have its gradient, texture or texture’s gradient edited in two different ways, either with the
Pencil Editor  or with the Edit Gradient/Texture   tool.

To use Pencil Editor tool to edit the texture or gradient on a pencil line:

1. In the Tools toolbar, select the Pencil Editor   tool. You can also select this tool from the top menu

under Drawing > Tools > Pencil Editor or press [Alt] + [W].

2. Click on the pencil line to bemodified to bring up its contour envelope.

3. Select one of the contour points around the envelope andmove its position to change the size of the tiled
texture or gradient. You can also pull directly on the lines of the contour envelope or play with the bezier
handles of any given point in order to continue to modify the envelope form.
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Expanding the width of the envelope parallel to the pencil line’s central vector will cause the tiled texture
to be stretched. Conversely, reducing the envelope’s width will cause the tiled texture to look squashed.

Reducing the contour’s width perpendicular to the pencil line’s central vector will reduce the number of
tiles, while expanding it will increase the number of tiled images.

This editing technique does not just work on texture fills, but can also be applied to pencil lines drawn
with a textured “brush”.

To use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line:

1. In the Tools toolbar, select the Edit Gradient/Texture  tool. You can also select this tool from the top

menu under Drawing > Tools > Edit Gradient/Texture or press [Shift] + [F3].

2. Click on the pencil line to bemodified to bring up the editor controls.

3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull on the
top of the editor controls to stretch the tiled texture throughout the length of the stroke.

As gradients are parallel to the stroke’s central vector, this will stretch the way that the gradient is
distributed in the pencil line’s envelope. The envelope still acts as a boundary for the texture or gradient.
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4. Drag the editor control perpendicular to the stroke. You will feel it glide along the strokes central vector
line. This is another way to resize the texture tile. Instead of stretching or shrinking it vertically, this
motion stretches or shrinks it vertically. As gradients are parallel to the pencil line’s central vector,
stretching them vertically gives no visual result.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawnwith
textured “brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both
elements independently at the same time.

To use Edit Gradient/Texture tool to edit both the texture and the gradient of a pencil line:

1. In the Tools toolbar, select the Edit Gradient/Texture  tool. You can also select this tool from the top

menu under Drawing > Tools > Edit Gradient/Texture or press [Shift] + [F3].

2. Click on the pencil line to bemodified to bring up the editor controls.

3. Use the top editor controls edit the gradient.
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4. Use the bottom controls edit the “brush” texture.

Related Topics

• Drawing Using the Pencil Tool on page 73

• Storing Your Favourite Gradient or Texture Settings below

Storing Your Favourite Gradient or Texture Settings
If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool to use your gradient’s
position, angle and scale settings instead of the default ones, you can store your own settings and reuse them
afterward.

To store your gradient and texture settings:

1. In the Tools toolbar, select the Select tool or press [Alt] + [S].

2. In the Camera or Drawing view, select the gradient or texture zone to store.
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3. In the Tool Properties view, click on the Store Colour Gradient button.

To use the stored gradient and texture settings:

1. In the Tools toolbar, select the Brush or Paint tool.

2. In the Tool Properties view enable theUse Stored Colour Gradient button.

3. In theCamera or Drawing view, draw and paint.

Related Topics

• Editing Gradients and Textures on page 241
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Closing Gaps Manually

When painting, notice that some of your drawing areas are not closed. To close the zone, you can either draw
themissing line with the Brush or Pencil tool, or close the gap with an invisible line. To do this, you will use the
Close Gap tool.

The Close Gap tool is used to close small gaps in a drawing. The Paint tool only paints closed areas. The Close
Gap tool will create a small, invisible stroke between the two closest points to close the colour zone. You do not
need to trace directly over the gap. You can draw it a few millimeters away. The two closest points automtically
close up the gap.

To close gaps:

1. In the Tools toolbar, select theClose Gap  tool, select Drawing> Tools > Close Gap or press [Alt] +

[C].

‣ Enable theAuto-Flatten option in the Tool Properties view if you want the stroke you will draw to

be flattened in your drawing instead to be on top.

‣ You can display the invisible lines with the Show Strokes option under View > Show Strokes or press
[K].

‣ If you do not display the strokes, a Message dialog box will appear.

Enabling the Don’t Show This Message Again option prevents this Message dialog box from appearing.

2. In the Camera or Drawing view, trace an invisible line near to the gap to be closed. The gap will
automatically close.
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Related Topics

• Close Gaps below

• How to Paint on page 206

Close Gaps
When you have too many gaps in your drawings, you can use the Close Gaps feature in Toon BoomHarmony

1. Close Gaps slider: Use this slider to determine the size of the gap youwant to be closed. Move the slider
to the left for smaller gaps and move it to the right for bigger gaps.

2. Apply to all drawings: Enable this option so that theClose Gaps feature is applied to all the drawings of
the selected layer.

To use the Close Gaps feature:

1. Select the Show Strokes option to see a preview of the result.

2. Select View > Show Strokes or press [K].

3. Select Drawing > Clean Up > Close Gaps or press[Shift] + [F10] (Windows/Linux only).

The Close Gaps dialog box opens.

4. Adjust the slider.

5. Select theApply to all drawings option if needed.
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6. Click OK.

Refer to Colour Preferences on page 293 at the end of this chapter to learn more about the Close
Gap options.

Related Topics

• Closing Gaps Manually on page 247
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Protecting Colours
When you are finished painting some zones, you can protect the colour swatch they are associated with so the
work cannot be accidentally painted over.

To use Protect Colour:

1. In the Colour view, select the colour to be protected.

2. In the Colour view menu, select Colours > Protect Colour. You can also right-click on the selected colour
and select Protect Colour.

A red bar will appear on the side of the colour, notifying you that it is locked.

Related Topics

• Respect Protected Colour on page 229
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Highlighting the Selected Colour
The Highlight Selected Colour option is used to identify colour pots used in a drawing. For example, if you have
unnamed colours in your palette and youwant to find out if a particular colour pot was used on the current
model or drawing, you can select the colour pot and use the Highlight Selected Colour option. The systemwill
wash out all the colours in the drawing except the selected one so that it stands out and can be identified. You
can rename it accordingly.

To use the Highlight Selected Colour option:

1. In the Colour view, select the colour you want to highlight.

2. In the Drawing view or Camera view menu, select View > Show > Highlight Selected Colour.

Related Topics

• Selecting a Colour in a Drawing on page 239
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Inverting a Colour Selection
When you need to select all colour swatches but one, or select only a few swatches here and there, it might be
faster to select the only colour you do not need, in order to select and invert the selection.

To invert a colour swatch selection in the Colour view:

1. In the Colour view, select the colour swatch youDO NOT want to have in your final selection.

2. In the top menu, select Edit > Invert Selection.

Related Topics

• Colours on page 208
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Line Art and Colour Art Layers
Toon BoomHarmony has an option allowing you to paint the lines and the colour fills separately.

In Toon BoomHarmony, a drawing is composed of four embedded layers:

• Overlay Layer

• Line Art Layer

• Colour Art Layer

• Underlay Layer

In general, use the Line Art and Colour Art layers. The Underlay and Overlay layers are used for advanced
purposes.

Refer to the topic to learnmore about these layers.

Toon BoomHarmony has an option allowing you to paint the lines and the colour fills separately.

In Toon BoomHarmony, a drawing is composed of two embedded layers:

• Line Art Layer

• Colour Art Layer

The Line Art and Colour Art layers are only available in the Advanced Art Mode.

By default, you draw on the Line Art layer. The colour layer is always placed under the Line Art layer. These layers
are accessible in the Drawing or Camera view (using drawing tools). When you look at your final drawing in the
Timeline, Xsheet or Network view, you will not see four layers; instead youwill see the final composition of the
lines and colours.

You can draw and paint in all layers, but if you prefer working in a single layer, you can do everything in Line Art.

Themain advantage of using the Line Art and Colour Art option is so you can repaint the lines easily. If your
colour fills are separated from the lines, it allows you to use the repaint tool and paint the lines without affecting
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the colour zones. Also, it allows you to paint tones and highlights in line art and then add some transparency to
see the Colour Art through it.

In order to paint in the Colour Art, you must first use the Create Colour Art from Line Art option to
create colour zones in the Colour Art. You need to use this option to paint drawings vectorized as
greyscale texture style.

To toggle between Line Art and Colour Art and enable the Preview mode:

1. In the Tools toolbar, select any drawing tool.

2. To toggle between Line Art and Colour Art:

‣ In the Drawing view,right-click and select Switch to Colour Art/Switch to Line Art or s[L].

‣ In the Drawing or Camera bottom toolbar, click on theColour Art button.

‣ In the Drawing or Camera bottom toolbar, click on the Line Art button.

3. To preview the Line Art and Colour Art at the same time:

‣ In the Drawing view,right-click and select Preview Line Art and Colour Art. While using the Preview
mode, you still edit onemode at a time or press [Shift] + [P].

‣ In the Drawing or Camera bottom toolbar, click on the Preview button. To be able to see only

one of the layers at a time in the Camera view, youmust enable theCurrent Drawing on Top option,
available from the Camera bottom toolbar drop-downmenu. If this option is not enabled, you will see
the final composition of all four layers.

In order to edit both Line Art and Colour Art at the same time, you must enable the Apply to Line Art
and Colour Art button in the Tool Properties of the tools supporting the operation.

Underlay and Overlay Layers
In Toon BoomHarmony, you have two extra art layers available beside the Line Art and the Colour Art, the
Underlay and theOverlay layers. The Underlay is situated at the very bottom and theOverlay at the very top.

Underlay
The Underlay layer can be used like any other of the art layers available in the drawing, but since it is situated

behind everything else, you can use it to create a matte for a quick line-test, write notes or store your rough
animation.
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Overlay
TheOverlay layer can be used as any other of the art layers available in the drawing, but since it is situated

on top of every other, it can be useful for writing notes about the colour model or animation or to draw the
highlight and tone shapes.

Related Topics

• Generating a Matte for Your Animation

• Creating Strokes to Paint Your Drawings on a Separated Layer below

• More Drawing Layers

Creating Strokes to Paint Your Drawings on a
Separated Layer
You can use the outline you traced on one of the four embedded layers and create invisible strokes to paint your
drawings on separate layers, this provides more inking and painting flexibility.

To do so, youmust use theCreate Colour Art from Line Art option. You can also configure the option to create
the invisible strokes on any of the four embedded layers.

Make sure to enable the Advanced Art Mode in the Preferences panel in order to be able to use this
feature.

To create Colour Art zones out of the Line Art content:

1. In the Tools toolbar, select the Select tool or press [Alt] + [S].

2. In the Camera or Drawing view, select the artwork to transfer to the Colour Art.
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3. In the Drawing View toolbar, click on theCreate Colour Art from Line Art button or press [*].
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To Configure the Line Art to Colour Art command settings:

1. In the Tools toolbar, select the Select tool or press [Alt] + [S].

2. In the Tool Properties view, hold down the [Shift] key and click on theCreate Colour Art from Line Art
button to open the Configure Line Art to Colour Art dialog box and modify the default settings of

this command.

The Configure Line Art to Colour Art dialog box opens.

3. Use rendered version of the drawing: This option will render the drawing and vectorize it to calculate the
position of the centreline that will produce the colour art stroke.

4. MaximumResolution for rendered image: This is the size of the rendered image.

5. Threshold for rendered image: The value of grey processed to create the rendered vectorized arts.

6. Fitting error for generated Beziers: This value represents how precise the fitting of the colour art zone in
relation of the line art will be.

7. Source Layer: In the Source Layer drop-downmenu, select the layer (Line Art, Colour Art, Underlay or
Overlay) you want the strokes to be created from.

8. Destination Layer: In the Destination Layer drop-downmenu, select the layer (Line Art, Colour Art,
Underlay or Overlay) you want the strokes to be created on.

9. Clear Destination Art Layer First: If you already have artwork on the destination layer and youwant the
content to be deleted before the strokes are added into it, enable this option.

10. Perform Line Art to Colour Art Operation Immediately: Enable this check box to perform the Create
Colour Art from Line Art command when you click on theOK button of this window.

Related Topics

• Line Art and Colour Art Layers on page 253
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Verifying Zones are Painted
When the painting process is completed, you should verify that each zone was painted correctly.

The Backlight feature produces a silhouette effect by changing the drawing’s coloured areas into a single dark,
solid colour use this to verify the completeness of the ink and paint process. Any unpainted zones can be seen as
the light shows through the unpainted areas of the silhouetted drawing.

To use the Backlight:

This feature is only available in the Drawing view.

1. In the top menu, select View > Backlight or press [Alt] + [Shift] + [B]. You can also click on the Backlight
button available in the Drawing View toolbar.

2. Verify the drawings in the Drawing view.

Related Topics

• How to Paint on page 206

• Painting Using the Paint Tool on page 223
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Palettes

In colour animation, specific colours are used to paint each particular character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production. These are
referred to as master palettes.

Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.

Using a master colour palette has many benefits, including:

• Each character consistently retains their dedicated colours.

• You cannot accidentally use a colour which is not in themaster palette.

• Standardization and colour consistency throughout the production

• Multiple artists can use the same colour palette and produce the same results.

Toon BoomHarmony uses palettes to hold all of the colours needed to paint your elements, allowing complete
control and consistency in your painting process.

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue,
shirt, pants, etc.

This topic is divided as follows:

• Displaying the Palette List on the next page

• Creating a Colour Palette on page 264

• Copying and Pasting Colours on page 276

• Removing a Colour Palette on page 277

• Duplicating a Colour Palette on page 278

• Cloning a Colour Palette on page 279
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• Mixing the Colours on page 281

• Importing a Colour Palette on page 283

• Ordering the Palette List on page 287

Displaying the Palette List
TheColour view has two modes: basic and advanced.

Basic Mode
The Colour view’s basic mode only shows the Colour list. When you open Toon BoomHarmony, you only see the
colours available in the default palette. This default palette contains six basic colour swatches and is
automatically named the same as your scene. For simple projects, you canmanagewith the default palette, but
for movies, series or shorts it is recommended that you create palettes for your characters. To create a palette,
you have to switch to the advanced display of the Colour view and show the Palette list.

Advanced Mode
To create palettes for your characters, youmust display the Palette list. Once you display the Palette list area, a
series of new buttons appear.

To show or hide the Palette List area:

1. In the Colour view, click on the Show/Hide Palette List View button to expand or collapse the

Palette List area.
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• Each palette you add in your scene will appear in the Palette list.

• You can add, delete, import and order palettes in your scene using the Palettemenu buttons.

Related Topics

• Creating a Colour Palette on page 264

• Toon BoomHarmony Palette File Storage below

Toon Boom Harmony Palette File Storage
In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is
created, it needs to be stored somewhere. Harmony is set on Basic Palette Lists modewhich saves the palette at
the Scene level.

In Toon BoomHarmony, you can switch from Basic Palette Listsmode to Advanced Palette Listsmodewhich
will allow you to choose the folder level you want to save your palette files to.

Refer to the Creating a Colour Palette on page 264 section to learn more on how to access these
options.

There are four locations where you can find Palette Library folders: Element, Scene, Job and Environment
folders.

• Element: The Palette Library folder is stored directly in the Drawing Element (Layer) folder.

• Scene: The Palette Library folder is stored directly in the Scene folder.

• Job: If you are working with Toon BoomHarmony as a stand alone version, the Palette Library folder is
stored in a Job folder contained within the Scene folder.
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• Environment: If you are working with Toon BoomHarmony as a stand alone version, the Palette Library
folder is stored in an Environment folder contained in the Scene folder.

This existing structure is compatible with Toon BoomHarmony Server. Toon BoomHarmony’s database has a
leveled structure starting from the Environment down to the Element. They have a client-server configuration
that allows all data, such as palettes and scenes, to be shared between a series of client machines.

In Toon BoomHarmony, you can switch from Basic Palette Lists Mode to Advanced Palette Lists Mode and
choose the folder level you want to save your palette files to.

Element Level
Working with Harmony stand alone, the Element level is very useful when there are a lot of different palettes.
When a colour model drawing is created, it is stored in its element folder. By storing the corresponding palette
file with the colour model, the colourist is able to load them both from the same location. This also creates a
more organized structure.

Scene Level
Working with Toon BoomHarmony stand alone, a palette file can also be saved at the scene level so that all of
the palettes from the scene are stored together. The palette naming will have to be structured so that the
colourist or character builders can find the correct one. Saving the palettes at the scene level makes it very easy
to backup the palettes and retrieve their location.

The scene level can also be useful for Cut-out animation. Instead of creating a colour model scene that includes
all of the characters, props, effects, and location, the colour palette or model will often be directly imported to,
or created in, the character building scene. Just as with a Cut-out character building scene, each element uses
the same palette so it would not be efficient to save the palette inside one element. Instead, it is saved at the
scene level. This prevents a palette overload because all of themodels are in different scenes. It also allows each
scene its own set of palettes corresponding to its model.

Whenworking on a cut-out animation production, it is highly recommended to work with the Scene level.

Related Topics

• Palettes on page 259

Scene Palette List and Element Palette List
There are two types of palette lists:

• Scene Palette List on the facing page

• Element Palette List on the facing page

Refer to the Colour Preferences on page 293 topic in this chapter to learn how to enable and disable
the Element Palette List mode.
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Scene Palette List
The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in twenty
to thirty different drawing elements that use the character’s master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to this
list will appear in every drawing element created in the scene. There is no need to manually load the palette in
each element.

The Scene Palette List is the simplest one to use. By default, Toon BoomHarmony is set to use only Scene
Palette Lists.

Element Palette List
In Toon BoomHarmony, you can switch to Advanced Palette Lists mode and choose to save your palette at an
element’s level. The Element Palette List is mainly used with Traditional and Paperless animation. Unlike Cut-out
animation, all columns (drawing elements) contain different characters, props, backgrounds and effects. The
Element Palette List is used because you do not necessarily want all of the palettes for all of your elements linked
in every column.

The palette list is stored in the drawing element’s directory instead of directly in the Scene level. This ensures
that the links to the palettes appear only in the appropriate element. If you prefer to access a global palette list,
link your palettes to the Scene Palette List.
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Related Topics

• Creating a Colour Palette below

Creating a Colour Palette
You can create a palette in either basic or advanced mode:

• Basic Palette Lists Mode below

• Advanced Palette Lists Mode below

• Renaming a Colour Palette on page 266

By default, Toon BoomHarmony is set on basic mode. For simple productions, it is recommended to use the
basic mode. For more advanced productions, it is a good idea to explore the possibilities of the advanced
mode.

If you are using Harmony Network, refer to Managing Palettes on page 266.

Basic Palette Lists Mode
To create a new palette (Basic Palette Lists mode):

1. In the Colour View menu, select Palettes >New or click on theNew Palette button.

The Create Palette window opens.

2. Enter the palette name according to themodel.

3. Click OK.

The palette appears in the drawing element’s palette list.

Advanced Palette Lists Mode
To use this method, you first need to set your preferences to Advanced Palette Lists mode in the Preferences
panel.
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To set the Advanced Palette Lists mode:

1. Select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS X) to open the
Preferences panel or press [Ctrl] + [U]Windows/Linux) or [⌘ ] + [U] (MacOS X).

2. In the Advanced tab, enable theAdvanced Palette Lists option.

3. Click OK.

To create a new palette (Advanced Palette Lists mode):

1. In the Timeline or Xsheet view, select the drawing that requires the palette.

2. In the Colour View menu, select Palettes > New or click on theCreate Palette button.

The advanced Palette Browser: Create Palette (Stand-alonemode) window opens.

‣ Palette Location: Select which location to store the palette file to.

• Element: Displays the drawing layers in your scene.

• Environment

• Job

• Scene

• Element.

• Palette: Displays the palettes available in the currently chosen storage folder.

• Palette Name: Name the new palette.

‣ Palette List: Select either Scene Palette List or Element Palette List.

3. Select an element from the Element window.

4. If you want to save your palette at the element level, select the Element option from the Palette Location
section and then select the desired element form the Element list.

5. Select either Scene Palette List or Element Palette List.
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6. Click OK.

The palette is created.

Refer to the Toon Boom Harmony Palette File Storage on page 261 and topics to learn more about
palette storage location as well as scene and element palette lists.

Renaming a Colour Palette
To rename a palette:

1. In the Colour view, select the palette to rename.

2. In the Colour View menu, select Palettes > Rename.

3. In the Rename dialog box, rename the palette.

4. Click OK.

Related Topics

• Copying and Pasting Colours on page 276

• Removing a Colour Palette on page 277

• Duplicating a Colour Palette on page 278

• Cloning a Colour Palette on page 279

Managing Palettes
The HarmonyNetwork solution incorporates palettes which hold all of the colours needed to paint elements, a
concept that brings complete control and consistency to the painting process. A palette is created by assigning
a set of colours to each character, prop or effect. The colour artist will create a new palette and add a new
colour, called a colour pot, for each zone of the character, such as the skin, hair, tongue, shirt, pants and so on.

When a zone on a character is painted with the colour contained in a colour pot, a link is automatically created
between that colour pot and the zone. This means that if the tint of the colour in the colour pot is modified, any
zone that is linked to it will automatically update to the new tint. This saves time andmoney spent on your
production. Another advantage of this system is that you can also create complete palettes for different lighting
situations. For instance, in addition to the regular palette for a character, you can have one for that character in
the rain, using colours that aremuted and less vibrant than the dry daytime colours, or another for use in a night
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scene. Using palettes that are linked to your character this way allows you to instantly change colouring to suit
themood and atmosphere of the scene without tediously repainting each element.

Related Topics

• Creating a Palette in Harmony below

• PaletteOperations on page 271

• Palette Storage on page 274

• Palette Backup on page 276

Creating a Palette in Harmony
Harmony is set to Basic Palette Listsmode by default. This setting stores the palettes automatically for you and
saves them at the Scene level. When you useAdvanced Palette Listsmode, you can decide at which level you
want to store your palettes; Environment, Job, Scene, Element.

To switch to Advanced Palette Lists mode:

1. Open the Preferences panel:

‣ Windows/Linux: Select Edit > Preferences.

‣ MacOS X: Select Stage > Preferences.

‣ The [Ctrl] + [U]Windows/Linux) or [⌘ ] + [U] (MacOS X).

The Preferences panel opens.

2. Select theAdvanced tab.

3. Enable theAdvance Palette Listsmode.

4. Click on theOK button.

To create a palette from the Advanced Palette Lists mode:

1. Make sure that you have the necessary rights to modify the palette list. If you do not, select Edit > Edit
Palette List Mode, a check mark will appear beside the command to indicate that themode is enabled.

2. In the Timeline or Xsheet view, select the drawing that requires a palette.

3. In theColour view, click on the Show Palette List View button to display the palette list.
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4. In theColour view, click on theMenu button and select Palettes > New or click on theCreate
Palette button.

The Palette Browser: Create Palette dialog box opens.

5. Select which level to store the palette file in.

• Environment

The Palette Library folder is stored in an Environment folder contained in the Scene folder.

• Job

The Palette Library folder is stored in a Job folder contained in the Scene folder.

• Scene

The Palette Library folder is stored directly in the Scene folder.

• Element

The Palette Library folder is stored directly in the Drawing Element folder.

When you select a level that has a palette stored in it, the palette names are displayed in the Palette field.

6. Name the palette. (There is no need to add the suffix "palette"  to the name as it is always recognized as a
palette file.)

7. Select a Palette List option:
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• Scene Palette List

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in
twenty to thirty different drawing elements that use the character's master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to
this list will appear in every drawing element created in the scene. There is no need to manually load the
palette in each element.

• Element Palette List

The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out
animation, all columns (drawing elements) contain different characters, props, backgrounds and effects.
The Element Palette List is used because you do not necessarily want all of the palettes for all of your
elements linked in every column.

The palette list is stored in the drawing element's directory instead of directly in the Scene level. This
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a
global palette list, link your palettes to the Scene Palette List.

8. Click on theOK button.

The new palette appears in the palette list.

Related Topics

• Palette Storage on page 274

• Linking a Palette in Harmony below

Linking a Palette in Harmony

To link a palette in Harmony:

1. Make sure that you have the necessary rights to modify the palette list. If you do not, select Edit > Edit
Palette List Mode, a check mark will appear beside the command to indicate that themode is enabled.

2. In the Timeline or Xsheet view, select the drawing that requires a palette.

3. In theColour view, click on the Show Palette List View button to display the palette list.

4. In theColour view, click on theMenu button and select Palettes > Link or click on the Link Palette

button.

The Palette Browser: Link Palette dialog box opens.
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5. Select the location and level where the palette file is stored. When a level is selected, the palettes it
contains are displayed in the Palette field.

6. Select your palette.

7. Select a Palette List option:

• Scene Palette List
The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in
twenty to thirty different drawing elements that use the character's master palette.
The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to
this list will appear in every drawing element created in the scene. There is no need to manually load the
palette in each element.

• Element Palette List
The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out
animation, all columns (drawing elements) contain different characters, props, backgrounds and effects.
The Element Palette List is used because you do not necessarily want all of the palettes for all of your
elements linked in every column.
The palette list is stored in the drawing element's directory instead of directly in the Scene level. This
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a
global palette list, link your palettes to the Scene Palette List.

8. Click on theOK button.

The palette appears in the drawing element's palette list.
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Related Topics

• Creating a Palette in Harmony on page 267

Palette Operations
When you launch Toon BoomHarmony connected to the database, you can have access to the Palette
Operations dialog box. The Palette Operations lets you clone, rename or delete palettes.

To open the Palette Operation dialog box:

1. Launch Toon BoomHarmony and login on the database. Refer to Connecting to the Database on page 1.

2. Click on theClose button to close theDatabase Selector dialog box.

3. Select Tools > Palette Operations.

The Palette Operations dialog box opens.

To clone a palette in the Palette Operation dialog box:

1. Select the palette you want to clone at the location and level it was stored in.

2. Click on theClone button.

3. AWarning dialog box opens.
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‣ Click in the checkbox besideDon't show this message again if you want to prevent the dialog box
from opening every time you do this operation.

4. Click on the Yes button to continue or click on theNo button to cancel the palette cloning operation.

The Palette Browser dialog box opens.

5. Select the location level where you want the new palette to be stored.

6. Name the new palette.

7. Select a Palette List option:

• Scene Palette List
The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in
twenty to thirty different drawing elements that use the character's master palette.
The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to
this list will appear in every drawing element created in the scene. There is no need to manually load the
palette in each element.

• Element Palette List
The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out
animation, all columns (drawing elements) contain different characters, props, backgrounds and effects.
The Element Palette List is used because you do not necessarily want all of the palettes for all of your
elements linked in every column.
The palette list is stored in the drawing element's directory instead of directly in the Scene level. This
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a
global palette list, link your palettes to the Scene Palette List.

8. Click on theOK button.
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To rename a palette in the Palette Operation dialog box:

1. Select the palette you want to rename at the location and level it was stored in.

2. Click on the Rename button.

AWarning dialog box opens.

‣ Click in the checkbox besideDon't show this message again if you want to prevent the dialog box
from opening every time you click on the Rename button.

3. Click on the Yes button to continue or click on theNo button to cancel the palette renaming operation.

The Rename Palette dialog box opens.

4. Rename the palette.

5. Click on theOK button.

To delete a palette in the Palette Operation dialog box:

1. Select the palette you want to clone at the location and level it was stored in.

2. Click on theDelete button. AWarning dialog box opens.

‣ Click in the checkbox besideDon't show this message again if you want to prevent the dialog box
from opening every time you click on theDelete button. It is not recommended to disable the warning
message in this case. Deleting a palette can not be undone.
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3. Click on the Yes button to continue or click on theNo button to cancel the palette deleting operation.

Related Topics

• Connecting to the Database on page 1.

Palette Storage
When a palette is created fromHarmony it needs to be stored somewhere. In Harmony, palettes are individual
*.plt files that can be copied, transferred and stored.

The palette files are saved in the scene directory and stored in a Palette Library folder. There are four locations
where you can find Palette Library folders:

• Element
The Palette Library folder is stored directly in the Drawing Element folder.

• Scene
The Palette Library folder is stored directly in the Scene folder.

• Job
The Palette Library folder is stored in a Job folder contained in the Scene folder.

• Environment
The Palette Library folder is stored in an Environment folder contained in the Scene folder.

Related Topics

• Where to Save the Palette File? below

• What Happens when you Export a Palette File? below

Where to Save the Palette File?

The palette storage location depends on the type of production and the backup plan being used.

Some studios like to store their palettes at the Element level and others at the Environment level. This will not
create a problem as long as the scene is in the Harmony structure, in fact as long as the structure is maintained it
can be stored at any level. However, difficulties may occur when the scene is backed-up or transferred to another
studio or database and removed from the initial structure.

Related Topics

• What Happens when you Export a Palette File? below

What Happens when you Export a Palette File?

It is important to understand what is happening to a palette file when the scene is exported.

Because of the Harmony client-server configuration, all of the data can be shared through all of the scenes via the
central database. This also includes the palette files, even if they are stored at the Element, Scene, Job, Drawing
or Environment level. This way, the palette files can be accessed from any scene of any project.
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When you export scenes fromHarmony using the Control Center, either to archive them or to send them to
other users or studios, the palettes stored in external scenes, jobs or environment willNOT be exported. An
exported scene will only carry palettes stored in its own Element's palette library, Scene's palette library, Job
and Environment. Any other palette from other Environments, Jobs, Elements or Scenes (even from the same
job) willNOT follow. Instead a recovery palette will be created when the scene is reopened in another Harmony
system.

A recovery palette is a local palette created by the systemwhen palettes and colours aremissing. This palette is
no longer shared with the rest of the project because the original link is broken.

For example, look at this chart. If you export Scene 2 from Job 1, the package will carry the palettes from Scene
2, Job 1 and Environment. It WILL NOT carry the palettes from Element 3 in Scene 1, Scene 1 and Job 2.

If Scene 2 was linked to any of these, the systemwould create a recovery palette the next time that Scene 2 is
opened in another Toon BoomHarmony system.

The best place to store your palette is:

• Environment level, for a movie or series

• Job level, for a publicity or small project
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• Scene level, for a student exercise

If you want to store your palettes with your colour models, you can use the Element level. However, this will
requiremore structure when exporting the different scenes of your project. The scenes will have to be exported
along with the colour model scene. Then, the other studio you are working with will have to recreate an identical
structure to yours, to be able to import the received scenes into the same location as you did. This will ensure
that the links aremaintained.

Related Topics

• Where to Save the Palette File? on page 274

Palette Backup
When sharing palettes between scenes, some users maymodify the colours by accident. That is why it is a good
idea to copy and backup your palette libraries and master palette directories.

When a palette file is copied, it automatically becomes a clone palette, so there is no trouble as for replacing an
altered file. Harmony automatically updates all of the files and drawings linked to it.

Related Topics

• Creating a Palette in Harmony on page 267

• PaletteOperations on page 271

• Palette Storage on page 274

Copying and Pasting Colours
When you are creating palettes, youmay want to copy colour swatches or their values and paste them in other
palettes to save time.

To copy and paste colours

1. In the Colour view, select the colour to copy.

2. In the Colour View menu, select Colours > Copy or press [Ctrl] + [C] (Windows/Linux) or [⌘ ] + [C] (Mac
OS X).

3. In the Palette list, select the palette in which you want to paste the colours.

4. In the Colour View menu, select Colours > Paste as New Colours or press [Ctrl] + [V] (Windows/Linux) or
[⌘ ] + [V] (MacOS X).
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‣ If you want to paste the colour values of the copied swatch over an existing colour swatch,
select Colours > Paste as Values.

Copying Colours from Another Palette
In Toon BoomHarmony you can quickly copy a colour value from a palette in your scene to a selected colour
swatch in a different palette.

To use Copy Colour From:

1. In the Colour view, select the colour swatch you want to copy the colour into.

2. In the Colour View menu, select Colour > Copy Colour From, then select the palette where the colour you
want to copy is listed and finally select the colour.

The selected colour swatch will immediately change to this new colour.

Related Topics

• Adding a Colour Swatch on page 210

Removing a Colour Palette
You can remove palettes from your Palette list if they are not needed in your scene. The actual palette file will not
be deleted and youwill be able to reimport it in your Palette list later on.

To remove a palette:

1. In the Colour view, select the palette to remove.

2. In the Colour View menu, select Palettes > Remove or click on the Remove Palette button.

‣ If the palette was in use in your scene, the zones painted with its colours will turn red.

Related Topics

• Creating a Colour Palette on page 264

• Duplicating a Colour Palette on the next page
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• Cloning a Colour Palette on the facing page

Duplicating a Colour Palette
Aduplicate palette uses the same names, colour values, but has a different ID and is independent from the
original palette. This ensures that both palettes are completely independent.

This option is used when there are similar models and youwant to avoid recreating and naming all of the colours.
You can change the values and the names afterward. You can also keep some RGBA values, such as the eyes,
teeth, tongue, insidemouth, etc.

To duplicate a palette:

1. In the Colour view, select the palette to be duplicated.

2. In the Colour View menu, select Palettes > Duplicate.

The Palette Browser: Duplicate Palette window opens.

3. Name the palette appropriately.

4. Click OK to create the palette.

The palette appears in the palette list.

Related Topics

• Cloning a Colour Palette on the facing page
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Cloning a Colour Palette

A character usually has only onemaster palette, although there are times when the characters are placed in
different lighting conditions and require a different colour shading. The night palette is a popular choice when a
scene or sequence changes from day to night. It can be difficult and time-consuming to repaint everything and
creating two independent palettes can be quite complex. As an alternative, Toon BoomHarmony provides clone
palettes.

The clone palette is a copy of themaster palette. The colours in each palette have the same properties. The
colours have the same identification number pointing to the same colour zones, but they can have different
names and RGBA values. Depending on the activated palette (night or day), the painted drawing will update. So
there is no need to repaint the animation, but to create or import a clone palette (palette style).

To clone a palette:

1. In the Colour view, select the palette to be cloned.

2. In the Colour View menu, select Palettes > Clone.

The Palette Browser: Clone Palette window opens.

3. Name the palette. (It is recommended to keep the suffix“-clone” in the name.)

4. Click OK to create the palette.

The clone appears in the palette list.
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In the Colour view, you can also modify the colours individually by using the Colour Picker window or all at once
using the Tint Panel window.

If there is more than one clone palette loaded, the system will use the one highest in the palette list.

When you want to see through painted drawings, but still see the outlines, you can create a clone
palette where you set a lower alpha value on all of the filling colours. This trick can be handy when
setting pivot points on cut-out puppets.

Cloning a Colour Swatch
In Toon BoomHarmony, you can copy a selected colour swatch and paste it as a clone.

To clone a colour swatch:

1. In the Colour view, select the colour swatch you want to clone.

2. In the Colour View menu, select Colours > Copy. The [Ctrl] + [C] (Windows/Linux) or [⌘ ] + [C] (MacOS X).

3. In the Colour view, select the colour palette you want to paste the clone into, or create a new palette.

4. In the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

Since it produces a clone colour swatch, it is impossible to use the Paste as Clone command in the same palette
as you copied the original colour swatch from. If you try to do it, a Message dialog box will open as a reminder.
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Related Topics

• Mixing the Colours below

• Duplicating a Colour Palette on page 278

Mixing the Colours
If you want to modify a series of colour at once to blend a tint in them or offset their RGBA values, you can use
the Tint panel. The Tint panel is quite useful when creating palette styles such as night and day styles.

Tomix colours:

1. In the palette list, select the palette to offset or blend colours in it.

2. In the Colour View menu, select Palettes > Tint Panel.

The Blend/Offset Tint panel opens.

3. Select one or more colours to bemodified in the colour list. To select all your colours, press [Ctrl] + [A]
(Windows/Linux) or [⌘ ] + [A] (MacOS X).
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4. Check Preview.

5. Offset, Blend orMix the selected colours.

‣ Offset

Use this option to simply offset the selected colours by the adjustments made using the HSB and RGB
sliders. Use the Amount slider to adjust the degree of offset. Use the Alpha slider to adjust the opacity of
the selected colour.

‣ Blend

Use this option to blend the selected colours with the colour swatch in the top right corner. Use the
Amount slider to adjust the degree of blend. A blend of 100% would turn the selected colours into the
same colour as the swatch. Adjusting the HSB and RGB sliders affect the swatch colour, which in turn
affects the selected colours on the left. Use the Alpha slider to adjust the opacity of the swatch.

‣ Mixer
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Select a Base and Tint colour to form a third colour swatch. Use the slider just beneath to mix the Base
and Tint colours by different amounts. This will affect themixed swatch whether it is selected or not.
Select either the Tint or Base swatch and use the HSB and RGB sliders to adjust its colour. This will affect
themixed swatch colour, which in turn affects the selected colours on the left.

6. Click on theApply button.

7. Close the Tint Offset/Blend Panel window.

Related Topics

• Cloning a Colour Palette on page 279

• Adding a Colour Swatch on page 210

Importing Palettes
• Importing a Colour Palette below

• Linking a Colour Palette on the next page

• Linking your Master Palette on the next page

• Palette Linkage Status Icons on page 286

Importing a Colour Palette
If you created a palette in another project and youwould like to import it in your current project, you can browse
for the palette file on your computer and add it to your project. When the palette is imported in your scene, the
file is copied in the project’s directory. It is not linked to the original file.

To import a palette into your project:

1. In the Colour View menu, select Palettes > Import or click on the Import Palette button.

The Browser window opens.

2. Browse for a palette file located on your hard-drive. You will generally find the palettes in your projects’
Palette-Library directory.

3. Click on theOpen button.

The palette appears in the Palette list.
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Linking a Colour Palette
Youmay encounter a scene where only the colour palette created for a certain layer is visible when that layer is
selected. A good example would be a scene where there is a character on one layer and the background on
another and each has its own custom colour palette. In order to see both colour palettes, independent of what
element is selected, youmust link your palette list to another palette file within the Harmony structure.

To link a colour palette:

1. In the Colour View menu, select Palette > Link.

The Palette Browser window opens.

2. Select the level where the palette file is stored. (Usually Scene or Element)

3. Select the Scene or Element Palette list. See Scene Palette List and Element Palette List on page 262
topic for more information.

The palette appears in the Colour view.

See Scene Palette List and Element Palette List on page 262 topic for more information.

Linking your Master Palette
With Toon BoomHarmony as a stand-alone application, every scene is local to themachine. This means that all
of the scene’s data is only accessible from that particular scene. Palettes are also local to the scene: they can be
shared between all drawing layers, but not between scenes.

However, some users may want to share their palettes across a whole project. Toon BoomHarmony offers that
possibility.

By default, a palette is an independent file stored in your Toon BoomHarmony scene. This file can be copied,
moved or deleted.

To fully link a palette throughout an entire project, you need to create a central directory where you can copy all
of the palettes you have created. Every time you link a palette in an element, it is linked to this folder. If you
modify the palette, it will be updated throughout the whole project.
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To link your master palette:

1. In the Colour view, click on theCreate Palette button to create your master palette.

2. Save your scene by selecting File > Save from the top menu or by clicking on the Save button or

press [Ctrl] + [S] (Windows/Linux) or [⌘ ] + [S] (MacOS X).

3. In your operating system, create a master directory. Ideally, this should be created in your Root folder to
keep it within the project directory. You could also place it inside your Colour Model’s subdirectory.

4. Name the folder appropriately, for example: Joe’s_master_palettes.

5. From your operating system, browse to your Toon BoomHarmony scene and open the palette-library
folder.

6. Select and copy your palette.plt file to copy it to themaster palette directory.

7. Create a new Toon BoomHarmony scene or open the scene where you will link this palette.

8. In the Timeline or Xsheet view, select the element to link the palette to.

9. In the Colour View menu, select Palettes > Link to External.

The Link to External Palette dialog box opens.
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‣ Files: Click on the button to browse to your master palettes folder and select the palette *.plt file
you want to link.

‣ Palette List: Select either you want to load this palette at scene or element level.

10. Click OK.

The linked palette appears in your Colour view.

If a palette is outside the scene, the External icon appears beside the palette name.

To link an element (such as a colour model) to the palette that is stored in the external palette
directory, you must remove the original palette from the element’s palette list. You will then load the
duplicated palette into the palette list using the Link to External command, like you did for the other
elements.

Palette Linkage Status Icons
Youwill also notice that when you create or link a palette, a small icon will appear on its left. These icons
represent the palette linkage status.

• Indicates a potentially dangerous situation.

Problems may occur when trying to export or link to the palette file. For example, a palette file is stored
into the element folder and is linked to the Scene Palette list. The issue in this case is that if you decide to
delete the layer containing the palette, you will loose it from your scene.

• Indicates that the palette is safe.
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There won’t be any trouble once the scene will be exported. For example, the palette file is stored in the
scene folder and is linked to the Scene Palette List.

• Indicates that the palette file is stored in a directory external to the scene’s structure.

The palette file is probably stored in a Master Palette directory on a hard drive external to the palette-
libraries planned for the palette storage. The warning in this case is that if youmove your Master Palette
directory to another location, youmay loose the palette in your scene.

• Indicates that a palette file stored in a level such as Element, Scene, Job or Environment is linked to a

Palette list that is not on the same level.

For example, a palette file is stored into the Environment folder and is linked to the Element Palette list.
The palette is shared.

Ordering the Palette List
When you are using several cloned palettes that are related to the same original palette, Toon Boom
Harmonyuses the highest palette in the list to determine the colour of the painted zones.

To reorder palettes in the Palette list:

1. In the Colour View menu, select Palettes >Move Up orMove Down. You can also use the Up and

Down icons.

Related Topics

• Cloning a Colour Palette on page 279



Chapter 5: Colour Colour Model

288

Colour Model

Once you have a fully painted drawing, you can use it as a colour model and load it in theModel view. That
drawing can be used and loaded in any of your Harmony scenes.

Once a drawing is loaded in theModel view, you can click on theDropper , select a colour from themodel

and use it to paint in your Camera or Drawing view without having to pick the colour from the colour palette.

• Loading a Colour Model below

• Cutting, Copying and Pasting from a Colour Model on page 291

Loading a Colour Model
To load a colour model from your Timeline or Xsheet view:

1. In the Timeline or Xsheet view, select the desired drawing (*.tvg).

2. Bring themodel into theModel view by doing one of the following:

‣ In the Timeline view, click and drag the selected drawing and drop it directly in theModel view.

‣ In theModel View menu, select Use Current Drawing as Model.
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‣ UseCurrent Drawing button in theModel View toolbar’s extra buttons.

Themodel appears in theModel view.

To browse for a colour model drawing on your hard drive:

1. Do one of the following: 

‣ In theModel View menu, select Import Model.

‣ Click the Import Model button or from theModel View’s toolbar.

‣ Select File > Import > Colour Model.

2. In the Browser window, browse for any *.tvg drawing file on your hard drive.

3. Click Open.

Themodel appears in theModel view.

To load the Default models:

1. In your scene’s folder, create a new folder and name it models.

2. On your hard drive copy the *.tvg drawing file you want to use as colour models in your scene.

3. In theModel View menu, select LoadDefault Model. You can also click on the LoadDefault Model

button available in theModel View toolbar’s extra buttons.

To load a single drawing from the Library view:

1. In the Library view, click the template containing the drawing to import in theModel view.

2. Right-click on the template and selectOpen As Folder.

3. In the Library view’s left side, select the template’s folder and continuing expanding its sub-folders until
*.tvg files appear on the right side.

4. In the Library view’s right side, select the TVG drawing to import and drag it into theModel view.

To load a template with multiple drawings from the Library view:

1. In the Library view, find the template you want to import in theModel view.

2. In the Library view’s right side, click and drag the template (*.tpl file) and drop it directly in theModel
view.
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3. Use the Scroll Backward and Scroll Forward buttons, found in theModel view’s toolbar, to view

all the drawings contained in the template. This can often be the front, profile and 3/4 views of a
character.

To load a symbol from the Library view:

1. In the Library view’s left side, click on the Symbols folder.

2. In the Library view’s right side, select the symbol that you would like to use as a model and drag and drop
it directly into theModel view.

3. Use the Scroll Backward and Scroll Forward buttons, found in theModel view’s toolbar, to view

all the drawings contained in the symbol. This can often be the front, profile and 3/4 views of a character.

To clear a colour model:

1. In theModel View menu, select Clear Model or press [Delete].
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Cutting, Copying and Pasting from a Colour Model
You can do more than just copy colours from a colour model. Harmony gives you the ability to copy parts of the
character directly from its colour model and paste these elements into the Drawing or Camera views.

To copy the entire model from the Model view:

1. In theModel view’s toolbar, select the Select tool.

2. In theModel view, select your model.

3. In the top menu, select Edit > Copy DrawingObject or press [Ctrl] + [C] (Windows/Linux) or [⌘ ] + [C]
(MacOS X).

4. In the Timeline view, make sure that you have the correct layer and frame selected.

5. Select either the Drawing or Camera views then go to the top menu and select Edit > Paste Drawing
Object, or select the Timeline view and from the top men select Edit > Paste cells in the Timeline or
press [Ctrl] + [V] (Windows/Linux) or [⌘ ] + [V] (MacOS X).

Themodel now appears in the selected view.

To copy part of the model from the Model view:

1. In theModel view’s toolbar, select theCutter tool or press [Alt] + [T].

2. In theModel view, use the Cutter tool to create a selection around the part of your model that you would
like to copy.
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3. In the top menu, select Edit > Copy DrawingObject or press [Ctrl] + [C] (Windows/Linux) or [⌘ ] + [C]
(MacOS X).

4. In the Timeline view, make sure you have the correct layer and frame selected.

5. Do one of the following:

‣ Select the Drawing or Camera view and select Edit > Paste DrawingObject.

‣ Select the Timeline view and select Edit > Paste cells in the Timeline or press [Ctrl] + [V]
(Windows/Linux) or [⌘ ] + [V] (MacOS X).

Themodel appears in the selected view.
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Colour Preferences
Adjusting preferences to suit your techniques allows you to paint your drawings more efficiently.

To open the Preferences panel:

‣ Windows/Linux: Select Edit > Preferences.

‣ MacOS X: Select Stage > Preferences.

‣ Or press [Ctrl] + [U]Windows/Linux) or [⌘ ] + [U] (MacOS X).

In the Preferences panel, you will find the following preferences that are related to adding colours to your
project.

Drawing Tab
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Default Multiwheel Colour Picker
Enable this option to display theMutliwheel Colour Picker window instead of the regular Colour Picker.

Sticky Eye Dropper
Enable this option to keep the Colour Picker’s Dropper tool active until it is released by clicking on the Dropper
icon again.

Create New Colour Pots Using Default Colour
Set the default colour for creating a new colour swatch. Enable the option so that this default colour is used each
time you add a new colour in your palettes. This option is useful for when you create new colour pots so that a
more recognizable colour is created and not just a duplicate of the currently selected colour. Choosing a colour
that is the opposite of your intended colour palette is recommended, such as grey if your palette will be filled
with bright, primary colours.

Auto Gap Closing on Startup
The values for automatic gap closing while painting drawings are:

• 0 = Disabled

• 1 = Small

• 2 =Medium

• 3 = Big
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Auto Gap Closing in Pixel Units
Disabling this option will cause your gap to be zoom dependant. Zoom dependent means that themore you
zoom in, the smaller the gap you can close with the Close Gap tools. By enabling this option, you choose to
make the gap display available in pixel units, which is not zoom dependant.

General Tab

Colour Management
In the General tab of the Preference panel, you will find the following options:

• Default to Element Palette Lists: When this option is enabled the new, cloned, duplicated, imported and
linked palettes will be stored in the Element Palette list instead of the Scene Palette List.

• Interactive Colour Recovery: If a colour palette for your scene is deleted or cannot be found, you will be
asked if you want to recover colours from the program’s memory. If this option is unchecked, the
program recovers missing colours without displaying a dialog box for your input.
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• Colour Recovery: If this option is unchecked, colour recovery will not occur.

• Replacement Colours: If colours are no longer available for your scene, these colours are automatically
replaced with the ones indicated by the Replacement Colour swatch. The default colour is red, as it acts
as a missing colour warning device.

Advanced Tab

Advanced Palette Lists
In the Advanced section, you will find the Advanced Palette Lists option. Enable this feature to switch your
palette list to advanced mode. The Advanced Palette Lists mode is used to create and store palettes in the
Scene or Element Palette List.
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Shortcuts Tab

Go to Next/Previous Colour in the Colour Palette
Under the Colour Management section, you can set two new possible shortcuts. You can set a shortcut to Go to
theNext Colour in the Colour Palette or to Go to the Previous Colour.
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Keyboard Shortcuts For Harmony Paint
This document lists default keyboard shortcuts for Harmony Paint.

The Harmony keyboard shortcuts set is used throughout the Harmony Paint module documentation.

To use a shortcut, press the key and the character simultaneously. The + sign, is not part of the sequence. If
there is no shortcut allocated to a command it is left blank.

General

COMMAND FLASH HARMONY
CUSTO
M

Win/Linux MacOS X Win/Linux MacOS X

Advanced
Save

Ctrl+Shift+-
S

⌘+Shift+S Ctrl+Shift+S ⌘+Shift+S

Copy Ctrl+C ⌘+C Ctrl+C ⌘+C

Cut Ctrl+X ⌘+X Ctrl+X ⌘+X

Delete Del Del Del Del

Delete
(secondary
key)

Backspace Backspace Backspace Backspace

Deselect All Esc Esc Esc Esc

Free Pan And
Zoom

Space Space Space Space

Get Rights to
Modify
Drawings

Alt+L Alt+L Alt+L Alt+L

Go to Next
Column

J J J J

Go to Next
Drawing

G G G G

Go to
Previous
Column

H H H H

Go to
Previous

F F F F
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General

COMMAND FLASH HARMONY
CUSTO
M

Win/Linux MacOS X Win/Linux MacOS X

Drawing

Help F1 F1 F1 F1

Open Ctrl+O ⌘+O Ctrl+O ⌘+O

Open
Elements

Ctrl+E ⌘+E Ctrl+E ⌘+E

Paste Ctrl+V ⌘+V Ctrl+V ⌘+V

Preferences Ctrl+U ⌘+U Ctrl+U ⌘+U

Quick Close-
up

Shift+Z Shift+Z Shift+Z Shift+Z

Read
Changed
Drawings

Ctrl+; ⌘+; Ctrl+; ⌘+;

Recentre F12 ⌘+F12 N N

Redo Ctrl+Y ⌘+Y Ctrl+Shift+-
Z

⌘+Shift+Z

Release
Rights to
Modify
Drawings

Alt+Shift+L Alt+Shift+-
L

Alt+Shift+L Alt+Shift+
L

Reset Pan Shift+N Shift+N Shift+N Shift+N

Reset
Rotation

Shift+X Shift+X Shift+X Shift+X

Reset View Shift+M Shift+M Shift+M Shift+M

Reset Zoom

Rotate View
CCW

Rotate View
CW

Save Ctrl+S ⌘+S Ctrl+S ⌘+S

Select All Ctrl+A ⌘+A Ctrl+A ⌘+A
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General

COMMAND FLASH HARMONY
CUSTO
M

Win/Linux MacOS X Win/Linux MacOS X

Show Colour
Model

Shift+K Shift+K Shift+K Shift+K

Toggle Auto-
Get-Rights-
to-Modify-
Palette-Lists

Toggle Auto-
Get-Rights-
to-Modify-
Palettes

Undo Ctrl+Z ⌘+Z Ctrl+Z ⌘+Z

Unload
Model

Del Del Del Del

Zoom In Ctrl+= ⌘+= 2 2

ZoomOut Ctrl+- ⌘+- 1 1

Colour Management

COMMAND FLASH HARMONY CUSTOM

Win/Linux MacOS X Win/Linux MacOS X

Get Rights To
Modify All
Palettes

Alt+L Alt+L Alt+L Alt+L

Palette Go to
Next Colour

Palette Go to
Previous Colour
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DrawingMode

COMMAND FLASH HARMONY
CUST
OM

Win/Linux MacOS X Win/Linux MacOS X

Activate
Magnifier

Apply Tool
to All
Drawings

Ctrl+Alt+A ⌘+Alt+A Alt+A Alt+A

Apply Tool
to All Visible
Layers

Shift+Q Shift+Q Shift+Q Shift+Q

Auto-Create
Colour Art
from Brush

Shift+F2 Shift+F2 Shift+F2 Shift+F2

Auto-Matte

Automatical
ly Fill Inside
Regions

Ctrl+Shift+
R

⌘+Shift+
R

Ctrl+Shift+R ⌘+Shift+R

Bring
Forward

Ctrl+Up ⌘+Up Ctrl+PgUp ⌘+PgUp

Bring To
Front

Ctrl+Shift+
Up

⌘+Shift+
Up

Ctrl+Shift+Pg
Up

⌘+Shift+Pg
Up

Brush Tool Alt+B Alt+B

Brush Tool
(General)

Alt+B Alt+B

Close Gap
Interactive
Tool

Shift+F10 Shift+F10

Close Gap
Tool

Alt+C Alt+C Alt+C Alt+C

Contour
Editor Tool

Alt+A Alt+A Alt+Q Alt+Q

Convert
Brush
Strokes to
Pencil Lines

^ ^ ^ ^
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DrawingMode

COMMAND FLASH HARMONY
CUST
OM

Win/Linux MacOS X Win/Linux MacOS X

Convert
Pencil Lines
to Brush
Strokes

& & & &

Convert
Strokes to
Pencil Lines

Shift+F12 Shift+F12

Create
Breaking
Triangles

Create
Colour Art
from Line
Art

* * * *

Crop Brush
Textures

Cutter Tool Alt+T Alt+T

Dropper
Tool

Alt+I Alt+I Alt+D Alt+D

Edit
Texture/Gr
adient Tool

Shift+F3 Shift+F3 Shift+F3 Shift+F3

Ellipse Tool Alt+O Alt+O Alt+= Alt+=

Eraser Tool Alt+E Alt+E Alt+E Alt+E

First Frame

Flatten Alt+Shift+F Alt+Shift+
F

Alt+Shift+F Alt+Shift+F

Flatten and
Remove
Extra
Strokes

Ctrl+Shift+
F

⌘+Shift+F Ctrl+Shift+F ⌘+Shift+F

Flatten
Latest

F2 F2 F2 F2

Flip
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DrawingMode

COMMAND FLASH HARMONY
CUST
OM

Win/Linux MacOS X Win/Linux MacOS X

Horizontal

Flip Vertical

Go to Next
Morphing
Frame

Go to
Previous
Morphing
Frame

Group Ctrl+G ⌘+G Ctrl+G ⌘+G

Hand Tool

Hide Line
Texture

Ctrl+Alt+H ⌘+Alt+H Ctrl+Shift+H ⌘+Shift+H

Ink Tool

Light Table Shift+L Shift+L Shift+L Shift+L

Line Tool Alt+N Alt+N Alt+\ Alt+\

Merge
Pencil Lines

Morphing
Tool

F3 F3 F3 F3

Onion Skin:
1 Next

Ctrl+1 ⌘+1 Ctrl+1 ⌘+1

Onion Skin:
1 Previous

! ! ! !

Onion Skin:
2 Next

Ctrl+2 ⌘+2 Ctrl+2 ⌘+2

Onion Skin:
2 Previous

@ @ @ @

Onion Skin:
3 Next

Ctrl+3 ⌘+3 Ctrl+3 ⌘+3

Onion Skin: # # # #
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DrawingMode

COMMAND FLASH HARMONY
CUST
OM

Win/Linux MacOS X Win/Linux MacOS X

3 Previous

Onion Skin:
Add 1 next

Onion Skin:
Add 1
Previous

Onion Skin:
No Next

Ctrl+` ⌘+` Ctrl+` ⌘+`

Onion Skin:
No Previous

~ ~ ~ ~

Onion Skin:
Reduce 1
Next

Onion Skin:
Reduce 1
Previous

Optimize Ctrl+Alt+Sh
ift+C

⌘+Alt+Sh
ift+C

Ctrl+Alt+Shift
+C

⌘+Alt+Shift
+C

Paint and
Remove
Texture

Ctrl+Shift+
F6

⌘+Shift+
F6

Shift+F6 Shift+F6

Paint Tool Alt+I Alt+I

Paint Tool
(General)

Alt+K Alt+K

Paint
Unpainted
Tool

Alt+Y Alt+Y

Pencil
Editor Tool

Alt+W Alt+W

Pencil Tool Alt+Y Alt+Y Alt+/ Alt+/

Permanent
Selection

Ctrl+Shift+
P

⌘+Shift+
P

Ctrl+Shift+P ⌘+Shift+P

Perspective Alt+0 Alt+0 Alt+0 Alt+0



Keyboard Shortcuts For Harmony Paint

306

DrawingMode

COMMAND FLASH HARMONY
CUST
OM

Win/Linux MacOS X Win/Linux MacOS X

Tool

Pivot Tool Shift+P Shift+P

Polyline
Tool

Alt+P Alt+P Alt+_ Alt+_

Preview Line
and Colour
Arts

Shift+P Shift+P P P

Real-Time
Antialiasing

Ctrl+Alt+Sh
ift+A

⌘+Alt+Sh
ift+A

Ctrl+Alt+A ⌘+Alt+A

Rectangle
Tool

Alt+R Alt+R Alt+7 Alt+7

Reduce
Drawing
Texture
Resolution

RemoveDirt Shift+D Shift+D Shift+D Shift+D

Remove
Hair

Remove
Selected
Drawing

Removes art
inside
selection

Removes art
inside
selection on
all drawings

Removes art
outside
selection

Removes art
outside
selection on
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DrawingMode

COMMAND FLASH HARMONY
CUST
OM

Win/Linux MacOS X Win/Linux MacOS X

all drawings

Repaint
Brush Tool

Alt+X Alt+X

Repaint
Tool

Alt+R Alt+R

Reposition
All
Drawings
Tool

Resize Pen
Style Tool

O O O O

Rotate 180

Rotate 90
CCW

Ctrl+7 ⌘+7 Ctrl+7 ⌘+7

Rotate 90
CW

Ctrl+9 ⌘+9 Ctrl+9 ⌘+9

Rotate View
Tool

Select
Delete
Morphing
Hint Mode

Del Del Del Del

Select
Morphing
Appearing
Point Mode

Select
Morphing
Contour
Hint Mode

Ctrl+Shift+
H

⌘+Shift+
H

F7 F7

Select
Morphing
Vanishing
Point Mode

F10 F10
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DrawingMode

COMMAND FLASH HARMONY
CUST
OM

Win/Linux MacOS X Win/Linux MacOS X

Select
Morphing
Zone Hint
Mode

Select
Strokes
With
Current
Colour

Ctrl+Shift+
A

⌘+Shift+
A

Ctrl+Shift+A ⌘+Shift+A

Select Tool Alt+V Alt+V Alt+S Alt+S

Send
Backward

Ctrl+Down ⌘+Down Ctrl+PgDown ⌘+PgDown

Send To
Back

Ctrl+Shift+
Down

⌘+Shift+
Down

Ctrl+Shift+Pg
Down

⌘+Shift+Pg
Down

Shift Trace
Drawing
MoveDown

Shift Trace
Drawing
Move Up

Shift Trace
Drawing
Reset
Position

Shift Trace
Drawing
Toggle Peg
State

Shift Trace
Drawing
Toggle
Visibility

Shift Trace
Move Tool

Shift Trace
Rotate Tool
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DrawingMode

COMMAND FLASH HARMONY
CUST
OM

Win/Linux MacOS X Win/Linux MacOS X

Shift Trace
Scale Tool

Shift Trace
Toggle
Manipulator

Shift Trace
Toggle View

Show Grid Ctrl+' ⌘+' Ctrl+' ⌘+'

Show Grid
Outiline
Only

Ctrl+Alt+G ⌘+Alt+G

Show Other
Morphing
Key
Drawing

= = Ctrl+Shift+M ⌘+Shift+M

Show Scan
Info Panel

Show
Strokes

D D K K

Show
Symbol
Pivot

Show/Hide
Contour
Editor
Controls

Alt+F5 Alt+F5 Alt+F5 Alt+F5

Show/Hide
Onion Skin

Ctrl+Alt+O ⌘+Alt+O Alt+O Alt+O

Smooth Alt+Shift+S Alt+Shift+
S

Alt+Shift+S Alt+Shift+S

Smooth
Editor Tool

Snap and
Align

Ctrl+Alt+, ⌘+Alt+, Ctrl+Alt+, ⌘+Alt+,
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DrawingMode

COMMAND FLASH HARMONY
CUST
OM

Win/Linux MacOS X Win/Linux MacOS X

Snap to
Contour

Ctrl+Alt+; ⌘+Alt+; Ctrl+Alt+; ⌘+Alt+;

Snap to
Grid

Ctrl+Alt+' ⌘+Alt+' Ctrl+Alt+' ⌘+Alt+'

Stroke Tool Alt+/ Alt+/ Alt+V Alt+V

Suggest
Morphing
Hints

Switch to
Line
Art/Colour
Art

L L L L

Switch To
Overlay/Un
derlay Layer

: : : :

Text Tool Alt+T Alt+T Alt+9 Alt+9

Toggle
Backlight

Ctrl+Shift+
C

⌘+Shift+
C

Alt+Shift+B Alt+Shift+B

Toggle Line
Building
Mode

Toggle
Protect
Colours

Shift+S Shift+S Shift+S Shift+S

Unpaint
Tool

Alt+U Alt+U

Zoom Tool Alt+Z Alt+Z Alt+Z Alt+Z
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